Understanding Remote Node Management Using OSC

The remote node management feature in NCS 1010 allows you to remotely manage an ILA node that is not connected to a management network through an OLT gateway node over Optical Supervisory Channel (OSC) interface. The OLT node is connected to a management network and manages ILA node remotely. If the OLT node link is down, the ILA node cannot be accessible.

DHCP Relay Configuration for OLT Node

The OLT node must be configured with the DHCP management connection to manage the ILA node remotely over OSC interface.

Figure 1. DHCP Relay Configuration for OLT Node

Following is the sample DHCP relay configuration for the OLT gateway node:

RP/0/RP0/CPU0:P2B_DT_02#sh running-config int mgmtEth 0/RP0/CPU0/2
Thu Jun  9 06:37:59.071 UTC
interface MgmtEth0/RP0/CPU0/2
 ipv4 address 192.168.1.1 255.255.255.252
!

RP/0/RP0/CPU0:P2B_DT_02#

RP/0/RP0/CPU0:P2C_DT_02#

RP/0/RP0/CPU0:P2B_DT_02#sh running-config dhcp ipv4 
Thu Jun  9 06:28:51.879 UTC
dhcp ipv4
 profile R1 relay
  helper-address vrf default 10.4.33.51 giaddr 10.8.1.20
 !
 interface GigabitEthernet0/0/0/0 relay profile R1
!

In the above sample CLI,

  • 10.4.33.51 is the DHCP server IP address

  • 10.8.1.20 is the OSC interface IP address that going to ILA node from OLT node

  • 0/0/0/0 is the interface number

  • R1 is the profile

Sample command for DHCP server:

3)	Config on dhcp server:
route add -net <OLT-OSCip> gw <OLT-MGMTip> netmask 255.255.255.255 dev eth3

route add -net 10.8.1.20 gw 10.4.33.70 netmask 255.255.255.255 dev eth3
route add -net 10.7.1.20 gw 10.4.33.70 netmask 255.255.255.255 dev eth3
Config on OLT:
dhcp ipv4 profile R1 relay helper-address vrf default 10.4.33.51 giaddr 10.8.1.20
router static
address-family ipv4 unicast
  0.0.0.0/0 10.4.33.1
  10.7.1.20/32 10.4.44.70
interface MgmtEth0/RP0/CPU0/0
ipv4 address dhcp
interface GigabitEthernet0/0/0/0
ipv4 address 10.8.1.20 255.255.255.0

Loopback IP address for OSC Interface

The loopback IP address must be mapped for the OSC interface.


Note


The loopback IP address is essential as it acts as a router ID for the OSPF configuration. Many communication protocols such as: SSH, GRPC and optical applications, and remote login need the router ID for OSPF configuration. .


Following is the sample of loopback and IP address for OSC interface:

RP/0/RP0/CPU0:P2B_DT_02#sh running-config interface loopback 0
Thu Jun  9 06:29:00.447 UTC
interface Loopback0
 ipv4 address 10.3.3.20 255.255.255.255
!

OSPF Neighbor Discovery

The OSPF neighbor discovery indicates the successful connection between OLT and ILA node.

Following is the sample CLI:
RP/0/RP0/CPU0:IOS#show ospf neighbor 
Tue Jul 26 07:31:29.532 UTC
* Indicates MADJ interface
# Indicates Neighbor awaiting BFD session up
Neighbors for OSPF 1
Neighbor ID     Pri   State           Dead Time   Address         Interface
198.51.100.1        1     FULL/  -        00:00:35    10.8.1.21       GigabitEthernet0/0/0/0
Neighbor is up for 00:00:42

Total neighbor count: 1
RP/0/RP0/CPU0:IOS#

In the above CLI,

  • 198.51.100.1 is the neighbor IP address

  • 10.8.1.21 is the OSC interface IP address

Configure ILA Node

The following is a sample command for ILA node configuration:

interface GigabitEthernet0/0/0/0
ipv4 address 10.8.1.21 255.255.255.0
!         
interface GigabitEthernet0/0/0/2
ipv4 address 10.7.1.21 255.255.255.0

router ospf 1
distribute link-state
network point-to-point
redistribute connected
area 0
  interface Loopback0
  !
  interface GigabitEthernet0/0/0/0
  !
  interface GigabitEthernet0/0/0/2

Configure OLT Node

The following is a sample command to configure the OLT node with loopback ip:
Configure 

interface Loopback0
ipv4 address 10.3.3.21 255.255.255.255
!
interface GigabitEthernet0/0/0/0
ipv4 address 10.7.1.20 255.255.255.0
router ospf 1
distribute link-state
network point-to-point
area 0
  interface Loopback0
  !
  interface GigabitEthernet0/0/0/0