VLAN Handoff

Table 1. Feature History

Feature Name

Release

Description

CEM and IP IW Feature Parity for NCS4200-1T8S-20CS and NCS4200-3GMS Interface Modules

Cisco IOS XE Bengaluru 17.4.1

Support for IPv4 and IPv6 with VLAN handoff for both cross connect and local connect on NCS4200-1T8S-20CS and NCS4200-3GMS Interface Module.

IP Interworking with VLAN Handoff

Cisco IOS XE Amsterdam 17.3.1

VLAN handoff enables the support for IP interworking Pseudowire. IP interworking Pseudowire enables the service provider to terminate the TDM circuit early in the network and transport the IP payload on HDLC, PPP, or MLPPP links, over the MPLS core to the Ethernet network.

This module describes the configuration of the VLAN handoff, which is an extension of the IP interworking pseudowire. The VLAN handoff enables the support for IP interworking pseudowire between HDLC, PPP, or MLPPP channel links to Ethernet virtual circuits (EVC).

Overview of VLAN Handoff

IP interworking pseudowire enables the service provider to terminate the TDM circuit early in the network and transport the IP payload on HDLC, PPP, or MLPPP links to the Ethernet network.

IP Interworking Switching on Single Router

Figure 1. Local Connect Setup

1

Terminate the circuit locally. IP keyword extracts the IP packets and transports it over PW and creates PW (Type 11)

2

IP PW (Type 11) terminated

Restrictions for VLAN Handoff

  • Ingress logical interface range must be reserved, with not more than 4K EVCs that can be supported per ASIC. This reduces the EVC scale from 16K to 8K, with a maximum of 4K EVCs per ASIC.

  • You can configure only a maximum of 3998 serial interface or Interworking Multiservice Gateway (iMSG).

  • For a ping to work, resolve the ARP from the Ethernet interface.

  • VLAN handoff with a local connect over HDLC, PPP, or MLPPP is not supported when configured with port channel.

  • Only IPv4 is supported until Cisco IOS XE Amsterdam 17.3.1.

Enabling the VLAN Handoff

Use the enable_tdm_to_ip_iw command to enable the SDM template.


Router# config terminal 
Router(config)# sdm prefer enable_tdm_to_ip_iw

Reload the router after you enable the template.

The new template is added and the ROMMON variable is set to 28.


TDM_TO_IP_FEAT_EXT_TEMPLATE = 28

Note


You must reload the router for the new template to be effective.

Configuring VLAN Handoff for IPv4 Local Connect

Before you begin

Interface module must be free from all configurations.

Procedure


Step 1

Configure the serial or MLPPP interface on a customer edge (CE).

To configure the interface on CE1, enter the following commands:


controller SONET 4/0/0
framing sonet
clock source line
!
sts-1 1
mode vt-15
vtg 1 t1 1 channel-group 0 timeslots 1-24

Step 2

Configure the serial or MLPPP interface on a provide edge (PE).

To configure the interface on PE, enter the following commands:


controller SONET 0/4/17
framing sonet
clock source line
!
sts-1 1
mode vt-15
vtg 1 t1 1 channel-group 0 timeslots 1-24

Step 3

Configure service instance on the Ethernet interface.

To configure service instance on the Ethernet interface, enter the following commands:


interface TenGigabitEthernet0/1/1
no ip address
 
service instance 10 ethernet
encapsulation dot1q 10
rewrite ingress tag pop 1 symmetric
!
end

Note

 
Only single tag EPF is supported.

Step 4

Bind the service instance and the serial interface under L2VPN xconnect.

To create L2VPN for local connect and bind the service instance and serial interface, enter the following commands:


l2vpn xconnect context vlan_handoff_10
interworking ip
member Serial0/4/17.1
member TenGigabitEthernet0/1/1 service-instance 10

Step 5

Configure the service instance on CE2 to terminate the traffic on BDI or VLAN.

To configure the service instance, enter the following commands:


interface TenGigabitEthernet0/12/1
no ip address
service instance 10 ethernet
encapsulation dot1q 10
rewrite ingress tag pop 1 symmetric
bridge-domain 10
!
end
interface BDI10
ip address 10.12.12.2 255.0.0.0
no shut

Example - VLAN Handoff for IPv4 Local Connect

The following is a sample VLAN handoff configuration for CE and PE respectively.

Router# show running-config | sec 4/0/0
controller SONET 4/0/0
 framing sonet
 clock source line
 !
 sts-1 1
  mode vt-15
  vtg 1 t1 1 channel-group 0 timeslots 1-24

Router# show ip int brief | i Se
             Serial4/0/0.1/1/1:0    10.12.12.1      YES manual up                    up 
Serial Interface Configuration
platform enable controller MediaType 0/4/17 oc12
controller MediaType 0/4/17
 mode sonet
controller SONET 0/4/17
 no snmp trap link-status
 rate OC12
 no ais-shut
 alarm-report all
 threshold sf-ber 3
 clock source internal
 !
 sts-1 1
  clock source internal
  mode vt-15
  vtg 1 t1 1 channel-group 0 timeslots 1-24
 !

Gigabit Ethernet Configuration
interface TenGigabitEthernet0/1/1
 no ip address
 service instance 10 ethernet
  encapsulation dot1q 10
  rewrite ingress tag pop 1 symmetric
 !
end

L2vpn xconnect
l2vpn xconnect context vlan_handoff_10
 interworking ip
 member Serial0/4/17.1 
 member TenGigabitEthernet0/1/1 service-instance 10 

Configuration on CE2


interface TenGigabitEthernet0/12/1
 no ip address
 service instance 10 ethernet
  encapsulation dot1q 10
  rewrite ingress tag pop 1 symmetric
  bridge-domain 10
 !
end

interface BDI10
ip address 10.12.12.2 255.0.0.0
no shut

Router# show ip int brief | i BDI 
	BDI10                  10.12.12.2      YES manual up                    up 

Configuring VLAN Handoff for IPv4 Cross Connect

Figure 2. Cross Connect Setup

Before you begin

Interface module must be free from all configurations.

Procedure


Step 1

Configure the serial interface on CE1.

To configure the serial interface on CE1, enter the following commands:


controller sonet 4/1/0
sts-1 1
mode vt-15
vtg 1 t1 1 channel-group 0 timeslots 1-24

interface Serial4/1/0.1/1/1:0
ip address 10.10.10.1 255.0.0.0
end

Step 2

Perform the following configurations on PE1:

  1. To configure the serial interface on PE1, enter the following commands:

    
    controller sonet 0/5/16
    sts-1 1
    mode vt-15
    vtg 1 t1 1 channel-group 0 timeslots 1-24
    
    
  2. To configure pseudowire on PE1, enter the following commands:

    
    interface pseudowire100
    encapsulation mpls
    signaling protocol ldp
    neighbor 10.2.2.2 100
    
    
  3. To perform L2VPN cross-connect, enter the following commands:

    
    l2vpn xconnect context vlan_handoff_xconn_100
    interworking ip
    member serial0/5/16.1
    member pseudowire100
    
    

Note

 

Ensure that PE1 and PE2 are reachable through any routing protocol and LDP is up.

Step 3

Perform the following configurations on PE2:

  1. To configure pseudowire on PE2, enter the following commands:

    
    interface pseudowire100
    encapsulation mpls
    signaling protocol ldp
    neighbor 10.1.1.1 100
    
    
  2. To configure service instance on the Ethernet interface, enter the following commands:

    
    interface tengig 0/12/1
    no shut
    interface tengig 0/12/1
    service instance 100 ethernet
    encapsulation dot1q 100
    rewrite ingress tag pop 1 symmetric
    
  3. To perform L2VPN cross-connect, enter the following commands:

    
    l2vpn xconnect context vlan_handoff_xconn_100
    interworking ip
    member tengig0/12/1 service-instance 100
    member pseudowire100
    
    

Step 4

Terminate the serial interface on the Ethernet interface.

Terminate the serial interface on the Ethernet interface, enter the following commands:


interface tengig 0/4/0
no shut

interface tengig 0/4/0
service instance 100 ethernet
encapsulation dot1q 100
rewrite ingress tag pop 1 symmetric
bridge-domain 100

interface BDI100
ip add 10.10.10.2 255.0.0.0
no shut


Configuring VLAN Handoff for IPv6 Local Connect

Table 2. Feature History

Feature Name

Release

Description

Before you begin

Interface module must be free from all configurations.

Procedure


Step 1

Configure the serial or MLPPP interface on a customer edge (CE).

To configure the interface on CE1, enter the following commands:


controller SONET 4/0/0
framing sonet
clock source line
!
sts-1 1
mode vt-15
vtg 1 t1 1 channel-group 0 timeslots 1-24

interface Serial4/0/0.1/1/1:0
ipv6 address 2001:1::1/64
ipv6 enable
end

Step 2

Configure the serial or MLPPP interface on a provide edge (PE).

To configure the interface on PE, enter the following commands:


controller SONET 0/4/17
framing sonet
clock source line
!
sts-1 1
mode vt-15
vtg 1 t1 1 channel-group 0 timeslots 1-24

Step 3

Configure service instance on the Ethernet interface.

To configure service instance on the Ethernet interface, enter the following commands:


interface TenGigabitEthernet0/1/1
no ip address
 
service instance 10 ethernet
encapsulation dot1q 10
rewrite ingress tag pop 1 symmetric
!
end

Note

 
Only single tag EPF is supported.

Step 4

Bind the service instance and the serial interface under L2VPN xconnect.

To create L2VPN for local connect and bind the service instance and serial interface, enter the following commands:


l2vpn xconnect context vlan_handoff_10
interworking ipv6
member Serial0/4/17.1
member TenGigabitEthernet0/1/1 service-instance 10

Step 5

Configure the service instance on CE2 to terminate the traffic on BDI or VLAN.

To configure the service instance, enter the following commands:


interface TenGigabitEthernet0/12/1
no ip address
service instance 10 ethernet
encapsulation dot1q 10
rewrite ingress tag pop 1 symmetric
bridge-domain 10
!
end
interface BDI10
ipv6 address 2001:1::2/64
ipv6 enable
no shut

Note

 
  • Ensure that atleast one interface is enabled with IPv6 on the TDM routers, for example:

    
    loopback 111
    ipv6 enable 
    
    
  • IPv6 unicast routing has to be enabled on all the routers.


Configuring VLAN Handoff for IPv6 Cross Connect

Figure 3. Cross Connect Setup

Before you begin

Interface module must be free from all configurations.

Procedure


Step 1

Configure the serial interface on CE1.

To configure the serial interface on CE1, enter the following commands:


controller sonet 4/1/0
sts-1 1
mode vt-15
vtg 1 t1 1 channel-group 0 timeslots 1-24

interface Serial4/1/0.1/1/1:0
ipv6 address 2001:1::1/64
ipv6 enable
end

Step 2

Perform the following configurations on PE1:

  1. To configure the serial interface on PE1, enter the following commands:

    
    controller sonet 0/5/16
    sts-1 1
    mode vt-15
    vtg 1 t1 1 channel-group 0 timeslots 1-24
    
    
  2. To configure pseudowire on PE1, enter the following commands:

    
    interface pseudowire100
    encapsulation mpls
    signaling protocol ldp
    neighbor 10.2.2.2 100
    
    
  3. To perform L2VPN cross-connect, enter the following commands:

    
    l2vpn xconnect context vlan_handoff_xconn_100
    interworking ip
    member serial0/5/16.1
    member pseudowire100
    
    

Note

 

Ensure that PE1 and PE2 are reachable through any routing protocol and LDP is up.

Step 3

Perform the following configurations on PE2:

  1. To configure pseudowire on PE2, enter the following commands:

    
    interface pseudowire100
    encapsulation mpls
    signaling protocol ldp
    neighbor 10.1.1.1 100
    
    
  2. To configure service instance on the Ethernet interface, enter the following commands:

    
    interface tengig 0/12/1
    no shut
    interface tengig 0/12/1
    service instance 100 ethernet
    encapsulation dot1q 100
    rewrite ingress tag pop 1 symmetric
    
  3. To perform L2VPN cross-connect, enter the following commands:

    
    l2vpn xconnect context vlan_handoff_xconn_100
    interworking ipv6
    member tengig0/12/1 service-instance 100
    member pseudowire100
    
    

Step 4

Terminate the serial interface on the Ethernet interface.

To terminate the serial interface on the Ethernet interface, enter the following commands:


interface tengig 0/4/0
no shut

interface tengig 0/4/0
service instance 100 ethernet
encapsulation dot1q 100
rewrite ingress tag pop 1 symmetric
bridge-domain 100

interface BDI100
ipv6 address 2001:1::1/64
ipv6 enable
no shut