RIP Commands

auto-summary (RIP)

To restore the default behavior of automatic summarization of subnet routes into network-level routes, use the auto-summary command in router configuration mode. Todisable this function and send subprefix routing information across classful network boundaries, use the no form of this command.

auto-summary

no auto-summary

Syntax Description

This command has no arguments or keywords.

Command Default

Enabled (the software summarizes subprefixes to the classful network boundary when crossing classful network boundaries).

Command Modes


Router configuration

Command History

Release

Modification

10.0

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

Route summarization reduces the amount of routing information in the routing tables.

RIP Version 1 always uses automatic summarization. If you are using RIP Version 2, you can turn off automatic summarization by specifying the no auto-summary command. Disable automatic summarization if you must perform routing between disconnected subnets. When automatic summarization is off, subnets are advertised.

Examples

In the following example, network numbers are not summarized automatically:

router rip
 version 2
 no auto-summary

bfd all-interfaces

To enable Bidirectional Forwarding Detection (BFD) for all interfaces participating in the routing process, use the bfd all-interfaces command in router configuration or address family interface configuration mode. To disable BFD for all neighbors on a single interface, use the no form of this command.

bfd all-interfaces

no bfd all-interfaces

Syntax Description

This command has no arguments or keywords.

Command Default

BFD is disabled on the interfaces participating in the routing process.

Command Modes

Router configuration (config-router)

Address family interface configuration (config-router-af)

Command History

Release

Modification

12.2(18)SXE

This command was introduced.

12.0(31)S

This command was integrated into Cisco IOS Release 12.0(31)S.

12.4(4)T

This command was integrated into Cisco IOS Release 12.4(4)T.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

Cisco IOS XE Release 2.1

This command was integrated into Cisco IOS Release XE 2.1 and implemented on the Cisco ASR 1000 Series Aggregation Services Routers.

12.2(33)SRE

This command was modified. Support for IPv6 was added.

15.0(1)M

This command was modified. The bfd all-interfaces command in named router configuration mode was replaced by the bfd command in address family interface mode.

15.1(2)T

This command was modified. Support for IPv6 was added.

Cisco IOS XE Release 3.3

This command was modified. Support for the Routing Information Protocol (RIP) was added.

15.2(4)S

This command was modified. Support for IPv6 was added.

Cisco IOS XE Release 3.7S

This command was modified. Support for IPv6 was added.

Usage Guidelines

There are two methods to configure routing protocols to use BFD for failure detection. To enable BFD for all interfaces, enter the bfd all-interfaces command in router configuration mode. In Cisco IOS Release 12.4(24)T, Cisco IOS 12.2(33)SRA, and earlier releases, the bfd all-interfaces command works in router configuration mode and address family interface mode.

In Cisco IOS Release 15.0(1)M and later releases, the bfd all-interfaces command in named router configuration mode is replaced by the bfd command in address family interface configuration mode. Use the bfd command in address family interface configuration mode to achieve the same functionality as that of the bfd all-interfaces command in router configuration mode.

Examples

The following example shows how to enable BFD for all Enhanced Interior Gateway Routing Protocol (EIGRP) neighbors:

Router> enable
Router# configure terminal
Router(config)# router eigrp 123
Router(config-router)# bfd all-interfaces
Router(config-router)# end

The following example shows how to enable BFD for all Intermediate System-to-Intermediate System (IS-IS) neighbors:

Router> enable
Router# configure terminal
Router(config)# router isis tag1
Router(config-router)# bfd all-interfaces
Router(config-router)# end

The following example shows how to enable BFD for all Open Shortest Path First (OSPF) neighbors:

Router> enable
Router# configure terminal
Router(config)# router ospf 123
Router(config-router)# bfd all-interfaces
Router(config-router)# end

The following example shows how to enable BFD for all EIGRP neighbors, using the bfd command in address family interface configuration mode:

Router> enable
Router# configure terminal
Router(config)# router eigrp my_eigrp
Router(config-router)# address family ipv4 autonomous-system 100
Router(config-router-af)# af-interface FastEthernet 0/0
Router(config-router-af)# bfd

The following example shows how to enable BFD for all Routing Information Protocol (RIP) neighbors:

Router> enable
Router# configure terminal
Router(config)# router rip
Router(config-router)# bfd all-interfaces
Router(config-router)# end

The following example shows how to enable IPv6 BFD for all IS-IS neighbors, in address family interface configuration mode:

Router> enable
Router# configure terminal
Router(config)# router isis
Router(config-router)# address family ipv6
Router(config-router-af)# bfd all-interfaces
Router(config-router-af)# end

Related Commands

Command

Description

bfd

Sets the baseline BFD session parameters on an interface.

clear ipv6 rip

To delete routes from the IPv6 Routing Information Protocol (RIP) routing table, use the clear ipv6 rip command in privileged EXEC mode.

Cisco IOS Release XE 3.9S, Cisco IOS Release 15.3(2)S, and Later Releases

clear ipv6 rip [ name] [ vrf vrf-name]

Releases Prior to Cisco IOS XE Release 3.9S and Cisco IOS Release 15.3(2)S

clear ipv6 rip [ name]

Syntax Description

name

(Optional) Name of an IPv6 RIP process.

vrf vrf-name

(Optional) Clears information about the specified Virtual Routing and Forwarding (VRF) instance.

Command Modes


Privileged EXEC

Command History

Release

Modification

12.0(22)S

This command was introduced.

12.2(13)T

This command was integrated into Cisco IOS Release 12.2(13)T.

12.2(28)SB

This command was integrated into Cisco IOS Release 12.2(28)SB.

12.2(25)SG

This command was integrated into Cisco IOS Release 12.2(25)SG.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2(33)SXH

This command was integrated into Cisco IOS Release 12.2(33)SXH.

Cisco IOS XE Release 3.9S

This command was integrated into Cisco IOS XE Release 3.9S. The vrf vrf-name keyword/argument pair was added.

15.3(3)M

This command was integrated into Cisco IOS Release 15.3(3)M.

Usage Guidelines

When the name argument is specified, only routes for the specified IPv6 RIP process are deleted from the IPv6 RIP routing table. If no name argument is specified, all IPv6 RIP routes are deleted.

Use the show ipv6 rip command to display IPv6 RIP routes.

Use the clear ipv6 rip name vrf vrf-name command to delete the specified VRF instances for the specified IPv6 RIP process.

Examples

The following example deletes all the IPv6 routes for the RIP process called one:

Device# clear ipv6 rip one

The following example deletes the IPv6 VRF instance, called vrf1 for the RIP process, called one:

Device# clear ipv6 rip one vrf vrf1

*Mar 15 12:36:17.022: RIPng: Deleting 2001:DB8::/32
*Mar 15 12:36:17.022: [Exec]IPv6RT[vrf1]: rip <name>, Delete all next-hops for 2001:DB8::1
*Mar 15 12:36:17.022: [Exec]IPv6RT[vrf1]: rip <name>, Delete 2001:DB8::1 from table
*Mar 15 12:36:17.022: [IPv6 RIB Event Handler]IPv6RT[<red>]: Event: 2001:DB8::1, Del, owner rip, previous None

Related Commands

Command

Description

debug ipv6 rip

Displays the current contents of the IPv6 RIP routing table.

ipv6 rip vrf-mode enable

Enables VRF-aware support for IPv6 RIP.

show ipv6 rip

Displays the current content of the IPv6 RIP routing table.

debug ipv6 rip

To display debug messages for IPv6 Routing Information Protocol (RIP) transactions, use the debug ipv6 rip command in privileged EXEC mode. To disable debug messages for IPv6 RIP routing transactions, use the no form of this command.

Cisco IOS XE Release 3.9S, Cisco IOS Release 15.3(2)S, and Later Releases

debug ipv6 rip [ interface-type interface-number ] [ vrf vrf-name ]

no debug ipv6 rip [ interface-type interface-number ] [ vrf vrf-name ]

debug ipv6 rip [ interface-type interface-number ]

no debug ipv6 rip [ interface-type interface-number ]

Syntax Description

interface-type

(Optional) Interface type for which to display the debug messages.

interface-number

(Optional) Interface number for which to display the debug messages.

vrf vrf-name

(Optional) Displays information about the specified virtual routing and forwarding (VRF) instance.

Command Modes


Privileged EXEC (#)

Command History

Release

Modification

12.2(2)T

This command was introduced.

12.0(21)ST

This command was integrated into Cisco IOS Release 12.0(21)ST.

12.2(28)SB

This command was integrated into Cisco IOS Release 12.2(28)SB.

12.2(25)SG

This command was integrated into Cisco IOS Release 12.2(25)SG.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2(33)SXH

This command was integrated into Cisco IOS Release 12.2(33)SXH.

Cisco IOS XE Release 2.1

This command was implemented on Cisco 1000 Series Aggregation Services Routers.

Cisco IOS XE Release 3.9S

This command was modified. The vrf vrf-name keyword-argument pair was added.

15.3(2)S

This command was integrated into Cisco IOS Release 15.3(2)S.

15.3(3)M

This command was integrated into Cisco IOS Release 15.3(3)M.

Usage Guidelines

The debug ipv6 rip command is similar to the debug ip rip command, except that it is IPv6-specific.


Note


By default, the network server sends the output from debug commands and system error messages to the console. To redirect debug output, use the logging command in global configuration mode. Destinations include the console, virtual terminals, internal buffer, and UNIX hosts running a syslog server. For complete information on debug commands and redirecting debug output, refer to the Cisco IOS Debug Command Reference.


Use the debug ipv6 rip command to enable IPv6 RIP debugging for RIP packets that are sent and received on all device interfaces. Use the debug ipv6 rip interface-type interface-number command to enable IPv6 RIP debugging for RIP packets that are sent and received only on the specified interface.

Use the debug ipv6 rip vrf vrf-name command to troubleshoot issues in the IPv6 RIP functionality when the VRF has already been enabled using a vrf definition vrf-name command. Ensure that the specified VRF name has already been defined. If a VRF name has not been defined, the following message is displayed:

% VRF <undefined VRF name> does not exist or does not have a RD.

Examples

The following is sample output from the debug ipv6 rip command:

Device# debug ipv6 rip

13:09:10:RIPng:Sending multicast update on Ethernet1/1 for as1_rip
13:09:10:       src=2001:DB8::1
13:09:10:       dst=2001:DB8:0:ABCD::1 (Ethernet1/1)
13:09:10:       sport=521, dport=521, length=32
13:09:10:       command=2, version=1, mbz=0, #rte=1
13:09:10:       tag=0, metric=1, prefix=::/0
13:09:28:RIPng:response received from 2001:DB8:0:0:E000::F on Ethernet1/1 for as1_rip
13:09:28:       src=FE80::202:FDFF:FE77:1E42 (Ethernet1/1)
13:09:28:       dst=FF02::9
13:09:28:       sport=521, dport=521, length=32
13:09:28:       command=2, version=1, mbz=0, #rte=1
13:09:28:       tag=0, metric=1, prefix=2000:0:0:1:1::/80

The above example shows two RIP packets; both are known as “responses” in RIP terminology and indicated by a “command” value of 2. The first is an update sent by the device, and the second is an update received by the device. Multicast update packets are sent to all neighboring IPv6 RIP devices (all devices that are on the same links as the device sending the update and have IPv6 RIP enabled). An IPv6 RIP device advertises the contents of its routing table to its neighbors by periodically sending update packets over those interfaces on which IPv6 RIP is configured. An IPv6 device may also send “triggered” updates immediately following a routing table change. In this case, the updates include only the changes to the routing table. An IPv6 RIP device may solicit the contents of the routing table of a neighboring device by sending a Request (command =1) message to the device. The device responds by sending an update (Response, command=2) containing its routing table. In the example, the received response packet could be a periodic update from the address 2001:DB8:0:0:E000::F or a response to a RIP request message that was previously sent by the local device.

The following is sample output from the debug ipv6 rip vrf command:

Device# debug ipv6 rip vrf blue

RIP Routing Protocol debugging is on for vrf blue

Sending:
*Mar 15 11:23:08.508: RIPng: Sending multicast update on Ethernet0/0 for vrf for vrf blue
*Mar 15 11:23:08.508:        src=2001:DB8:0:1:FFFF:1234::5
*Mar 15 11:23:08.508:        dst=2001:DB8:0:1::1 (Ethernet0/0)
*Mar 15 11:23:08.508:        sport=521, dport=521, length=52
*Mar 15 11:23:08.508:        command=2, version=1, mbz=0, #rte=2
*Mar 15 11:23:08.508:        tag=0, metric=1, prefix=6000::/64
*Mar 15 11:23:08.508:        tag=0, metric=1, prefix=2000::/64
*Mar 15 11:23:08.508: RIPng: Packet waiting
*Mar 15 11:23:08.508: RIPng: Process vrf received own response on Loopback1

Receiving
*Mar 15 11:23:20.316: RIPng: Packet waiting
*Mar 15 11:23:20.316: RIPng: response received from FE80::A8BB:CCFF:FE00:7C00 on Ethernet0/0 for vrf
*Mar 15 11:23:20.316:        src=2001:DB8:0:1:FFFF:1234::4 (Ethernet0/0)
*Mar 15 11:23:20.316:        dst=2001:DB8::1
*Mar 15 11:23:20.316:        sport=521, dport=521, length=32
*Mar 15 11:23:20.316:        command=2, version=1, mbz=0, #rte=1
*Mar 15 11:23:20.316:        tag=0, metric=1, prefix=AAAA::/64

The table below describes the significant fields shown in the display.

Table 1 debug ipv6 rip vrf Field Descriptions

Field

Description

src

The address from which the update was originated.

dst

The destination address for the update.

sport, dport, length

The source, destination ports and the length for the update. (IPv6 RIP uses port 521, as shown in the display.)

command

The command field within the RIP packet. A value of 2 indicates that the RIP packet is a response (update); a value of 1 indicates that the RIP packet is a request.

version

The version of IPv6 RIP being used. The current version is 1.

mbz

There must be a 0 (mbz) field within the RIP packet.

#rte

Indicates the number of routing table entries (RTEs) that the RIP packet contains.

tag

metric

prefix

The tag, metric, and prefix fields are specific to each RTE contained in the update.

The tag field is intended to allow for the flagging of IPv6 RIP “internal” and “external” routes.

The metric field is the distance metric from the device (sending this update) to the prefix.

The prefix field is the IPv6 prefix of the destination being advertised.

Related Commands

Command

Description

clear ipv6 rip

Deletes routes from the IPv6 RIP routing table.

ipv6 rip vrf-mode enable

Enables VRF support for IPv6 RIP.

show ipv6 rip

Displays information about current IPv6 RIP processes.

vrf definition

Configures a VRF routing table instance.

default-information originate (RIP)

To generate a default route into Routing Information Protocol (RIP), use the default-information originate command in router configuration mode. To disable this feature, use the no form of this command.

default-information originate [ on-passive | route-map map-name ]

no default-information originate

Syntax Description

on-passive

(Optional) Sends default routes only on RIP passive interfaces.

route-map map-name

(Optional) Specifies that the routing process will generate the default route if the route map is satisfied.

Command Default

No default routes are generated into RIP.

Command Modes


Router configuration (config-router)

Command History

Release

Modification

11.2

This command was introduced.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

15.1(2)S

This command was modified. The on-passive keyword was added.

Usage Guidelines

The route map referenced in the default-information originate command cannot use an extended access list; it can use a standard access list.

When you configure the default-information originate on-passive command, RIP sends the default route on a passive interface. A default route is the network route with which a router communicates when no other known route exists for a given IP packet’s destination address. Before a RIP provider edge (PE) router can send the default route to the customer edge (CE) router, you must configure the interfaces facing the CE as passive interfaces by using the default-information originate on-passive command.

Once you configure the default-information originate on-passive command, the output of the show ip protocols command displays that RIP default routes are sent on passive interfaces.

Applying a condition to determine when the default route is originated is called conditional default origination.

Examples

The following example shows how to originate a default route (0.0.0.0/0) over a certain interface when 172.17.0.0/16 is present. In this example a route map condition is applied.

router rip 
 version 2
 network 172.17.16.0
 default-information originate route-map condition
!
route-map condition permit 10
 match ip address 10
 set interface s1/0
!
access-list 10 permit 172.17.16.0 0.0.255.255
!

Related Commands

Command

Description

access-list

Configures the access list mechanism for filtering frames by protocol type or vendor code.

match ip address

Distributes any routes that have a destination network number address that is permitted by a standard access list, an extended access list, or a prefix list, or performs policy routing on packets.

route-map

Defines the conditions for redistributing routes from one routing protocol into another routing protocol, or to enable policy routing.

router rip

Configures the RIP routing process.

set interface

Indicates where to forward packets that pass a match clause of a route map for policy routing.

show ip protocols

Displays the parameters and the current state of the active routing protocol process.

default-metric (RIP)

To set default metric values for Routing Information Protocol ( RIP), use the default-metric command in router configuration mode. To return to the default state, use the no form of this command.

default-metric number-value

no default-metric [number-value]

Syntax Description

number-value

Default metric value.

Command Default

Built-in, automatic metric translations, as appropriate for each routing protocol

Command Modes


Router configuration

Command History

Release

Modification

10.0

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

T he default-metric command is used in conjunction with the redistribute router configuration command to cause the current routing protocol to use the same metric value for all redistributed routes. A default metric helps solve the problem of redistributing routes with incompatible metrics. Whenever metrics do not convert, using a default metric provides a reasonable substitute and enables the redistribution to proceed.

Examples

The following example shows a router in autonomous system 109 using both the RIP and the Open Shortest Path First (OSPF) routing protocols. The example advertises OSPF-derived routes using RIP and assigns the OSPF-derived routes a RIP metric of 10.

router rip
 default-metric 10
 redistribute ospf 109

Related Commands

Command

Description

redistribute (IP)

Redistributes routes from one routing domain into another routing domain.

flash-update-threshold

To suppress regularly scheduled flash updates, use the flash-update-threshold command in router configuration mode. To return to the default state, use the no form of this command.

flash-update-threshold seconds

no flash-update-threshold

Syntax Description

seconds

The time interval in seconds for which the suppression of flash updates can be configured. The range is from 1 to 30 seconds.

Command Default

This command is disabled by default.

Command Modes


Router configuration

Command History

Release

Modification

12.0

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

This command suppresses flash updates when the arrival of a regularly scheduled update matches the number of seconds that is configured with the seconds argument. The range of seconds that can be configure is from 0 to 30 seconds. If the number of seconds matches the number of seconds or is less than the number seconds that is configured with the seconds argument, the flash update is suppressed. If the numbers seconds until the flash update arrives exceeds the number of seconds that is configured with the seconds argument, the flash update is not suppressed. The regular scheduled interval for flash updates and the configuration of the suppression of flash updates can be verified with the show ip protocol command.

Examples

The following example configures a router to suppress a regularly scheduled flash update if the update is due in 10 seconds or less:

router rip
 flash-update-threshold 10 

Related Commands

Command

Description

show ip protocols

Displays the parameters and current state of the active routing protocol process.

input-queue

The input-queue command defines the number of received, but not yet processed RIP update packets contained in the Routing Information Protocol (RIP) input queue. Use the input-queuecommand in router configuration mode. To remove the configured depth and restore the default depth, use the no form of this command.

input-queue depth

no input-queue

Syntax Description

depth

Numerical value associated with the maximum number of packets in the RIP input queue. The larger the numerical value, the larger the depth of the queue. The range is from 0 to 1024. The default is 50.

Command Default

A depth of 50.

Command Modes


Router configuration

Command History

Release

Modification

11.0

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

Consider using the input-queue command if you have a high-end router that is sending at high speed to a low-speed router that might not be able to receive at the high speed. Configuring this command will help prevent the routing table from losing information.

Another way to prevent the routing table from losing information is to use the output-delay command to change the interpacket delay for RIP updates.

Examples

The following example sets the depth of the RIP input queue to 100:

router rip
 input-queue 100

Related Commands

Command

Description

output-delay

Changes the interpacket delay for RIP updates sent.

ip rip advertise

To configure the interval in which Routing Information Protocol (RIP) updates are advertised from a specific RIP-enabled interface, use the ip rip advertise command in interface configuration mode. To remove the configured interval in which RIP updates are advertised from a specific RIP-enabled interface, use the no form of this command.

ip rip advertise [interval]

no ip rip advertise

Syntax Description

interval

(Optional) Periodic advertisement interval, in seconds, in which RIP updates are sent from a specific RIP-enabled interface. The range is from 0 to 429466. The default is 30.

Command Default

RIP updates are advertised every 30 seconds, which is the default global periodic interval for a Cisco device.

Command Modes

Interface configuration (config-if)
        
      

Command History

Release

Modification

12.2(2)T

This command was introduced.

12.2(22)S

This command was integrated into Cisco IOS Release 12.2(22)S.

12.2(18)SXE

This command was integrated into Cisco IOS Release 12.2(18)SXE.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

Cisco IOS XE Release 2.1

This command was integrated into Cisco IOS XE Release 2.1.

Usage Guidelines

RIP uses broadcast UDP data packets to exchange routing information. RIP sends routing information updates every 30 seconds, which is the default global periodic advertisement interval for a Cisco device.

Use the ip rip advertise command to override the default global periodic advertisement interval on a specific RIP-enabled interface and configure the required periodic advertisement interval on that interface.

If you have to configure a specific periodic advertisement interval on all RIP-enabled interfaces in a Cisco device, use the timers basic command. If you have to configure a specific periodic advertisement interval on a specific interface, use the ip rip advertise command.

Examples

The following example shows how to configure the periodic advertisement interval on an interface:

Device> enable
Device# configure terminal 
Device(config)# interface ethernet 0/1
Device(config-if)# ip rip advertise 5 
Device(config-if)# end

Related Commands

Command

Description

timers basic

Adjusts RIP network timers.

ip rip authentication key-chain

To enable authentication for Routing Information Protocol (RIP) Version 2 packets and to specify the set of keys that can be used on an interface, use the ip rip authentication key-chain command in interface configuration mode. To prevent authentication, use the no form of this command.

ip rip authentication key-chain name-of-chain

no ip rip authentication key-chain [name-of-chain]

Syntax Description

name-of-chain

Enables authentication and specifies the group of keys that are valid.

Command Default

No authentication is provided for RIP packets.

Command Modes


Interface configuration

Command History

Release

Modification

11.1

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

If no key chain is configured with the key-chain command, no authentication is performed on the interface (not even the default authentication).

Examples

The following example configures the interface to accept and send any key belonging to the key chain named trees:

ip rip authentication key-chain trees

Related Commands

Command

Description

key chain

Enables authentication for routing protocols.

ip rip authentication mode

To specify the type of authentication used in Routing Information Protocol (RIP) Version 2 packets, use the ip rip authentication mode command in interface configuration mode. To restore clear text authentication, use the no form of this command.

ip rip authentication mode { text | md5 }

no ip rip authentication mode

Syntax Description

text

Clear text authentication.

md5

Keyed Message Digest 5 (MD5) authentication.

Command Default

Clear text authentication is provided for RIP packets.

Command Modes


Interface configuration

Command History

Release

Modification

11.1

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

RIP Version 1 does not support authentication.

Examples

The following example configures the interface to use MD5 authentication:

ip rip authentication mode md5

Related Commands

Command

Description

ip rip authentication key-chain

Enables authentication for RIP Version 2 packets and specifies the set of keys that can be used on an interface.

key chain

Enables authentication for routing protocols.

ip rip initial-delay

To delay the initiation of RIPv2 neighbor sessions using MD5 authentication until the network connectivity between the neighbor routers is fully operational, use the ip rip initial-delay command in interface, or subinterface configuration mode. To remove the configured delay, use the no form of this command.

ip rip initial-delay delay

no ip rip initial-delay

Syntax Description

delay

The number of seconds to wait before sending the first MD5 authentication packet to the RIPv2 neighbor. The range is from 0 to 1800.

Command Default

The delay of RIPv2 neighbor sessions is not configured.

Command Modes


Interface configuration (config-if)
Subinterface configuration (config-subif)

Command History

Release

Modification

12.4(12)

This command was introduced.

Cisco IOS XE Release 2.6

This command was integrated into Cisco IOS XE Release 2.6.

15.0(1)SY

This command was integrated into Cisco IOS Release 15.0(1)SY

Usage Guidelines

Some non-Cisco routers will not allow an MD5-authenticated RIPv2 neighbor session to start when the sequence number of the first MD5 packet received from the Cisco router is greater than 0. The IP-RIP Delay Start feature is used on Cisco routers to delay the initiation of RIPv2 neighbor sessions using MD5 authentication until the network connectivity between the neighbor routers is fully operational. This ensures the sequence number of the first MD5 packet that the router sends to the non-Cisco neighbor router is 0.

Examples

The following example configures the router to wait 45 seconds before sending the first MD5 authentication packet to a non-Cisco device:

Router(config)# interface POS 0/1/0
Router(config-subif)# ip rip initial-delay 45

Related Commands

Command

Description

debug ip rip

Displays information on Routing Information Protocol (RIP) routing transactions.

show ip rip database

Displays information about the IP route entries in the RIP database.

ip rip receive version

To specify a Routing Information Protocol ( RIP) version to receive on an interface basis, use the ip rip receive version command in interface configuration mode. To follow the global version rules, use the no form of this command.

ip rip receive version [1] [2]

no ip rip receive version

Syntax Description

1

(Optional) Accepts only RIP Version 1 packets on the interface.

2

(Optional) Accepts only RIP Version 2 packets on the interface.

Command Default

This command is disabled by default.

Command Modes


Interface configuration

Command History

Release

Modification

11.1

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

Use this command to override the default behavior of RIP as specified by the version command. This command applies only to the interface being configured. You can configure the interface to accept both RIP versions.

Examples

The following example configures the interface to receive both RIP Version 1 and Version 2 packets:

ip rip receive version 1 2

The following example configures the interface to receive only RIP Version 1 packets:

ip rip receive version 1

Related Commands

Command

Description

key chain

Enables authentication for routing protocols.

ip rip authentication key-chain

Enables authentication for RIP Version 2 packets and specifies the set of keys that can be used on an interface.

ip rip send version

Specifies a RIP version to send on an interface basis.

version

Specifies a RIP version used globally by the router.

ip rip send version

To specify a Routing Information Protocol ( RIP) version to send on an interface basis, use the ip rip send version command in interface configuration mode. To follow the global version rules, use the no form of this command.

ip rip send version [1] [2]

no ip rip send version

Syntax Description

1

(Optional) Sends only RIP Version 1 packets out the interface.

2

(Optional) Sends only RIP Version 2 packets out the interface.

Command Default

This command is disabled by default.

Command Modes


Interface configuration

Command History

Release

Modification

11.1

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

Use this command to override the default behavior of RIP as specified by the version command. This command applies only to the interface being configured.

Examples

The following example configures the interface to send both RIP Version 1 and Version 2 packets out the interface:

ip rip send version 1 2

The following example configures the interface to send only RIP Version 2 packets out the interface:

ip rip send version 2

Related Commands

Command

Description

ip rip receive version

Specifies a RIP version to receive on an interface basis.

version

Specifies a RIP version used globally by the router.

ip rip triggered

To enable triggered extensions to Routing Information Protocol (RIP), use the ip rip triggered command in interface configuration mode. To disable triggered extensions to RIP, use the no form of this command.

ip rip triggered

no ip rip triggered

Syntax Description

This command has no arguments or keywords.

Command Default

This command is disabled by default.

Command Modes


Interface configuration

Command History

Release

Modification

12.0(1)T

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

When triggered extensions to RIP are enabled, routing updates are sent on the WAN only if one of the following events occurs:

  • The router receives a specific request for a routing update. (Full database is sent.)

  • Information from another interface modifies the routing database. (Only latest changes are sent.)

  • The interface comes up or goes down. (Partial database is sent.)

  • The router is first powered on, to ensure that at least one update is sent. (Full database is sent.)

You might want to enable this feature if you are using an on-demand circuit and you are charged for usage time. Fewer routing updates will incur lower usage costs.

Entries in the routing database can be either temporary or semipermanent. Entries learned from broadcasts on LANs are temporary; they will expire if not periodically refreshed by more broadcasts.

Entries learned from a triggered response on the WAN are semipermanent; they do not time out like other entries. Certain events can cause these routes to time out, such as the interface going down, or if the outgoing interface is the same as the incoming interface. Neighbor updates of the routes with a metric of 16 (infinity) mean the route is unreachable, and those routes are eventually removed from the routing table.

Examples

The following example enables triggered extensions to RIP:

interface serial 0
 ip rip triggered

Related Commands

Command

Description

show ip rip database

Displays the contents of the RIP private database when triggered extensions to RIP are enabled.

ip rip v2-broadcast

To allow Routing Information Protocol (RIP) Version 2 update packets to be sent as broadcast packets instead of multicast packets, use the ip rip v2-broadcast command in interface configuration mode. To disable the broadcast of IP RIP Version 2 update packets that are sent as broadcast packets, use the no form of this command.

ip rip v2-broadcast

no ip rip v2-broadcast

Syntax Description

This command has no arguments or keywords.

Command Default

This command is disabled by default. Unless the ip rip v2-broadcast commend is entered, RIP Version 2 update packets are sent as multicast packets.

Command Modes


Interface configuration (config-if)

Command History

Release

Modification

12.1(5)T

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

Use the ip rip v2-broadcast command to broadcast RIP Version 2 broadcast updates to hosts that do not listen to multicast broadcasts. Version 2 updates (requests and responses) will be sent to the IP broadcast address 255.255.255.255 instead of the IP multicast address 224.0.0.9.

In order to reduce unnecessary load on those hosts that are not listening to RIP Version 2 broadcasts, the system uses an IP multicast address for periodic broadcasts. The IP multicast address is 224.0.0.9.


Note


It is not necessary to configure Internet Group Management Protocol (IGMP) because the periodic broadcasts are interrouter messages that are not forwarded.


Examples

The following example configures Version 2 IP broadcast updates on RIP Ethernet interface 3/1:

Router(config) interface ethernet3/1
Router(config-if) ip address 172.16.1.1 255.255.255.0
Router(config-if) ip rip v2-broadcast
.
.
.
Router(config-if) router rip
Router(config-if) version 2
Router(config-if) network 172.0.0.0

Enter debug ip rip command to verify that RIP Version 2 IP broadcast updates are being sent to the IP broadcast address 255.255.255 instead of IP multicast address 224.0.0.9:

Router# debug ip rip
14:41:59: RIP: sending v2 update to 255.255.255.255 via Ethernet3/1 (172.16.1.1)

If the ip rip v2-broadcastcommand has not been entered, the output from the debug ip rip command verifies that the RIP Version 2 IP broadcast updates are being sent to the IP multicast address 224.0.0.9:

Router# debug ip rip
15:45:16: RIP: sending v2 update to 224.0.0.9 via Ethernet3.1 (172.16.1.1)

Related Commands

Command

Description

debug ip rip

Displays information on RIP routing transactions.

ip split-horizon (RIP)

To enable the split horizon mechanism, use the ip split-horizon command in interface configuration mode. To disable the split horizon mechanism, use the no form of this command.

ip split-horizon

no ip split-horizon

Syntax Description

This command has no arguments or keywords.

Command Default

Default behavior varies with media type.

Command Modes


Interface configuration

Command History

Release

Modification

10.0

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

For all interfaces except those for which either Frame Relay or Switched Multimegabit Data Service (SMDS) encapsulation is enabled, the default condition for this command is ip split-horizon; in other words, the split horizon feature is active. If the interface configuration includes either the encapsulation frame-relay or encapsulation smds command, then the default is for split horizon to be disabled. Split horizon is not disabled by default for interfaces using any of the X.25 encapsulations.


Note


For networks that include links over X.25 packet switched networks (PSNs), the neighbor router configuration command can be used to defeat the split horizon feature. You can as an alternative explicitly specify the no ip split-horizon command in your configuration. However, if you do so you must similarly disable split horizon for all routers in any relevant multicast groups on that network.



Note


If split horizon has been disabled on an interface and you want to enable it, use the ip split-horizon command to restore the split horizon mechanism.



Note


In general, changing the state of the default for the ip split-horizon command is not recommended, unless you are certain that your application requires a change in order to properly advertise routes. If split horizon is disabled on a serial interface (and that interface is attached to a PSN), you must disable split horizon for all routers and access servers in any relevant multicast groups on that network.


Examples

The following simple example disables split horizon on a serial link. The serial link is connected to an X.25 network.

interface serial 0
 encapsulation x25
 no ip split-horizon

Related Commands

Command

Description

neighbor (RIP)

Defines a neighboring router with which to exchange routing information.

ip summary-address rip

To configure a summary aggregate address under an interface for the Routing Information Protocol (RIP), use the ip summary-address rip command in interface configuration mode. To disable summarization of the specified address or subnet, use the no form of this command.

ip summary-address rip ip-address ip-network-mask

no ip summary-address rip ip-address ip-network-mask

Syntax Description

ip-address

IP address to be summarized.

ip-network-mask

IP network mask that drives route summarization for the specified IP address.

Command Default

RIP automatically summarizes to classful network boundaries.

Command Modes


Interface configuration

Command History

Release

Modification

12.0(6)T

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

The ip summary-address rip command is used to summarize an address or subnet under a specific interface. RIP automatically summarizes to classful network boundaries. Only one summary address can be configured for each classful subnet.

Examples

In the following example the major network is 10.0.0.0. The summary address 10.2.0.0 overrides the autosummary address of 10.0.0.0, so that 10.2.0.0 is advertised out Ethernet interface 1 and 10.0.0.0 is not advertised.


Note


If split horizon is enabled, neither autosummary nor interface summary addresses (those configured with the ip summary-address rip command) are advertised.


interface Ethernet1
 ip address 10.1.1.1 255.255.255.0
 ip summary-address rip 10.2.0.0 255.255.0 
 exit
router rip
 network 10.0.0.0
 end

Related Commands

Command

Description

auto-summary (RIP)

Restores the default behavior of automatic summarization of subnet routes into network-level routes.

ip split-horizon (RIP)

Enables the split horizon mechanism.

ipv6 rip vrf-mode enable

To enable VRF-aware support for IPv6 Routing Information Protocol (RIP), use the ipv6 rip vrf-mode enable command in global configuration mode. To disable VRF-aware support for IPv6 RIP, use the no form of this command.

ipv6 rip vrf-mode enable

no ipv6 rip vrf-mode enable

Syntax Description

This command has no arguments or keywords.

Command Default

VRF-aware support is not enabled in IPv6 RIP.

Command Modes

Global configuration (config)

Command History

Release Modification

Cisco IOS XE Release 3.9S

This command was introduced.

15.3(2)S

This command was integrated into Cisco IOS Release 15.3(2)S.

15.3(3)M

This command was integrated into Cisco IOS Release 15.3(3)M.

Usage Guidelines

When VRF-aware support is enabled in IPv6 RIP, you can configure only one RIP instance at a given time. More than one RIP instance is not allowed.

Examples

The following example shows how to enable VRF-aware support for IPv6 RIP routing.

Device> enable
Device# configure terminal
Device(config)# ipv6 rip vrf-mode enable
Device(config)# end

Related Commands

Command

Description

clear ipv6 rip

Deletes routes from the IPv6 RIP routing table.

debug ipv6 rip

Displays debug messages for IPv6 RIP routing transactions.

show ipv6 rip

Displays information about current IPv6 RIP processes.

neighbor (RIP)

To define a neighboring router for exchanging routing information, use the neighbor command in router configuration mode. To remove a neighboring router entry, use the no form of this command.

neighbor ip-address [bfd]

no neighbor ip-address [bfd]

Syntax Description

ip-address

IP address of a peer router with which the routing information is exchanged.

bfd

(Optional) Sets the baseline Bidirectional Forwarding Detection (BFD) session parameters on an interface.

Command Default

No neighboring routers are defined.

Command Modes


Router configuration (config-router)

Command History

Release

Modification

10.0

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Cisco IOS XE Release 3.3

This command was modified and integrated into Cisco IOS XE Release 3.3S and implemented on the Cisco ASR 1000 Series Aggregation Services Routers. The bfd keyword was added.

15.1(2)S

This command was integrated into Cisco IOS Release 15.1(2)S.

Usage Guidelines

This command permits point-to-point (nonbroadcast) exchange of routing information. When it is used in combination with the passive-interface command, routing information can be exchanged between a subset of routers and access servers on a LAN.

Use multiple neighbor commands to specify additional neighbors or peers.

Examples

In the following example, RIP updates are sent to all interfaces on network 10.108.0.0 except Ethernet interface 1. However, in this case, a neighbor router configuration command is included. This command permits the sending of routing updates to specific neighbors. One copy of the routing update is generated per neighbor.

Router> enable
Router# configure terminal
Router(config)# router rip
Router(config-router)# network 10.108.0.0
Router(config-router)# passive-interface Ethernet 1
Router(config-router)# neighbor 10.108.20.4

Router(config-router)# end



      

The following example shows how to enable BFD for RIP neighbors:

Router> enable
Router# configure terminal
Router(config)# neighbor 10.0.0.1 bfd
Router(config-router)# end

Related Commands

Command

Description

passive-interface

Disables sending routing updates on an interface.

network (RIP)

To specify a list of networks for the Routing Information Protocol (RIP) routing process, use the network command in router configuration mode. To remove an entry, use the no form of this command.

network ip-address

no network ip-address

Syntax Description

ip-address

IP address of the network of directly connected networks.

Command Default

No networks are specified.

Command Modes


Router configuration

Command History

Release

Modification

10.0

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

The network number specified must not contain any subnet information. There is no limit to the number of network commands you can use on the router. RIP routing updates will be sent and received only through interfaces on this network.

RIP sends updates to the interfaces in the specified networks. Also, if the network of an interface is not specified, the interface will not be advertised in any RIP update.

Examples

The following example defines RIP as the routing protocol to be used on all interfaces connected to networks 10.99.0.0 and 192.168.7.0:

router rip
 network 10.99.0.0
 network 192.168.7.0

Related Commands

Command

Description

router rip

Configures the RIP routing process.

offset-list (RIP)

To add an offset to incoming and outgoing metrics to routes learned via Routing Information Protocol (RIP), use the offset-listcommand in router configuration mode. To remove an offset list, use the no form of this command.

offset-list { access-list-number | access-list-name } { in | out } offset { interface-type | interface-number }

no offset-list { access-list-number | access-list-name } { in | out } offset { interface-type | interface-number }

Syntax Description

access-list-number

Standard access list number to be applied. Access list number 0 indicates all access lists. If offset is 0, no action is taken. For IGRP, the offset is added to the delay component only.

access-list-name

Standard access list name to be applied.

in

Applies the access list to incoming metrics.

out

Applies the access list to outgoing metrics.

offset

Positive offset to be applied to metrics for networks matching the access list. If the offset is 0, no action is taken.

interface-type

(Optional) Interface type to which the offset list is applied.

interface-number

(Optional) Interface number to which the offset list is applied.

Command Default

This command is disabled by default.

Command Modes


Router configuration

Command History

Release

Modification

10.0

This command was introduced.

10.3

The interface-type and interface- number arguments were added.

11.2

The access-list-name argument was added.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

The offset value is added to the routing metric. An offset list with an interface type and interface number is considered extended and takes precedence over an offset list that is not extended. Therefore, if an entry passes the extended offset list and the normal offset list, the offset of the extended offset list is added to the metric.

Examples

In the following example, the router applies an offset of 10 to the delay component of a router only to access list 21:

offset-list 21 out 10

In the following example, the router applies an offset of 10 to routes learned from Ethernet interface 0:

offset-list 21 in 10 ethernet 0

output-delay

To change the interpacket delay for Routing Information Protocol (RIP) updates sent, use the output-delay command in router configuration mode. To remove the delay, use the no form of this command.

output-delay delay

no output-delay

Syntax Description

delay

Delay between packets in a multiple-packet RIP update (in milliseconds). The range is from 8 to 50. The default is 0.

Command Default

The default interpacket delay is 0 milliseconds.

Command Modes


Router configuration

Command History

Release

Modification

10.0

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

Consider using this command if you have a high-end router that is sending at high speed to a low-speed router that might not be able to receive at the high speed. Configuring this command will help prevent the routing table from losing information.

Examples

The following example sets the interpacket delay to 10 milliseconds:

router rip
 output-delay 10

router rip

To configure the Routing Information Protocol (RIP) routing process, use the route r rip command in global configuration mode. To turn off the RIP routing process, use the no form of this command.

router rip

no router rip

Syntax Description

This command has no arguments or keywords.

Command Default

No RIP routing process is defined.

Command Modes


Global configuration

Command History

Release

Modification

10.0

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Examples

The following example shows how to begin the RIP routing process:

router rip

Related Commands

Command

Description

network (RIP)

Specifies a list of networks for the RIP process.

service-module ip rip relay

To enable the delivery of RIP update messages from a Cisco IOS router containing an integrated cable modem or a cable modem HWIC to a Hybrid Fiber-Coaxial (HFC) CMTS when they are on different subnets, use the service-module ip rip relay command in interface configuration mode. To disable RIP relay, use the no form of this command.

service-module ip rip relay

no service-module ip rip relay

Syntax Description

This command has no keywords or arguments.

Command Default

RIP relay is disabled.

Command Modes


Interface configuration (config-if)

Command History

Release

Modification

12.4(15)XY

This command was introduced.

12.4(20)T

This command was integrated into Cisco IOS Release 12.4(20)T.

Usage Guidelines

The service-module ip rip relay command is used to enable the HFC RIP Relay feature that allows the delivery of RIP messages from a Cisco IOS router containing an integrated cable modem or a cable modem High-Speed WAN Interface Card (HWIC) to the Cable Modem Termination system (CMTS) when they are on different subnets. In Cisco IOS releases prior to 12.4(15)XY and 12.4(20)T, RIP messages were rejected by the CMTS because the interface on the Cisco IOS router was in a different subnet from the CMTS.

Examples

The following example enables RIP relay on an Integrated Services Router (ISR) cable modem. A static IP address is configured for the cable modem interface, and RIP relay is enabled on the interface. To allow RIP updates from unknown sources, the normal validation of the source IP address of incoming RIP routing updates is disabled. RIP is defined as the routing protocol to be used on all interfaces that are connected to networks 10.0.0.0 and 172.18.0.0.

interface Cable-Modem0/3/0
 ip address 10.5.5.5 255.255.255.0
 service-module ip rip relay
 exit 
router rip
 version 2
 no validate-update-source            
 network 10.0.0.0
 network 172.18.0.0

Related Commands

Command

Description

show controllers

Displays information that is specific to the hardware.

show ip rip database

To display summary address entries in the Routing Information Protocol (RIP) routing database entries if relevant are routes being summarized based upon a summary address, use the show ip rip database command in privileged EXEC mode.

show ip rip database [ ip-address mask ]

Syntax Description

ip-address

(Optional) Address about which routing information should be displayed.

mask

(Optional) Argument for the subnet mask. The subnet mask must also be specified if the IP address argument is entered.

Command Default

No default behavior or values.

Command Modes


Privileged EXEC

Command History

Release

Modification

12.0(6)T

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

Summary address entries will appear in the database only if relevant child routes are being summarized. When the last child route for a summary address becomes invalid, the summary address is also removed from the routing table.

The RIP private database is populated only if triggered extensions to RIP are enabled with the ip rip triggered command.

Examples

The following output shows a summary address entry for route 10.11.0.0/16, with three child routes active:

Router# show ip rip database
 10.0.0.0/8    auto-summary
 10.11.11.0/24    directly connected, Ethernet2
 10.1.0.0/8    auto-summary
 10.11.0.0/16    int-summary
 ^^^^^^^^^^^^^^^^^^^^^^^^^^^
 10.11.10.0/24    directly connected, Ethernet3
 10.11.11.0/24    directly connected, Ethernet4
 10.11.12.0/24    directly connected, Ethernet5

The following is sample output from the show ip rip databasecommand with a prefix and mask:

Router# show ip rip database
 172.19.86.0 255.255.255.0172.19.86.0/24
    [1] via 172.19.67.38, 00:00:25, Serial0
    [2] via 172.19.70.36, 00:00:14, Serial1 

The table below describes the fields in the display.

Table 2 show ip rip database Field Descriptions

Field

Description

10.0.0.0/16 auto-summary

Summary address entry.

10.11.11.0/24 directly connected, Ethernet0

Directly connected entry for Ethernet 0.

172.19.65.0/24

[1] via 172.19.70.36, 00:00:17, Serial0

[2] via 172.19.67.38, 00:00:25, Serial1

The destination 172.19.65.0/24 is learned via RIP. There are two sources advertising it. One is 172.19.70.36 via Serial interface0, and it was updated 17 seconds ago. The other source is 172.19.67.38 via Serial interface 1, and it was updated 25 seconds ago.

Related Commands

Commands

Description

ip rip triggered

Enables triggered extensions of RIP.

ip summary-address rip

Configures a Cisco router running RIP Version 2 to advertise a summarized local IP address pool on a network access server so that the address pool can be provided to dialup clients, and specifies the IP address and network mask that identify the routes to be summarized.

show ip protocols

Displays the parameters and current state of the active routing protocol process.

show ip rip neighbors

To display Routing Information Protocol (RIP) neighbors for which Bidirectional Forwarding Detection (BFD) sessions are created, use the show ip rip neighbors command in privileged EXEC mode.

show ip rip neighbors

Syntax Description

This command has no argument or keywords.

Command Modes


Privileged EXEC (#)

Command History

Release

Modification

Cisco IOS XE Release 3.3

This command was introduced.

15.1(2)S

This command was integrated into Cisco IOS Release 15.1(2)S.

Usage Guidelines

Use the show ip rip neighbors command to display RIP neighbors for which BFD sessions are created.

Examples

The following is sample output from the show ip rip neighborscommand:

Router# show ip rip neighbors
BFD sessions created for the RIP neighbors
Neighbor      Interface      SessionHandle
10.10.10.2    Ethernet0/0    1
10.10.20.2    Ethernet1/0    2

The table below describes the significant fields shown in the display.

Table 3 show ip rip neighbors Field Descriptions

Field

Description

Neighbor

A neighboring router for which BFD sessions are created.

Interface

The interface type of the neigboring router.

SessionHandle

The unique session handle number to track the neighbor. The BFD system provides this number.

Related Commands

Command

Description

show ip rip database

Displays summary address entries in the RIP database.

show ipv6 rip

To display information about current IPv6 Routing Information Protocol (RIP) processes, use the show ipv6 rip command in user EXEC or privileged EXEC mode.

Cisco IOS XE Release 3.9S, Cisco IOS Release 15.3(2)S, and Later Releases

show ipv6 rip [ name] [ vrf vrf-name] [ database | next-hops ]

Releases Prior to Cisco IOS XE Release 3.9S and Cisco IOS Release 15.3(2)S

show ipv6 rip [ name] [ database | next-hops ]

Syntax Description

name

(Optional) Name of the RIP process. If the name is not entered, details of all configured RIP processes are displayed.

vrf vrf-name

(Optional) Displays information about the specified Virtual Routing and Forwarding (VRF) instance.

database

(Optional) Displays information about entries in the specified RIP IPv6 routing table.

next-hops

(Optional) Displays information about the next hop addresses for the specified RIP IPv6 process. If no RIP process name is specified, the next-hop addresses for all RIP IPv6 processes are displayed.

Command Default

Information about all current IPv6 RIP processes is displayed.

Command Modes

User EXEC (>)

Privileged EXEC (#)

Command History

Release

Modification

12.2(2)T

This command was introduced.

12.0(21)ST

This command was integrated into Cisco IOS Release 12.0(21)ST.

12.0(22)S

This command was integrated into Cisco IOS Release 12.0(22)S. The name argument and the database and next-hops keywords were added.

12.2(13)T

The command was modified. The name argument, and the database and next-hops keywords were added.

12.2(28)SB

This command was integrated into Cisco IOS Release 12.2(28)SB.

12.2(25)SG

This command was integrated into Cisco IOS Release 12.2(25)SG.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2(33)SXH

This command was integrated into Cisco IOS Release 12.2(33)SXH.

Cisco IOS XE Release 2.1

This command was implemented on Cisco 1000 Series Aggregation Services Routers.

Cisco IOS XE Release 3.9S

This command was modified. The vrf vrf-name keyword/argument pair was added.

15.3(2)S

This command was integrated into Cisco IOS Release 15.3(2)S.

15.3(3)M

This command was integrated into Cisco IOS Release 15.3(3)M.

Examples

The following is sample output from the show ipv6 rip command:

Device# show ipv6 rip

RIP process "one", port 521, multicast-group FF02::9, pid 55
     Administrative distance is 25. Maximum paths is 4
     Updates every 30 seconds, expire after 180
     Holddown lasts 0 seconds, garbage collect after 120
     Split horizon is on; poison reverse is off
     Default routes are not generated
     Periodic updates 8883, trigger updates 2
  Interfaces:
    Ethernet2
  Redistribution:
RIP process "two", port 521, multicast-group FF02::9, pid 61
     Administrative distance is 120. Maximum paths is 4
     Updates every 30 seconds, expire after 180
     Holddown lasts 0 seconds, garbage collect after 120
     Split horizon is on; poison reverse is off
     Default routes are not generated
     Periodic updates 8883, trigger updates 0
  Interfaces:
    None
  Redistribution:

The table below describes the significant fields shown in the display.

Table 4 show ipv6 rip Field Descriptions

Field

Description

RIP process

The name of the RIP process.

port

The port that the RIP process is using.

multicast-group

The IPv6 multicast group of which the RIP process is a member.

pid

The process identification number (pid) assigned to the RIP process.

Administrative distance

Used to rank the preference of sources of routing information. Connected routes have an administrative distance of 1 and are preferred over the same route learned by a protocol with a larger administrative distance value.

Updates

The value (in seconds) of the update timer.

expire

The interval (in seconds) in which updates expire.

Holddown

The value (in seconds) of the hold-down timer.

garbage collect

The value (in seconds) of the garbage-collect timer.

Split horizon

The split horizon state is either on or off.

poison reverse

The poison reverse state is either on or off.

Default routes

The origination of a default route into RIP. Default routes are either generated or not generated.

Periodic updates

The number of RIP update packets sent on an update timer.

trigger updates

The number of RIP update packets sent as triggered updates.

The following is sample output from the show ipv6 rip database command.

Device# show ipv6 rip one database

RIP process "one", local RIB
 2001:72D:1000::/64, metric 2
     Ethernet2/2001:DB8:0:ABCD::1, expires in 168 secs
 2001:72D:2000::/64, metric 2, installed
     Ethernet2/2001:DB8:0:ABCD::1, expires in 168 secs
 2001:72D:3000::/64, metric 2, installed
     Ethernet2/2001:DB8:0:ABCD::1, expires in 168 secs
     Ethernet1/2001:DB8::1, expires in 120 secs
 2001:72D:4000::/64, metric 16, expired, [advertise 119/hold 0]
     Ethernet2/2001:DB8:0:ABCD::1
 3004::/64, metric 2 tag 2A, installed
     Ethernet2/2001:DB8:0:ABCD::1, expires in 168 secs

The table below describes the significant fields shown in the display.

Table 5 show ipv6 rip database Field Descriptions

Field

Description

RIP process

The name of the RIP process.

2001:72D:1000::/64

The IPv6 route prefix.

metric

Metric for the route.

installed

Route is installed in the IPv6 routing table.

Ethernet2/2001:DB8:0:ABCD::1

Interface and LL next hop through which the IPv6 route was learned.

expires in

The interval (in seconds) before the route expires.

advertise

For an expired route, the value (in seconds) during which the route will be advertised as expired.

hold

The value (in seconds) of the hold-down timer.

tag

Route tag.

The following is sample output from the show ipv6 rip next-hops command.

Device# show ipv6 rip one next-hops

RIP process "one", Next Hops
  FE80::210:7BFF:FEC2:ACCF/Ethernet4/2 [1 routes]
  FE80::210:7BFF:FEC2:B286/Ethernet4/2 [2 routes]

The table below describes the significant fields shown in the display.

Table 6 show ipv6 rip next-hops Field Descriptions

Field

Description

RIP process

The name of the RIP process.

2001:DB8:0:1::1/Ethernet4/2

The next-hop address and interface through which it was learned. Next hops are either the addresses of IPv6 RIP neighbors from which we have learned routes or explicit next hops received in IPv6 RIP advertisements.

Note   

An IPv6 RIP neighbor may choose to advertise all its routes with an explicit next hop. In this case the address of the neighbor would not appear in the next hop display.

[1 routes]

The number of routes in the IPv6 RIP routing table using the specified next hop.

The following is sample output from the show ipv6 rip vrf command:

Device# show ipv6 rip vrf red 
					
					RIP VRF "red", port 521, multicast-group 2001:DB8::/32, pid 295
     Administrative distance is 120. Maximum paths is 16
     Updates every 30 seconds, expire after 180
     Holddown lasts 0 seconds, garbage collect after 120
     Split horizon is on; poison reverse is off
     Default routes are not generated
     Periodic updates 99, trigger updates 3
     Full Advertisement 0, Delayed Events 0
  Interfaces:
    Ethernet0/1
    Loopback2
  Redistribution:
    None

The table below describes the significant fields shown in the display.

Table 7 show ipv6 rip vrf Field Descriptions

Field

Description

RIP VRF

The name of the RIP VRF.

port

The port that the RIP process is using.

multicast-group

The IPv6 multicast group of which the RIP process is a member.

Administrative distance

Used to rank the preference of sources of routing information. Connected routes have an administrative distance of 1 and are preferred over the same route learned by a protocol with a larger administrative distance value.

Updates

The value (in seconds) of the update timer.

expires after

The interval (in seconds) in which updates expire.

Holddown

The value (in seconds) of the hold-down timer.

garbage collect

The value (in seconds) of the garbage-collect timer.

Split horizon

The split horizon state is either on or off.

poison reverse

The poison reverse state is either on or off.

Default routes

The origination of a default route into RIP. Default routes are either generated or not generated.

Periodic updates

The number of RIP update packets sent on an update timer.

trigger updates

The number of RIP update packets sent as triggered updates.

The following is sample output from show ipv6 rip vrf next-hops command:

Device# show ipv6 rip vrf blue next-hops 
					
					RIP VRF "blue", local RIB
      AAAA::/64, metric 2, installed
     Ethernet0/0/FE80::A8BB:CCFF:FE00:7C00, expires in 177 secs

Table 8 show ipv6 rip vrf next-hops Field Descriptions

Field

Description

RIP VRF

The name of the RIP VRF.

metric

Metric for the route.

installed

Route is installed in the IPv6 routing table.

Ethernet0/0/FE80::A8BB:CCFF:FE00:7C00

The next hop address and interface through which it was learned. Next hops are either the addresses of IPv6 RIP neighbors from which we have learned routes, or explicit next hops received in IPv6 RIP advertisements.

Note   

An IPv6 RIP neighbor may choose to advertise all its routes with an explicit next hop. In this case the address of the neighbor would not appear in the next hop display.

expires in

The interval (in seconds) before the route expires.

The following is sample output from show ipv6 rip vrf database command:

Device# show ipv6 rip vrf blue database
					
								RIP VRF "blue", Next Hops
							FE80::A8BB:CCFF:FE00:7C00/Ethernet0/0 [1 paths]

Table 9 show ipv6 rip vrf database Field Descriptions

Field

Description

RIP VRF

The name of the RIP VRF.

FE80::A8BB:CCFF:FE00:7C00/Ethernet0/0

Interface and LL next hop through which the IPv6 route was learned.

1 paths

Indicates the number of unique paths to this router that exist in the routing table.

Related Commands

Command

Description

clear ipv6 rip

Deletes routes from the IPv6 RIP routing table.

debug ipv6 rip

Displays the current contents of the IPv6 RIP routing table.

ipv6 rip vrf-mode enable

Enables VRF-aware support for IPv6 RIP.

skeptical interval

To configure cautious Cisco nonstop forwarding (NSF) helper functionality with a neighbor with an interval, use the skeptical interval command in router configuration mode. To configure a cautious NSF helper with the default interval, use the no form of this command.

skeptical interval minutes

no skeptical interval

Syntax Description

minutes

Number of minutes for the interval. Range: 0 to 1440. Default: 5.

Command Default

The default interval for configuring an NSF helper is 5 minutes.

Command Modes


Router configuration (config-router)

Command History

Release

Modification

12.2(33)SXI

This command was introduced.

Usage Guidelines

When the skeptical interval command is configured with an interval, NSF will not be supported with the neighbor during this period. If you configure the skeptical interval 0 command, it means that you always support NSF with the neighbor. Whenever you configure the skeptical interval command, you should also configure the nsf interval command.

Examples

The following example configures the skeptical interval to 30 minutes:

Router(config)# router isis
Router(config-router)# skeptical interval 30
Router(config-router)#

Related Commands

Command

Description

nsf interval

Configures the minimum time between Cisco nonstop forwarding (NSF) restart attempts.

router isis

Configures an ISIS routing process for IP on an interface and attaches an area designator to the routing process.

throttle (router configuration)

To enable throttle for Routing Information Protocol (RIP) requests, use the throttlecommand in router configuration mode. To disable the configuration, use the no form of this command.

throttle

no throttle

Syntax Description

This command has no arguments or keywords.

Command Default

Throttle is not enabled by default.

Command Modes


Router configuration (config-router)

Command History

Release

Modification

12.2(31)SB14

This command was introduced.

Usage Guidelines

You can use the throttle command if you are using RIP as a routing protocol to serve a large number of routers. This command prevents RIP from generating update packets in response to RIP requests from a faulty neighbor. Because only one RIP request per minute will be serviced from a neighbor, incoming regular updates are less likely to be dropped.

You can configure the throttle command only when the interpacket delay is configured using the output-delay command.

Examples

The following example shows how to enable throttle for RIP requests:

Router# configure terminal
Router(config-router)# network 192.0.2.1
Router(config-router)# output-delay 20
Router(config-router)# throttle

Related Commands

Command

Description

output-delay

Changes the interpacket delay for RIP updates sent.

timers basic (RIP)

To adjust Routing Information Protocol (RIP) network timers, use the timers basic command in router configuration mode. To restore the default timers, use the no form of this command.

timers basic update invalid holddown flush

no timers basic

Syntax Description

update

Rate (in seconds) at which updates are sent. This is the fundamental timing parameter of the routing protocol. The default is 30 seconds.

invalid

Interval of time (in seconds) after which a route is declared invalid; it should be at least three times the value of the updateargument. A route becomes invalid when there is an absence of updates that refresh the route. The route then enters into a holddown state. The route is marked inaccessible and advertised as unreachable. However, the route is still used for forwarding packets. The default is 180 seconds.

holddown

Interval (in seconds) during which routing information regarding better paths is suppressed. It should be at least three times the value of the updateargument. A route enters into a holddown state when an update packet is received that indicates the route is unreachable. The route is marked inaccessible and advertised as unreachable. However, the route is still used for forwarding packets. When holddown expires, routes advertised by other sources are accepted and the route is no longer inaccessible. The default is 180 seconds.

flush

Amount of time (in seconds) that must pass before the route is removed from the routing table; the interval specified should be greater than the value of the invalid argument. If it is less than this sum, the proper holddown interval cannot elapse, which results in a new route being accepted before the holddown interval expires. The default is 240 seconds.

Command Default

No RIP network timers are adjusted.

Command Modes


Router configuration

Command History

Release

Modification

10.0

This command was introduced.

12.2S, 12.4T

This command was enhanced to allow for the explicit specification of timers for an address family (VRF).

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

The basic timing parameters for RIP are adjustable. Because RIP is executing a distributed, asynchronous routing algorithm, these timers must be the same for all routers and access servers in the network.


Note


The current and default timer values can be seen by inspecting the output of the show ip protocols EXEC command. The relationships of the various timers should be preserved as described previously.


In addition, an address family can have explicitly specified timers that apply to that address-family (or VRF) only. The timers basic command must be specified for an address family or the system defaults for the timers basic command are used regardless of what is configured for RIP routing. The VRF does not inherit the timer values from the base RIP configuration. The VRF will always use the system default timers unless explicitly changed using the timers basic command.

Examples

The following example sets updates to be broadcast every 5 seconds. If a router is not heard from in 15 seconds, the route is declared unusable. Further information is suppressed for an additional 15 seconds. At the end of the suppression period, the route is flushed from the routing table.

router rip
 timers basic 5  15  15  30 

Note


By setting a short update period, you run the risk of congesting slow-speed serial lines. A short update period can be a concern on faster-speed Ethernets and T1-rate serial lines. Also, if you have many routes in your updates, you can cause the routers to spend an excessive amount of time processing updates.


The following example show adjusting address family timers.

router rip
 version 2
 timers basic 5 10 15 20
 redistribute connected
 network 5.0.0.0
 default-metric 10
  no auto-summary
  !
  address-family ipv4 vrf foo
  timers basic 10 20 20 20
  redistribute connected
  network 10.0.0.0
  default-metric 5
  no auto-summary
  version 2
  exit-address-family
  !
  address-family ipv4 vrf bar
  timers basic 20 40 60 80
  redistribute connected
  network 20.0.0.0
  default-metric 2
  no auto-summary
  version 2
  exit-address-family
 !

validate-update-source

To have the Cisco IOS software valida te the source IP address of incoming routing updates for Routing Information Protocol (RIP) and Interior Gateway Routing Protocol (IGRP) routing protocols, use the validate-update-sourcecommand in router configuration mode. To disable this function, use the no form of this command.

validate-update-source

no validate-update-source

Syntax Description

This command has no arguments or keywords.

Command Default

The behavior of this command is enabled by default.

Command Modes


Router configuration

Command History

Release

Modification

10.0

This command was introduced.\

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

This command is applicable only to RIP and IGRP. The software ensures that the source IP address of incoming routing updates is on the same IP network as one of the addresses defined for the receiving interface.

Disabling split horizon on the incoming interface will also cause the system to perform this validation check.

For unnumbered IP interfaces (interfaces configured asIP unnumbered), no checking is performed.

Examples

The following example configures a router not to perform validation checks on the source IP address of incoming RIP updates:

router rip
 network 10.105.0.0
 no validate-update-source

version

To specify a Routing Information Protocol (RIP) version used globally by the router, use the version command in router configuration mode. To restore the default value, use the no form of this command.

version { 1 | 2 }

no version

Syntax Description

1

Specifies RIP Version 1.

2

Specifies RIP Version 2.

Command Default

The software receives RIP Version 1 and Version 2 packets, but sends only Version 1 packets.

Command Modes


Router configuration

Command History

Release

Modification

11.1

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

Usage Guidelines

To specify RIP versions used on an interface basis, use the ip rip receive version and ip rip send version commands.

Examples

The following example enables the software to send and receive RIP Version 2 packets:

version 2

Related Commands

Command

Description

ip rip receive version

Specifies a RIP version to receive on an interface basis.

ip rip send version

Specifies a RIP version to send on an interface basis.

show ip protocols

Displays the parameters and current state of the active routing protocol process.