IPv6 Routing: Static Routing

This feature provides static routing for IPv6. Static routes are manually configured and define an explicit path between two networking devices.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Prerequisites for IPv6 Routing: Static Routing

Before configuring the device with a static IPv6 route, you must enable the forwarding of IPv6 packets using the ipv6 unicast-routing global configuration command, enable IPv6 on at least one interface, and configure an IPv6 address on that interface.

Restrictions for IPv6 Routing: Static Routing

  • IPv6 static routes do not support the tag and permanent keywords of the IPv4 ip route command.

  • IPv6 does not support inserting static routes into virtual routing and forwarding (VRF) tables.

  • You should not configure static configurations over dynamic interfaces, because static configurations will be lost during reboot or when the user disconnects and reconnects the device.

Information About IPv6 Routing: Static Routing

Static Routes

Networking devices forward packets using route information that is either manually configured or dynamically learned using a routing protocol. Static routes are manually configured and define an explicit path between two networking devices. Unlike a dynamic routing protocol, static routes are not automatically updated and must be manually reconfigured if the network topology changes. The benefits of using static routes include security and resource efficiency. Static routes use less bandwidth than dynamic routing protocols and no CPU cycles are used to calculate and communicate routes. The main disadvantage to using static routes is the lack of automatic reconfiguration if the network topology changes.

Static routes can be redistributed into dynamic routing protocols but routes generated by dynamic routing protocols cannot be redistributed into the static routing table. No algorithm exists to prevent the configuration of routing loops that use static routes.

Static routes are useful for smaller networks with only one path to an outside network and to provide security for a larger network for certain types of traffic or links to other networks that need more control. In general, most networks use dynamic routing protocols to communicate between networking devices but may have one or two static routes configured for special cases.

Directly Attached Static Routes

In directly attached static routes, only the output interface is specified. The destination is assumed to be directly attached to this interface, so the packet destination is used as the next-hop address. This example shows such a definition:


ipv6 route 2001:DB8::/32 gigabitethernet1/0/0 

The example specifies that all destinations with address prefix 2001:DB8::/32 are directly reachable through interface GigabitEthernet1/0/0.

Directly attached static routes are candidates for insertion in the IPv6 routing table only if they refer to a valid IPv6 interface; that is, an interface that is both up and has IPv6 enabled on it.

Recursive Static Routes

In a recursive static route, only the next hop is specified. The output interface is derived from the next hop. This example shows such a definition:


ipv6 route 2001:DB8::/32 2001:DB8:3000:1

This example specifies that all destinations with address prefix 2001:DB8::/32 are reachable via the host with address 2001:DB8:3000:1.

A recursive static route is valid (that is, it is a candidate for insertion in the IPv6 routing table) only when the specified next hop resolves, either directly or indirectly, to a valid IPv6 output interface, provided the route does not self-recurse, and the recursion depth does not exceed the maximum IPv6 forwarding recursion depth.

A route self-recurses if it is itself used to resolve its own next hop. For example, suppose we have the following routes in the IPv6 routing table:


IPv6 Routing Table - 9 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
R   2001:DB8::/32 [130/0]
     via ::, Serial2/0
B   2001:DB8:3000:0/16 [200/45]
     Via 2001:DB8::0104

The following examples defines a recursive IPv6 static route:


ipv6 route 
2001:DB8::/32 2001:0BD8:3000:1

This static route will not be inserted into the IPv6 routing table because it is self-recursive. The next hop of the static route, 2001:DB8:3000:1, resolves via the BGP route 2001:DB8:3000:0/16, which is itself a recursive route (that is, it only specifies a next hop). The next hop of the BGP route, 2001:DB8::0104, resolves via the static route. Therefore, the static route would be used to resolve its own next hop.

It is not normally useful to manually configure a self-recursive static route, although it is not prohibited. However, a recursive static route that has been inserted in the IPv6 routing table may become self-recursive as a result of some transient change in the network learned through a dynamic routing protocol. If this occurs, the fact that the static route has become self-recursive will be detected and it will be removed from the IPv6 routing table, although not from the configuration. A subsequent network change may cause the static route to no longer be self-recursive, in which case it will be reinserted in the IPv6 routing table.

Fully Specified Static Routes

In a fully specified static route, both the output interface and the next hop are specified. This form of static route is used when the output interface is a multi-access one and it is necessary to explicitly identify the next hop. The next hop must be directly attached to the specified output interface. The following example shows a definition of a fully specified static route:


ipv6 route 2001:DB8:/32 gigabitethernet1/0/0 2001:DB8:3000:1

A fully specified route is valid (that is, a candidate for insertion into the IPv6 routing table) when the specified IPv6 interface is IPv6-enabled and up.

Floating Static Routes

Floating static routes are static routes that are used to back up dynamic routes learned through configured routing protocols. A floating static route is configured with a higher administrative distance than the dynamic routing protocol it is backing up. As a result, the dynamic route learned through the routing protocol is always used in preference to the floating static route. If the dynamic route learned through the routing protocol is lost, the floating static route will be used in its place. The following example defines a floating static route:


ipv6 route 2001:DB8:/32 gigabitethernet1/0/0 2001:DB8:3000:1 210

Any of the three types of IPv6 static routes can be used as a floating static route. A floating static route must be configured with an administrative distance that is greater than the administrative distance of the dynamic routing protocol, because routes with smaller administrative distances are preferred.


Note

By default, static routes have smaller administrative distances than dynamic routes, so static routes will be used in preference to dynamic routes.


How to Configure IPv6 Static Routing

Configuring a Static IPv6 Route

SUMMARY STEPS

  1. enable
  2. configure terminal
  3. ipv6 route ipv6-prefix / prefix-length ipv6-address | interface-type interface-number ipv6-address ]} [administrative-distance ] [administrative-multicast-distance | unicast | multicast ] [tag tag ]

DETAILED STEPS

  Command or Action Purpose
Step 1

enable

Example:


Device> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

Example:


Device# configure terminal

Enters global configuration mode.

Step 3

ipv6 route ipv6-prefix / prefix-length ipv6-address | interface-type interface-number ipv6-address ]} [administrative-distance ] [administrative-multicast-distance | unicast | multicast ] [tag tag ]

Example:


Device(config)# ipv6 route ::/0 serial 2/0

Configures a static IPv6 route.

  • A static default IPv6 route is being configured on a serial interface.

  • See the syntax examples that immediately follow this table for specific uses of the ipv6 route command for configuring static routes.

Configuring a Recursive IPv6 Static Route to Use a Default IPv6 Static Route

By default, a recursive IPv6 static route will not resolve using the default route (::/0). Perform this task to restore legacy behavior and allow resolution using the default route.

SUMMARY STEPS

  1. enable
  2. configure terminal
  3. ipv6 route static resolve default

DETAILED STEPS

  Command or Action Purpose
Step 1

enable

Example:


Device> enable 

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

Example:


Device# configure terminal 

Enters global configuration mode.

Step 3

ipv6 route static resolve default

Example:


Device(config)# ipv6 route static resolve default 

Allows a recursive IPv6 static route to resolve using the default IPv6 static route.

Configuring a Floating Static IPv6 Route

SUMMARY STEPS

  1. enable
  2. configure terminal
  3. ipv6 route ipv6-prefix / prefix-length {ipv6-address | interface-type interface-number ipv6-address ]} [administrative-distance ] [administrative-multicast-distance | unicast | multicast ] [tag tag ]

DETAILED STEPS

  Command or Action Purpose
Step 1

enable

Example:


Device> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

Example:


Device# configure terminal

Enters global configuration mode.

Step 3

ipv6 route ipv6-prefix / prefix-length {ipv6-address | interface-type interface-number ipv6-address ]} [administrative-distance ] [administrative-multicast-distance | unicast | multicast ] [tag tag ]

Example:


Device(config)# ipv6 route 2001:DB8::/32 serial 2/0 201

Configures a static IPv6 route.

  • In this example, a floating static IPv6 route is being configured.

  • Default administrative distances are as follows:
    • Connected interface--0
    • Static route--1
    • Enhanced Interior Gateway Routing Protocol (EIGRP) summary route--5
    • External Border Gateway Protocol (eBGP)--20
    • Internal Enhanced IGRP--90
    • IGRP--100
    • Open Shortest Path First--110
    • Intermediate System-to-Intermediate System (IS-IS)--115
    • Routing Information Protocol (RIP)--120
    • Exterior Gateway Protocol (EGP)--140
    • EIGRP external route--170
    • Internal BGP--200
    • Unknown--255

Verifying Static IPv6 Route Configuration and Operation

SUMMARY STEPS

  1. enable
  2. Do one of the following:
    • show ipv6 static [ipv6-address | ipv6-prefix / prefix-length ][interface interface-type interface-number ] [recursive ] [detail ]
    • show ipv6 route [ipv6-address | ipv6-prefix / prefix-length | protocol | interface-type interface-number ]
  3. debug ipv6 routing

DETAILED STEPS

  Command or Action Purpose
Step 1

enable

Example:


Device> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

Do one of the following:

  • show ipv6 static [ipv6-address | ipv6-prefix / prefix-length ][interface interface-type interface-number ] [recursive ] [detail ]
  • show ipv6 route [ipv6-address | ipv6-prefix / prefix-length | protocol | interface-type interface-number ]

Example:


Device# show ipv6 static

Example:


Device# show ipv6 route static

Displays the current contents of the IPv6 routing table.

  • These examples show two different ways of displaying IPv6 static routes.

Step 3

debug ipv6 routing

Example:


Device# debug ipv6 routing

Displays debugging messages for IPv6 routing table updates and route cache updates.

Configuration Examples for IPv6 Static Routing

Static routes may be used for a variety of purposes. Common usages include the following:

  • Manual summarization

  • Traffic discard

  • Fixed default route

  • Backup route

In many cases, alternative mechanisms exist within Cisco software to achieve the same objective. Whether to use static routes or one of the alternative mechanisms depends on local circumstances.

Example Configuring Manual Summarization

The following example shows a static route being used to summarize local interface prefixes advertised into RIP. The static route also serves as a discard route, discarding any packets received by the router to a 2001:DB8:1::/48 destination not covered by a more specific interface prefix.


Router> enable
Router# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)# interface gigabitethernet0/0/0
Router(config-if)# ipv6 address 2001:DB8:2:1234/64
Router(config-if)# exit
Router(config)# 
Router(config)# interface gigabitethernet1/0/0
Router(config-if)# ipv6 address 2001:DB8:3:1234/64
Router(config-if)# exit
Router(config)#
Router(config)# interface gigabitethernet2/0/0
Router(config-if)# ipv6 address 2001:DB8:4:1234/64
Router(config-if)# exit
Router(config)#
Router(config)# interface gigabitethernet3/0/0
Router(config-if)# ipv6 address 2001:DB8::1234/64
Router(config-if)# ipv6 rip one enable
Router(config-if)# exit
Router(config)#
Router(config)# ipv6 router rip one
Router(config-rtr)# redistribute static
Router(config-rtr)# exit
Router(config)#
Router(config)# ipv6 route 2001:DB8:1:1/48 null0
Router(config)# end
Router#
00:01:30: %SYS-5-CONFIG_I: Configured from console by console
Router# show ipv6 route static

IPv6 Routing Table - 3 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
S   2001:DB8:1::/48 [1/0]
     via ::, Null0

Example: Configuring Traffic Discard

Configuring a static route to point at interface null0 may be used for discarding traffic to a particular prefix. For example, if it is required to discard all traffic to prefix 2001:DB8:42:1/64, the following static route would be defined:


Device> enable
Device# configure
 terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Device(config)# ipv6 route 2001:DB8:42:1::/64 null0 
Device(config)# end

Example: Configuring a Fixed Default Route

A default static route is often used in simple router topologies. In the following example, a router is connected to its local site via GigabitEthernet 0/0/0 and to the main corporate network via Serial 2/0/0 and Serial 3/0/0. All nonlocal traffic will be routed over the two serial interfaces.


Router(config)# interface gigabitethernet0/0/0
Router(config-if)# ipv6 address 2001:DB8:17:1234/64
Router(config-if)# exit
Router(config)# interface Serial2/0/0
Router(config-if)# ipv6 address 2001:DB8:1:1234/64
Router(config-if)# exit
Router(config)# interface Serial3/0/0
Router(config-if)# ipv6 address 2001:DB8:2:124/64
Router(config-if)# exit
Router(config)# ipv6 route ::/0 Serial2/0
Router(config)# ipv6 route ::/0 Serial3/0
Router(config)# end
Router#
00:06:30: %SYS-5-CONFIG_I: Configured from console by console
Router# show ipv6 route static
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
S   ::/0 [1/0]
     via ::, Serial2/0
     via ::, Serial3/0

Example: Configuring a Floating Static Route

A floating static route often is used to provide a backup path in the event of connectivity failure. In the following example, the router has connectivity to the network core via GigabitEthernet0/0/0 and learns the route 2001:DB8:1:1/32 via IS-IS. If the GigabitEthernet0/0/0 interface fails, or if route 2001:DB8:1:1/32 is no longer learned via IS-IS (indicating loss of connectivity elsewhere in the network), traffic is routed via the backup ISDN interface.


Router> enable
Router# configure
 terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)# interface gigabitethernet0/0/0
Router(config-if)# ipv6 address 2001:DB8:17:1234/64
Router(config-if)# exit
Router(config)# interface gigabitethernet0/0/0
Router(config-if)# ipv6 address 2001:DB8:1:1234/64
Router(config-if)# ipv6
 router
 isis
Router(config-if)# exit
Router(config)# router isis
Router(config-router)# net 42.0000.0000.0000.0001.00
Router(config-router)# exit
Router(config)# interface BRI1/0
Router(config-if)# encapsulation ppp
Router(config-if)# ipv6 enable
Router(config-if)# isdn switch-type basic-net3
Router(config-if)# ppp authentication chap optional
Router(config-if)# ppp multilink
Router(config-if)# exit
Router(config)# dialer-list 1 protocol ipv6 permit
Router(config)# ipv6 route 2001:DB8:1::/32 BRI1/0 200
Router(config)# end
Router#
00:03:07: %SYS-5-CONFIG_I: Configured from console by console

Additional References

Related Documents

Related Topic

Document Title

IPv6 addressing and connectivity

IPv6 Configuration Guide

IPv6 commands

Cisco IOS IPv6 Command Reference

Cisco IOS IPv6 features

Cisco IOS IPv6 Feature Mapping

Standards and RFCs

Standard/RFC

Title

RFCs for IPv6

IPv6 RFCs

MIBs

MIB

MIBs Link

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs

Technical Assistance

Description

Link

The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html

Feature Information for IPv6 Routing: Static Routing

The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.
Table 1. Feature Information for IPv6 Routing: Static Routing

Feature Name

Releases

Feature Information

IPv6 Routing: Static Routing

12.0(22)S

12.2(2)T

12.2(14)S

12.2(17a)SX1

12.2(25)SG

12.2(28)SB

12.2(33)SRA

Cisco IOS XE Release 2.1

Static routes are manually configured and define an explicit path between two networking devices.

The following commands were introduced or modified: ipv6 route , ipv6 route static resolve default , show ipv6 route , show ipv6 static .