Graceful Shutdown Support for OSPFv3

This feature provides the ability to temporarily shut down an Open Shortest Path First version 3 (OSPFv3) process or interface in the least disruptive manner, and to notify its neighbors that it is going away. A graceful shutdown of a protocol can be initiated on all OSPFv3 interfaces or on a specific interface.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Information About Graceful Shutdown Support for OSPFv3

OSPFv3 Graceful Shutdown

The Graceful Shutdown for OSPFv3 feature provides the ability to temporarily shut down the OSPFv3 protocol in the least disruptive manner and to notify its neighbors that it is going away. All traffic that has another path through the network will be directed to that alternate path. A graceful shutdown of the OSPFv3 protocol can be initiated using the shutdown command in router configuration mode or in address family configuration mode.

This feature also provides the ability to shut down OSPFv3 on a specific interface. In this case, OSPFv3 will not advertise the interface or form adjacencies over it; however, all of the OSPFv3 interface configuration will be retained. To initiate a graceful shutdown of an interface, use the ipv6 ospf shutdown or the ospfv3 shutdown command in interface configuration mode.

How to Configure Graceful Shutdown Support for OSPFv3

Configuring Graceful Shutdown of the OSPFv3 Process

SUMMARY STEPS

  1. enable
  2. configure terminal
  3. Do one of the following:
    • ipv6 router ospf process-id
    • router ospfv3 process-id
  4. shutdown
  5. end
  6. Do one of the following:
    • show ipv6 ospf [process-id ]
    • show ospfv3 [process-id ]

DETAILED STEPS

  Command or Action Purpose
Step 1

enable

Example:

Device> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

Example:

Device# configure terminal

Enters global configuration mode.

Step 3

Do one of the following:

  • ipv6 router ospf process-id
  • router ospfv3 process-id

Example:

Device(config)# ipv6 router ospf 1

Example:

Device(config)# router ospfv3 101

Enables OSPFv3 routing and enters router configuration mode.

Step 4

shutdown

Example:

Device(config-router)# shutdown

Shuts down the selected interface.

Step 5

end

Example:

Device(config-router)# end

Returns to privileged EXEC mode.

Step 6

Do one of the following:

  • show ipv6 ospf [process-id ]
  • show ospfv3 [process-id ]

Example:

Device# show ipv6 ospf

Example:

Device# show ospfv3

(Optional) Displays general information about OSPFv3 routing processes.

Configuring Graceful Shutdown of the OSPFv3 Process in Address-Family Configuration Mode

SUMMARY STEPS

  1. enable
  2. configure terminal
  3. router ospfv3 [process-id ]
  4. address-family ipv6 unicast [vrf vrf-name]
  5. shutdown
  6. end
  7. show ospfv3 [process-id ]

DETAILED STEPS

  Command or Action Purpose
Step 1

enable

Example:


Device> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

Example:


Device# configure terminal

Enters global configuration mode.

Step 3

router ospfv3 [process-id ]

Example:


Device(config)# router ospfv3 1

Enables router configuration mode for the IPv6 address family.

Step 4

address-family ipv6 unicast [vrf vrf-name]

Example:

Device(config-router)#address-family ipv6

Enters IPv6 address family configuration mode for OSPFv3.

Step 5

shutdown

Example:


Device(config-router-af)# shutdown

Shuts down the selected interface.

Step 6

end

Example:


Device(config-router-af)# end

Returns to privileged EXEC mode.

Step 7

show ospfv3 [process-id ]

Example:

Device# show ospfv3

(Optional) Displays general information about OSPFv3 routing processes.

Configuring OSPFv3 Graceful Shutdown of the OSPFv3 Interface

SUMMARY STEPS

  1. enable
  2. configure terminal
  3. interface type number
  4. Do one of the following:
    • ipv6 ospf shutdown
    • ospfv3 shutdown
  5. end
  6. show ospfv3 process-id [area-id] [address-family] [ vrf {vrf-name | * }] interface [type number ] [brief ]

DETAILED STEPS

  Command or Action Purpose
Step 1

enable

Example:


Device> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

Example:


Device# configure terminal

Enters global configuration mode.

Step 3

interface type number

Example:


Device(config)# interface GigabitEthernet

Configures an interface type and number and enters interface configuration mode.

Step 4

Do one of the following:

  • ipv6 ospf shutdown
  • ospfv3 shutdown

Example:


Device(config-if)# ipv6 ospf shutdown

Example:


Device(config-if)# ospfv3 process-id ipv6 shutdown

Initiates an OSPFv3 protocol graceful shutdown at the interface level.

  • When the ipv6 ospf shutdown interface command is entered, the interface on which it is configured sends a link-state update advising its neighbors that is going down, which allows those neighbors to begin routing OSPFv3 traffic around this device.

Step 5

end

Example:


Device(config-if)# end

Returns to privileged EXEC mode.

Step 6

show ospfv3 process-id [area-id] [address-family] [ vrf {vrf-name | * }] interface [type number ] [brief ]

Example:


Device# show ospfv3 1 interface

(Optional) Displays OSPFv3-related interface information.

Configuration Examples for Graceful Shutdown Support for OSPFv3

Example: Configuring Graceful Shutdown of the OSPFv3 Process

The following example shows how to configure graceful shutdown of the OSPFv3 process in IPv6 router OSPF configuration mode configuration mode:

ipv6 router ospf 6
 router-id 10.10.10.10
 shutdown

The following example shows how to configure graceful shutdown of the OSPFv3 process in router OSPFv3 configuration mode:

!
router ospfv3 1
 shutdown
 !
 address-family ipv6 unicast
  exit-address-family

The following example shows how to configure graceful shutdown of the OSPFv3 process in address-family configuration mode:

!
router ospfv3 1
 !
 address-family ipv6 unicast
  shutdown
  exit-address-family

Example: Configuring Graceful Shutdown of the OSPFv3 Interface

The following example shows how to configure graceful shutdown of the OSPFv3 interface using the ipv6 ospf shutdown command:

!
interface Serial2/1
 no ip address
 ipv6 enable
 ipv6 ospf 6 area 0
 ipv6 ospf shutdown
 serial restart-delay 0
 end

The following example shows how to configure graceful shutdown of the OSPFv3 interface using the ospfv3 shutdown command:

!
interface Serial2/0
 ip address 10.10.10.10 255.255.255.0
 ip ospf 1 area 0
 ipv6 enable
 ospfv3 shutdown
 ospfv3 1 ipv6 area 0
 serial restart-delay 0
 end

Additional References for Graceful Shutdown Support for OSPFv3

Related Documents

Related Topic

Document Title

Configuring OSPF

“Configuring OSPF”

OSPF commands

Cisco IOS IP Routing: OSPF Command Reference

Cisco IOS commands

Cisco IOS Master Command List, All Releases

Technical Assistance

Description

Link

The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html

Feature Information for Graceful Shutdown Support for OSPFv3

The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.
Table 1. Feature Information for Graceful Shutdown Support for OSPFv3

Feature Name

Releases

Feature Information

Graceful Shutdown Support for OSPFv3

Cisco IOS XE Release 3.8

15.3(1)S

This feature provides the ability to temporarily shut down an Open Shortest Path First version 3 (OSPFv3) process or interface in the least disruptive manner, and to notify its neighbors that it is going away.

A graceful shutdown of a protocol can be initiated on all OSPFv3 interfaces or on a specific interface.

The following commands were introduced:

  • ipv6 ospf shutdown

  • ospfv3 shutdown

  • shutdown (router ospfv3)