Contents

Configuring UDP Forwarding Support for IP Redundancy Virtual Router Groups

User Datagram Protocol (UDP) forwarding is a feature used in Cisco IOS software to forward broadcast and multicast packets received for a specific IP address. Virtual Router Group (VRG) support, implemented with the Hot Standby Routing Protocol (HSRP), allows a set of routers to be grouped as a logical router that answers to a well-known IP address. The UDP Forwarding Support for IP Redundancy Virtual Router Groups feature enables UDP forwarding to be VRG aware; this results in packets getting forwarde only to the active router in the VRG.

This module explains the concepts related UDP forwarding and VRG support and describes how to configure UDP forwarding support for IP Redundancy Virtual Router Groups in a network.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Prerequisites for UDP Forwarding Support for IP Redundancy Virtual Router Groups

  • The UDP Forwarding Support for Virtual Router Groups feature is available only on platforms that support VRGs.

Information About UDP Forwarding Support for IP Redundancy Virtual Router Groups

Benefits of the UDP Forwarding Support for Virtual Router Groups Feature

Forwarding is limited to the active router in the VRG instead of all routers within the VRG. Prior to the implementation of this feature, the only VRG support was HSRP. Within a VRG that is formed by HSRP, the forwarding of UDP-based broadcast and multicast packets is done by all the routers within the VRG. This process can cause some DHCP servers to operate incorrectly. The UDP Forwarding Support for VRGs feature limits forwarding to the active router in the VRG.

VRG awareness is achieved with IP Redundancy Service (IRS). The IRS application programming interface (API) provides notification updates of a specific VRG, addition and deletion of a VRG, and querying of the current state of a VRG. A state change notification is provided to avoid the performance impact of querying the state of the VRG each time it is needed. The UDP forwarding code caches the VRG state for each required helper address that is defined. Each time the UDP forwarding code needs to execute, it checks the current state of the VRG associated with the helper address and forwards packets only to VRGs that are active.

How to Configure UDP Forwarding Support for IP Redundancy Virtual Router Groups

Configuring UDP Forwarding Support for IP Redundancy Virtual Router Groups

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    interface type number

    4.    no shutdown

    5.    ip address ip-address mask

    6.    ip helper-address address redundancy vrg-name

    7.    standby group-number ip ip-address

    8.    standby group-number name group-name

    9.    end


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Router> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.

     
    Step 2 configure terminal


    Example:
    Router# configure terminal
     

    Enters global configuration mode.

     
    Step 3 interface type number


    Example:
    Router(config)# interface fastethernet 0/0
     

    Specifies an interface and enters interface configuration mode.

     
    Step 4 no shutdown


    Example:
    Router(config-if)# no shutdown
     

    Restarts a disabled interface.

     
    Step 5 ip address ip-address mask


    Example:
    Router(config-if)# ip address 172.16.10.1 255.255.255.0
     

    Sets a primary address for the interface.

     
    Step 6 ip helper-address address redundancy vrg-name


    Example:
    Router(config-if)# ip helper-address 10.1.1.1 redundancy vrg1
     

    Enables UDP forwarding support for the VRG.

     
    Step 7 standby group-number ip ip-address


    Example:
    Router(config-if)# standby 1 ip 172.16.10.254
     

    Activates HSRP.

     
    Step 8 standby group-number name group-name


    Example:
    Router(config-if)# standby 1 name vrg1
     

    Configures the name of the standby group.

     
    Step 9 end


    Example:
    Router(config-if)# end
     

    Exits the current configuration mode and returns to privileged EXEC mode.

     

    Configuration Examples for UDP Forwarding Support for IP Redundancy Virtual Router Groups

    Example: Configuring UDP Forwarding Support for IP Redundancy Virtual Router Groups

    The following example shows how to configure UDP Forwarding Support for IP Redundancy Virtual Router Groups:

    Router(config)# interface fastethernet 0/0
    Router(config-if)# no shutdown
    Router(config-if)# ip address 172.16.10.1 255.255.255.0
    Router(config-if)# ip helper-address 10.1.1.1 redundancy vrg1
    Router(config-if)# standby 1 ip 172.16.10.254
    Router(config-if)# standby 1 name vrg1
    Router(config-if)# end

    Additional References

    Related Documents

    Related Topic

    Document Title

    Cisco IOS commands

    Cisco IOS Master Commands List, All Releases

    IP application services commands: complete command syntax, command mode, command history, defaults, usage guidelines, and examples

    Cisco IOS IP Application Services Command Reference

    Standards

    Standard

    Title

    No new or modified standards are supported, and support for existing standards has not been modified

    MIBs

    MIB

    MIBs Link

    No new or modified MIBs are supported, and support for existing MIBs has not been modified

    To locate and download MIBs for selected platforms, Cisco software releases, and feature sets, use Cisco MIB Locator found at the following URL:

    http:/​/​www.cisco.com/​go/​mibs

    RFCs

    RFC

    Title

    No new or modified RFCs are supported, and support for existing RFCs has not been modified

    Technical Assistance

    Description

    Link

    The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

    http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

    Feature Information for UDP Forwarding Support for IP Redundancy Virtual Router Groups

    The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

    Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

    Table 1 Feature Information for UDP Forwarding Support for IP Redundancy Virtual Router Groups

    Feature Name

    Releases

    Feature Information

    UDP Forwarding Support for IP Redundancy Virtual Router Group

    Cisco IOS XE 3.1.0SG

    12.2(50)SY

    12.2(15)T

    15.0(1)SY

    15.2(1)S

    UDP forwarding is a feature used in Cisco IOS software to forward broadcast and multicast packets received for a specific IP address. Virtual Router Group (VRG) support is implemented with the Hot Standby Routing Protocol (HSRP) and it allows a set of routers to be grouped as a logical router that answers to a well-known IP address. The UDP Forwarding Support for IP Redundancy Virtual Router Groups feature enables UDP forwarding to be VRG aware, resulting in forwarding only to the active router in the VRG.

    The following command was introduced or modified: ip helper-address.


    Configuring UDP Forwarding Support for IP Redundancy Virtual Router Groups

    Configuring UDP Forwarding Support for IP Redundancy Virtual Router Groups

    User Datagram Protocol (UDP) forwarding is a feature used in Cisco IOS software to forward broadcast and multicast packets received for a specific IP address. Virtual Router Group (VRG) support, implemented with the Hot Standby Routing Protocol (HSRP), allows a set of routers to be grouped as a logical router that answers to a well-known IP address. The UDP Forwarding Support for IP Redundancy Virtual Router Groups feature enables UDP forwarding to be VRG aware; this results in packets getting forwarde only to the active router in the VRG.

    This module explains the concepts related UDP forwarding and VRG support and describes how to configure UDP forwarding support for IP Redundancy Virtual Router Groups in a network.

    Finding Feature Information

    Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

    Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

    Prerequisites for UDP Forwarding Support for IP Redundancy Virtual Router Groups

    • The UDP Forwarding Support for Virtual Router Groups feature is available only on platforms that support VRGs.

    Information About UDP Forwarding Support for IP Redundancy Virtual Router Groups

    Benefits of the UDP Forwarding Support for Virtual Router Groups Feature

    Forwarding is limited to the active router in the VRG instead of all routers within the VRG. Prior to the implementation of this feature, the only VRG support was HSRP. Within a VRG that is formed by HSRP, the forwarding of UDP-based broadcast and multicast packets is done by all the routers within the VRG. This process can cause some DHCP servers to operate incorrectly. The UDP Forwarding Support for VRGs feature limits forwarding to the active router in the VRG.

    VRG awareness is achieved with IP Redundancy Service (IRS). The IRS application programming interface (API) provides notification updates of a specific VRG, addition and deletion of a VRG, and querying of the current state of a VRG. A state change notification is provided to avoid the performance impact of querying the state of the VRG each time it is needed. The UDP forwarding code caches the VRG state for each required helper address that is defined. Each time the UDP forwarding code needs to execute, it checks the current state of the VRG associated with the helper address and forwards packets only to VRGs that are active.

    How to Configure UDP Forwarding Support for IP Redundancy Virtual Router Groups

    Configuring UDP Forwarding Support for IP Redundancy Virtual Router Groups

    SUMMARY STEPS

      1.    enable

      2.    configure terminal

      3.    interface type number

      4.    no shutdown

      5.    ip address ip-address mask

      6.    ip helper-address address redundancy vrg-name

      7.    standby group-number ip ip-address

      8.    standby group-number name group-name

      9.    end


    DETAILED STEPS
       Command or ActionPurpose
      Step 1 enable


      Example:
      Router> enable
       

      Enables privileged EXEC mode.

      • Enter your password if prompted.

       
      Step 2 configure terminal


      Example:
      Router# configure terminal
       

      Enters global configuration mode.

       
      Step 3 interface type number


      Example:
      Router(config)# interface fastethernet 0/0
       

      Specifies an interface and enters interface configuration mode.

       
      Step 4 no shutdown


      Example:
      Router(config-if)# no shutdown
       

      Restarts a disabled interface.

       
      Step 5 ip address ip-address mask


      Example:
      Router(config-if)# ip address 172.16.10.1 255.255.255.0
       

      Sets a primary address for the interface.

       
      Step 6 ip helper-address address redundancy vrg-name


      Example:
      Router(config-if)# ip helper-address 10.1.1.1 redundancy vrg1
       

      Enables UDP forwarding support for the VRG.

       
      Step 7 standby group-number ip ip-address


      Example:
      Router(config-if)# standby 1 ip 172.16.10.254
       

      Activates HSRP.

       
      Step 8 standby group-number name group-name


      Example:
      Router(config-if)# standby 1 name vrg1
       

      Configures the name of the standby group.

       
      Step 9 end


      Example:
      Router(config-if)# end
       

      Exits the current configuration mode and returns to privileged EXEC mode.

       

      Configuration Examples for UDP Forwarding Support for IP Redundancy Virtual Router Groups

      Example: Configuring UDP Forwarding Support for IP Redundancy Virtual Router Groups

      The following example shows how to configure UDP Forwarding Support for IP Redundancy Virtual Router Groups:

      Router(config)# interface fastethernet 0/0
      Router(config-if)# no shutdown
      Router(config-if)# ip address 172.16.10.1 255.255.255.0
      Router(config-if)# ip helper-address 10.1.1.1 redundancy vrg1
      Router(config-if)# standby 1 ip 172.16.10.254
      Router(config-if)# standby 1 name vrg1
      Router(config-if)# end

      Additional References

      Related Documents

      Related Topic

      Document Title

      Cisco IOS commands

      Cisco IOS Master Commands List, All Releases

      IP application services commands: complete command syntax, command mode, command history, defaults, usage guidelines, and examples

      Cisco IOS IP Application Services Command Reference

      Standards

      Standard

      Title

      No new or modified standards are supported, and support for existing standards has not been modified

      MIBs

      MIB

      MIBs Link

      No new or modified MIBs are supported, and support for existing MIBs has not been modified

      To locate and download MIBs for selected platforms, Cisco software releases, and feature sets, use Cisco MIB Locator found at the following URL:

      http:/​/​www.cisco.com/​go/​mibs

      RFCs

      RFC

      Title

      No new or modified RFCs are supported, and support for existing RFCs has not been modified

      Technical Assistance

      Description

      Link

      The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

      http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

      Feature Information for UDP Forwarding Support for IP Redundancy Virtual Router Groups

      The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

      Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

      Table 1 Feature Information for UDP Forwarding Support for IP Redundancy Virtual Router Groups

      Feature Name

      Releases

      Feature Information

      UDP Forwarding Support for IP Redundancy Virtual Router Group

      Cisco IOS XE 3.1.0SG

      12.2(50)SY

      12.2(15)T

      15.0(1)SY

      15.2(1)S

      UDP forwarding is a feature used in Cisco IOS software to forward broadcast and multicast packets received for a specific IP address. Virtual Router Group (VRG) support is implemented with the Hot Standby Routing Protocol (HSRP) and it allows a set of routers to be grouped as a logical router that answers to a well-known IP address. The UDP Forwarding Support for IP Redundancy Virtual Router Groups feature enables UDP forwarding to be VRG aware, resulting in forwarding only to the active router in the VRG.

      The following command was introduced or modified: ip helper-address.