
Cisco UCS Director Administration Guide, Release 6.6
First Published: 2018-04-30

Americas Headquarters
Cisco Systems, Inc.
170 West Tasman Drive
San Jose, CA 95134-1706
USA
http://www.cisco.com
Tel: 408 526-4000

800 553-NETS (6387)
Fax: 408 527-0883



THE SPECIFICATIONS AND INFORMATION REGARDING THE PRODUCTS IN THIS MANUAL ARE SUBJECT TO CHANGE WITHOUT NOTICE. ALL STATEMENTS,
INFORMATION, AND RECOMMENDATIONS IN THIS MANUAL ARE BELIEVED TO BE ACCURATE BUT ARE PRESENTED WITHOUT WARRANTY OF ANY KIND,
EXPRESS OR IMPLIED. USERS MUST TAKE FULL RESPONSIBILITY FOR THEIR APPLICATION OF ANY PRODUCTS.

THE SOFTWARE LICENSE AND LIMITED WARRANTY FOR THE ACCOMPANYING PRODUCT ARE SET FORTH IN THE INFORMATION PACKET THAT SHIPPED WITH
THE PRODUCT AND ARE INCORPORATED HEREIN BY THIS REFERENCE. IF YOU ARE UNABLE TO LOCATE THE SOFTWARE LICENSE OR LIMITED WARRANTY,
CONTACT YOUR CISCO REPRESENTATIVE FOR A COPY.

The Cisco implementation of TCP header compression is an adaptation of a program developed by the University of California, Berkeley (UCB) as part of UCB's public domain version of
the UNIX operating system. All rights reserved. Copyright © 1981, Regents of the University of California.

NOTWITHSTANDING ANY OTHERWARRANTY HEREIN, ALL DOCUMENT FILES AND SOFTWARE OF THESE SUPPLIERS ARE PROVIDED “AS IS" WITH ALL FAULTS.
CISCO AND THE ABOVE-NAMED SUPPLIERS DISCLAIM ALL WARRANTIES, EXPRESSED OR IMPLIED, INCLUDING, WITHOUT LIMITATION, THOSE OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OR ARISING FROM A COURSE OF DEALING, USAGE, OR TRADE PRACTICE.

IN NO EVENT SHALL CISCO OR ITS SUPPLIERS BE LIABLE FOR ANY INDIRECT, SPECIAL, CONSEQUENTIAL, OR INCIDENTAL DAMAGES, INCLUDING, WITHOUT
LIMITATION, LOST PROFITS OR LOSS OR DAMAGE TO DATA ARISING OUT OF THE USE OR INABILITY TO USE THIS MANUAL, EVEN IF CISCO OR ITS SUPPLIERS
HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display output, network
topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative content is unintentional
and coincidental.

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates in the U.S. and other countries. To view a list of Cisco trademarks, go to this URL:
https://www.cisco.com/go/trademarks. Third-party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship
between Cisco and any other company. (1721R)

© 2018 Cisco Systems, Inc. All rights reserved.

https://www.cisco.com/go/trademarks


C O N T E N T S

Full Cisco Trademarks with Software License ?

Preface xviiP R E F A C E

Audience xvii

Conventions xvii

Documentation Feedback xix

Obtaining Documentation and Submitting a Service Request xix

New and Changed Information for this Release 1C H A P T E R 1

New and Changed Information for this Release 1

Overview 5C H A P T E R 2

Cisco UCS Director 5

Features and Benefits 6

Physical and Virtual Management Features 7

Model-Based Orchestration 8

New User Interface of Cisco UCS Director 9

Landing Page 10

Common Icons 12

Converged View 14

Generating Additional Reports for a Cloud Account 14

Switching to the Classic View 14

Guided Setup Wizards in Cisco UCS Director 15

Creating a Wizard from a Workflow 15

Setting up Non-Secure Connection to the Cisco UCS Director User Interface 16

Initial Login 17

Cisco UCS Director Administration Guide, Release 6.6
iii



Recommended Order of System Setup 17

Configuring the Host Name for Cisco UCS Director 19

Working with Ciphers 20

Editing Cipher Usage 20

Installing the Latest Java Cryptograpy Extension (JCE) Policy Files 20

Managing Users and Groups 23C H A P T E R 3

User Roles 23

Adding a User Role 25

Adding Users 26

Managing User Types 28

Default User Permissions 28

User Roles and Permissions 28

Permissions for Server Management 31

All Policy Admin 32

Billing Admin 33

Computing Admin 35

Group Admin 37

IS Admin 38

Network Admin 40

Operator 42

Service End User 43

Storage Admin 45

Viewing User Role Information for Users 47

Reviewing Recent Login History of Users 47

Configuring Session Limits for Users 48

Managing User Account Status 48

Unassigning Resources From a User 49

Disabling a User Account in Cisco UCS Director 49

Disabling User Accounts within a Group 50

MSP Administrator Role 50

Managing Groups 51

Creating a User Group 51

Using the Global Dashlet Setup Option 53

Cisco UCS Director Administration Guide, Release 6.6
iv

Contents



Creating an MSP Organization 53

Creating a Customer Organization 54

Password Policy 55

Creating a Password Policy 56

Group Budget Policy 57

Viewing and Editing a Group Budget Policy 57

Resource Limits 57

Viewing Resource Limits 58

Editing Resource Limits 58

Configuring the Administration Profile 61

Creating the Admin Profile 61

Editing Your Administrative Profile 62

Sending a Broadcast Message 63

Changing the Admin Password 63

Viewing Current Online Users 64

Managing User Access Profiles 64

Multi-Role Access Profiles 64

Creating a User Access Profile 65

Logging in to a Profile 65

Default Profile 66

Changing a Default Profile 66

Authentication and LDAP Integration 66

Configuring Authentication Preferences 67

LDAP Integration 67

Single Sign On 79

Branding for Customer Organizations 85

Branding User Groups 86

Branding Customer Organizations 87

Login Page Branding 88

Configuring a Custom Domain Logo 88

Setting Up the End User Portal 89C H A P T E R 4

End User Portal 89

Summary of Tasks to Set Up the End User Portal 89

Cisco UCS Director Administration Guide, Release 6.6
v

Contents



Setting Up User Accounts for the End User Portal 90

Creating a User Group 90

Adding Users 91

Setting Permissions for the End User Portal 93

Permissions Required for Approvals 93

Permissions Required for Catalogs 93

Permissions Required for Budget Entries 94

Physical Resources 94

Permissions Required for CloudSense Reports 94

Permissions Required for Rack Servers 94

Permissions Required for Servers 95

Permissions Required for Service Profiles 95

Permissions Required for SnapMirrors 95

Permissions Required for Storage Virtual Machines 95

Permissions Required for vFilers 96

Permissions Required for SVM Initiator Groups 96

Permissions Required for SVM LUNs 96

Permissions Required for SVM CIFS Shares 96

Permissions Required for SVM Export Policies 97

Permissions Required for SVM Export Rules 97

Permissions Required for SVM Initiators 97

Permissions Required for SVM Port Sets 97

Permissions Required for SVM SIS Policies 97

Permissions Required for SVM Snapshot Policies 98

Permissions Required for SVMWWPN Aliases 98

Permissions Required for SVM Volume Snapshots 98

Permissions Required for SVM Volumes 98

Permissions Required for vFiler Volumes 99

Services 100

Permissions Required for Payment Information 100

Permissions Required for Service Requests 100

Permissions Required for User OVF Management 100

Virtual Resources 101

Permissions Required for Application Containers 101

Cisco UCS Director Administration Guide, Release 6.6
vi

Contents



Permissions Required for VMs 101

Permissions Required for Images 102

Setting Up the User Interface of the End User Portal 102

Configuring Dashlets 103

Changing Colors of Dashlet Reports 104

Selecting Catalogs for End User Portal 104

Managing System Administration Settings 107C H A P T E R 5

Setting up the Outgoing Mail Server 107

Working with Email Templates 108

Adding an Email Template 109

Previewing an Email Template 109

Setting a Default Email Template 110

Configuring System Parameters (Optional) 110

Configuring System Parameters 110

Configuring Infrastructure System Parameters (Optional) 111

Configuring Proxy Settings 112

Running an Object Search 112

Updating the License 113

Replacing a License 113

Verifying License Utilization 114

Viewing License Utilization History 114

Viewing Resource Usage Data 115

Viewing Deactivated License Information 115

Application Categories 115

Adding Application Categories 116

Customizing the Portal 117

Customizing the Login Page and Background Images 117

Customizing the Application Logo 118

Customizing Favicons 119

Customizing Application Header 120

Customizing Date Display 120

Customizing the Color Theme 121

Customizing Logout Redirect 121

Cisco UCS Director Administration Guide, Release 6.6
vii

Contents



Customizing Reports 121

Enabling Advanced Controls 122

Enabling the Service Provider Feature 123

User Menus 123

Setting User Menus 123

Setting User Permissions 124

System Tasks 124

Creating a Node Pool 125

Creating a System Task Policy 125

Assigning a Node Pool to a System Task Policy 126

Creating a Service Node 126

Assigning a System Policy to a System Task 127

Executing System Tasks 127

Disabling or Enabling a System Task 128

Scheduling a System Task 128

System Tasks with Fixed Rate Option 130

Managing Icons in the Cisco UCS Director User Interface 130

Modifying an Icon in the Cisco UCS Director User Interface 131

Editing an Icon 132

Deleting an Icon 132

Previewing an Icon 133

Tag Library 133

Creating a Tag 133

Support Information 135

Viewing System Information 135

Showing Logs 136

Downloading Logs 136

Starting the Debug Log 137

Generating API Logs 137

Database Audit Logging 137

Enabling Audit Logging 138

Device Connector 138

Configuring Device Connector 139

Launching Cisco UCS Director from Cisco Intersight 139

Cisco UCS Director Administration Guide, Release 6.6
viii

Contents



Connector Pack Management 141

Upgrading Connector Packs 142

Viewing Connector Pack Upgrade Information 143

Managing Integration Settings 145C H A P T E R 6

About Integration Settings 145

Configuration Management Database Integration 145

Setting Up CMBD Integration 145

Metering Data Export 146

Setting Up Metering Data Export 146

Change Records 147

Viewing Change Records 147

System Logs 147

Setting up System Logs 147

Storage and OVF Upload 148

Multiple Language Support 148

Choosing a Language for Cisco UCS Director 149

Setting a Locale for the User Interface 149

Managing a Physical Infrastructure 151C H A P T E R 7

About Managing a Physical Infrastructure 151

Using the Converged View 151

Adding a Site 152

Adding a Pod 152

Adding a Physical Account 154

Adding a Multi-Domain Manager Account 155

Adding a Network Element 157

Enabling DHCP Logging 158

Testing Connectivity 158

Testing Connectivity of Managed Network Elements 158

Testing the Connection to a Physical Account 158

Enabling Device Discovery 159

Managing a Virtual Infrastructure 161C H A P T E R 8

Cisco UCS Director Administration Guide, Release 6.6
ix

Contents



About Managing VMware Clouds 161

Creating a VMware Cloud 162

Downloading the PowerShell Agent Installer 165

Creating a PowerShell Agent 165

Verifying Cloud Discovery and Connectivity 166

Testing the Connection 166

Viewing vCenter Plug-ins 166

Provisioning Virtual Machines in Cisco UCS Director 167

Managing Policies 169C H A P T E R 9

Policies 169

Computing Policies 170

Creating a Computing Policy 170

Configuring a Bare Metal Server Provisioning Policy 172

Validating a Bare Metal Server Provisioning Policy 176

Data Collection Policy 176

Configuring a Data Collection Policy for a Virtual Account 177

Associating the Data Collection Policy for a Virtual Account 178

About Group Share Policy 179

Creating a Group Share Policy 179

Storage Policies 180

Storage Policies for Multiple VM Disks 180

Adding and Configuring a Storage Policy 180

Virtual Storage Catalogs 186

Configuring a Virtual Storage Catalog 186

Credential Policies 187

Configuring a Credential Policy 188

Network Policies 188

Adding a Static IP Pool Policy 188

Configuring a IP Subnet Pool Policy 190

Adding a Network Policy 191

Networking Provisioning Policies 193

Configuring a Network Provisioning Policy 193

VLAN Pool Policies 195

Cisco UCS Director Administration Guide, Release 6.6
x

Contents



Configuring a VLAN Pool Policy 195

System Policies 195

Configuring a System Policy 196

OS Licenses 201

Adding an OS License 201

End User Self-Service Policy 202

Creating an End User Policy 203

Configuring a VM Management Policy 203

Managing Virtual Data Centers 207C H A P T E R 1 0

Virtual Data Centers 207

VDC Actions 207

Adding a Virtual Data Center 207

Viewing a Virtual Data Center 211

Managing Application Categories in a Virtual Data Centers 211

Assigning an Application Category to Multiple VDCs 211

Virtual Data Center Service Profiles 212

Adding a Virtual Data Center Service Profile 213

Managing Resource Groups 217C H A P T E R 1 1

Resource Groups 217

Environment Variables 217

Adding a Custom Environment Variable 226

Adding a Resource Group 227

Editing a Resource Group 235

Adding a Pod to a Resource Group 236

Managing Tags of a Resource Group 237

Deleting a Resource Group 238

Tenant 239

Service Offerings 239

Adding a Service Offering 240

Cloning a Service Offering 243

Editing a Service Offering 246

Deleting a Service Offering 249

Cisco UCS Director Administration Guide, Release 6.6
xi

Contents



Tenant Profiles 249

Adding a Tenant Profile 250

Troubleshooting a Service Offering List 251

Cloning a Tenant Profile 252

Editing a Tenant Profile 253

Deleting a Tenant Profile 254

Managing Catalogs 257C H A P T E R 1 2

About Managing Catalogs 257

Publishing a Catalog 258

About Publishing Advanced Catalogs 265

Publishing Advanced Catalogs 265

Creating a Bare Metal Server Catalog 266

Reordering Catalogs Within a Folder 268

Accessing Hosts for Deployment 268

Reordering Catalog Folders 269

Using Self-Service Provisioning 271C H A P T E R 1 3

Self-Service Provisioning 271

Service Requests 271

Creating a Service Request with Catalog Type—Standard 272

Creating a Service Request with Catalog Type—Advanced 277

Creating a Service Request with Catalog Type—Bare Metal 278

Service Request Workflow and Details 281

Service Request Workflow 281

Service Request Details 283

Viewing the Workflow Status of a Service Request 284

Viewing Log Details for a Service Request 284

About Scheduling a Service Request 285

Scheduling Service Requests 285

About Resubmitting a Service Request 285

Resubmitting a Service Request 285

Other Service Request Functions 286

Canceling a Service Request 286

Cisco UCS Director Administration Guide, Release 6.6
xii

Contents



Rolling Back a Service Request 286

Archiving a Service Request 287

Deleting Service Requests 287

Viewing Service Requests for a Particular Group 288

Searching the Records of Service Requests for a Group 288

Exporting a Report of Service Requests for a Group 289

Reinstating an Archived Service Request 289

Service Request Approval Process 289

Approving a Service Request 290

Rejecting a Service Request 290

Viewing Approval Information on Service Requests 290

Searching the Records of Service Request Approvals 290

Exporting a Report of Service Request Approvals 291

Service Request Budgeting 291

Viewing the Current Month Budget Availability 291

Viewing Budget Entries 291

Adding a Budget Entry 291

Multiple Disk VM Provisioning 293C H A P T E R 1 4

About Multiple Disk VM Provisioning 293

Overview of the Procedure for Multiple Disk VM Provisioning 293

About Templates with Multiple Disks 294

Assigning Disk Categories 294

Defining Storage Policies 294

Creating a Storage Policy 295

Creating a Catalog 300

Adding a Catalog 300

Creating a VM Disk 307

Using the Chargeback Module 311C H A P T E R 1 5

About Chargeback Features 311

Budget Policies 312

Configuring a Budget Policy 312

Creating a Tag-Based Cost Model 312

Cisco UCS Director Administration Guide, Release 6.6
xiii

Contents



Cost Models 313

Creating a Cost Model 314

Creating a Bare Metal Cost Model 316

Modifying a VDC to Include a Cost Model 317

Adding a Cost Model to a VDC 317

Editing a VDC to Include a Cost Model 319

Package-Based Cost Models 320

Creating a Package-Based Cost Model 320

Storage Tier Cost Models 322

Assigning a Cost to a Tier 322

About Assigning a Datastore to Tiers 322

Assigning a Datastore to a Tier 322

Chargeback Reports 323

Viewing the Current Month Summary 324

Viewing the Previous Month’s Summary 324

Viewing Monthly Resource Accounting Information 324

Viewing the VM Level Resource Accounting Details 325

Viewing the VM Level Chargeback Details 325

Exporting the Monthly Resource Accounting Details 325

Exporting VM Level Resource Accounting Details 326

Exporting VM Level Chargeback Details 326

About Change Records 327

Accessing Change Records 327

Chargeback Calculations 327

System Monitoring and Reporting 331C H A P T E R 1 6

Dashboard 331

Enabling the Dashboard 331

Creating Additional Dashboards 332

Deleting a Dashboard 332

Adding Report Widgets 332

Refreshing Widget Data 333

Summary 333

Viewing Virtual Machine, Cloud, and System Summary Information 333

Cisco UCS Director Administration Guide, Release 6.6
xiv

Contents



Customizing Summary Report Widgets 333

Inventory Management 333

Accessing System Inventory Details 333

Resource Pools 334

Accessing Resource Details 334

Clusters 334

Accessing Clusters 335

Images 335

Accessing Images 335

Assigning VM Images to Users or Groups 335

Host Nodes 336

Accessing Host Nodes 336

Virtual Machines (VMs) 336

Accessing VMs 336

Accessing Group Level VMs 337

Topology 337

Accessing Topology Types 337

Assessment 337

Accessing Assessments 338

Reports 338

Accessing Reports 338

Managing Lifecycles 339C H A P T E R 1 7

Managing VM Power Settings 339

Managing VM Snapshots 340

Creating VM Snapshots 340

Reverting to a Snapshot 341

Marking a Golden Snapshot 341

Deleting a Snapshot 342

Deleting All Snapshots 342

Configuring the Lease Time for a Virtual Machine 342

Managing VM Actions 343

Viewing VM Details 344

Resizing VMs 344

Cisco UCS Director Administration Guide, Release 6.6
xv

Contents



Using the Stack View Option 345

Creating a VM Disk 346

Resizing a VM Disk 347

Locking VMs in Cisco UCS Director 348

Adding vNICs 349

Replacing a vNIC 350

Launching the VM Client 351

Enabling the VNC Console on a VM 352

Automatically Unconfiguring the VNC Console on a VM 352

Accessing VM Console Using VNC Client 353

Configuring ESX/ESXi Server for VNC Access to VM Console 354

Assigning a VM 355

VM Credentials 356

Viewing VM Credentials 356

Initiating Inventory Collection for a VM 356

Testing VNC Connectivity 357

Cloning a VM 357

Moving a VM to VDC 362

Resynchronizing a VM 362

Applying a Tag to a VM 362

Mounting an ISO Image as a CD/DVD Drive 363

Unmounting an ISO Image as a CD/DVD Drive 364

Managing CloudSense Analytics 365C H A P T E R 1 8

CloudSense Analytics 365

Generating a Report 366

Generating an Assessment 367

Report Builder for Custom Report Templates 368

Creating a Report Builder Template 368

Generating a Report from a Template 370

Viewing Reports Generated From a Template 371

Emailing Reports Generated From a Template 371

Cisco UCS Director Administration Guide, Release 6.6
xvi

Contents



Preface

This preface contains the following sections:

• Audience, on page xvii
• Conventions, on page xvii
• Documentation Feedback, on page xix
• Obtaining Documentation and Submitting a Service Request, on page xix

Audience
This guide is intended primarily for data center administrators who use Cisco UCS Director and who have
responsibilities and expertise in one or more of the following:

• Server administration

• Storage administration

• Network administration

• Network security

• Virtualization and virtual machines

Conventions
IndicationText Type

GUI elements such as tab titles, area names, and field labels appear in this font.

Main titles such as window, dialog box, and wizard titles appear in this font.

GUI elements

Document titles appear in this font.Document titles

In a Text-based User Interface, text the system displays appears in this font.TUI elements

Terminal sessions and information that the system displays appear in this
font.

System output

Cisco UCS Director Administration Guide, Release 6.6
xvii



IndicationText Type

CLI command keywords appear in this font.

Variables in a CLI command appear in this font.

CLI commands

Elements in square brackets are optional.[ ]

Required alternative keywords are grouped in braces and separated by vertical
bars.

{x | y | z}

Optional alternative keywords are grouped in brackets and separated by vertical
bars.

[x | y | z]

A nonquoted set of characters. Do not use quotation marks around the string or
the string will include the quotation marks.

string

Nonprinting characters such as passwords are in angle brackets.< >

Default responses to system prompts are in square brackets.[ ]

An exclamation point (!) or a pound sign (#) at the beginning of a line of code
indicates a comment line.

!, #

Means reader take note. Notes contain helpful suggestions or references to material not covered in the
document.

Note

Means reader be careful. In this situation, you might perform an action that could result in equipment damage
or loss of data.

Caution

Means the following information will help you solve a problem. The tips information might not be
troubleshooting or even an action, but could be useful information, similar to a Timesaver.

Tip

Means the described action saves time. You can save time by performing the action described in the paragraph.Timesaver

IMPORTANT SAFETY INSTRUCTIONS

This warning symbol means danger. You are in a situation that could cause bodily injury. Before you work
on any equipment, be aware of the hazards involved with electrical circuitry and be familiar with standard
practices for preventing accidents. Use the statement number provided at the end of each warning to locate
its translation in the translated safety warnings that accompanied this device.

SAVE THESE INSTRUCTIONS

Warning
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Documentation Feedback
To provide technical feedback on this document, or to report an error or omission, please send your comments
to ucs-director-docfeedback@cisco.com. We appreciate your feedback.

Obtaining Documentation and Submitting a Service Request
For information on obtaining documentation, submitting a service request, and gathering additional information,
see the monthly What's New in Cisco Product Documentation, which also lists all new and revised Cisco
technical documentation.

Subscribe to theWhat's New in Cisco Product Documentation as a Really Simple Syndication (RSS) feed
and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a free
service and Cisco currently supports RSS version 2.0.

Cisco UCS Director Administration Guide, Release 6.6
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C H A P T E R 1
New and Changed Information for this Release

This chapter contains the following section:

• New and Changed Information for this Release, on page 1

New and Changed Information for this Release
The following table provides an overview of the significant changes to this guide for release 6.6(1.0). The
table does not provide an exhaustive list of all changes made to this guide or of all new features in this release.
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Where DocumentedDescriptionFeature

Adding Users, on page 26

Viewing User Role Information for
Users, on page 47

This release introduces the
following password related
enhancements:

• TheUsers screen displays the
password expiry date and time
for each user. This
information is derived from
the Password policy that is
configured in the system.

The Users screen also
graphically represents the
password expiry status for
each user. A new column
titled Password Expiry
Status displays a green icon
for passwords that have not
yet expired, and a red icon for
passwords that have expired.

• All users will receive an email
notification when their
passwords are reset or
modified by the administrator.

• While upgrading the Cisco
UCS Director version, the
UpdatePatch.log now
displays password expiry
related information for the
administrator user.

Password related enhancements

Configuring Proxy Settings, on
page 112

You can enable proxy configuration
on the system. It is a system-wide
configuration.

Proxy Configuration

Single Sign-on with Ping Federate,
on page 82

You can enable Single Sign-On
(SSO) using Ping Federate.

You cannot enable SSO using
OneLogin and Ping Federate
simultaneously.

Support for IDP initiated Single
Sign-On using Ping Federate

The following table provides an overview of the significant changes to this guide for release 6.6. The table
does not provide an exhaustive list of all changes made to this guide or of all new features in this release.
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Where DocumentedDescriptionFeature

Managing LDAP Integration, on
page 70

Configuring LDAP Servers, on
page 71

Adding LDAP Search BaseDN
Entries, on page 75

While configuring an LDAP server,
you can choose to add search based
OUs manually to the system.

Also, at any point, you can enable
or disable the manual search based
OU integration.

New option to provide OUs
manually and synchronize the user
records with the LDAP server.

Device Connector, on page 138

Launching Cisco UCS Director
from Cisco Intersight, on page 139

This release of Cisco UCSDirector
introduces a new tab calledDevice
Connector in the Administration
menu.

Using this tab, you can enable or
disable the device connector that
establishes a bi-directional
communication between Cisco
Intersight and Cisco UCSDirector.

After a connection is established,
you can launch CiscoUCSDirector
from Cisco Intersight.

Introduction of the Device
Connector tab.

Adding a Virtual Data Center, on
page 207

Service RequestWorkflow, on page
281

While adding a virtual data center,
you can now choose either user
groups or users as first level and
second level approvers.

If you choose user groups as
approvers, then you can also
specify if the task requires
approvals from all users within the
chosen groups.

TheWorkflow Status screen for a
service request will also display
names of the user groups that have
been selected as approvers.

Support for selecting user groups
to approve adding, editing or
cloning a virtual data center.

Creating a Service Request with
Catalog Type—Advanced, on page
277

While creating a service request
using an advanced catalog, the
Summary screen displays
information on all the values that
you entered while creating the
service request.

While provisioning a VM using an
advanced catalog, the Summary
screen displays the approximate SR
cost estimate.

Additional information displayed
in the Summary screen while
creating a service request using an
advanced catalog.
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Where DocumentedDescriptionFeature

Using the Global Dashlet Setup
Option, on page 53

With this option, you can configure
the number of dashlets that users
within all groups can view when
they login to the End User Portal.

Introduction of theGlobal Dashlet
option to customize the availability
of dashlets in the end user portal
for service end-users.

Adding Users, on page 26In the prior release, while adding
or modifying a user, you could
check theLoginwith Classic View
check box. This check box has been
removed as the Classic View is no
longer available.

Removed the Login with Classic
View check box

Publishing a Catalog, on page 258This release of Cisco UCSDirector
introduces support for executing
orchestration workflows before
provisioning VMs using a standard
catalog.

Support for executing
pre-provisioning workflows while
provisioning VMs using a standard
catalog.

Scheduling a SystemTask, on page
128

System Tasks with Fixed Rate
Option, on page 130

This release of Cisco UCSDirector
introduces an option to schedule a
system task with a Fixed Delay
option. This option implies a fixed
amount of time gap between
consecutive executions of a system
task.

By default, most system tasks are
configured with the Fixed Delay
option. However, there are a few
tasks that are configured only with
the Fixed Rate option.

This release also introduces the
capability to configure a
customized frequency for the
system tasks.

Enhanced scheduling capabilities
for system tasks.

Editing Resource Limits, on page
58

This release of Cisco UCSDirector
introduces support for configuring
resource limits for provisioning
Hyper-V systems.

Resource limits support for
Hyper-V provisioning

Connector Pack Management, on
page 141

Upgrading Connector Packs, on
page 142

This release introduces support for
upgrading connector packs from
the graphical user interface of Cisco
UCS Director.

Upgrading Connector Packs

Cisco UCS Director Administration Guide, Release 6.6
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C H A P T E R 2
Overview

This chapter contains the following sections:

• Cisco UCS Director, on page 5
• Setting up Non-Secure Connection to the Cisco UCS Director User Interface, on page 16
• Initial Login, on page 17
• Recommended Order of System Setup, on page 17
• Configuring the Host Name for Cisco UCS Director, on page 19
• Working with Ciphers, on page 20

Cisco UCS Director
Cisco UCS Director is a complete, highly secure, end-to-end management, orchestration, and automation
solution for a wide array of Cisco and non-Cisco data infrastructure components, and for the industry's leading
converged infrastructure solutions based on the Cisco UCS and Cisco Nexus platforms. For a complete list
of supported infrastructure components and solutions, see the Cisco UCS Director Compatibility Matrix.

Cisco UCS Director is a 64-bit appliance that uses the following standard templates:

• Open Virtualization Format (OVF) for VMware vSphere

• Virtual Hard Disk (VHD) for Microsoft Hyper-V

Management through Cisco UCS Director

Cisco UCSDirector extends the unification of computing and networking layers through Cisco UCS to provide
you with comprehensive visibility and management of your data center infrastructure components. You can
use Cisco UCS Director to configure, administer, and monitor supported Cisco and non-Cisco components.
The tasks you can perform include the following:

• Create, clone, and deploy service profiles and templates for all Cisco UCS servers and compute
applications.

• Monitor organizational usage, trends, and capacity across a converged infrastructure on a continuous
basis. For example, you can view heat maps that show virtual machine (VM) utilization across all your
data centers.

• Deploy and add capacity to converged infrastructures in a consistent, repeatable manner.

Cisco UCS Director Administration Guide, Release 6.6
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• Manage, monitor, and report on data center components, such as Cisco UCS domains or Cisco Nexus
network devices.

• Extend virtual service catalogs to include services for your physical infrastructure.

• Manage secure multi-tenant environments to accommodate virtualized workloads that run with
non-virtualized workloads.

Automation and Orchestration with Cisco UCS Director

Cisco UCS Director enables you to build workflows that provide automation services, and to publish the
workflows and extend their services to your users on demand. You can collaborate with other experts in your
company to quickly and easily create policies. You can build Cisco UCS Director workflows to automate
simple or complex provisioning and configuration processes.

Once built and validated, these workflows perform the sameway every time, nomatter who runs the workflows.
An experienced data center administrator can run them, or you can implement role-based access control to
enable your users and customers to run the workflows on a self-service basis, as needed.

With Cisco UCS Director, you can automate a wide array of tasks and use cases across a wide variety of
supported Cisco and non-Cisco hardware and software data center components. A few examples of the use
cases that you can automate include, but are not limited to:

• VM provisioning and lifecycle management

• Network resource configuration and lifecycle management

• Storage resource configuration and lifecycle management

• Tenant onboarding and infrastructure configuration

• Application infrastructure provisioning

• Self-service catalogs and VM provisioning

• Bare metal server provisioning, including installation of an operating system

Features and Benefits
The features and benefits of Cisco UCS Director are as follows:

BenefitFeature

• Provides a single interface for administrators to provision, monitor, and
manage the system across physical, virtual, and bare metal environments

• Provides unified dashboards, reports, and heat maps, which reduce
troubleshooting and performance bottlenecks

Central management

• Allows end users to order and deploy new infrastructure instances
conforming to IT-prescribed policies and governance

Self-service catalog

• Provides a real-time available capability, internal policies, and application
workload requirements to optimize the availability of your resources

Adaptive provisioning
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BenefitFeature

• Provides continuous monitoring of infrastructure resources to improve
capacity planning, utilization, and management

• Identifies underutilized and overutilized resources

Dynamic capacity
management

• Supports VMware ESX, ESXi, Microsoft Hyper-V, and Red Hat
hypervisors

Multiple hypervisor support

• Provisions, monitors, and manages physical, virtual, and bare metal
servers, as well as blades

• Allows end users to implement virtual machine life-cycle management
and business continuance through snapshots

• Allows administrators to access server utilization trend analysis

Computing management

• Provides policy-based provisioning of physical and virtual switches and
dynamic network topologies

• Allows administrators to configure VLANs, virtual network interface
cards (vNICs), port groups and port profiles, IP and Dynamic Host Control
Protocol (DHCP) allocation, and access control lists (ACLs) across
network devices

Network management

• Provides policy-based provisioning and management of filers, virtual
filers (vFilers), logical unit numbers (LUNs), and volumes

• Provides unified dashboards that allow administrators comprehensive
visibility into organizational usage, trends, and capacity analysis details.

Storage management

Physical and Virtual Management Features
Virtual Computing Management

• Discover, collect, and monitor virtual computing
environments

• Perform policy-based provisioning and dynamic
resource allocation

• Manage the host server load and power

• Manage VM life cycle and snapshots

• Perform analysis to assess VM capacity, sprawl,
and host utilization

Physical Server Management

• Discover and collect configurations and changes

• Monitor and manage physical servers

• Perform policy-based server provisioning

• Manage blade power

• Manage server life cycle

• Perform server use trending and capacity analysis

• Perform bare metal provisioning using preboot
execution environment (PXE) boot management
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Virtual Storage Management

• Discover, collect, and monitor storage of vFilers
and storage pools

• Perform policy-based storage provisioning for
thick and thin clients

• Create new datastores and map them to virtual
device contexts (VDCs)

• Add and resize disks to VMs

• Monitor and manage organizational storage use

• Perform virtual storage trend and capacity
analysis

Physical Storage Management

• Discover, collect, and monitor storage filers

• Perform policy-based provisioning of vFilers

• Provision and map volumes

• Create and map Logical Unit Number (LUN)
and iGroup instances

• Perform SAN zone management

• Monitor and manage network-attached storage
(NAS) and SAN-based storage

• Implement storage best practices and
recommendation

Virtual Network Management

• Add networks to VMs

• Perform policy-based provisioning with IP and
DHCP allocation

• Configure and connect Virtual Network Interface
Cards ( vNICs) to VLANs and private VLANs

• Create port groups and port profiles for VMs

• Monitor organizational use of virtual networks

Physical Network Management

• Discover, collect, and monitor physical network
elements

• Provision VLANs across multiple switches

• Configure Access Control Lists (ACLs) on
network devices

• Configure storage network s

• Implement dynamic network topologies

Model-Based Orchestration
Cisco UCS Director includes a task library containing over 1000 tasks and out-of-the-box workflows.
Model-based orchestration and a workflow designer enable you to customize and automate the infrastructure
administrative and operational tasks. You can extend and customize the system to meet individual needs.

The following table shows the maintenance and update activities of the task library from day1 through day
3:

Day-3Day-2Day-1

• Add/upgrade hardware

• Repurpose

• Monitor performance

• Start meeting and billing

• Manage tenant change

• Self-service Infrastructure as
a Service (IaaS)

• Add tenants

• Migrate or add applicants

• Integrate with enterprise
systems

• Use End User Portal
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New User Interface of Cisco UCS Director
Cisco UCS Director introduces a new user interface for the administrative portal. This section introduces you
to some of the key features of this new user interface.

Change in Navigation

In earlier releases, you could access screens using the main menu bar. Starting with this release, all navigation
options are now available from a side bar, and not from the horizontal main menu bar. As a result, the main
menu bar is no longer visible in the user interface. You can use your mouse or the cursor to hover over an
option on the side navigation bar, and then click on any of the menu options.

Absence of User Interface Labels

The user interface no longer includes labels for actions such as Add, Edit, Delete, Export, and Filter. These
actions are represented only with icons. If you use your mouse or cursor to hover over the icon, the label will
display the action you can perform using that icon. You can also modify the icons in the user interface for all
actions and status messages. For more information, see Modifying an Icon in the Cisco UCS Director User
Interface, on page 131.

Availability of the Classic View

When you login to Cisco UCS Director, by default, the new user interface is displayed. The earlier version
of the interface, now referred to as the Classic View, is currently available. However, this Classic View will
soon be removed from the user interface. For information on accessing the Classic View, see Switching to
the Classic View, on page 14.

Using Dashboard to Access Detailed Reports

If you have enabled the Dashboard, then it is the first screen that you will see when you login to Cisco UCS
Director. Typically, you can use this dashboard to add important or frequently accessed report widgets. Now,
you can click on any of the reports that are displayed on the Dashboard, and immediately access the screen
in the user interface where more detailed information is displayed.

For more information, see Enabling the Dashboard, on page 331

In addition, you can create multiple dashboards and delete them when you no longer need them. For more
information, see Creating Additional Dashboards, on page 332 and Deleting a Dashboard, on page 332.

Enhanced Capabilities with Tabular Reports

Following are some of the enhanced capabilities with tabular reports available in the user interface:

• Right-click to view additional options

After you select a row, if you right-click on your mouse, a list of options relevant to the row you selected
are displayed.

• Filter and Search

You can use a Filter option or a Search option with tabular reports in the Cisco UCS Director interface.
On any page with a tabular report, you can use the Filter option that allows you to narrow down the
tabular report results with a specific criteria. You can use this Filter option on tabular reports that do not
span across pages. For tabular reports that do span across multiple pages, you can use the Search option
to narrow down your search result.
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• Adding tabular reports to the Favorites menu

You can add any tabular report displayed in the user interface as a Favorite. By adding a report as a
favorite, you can access this report from the Favorites menu.

• Resizing of columns

You can resize all the columns that are displayed in the tabular report, including the last column. After
you expand the columns, you can use the horizontal scroll bar to view the complete screen.

• Informational message displayed in the absence of data

If there is no information to be displayed in a report, the following message is displayed.

No Data

Removing and Restoring Tabs

On any screen that has multiple tabs available, you can choose the number of tabs that you would like to see
on that screen. If you close a tab on a screen, it will no longer be displayed in the row of tabs displayed in the
user interface. If you would like to bring it back on the screen, then click the arrow facing downwards that is
visible on the far right of the screen. It displays a drop-down list of tabs that are available but hidden from
view. Choose the tab you would like to restore.

You can remove and restore tabs on a screen only when there are a minimum of two tabs. This functionality
is not available when there is only one tab displayed on a screen in the interface.

Note

Enhancements to Reporting Capabilities

Following are some of the enhanced reporting capabilities available in the user interface:

• Introduction of pie charts and bar graphs

Each individual pie chart or bar graph can be exported out of the system in PDF, CSV or XLS format,
or can be added to the Dashboard.

• Availability ofMore Reports option

Using theMore Reports option, you can now generate reports on specific data for the resources in the
cloud accounts. For more information, see Generating Additional Reports for a Cloud Account, on page
14.

Landing Page
The landing page opens when you log in to the Cisco UCS Director administrator portal. The elements that
you see on the landing page depend upon how you have configured the display. By default, the Converged
View is displayed when you login to the portal.

The following are the available elements for your landing page:

• Header—Displays across the top of the screen.

• Navigation menu—The main navigation bar is no longer on the top of the screen. It is now available as
a vertical menu on the left-side of the screen.
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The menu does not have a scroll bar. The menu only displays the number of options that fit in the space
available. Some options may not appear if you minimize your screen or zoom in. You can click Site Map to
view all available options.

Note

Figure 1: New User Interface

DescriptionNameNumber

Contains frequently accessed elements,
including the menu. The header is always
visible.

Header1

Provides a link to the Cisco website from
where you can access information on using
the software.

Link2

Allows you to search for and navigate directly
to a specific report in the portal.

Search icon3

Displays the number of diagnostic system
messages that have been logged. Clicking on
this link takes you to the Diagnostic System
Messages screen from where you can view
detailed information.

Diagnostic System Messages icon4

Displays the list of connector packs available
for upgrade. Clicking on this link takes you to
the Available Connector Packs for Upgrade
screen from where you can view detailed
information.

Connector Pack Upgrade Notification5
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DescriptionNameNumber

Links to the online help system for the
administrator portal.

Help icon6

Displays information about the software, and
the version that is currently installed.

About icon7

Returns you to the landing page from any
location in the user interface.

Home icon8

Allows you to edit your profile, enable or
disable the dashboard, access the classic view
of the user interface, and log out.

User icon9

The vertical navigationmenu using which you
can access different screens in the interface.

Navigation menu9

Common Icons
The following table provides information about the common icons used in the user interface. You can see the
name of an icon when you hover over it with your mouse. Some icons may have a different name, depending
upon the context in which they're used.

DescriptionNameIcon

Search is available on the header and on individual screens. Click Search on
the header to find a report in the user interface. Click Search on an individual
screen to find one or more items in the report.

Search

Alert is available on the header. Click Alert to view your diagnostic system
messages.

Alert

User is available on the header. Click User to access your profile, log out, or
access the classic view of the user interface.

User

Export is available on individual screens. Click Export to export the content
of the report that is visible on the screen.

Export

Import is available on individual screens. Click Import to import a file.Import

Refresh is available on individual screens. Click Refresh to refresh the data
that is visible on the screen.

Refresh

View Details is available on individual screens. Click View Details to see
details about the selected row in the table.

View Details

Table view is available for your application containers and catalogs. Click
Table View to view your application containers or catalogs in a table with
details about each application container or catalog displayed.

Table View
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DescriptionNameIcon

Tile view is available for your catalogs and application containers. Tile View
to view your catalogs and application containers in a tiled view of icons. With
this view, you must click on an icon to see details about that catalog item or
application container.

Tile View

Create is available on individual screens. ClickCreate to create a new object,
such as a VM disk.

Create

Add is available on individual screens. ClickAdd to add an item to an existing
object, such as adding a catalog item to an existing catalog folder. The name
of this icon may also include the item that you want to add, such as Add
Catalog.

Add

Lists of values are available in forms when you must select one (single select)
or more (multi select) items, for example IP addresses or VMs.

A multi-select list displays a check box in the upper left corner of
the table next to the first column label. Click this check box to select
all items in the table.

Tip

The item label appears to the right of theExpand icon. Click theExpand icon
to display the list, then select an item or items.

Once an item is selected, its value appears in parentheses to the right of the
Expand icon and label.

Expand a list of
values

Once a list of values is expanded, the Expand icon changes to a Collapse
icon. Click theCollapse icon to hide the list of values, for example to see what
is beneath the list.

Collapse a list of
values

Edit is available on individual screens. ClickEdit to modify an existing object,
such as a catalog item or a VM disk.

Edit

Delete is available on individual screens. ClickDelete to delete an object, such
as a catalog item or a VM disk.

Delete

This icon represents additional tasks that do not have an associated icon. It
also represents the default icon available in the user interface.

Custom Actions

Adds a page to the Favoritesmenu. You can use this option to view frequently
accessed pages more quickly.

Favorites

Provides filtering parameters on the page.Filter

You can view the complete list of icons and the details from theAdministration >User Interface Settings >
Icon Management screen. These icons are listed in the Action Icon Set category.

Note
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Converged View
When you login to the administrator portal for the first time, by default, the Converged screen is displayed.
This screen displays the currently configured pods in your environment. From this screen, you can add
additional pods, or you can select a pod and view additional details on the resources within the pod. Typically,
the additional details displayed include the following:

• Virtual resources

• Compute resources

• Network resources

• Storage resources

You can click on any of these resources, and the screen loads additional information.

Cisco UCS Director allows you to configure the Dashboard as the first screen to be displayed when you login
to the user interface. For more information, see Enabling the Dashboard, on page 331.

Generating Additional Reports for a Cloud Account
You can use theMore Reports option to generate specific reports for either a virtual cloud account or for a
physical pod account. The type of reports that are generated using thisMore Reports option varies based on
the type of account.

If there is no information available to generate this report, then a message stating that there is no data is
displayed.

Step 1 Navigate to the cloud account that you want to generate additional reports for.
Step 2 From theMore Actions drop-down menu, clickMore Reports.
Step 3 From the Type drop-down list, and Report drop-down list, choose the type of report that you want to generate.

The report is generated and displayed in the user interface.

Step 4 (Optional) Click Settings > Export Report to choose the format in which you want the report to be exported in.

Switching to the Classic View
The classic view is the earlier version of the administrator user interface of Cisco UCS Director. You can
switch to the classic view from the new user interface.

On the header, click the icon for your user name, and choose Classic View. The earlier interface opens in a
new browser tab.

This Classic View option is available in the user interface only if you set the enableClassicView parameter
to true.
cd /opt/infra/web_cloudmgr/apache-tomcat/webapps/app/ux/resources/
vi appConfigs.json
enableClassicView=true

You must refresh the user interface to view this option.
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Guided Setup Wizards in Cisco UCS Director
Cisco UCS Director includes a set of wizards that guide you through configuring important features. The
following are the available guided setup wizards:

• Device Discovery—This wizard enables you to discover devices and assign them to a pod.

• Initial System Configuration—This wizard helps you complete initial tasks to set up Cisco UCSDirector,
such as uploading licenses, and setting up SMTP, NTP, and DNS servers.

• vDC Creation—This wizard enables you to configure the policies required to provision VMs in private
clouds.

• FlexPod Configuration—This wizard helps you set up a FlexPod account.

• Vblock Pod Configuration—This wizard enables you to discover and assign accounts to Vblock pods.

• VSPEX Pod Configuration—This wizard enables you to discover and assign accounts to VSPEX pods.

• Virtual SAN Pod Configuration—This wizard enables you to set up a Virtual SAN Pod and add devices.

When you first log into Cisco UCS Director, aWizard Explorer window is displayed. From this window,
you can view the details of the available guided setup wizards and choose to launch any of them. If you do
not want thisWizard Explorer to appear every time you log in, you can check the Do not show this page
again checkbox. To launch these wizards later on, click Administration > Guided Setup.

In addition to these system-providedwizards, you can create a wizard from aworkflow that you have previously
configured. For more information, see Creating a Wizard from a Workflow, on page 15.

Creating a Wizard from a Workflow
You can convert valid workflows into wizards, and save them in Cisco UCS Director.

Before you begin

You must have created valid workflows in Cisco UCS Director.

Step 1 Choose Administration > Guided Setup.
Step 2 On the Guided Setup page, click Setup.
Step 3 From theMore Actions drop-down menu, click Create from Workflow.
Step 4 In the Create Wizard from Workflow screen, complete the required fields, including the following:

DescriptionName

Click Select to view a list of available workflows in the
Select Workflow screen.

Check the check boxes of the workflows that you want to
convert to a wizard and click Select.

Select Workflow field

Check this check box if you want the static values from the
selected workflow tasks to be carried over into the wizard
pages.

Carry over static field values check box
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DescriptionName

The name of the wizard. This is the primary name of the
wizard.

Label field

A secondary name of the wizard.Second Label field

A description of the wizard.Description field

Click Select to view a list of available icons in the Icon
Image screen.

Check the check box of the icon that you want to associate
with this workflow and click Select.

Icon Image field

Step 5 Click Submit.

What to do next

You can perform the following tasks:

• Launch the wizard.

• Edit the wizard.

• View details of the wizard.

• Re-order the wizard in the interface.

• Delete the wizard.

Setting up Non-Secure Connection to the Cisco UCS Director
User Interface

By default, the Cisco UCS Director user interface launches in the secure mode. If you want to bypass the
secure mode, and launch the user interface in a non-secure mode (HTTP), you must follow this procedure.

Step 1 Log in as root.
Step 2 Make the following changes in the /opt/infra/web_cloudmgr/apache-tomcat/conf/server.xml file:

a) Comment out the existing port 8080 Connector tag

<!--
<Connector port="8080" protocol="HTTP/1.1"
redirectPort="443" maxHttpHeaderSize="65536"
URIEncoding = "UTF-8"/>
-->

b) Add the following as a new port 8080 Connector tag:
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<Connector port="8080" protocol="HTTP/1.1"
maxThreads="150" minSpareThreads="4"
connectionTimeout="20000"
URIEncoding = "UTF-8" />

Step 3 Comment the <security-constraint> tag in the
/opt/infra/web_cloudmgr/apache-tomcat/webapps/app/WEB-INF/web.xml file.

<!--
<security-constraint>
<web-resource-collection>
<web-resource-name>HTTPSOnly</web-resource-name>
<url-pattern>/*</url-pattern>
</web-resource-collection>
<user-data-constraint>
<transport-guarantee>CONFIDENTIAL</transport-guarantee>
</user-data-constraint>
</security-constraint>
-->

Step 4 Restart the services.
Step 5 Launch the user interface and log in to the system.

You can now log into the system in the non-secure mode using the following URL format:

http://<IP-Address>:8080 or http://<IP-Address>

You can launch the user interface in both, secure and non-secure modes.

Initial Login
Log into Cisco UCS Director by hostname or IP address with the following credentials:

• Username: admin

• Password: admin

We recommend that you delete the startup admin account after you create the first admin account or, at least,
change the default password. To access the End User Portal, you must have a valid email address.

Note

Recommended Order of System Setup
The following figure illustrates the workflow to set up your environment using Cisco UCS Director:
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Figure 2: Sample Workflow to Set up Your Environment

The following table describes the chapters available in this book using which you can complete setting up
your environment.

DescriptionChapterName

Describes how to apply a license, set up the Admin profile, create groups,
and create users. You will learn how to access language support, apply
portal customization, and system settings

2, 3, 4
and 5

Initial set up

Describes how to optionally add a pod and physical account, add network
elements, test the connections, and verify account discovery.

6Physical Infrastructure

You can create the virtual infrastructure before the physical
infrastructure if you want.

Note
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DescriptionChapterName

Describes how to create a cloud, verify cloud discovery and connectivity,
test the connections, and view vCenter plug ins.

7Virtual Infrastructure

Describes how to create and manage computing policies, storage policies,
network policies, and system policies. You will learn how to add OS
licenses for Microsoft Windows catalogs.

8Policies

Describes how to set up VDCs to manage specific environments for
groups. policies, and cost models, and how resource limits are configured
and managed at the VDC level.

9Virtual Data Centers

Describes how to set up catalog items, attach groups with access to a
catalog, and publish catalog items.

10Catalogs

Describes how you can create and manage provisioning service requests.11Self-Service
Provisioning

Describes how to configure VM disk provisioning on a preferred single
datastore or multiple datastores. It also provides instructions on how to
configure individual disk policies for each additional disk in a template.

12Multi-Disk
Provisioning

Describes how to create chargeback summary reports, detailed reports,
and resource accounting reports. It shows how cost models are defined
and assigned to policies within departments and organizations.

13Chargeback

Describes how you can get complete cloud visibility, monitor resource
usage, and manage the cloud stack—clouds, clusters, host servers, and
virtual machines.

14Cloud Management

Describes how to perform post provisioning life cyclemanagement actions
on VMs, such as VM power management, VM resizing, VM snapshot
management, and other VM actions.

15Life Cycles

Describes the analytical reports about the underlying physical and virtual
infrastructure that Cisco UCS Director can generate.

16CloudSense

Configuring the Host Name for Cisco UCS Director
If you changed the default host name of the appliance of Cisco UCS Director using the command prompt,
then you must follow this procedure to ensure that the name is updated in the /etc/hosts file.

Step 1 SSH to the appliance using the root account.
Step 2 Edit the /etc/hosts to update the new host name.

In a single node environment, you must update the file in the following format:
vi /etc/hosts
198.51.100.1 new_hostname
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In a multi-node environment, if the host names of other nodes are changed, then you must update the IP address and the
new host name on the primary node, service nodes and database nodes. For example:
vi /etc/hosts
198.51.100.1 new_hostname
Ex:
198.51.100.2 UCSD_Primary
198.51.100.3 UCSD_Service
198.51.100.4 UCSD_Inv_DB
198.51.100.5 UCSD_Mon_DB

Step 3 Restart the appliance services.

Working with Ciphers
As an administrator in Cisco UCS Director, you have the capability to enable or disable ciphers from the
property file. In the event that you enable a cipher with a potential security risk, a warning message is logged
in the Cisco UCS Director log file. By default, all ciphers that pose a risk are disabled. You can configure
specific ciphers from the defaultEnabledCipherSuites.properties file, located in the
/opt/infra/inframgr folder. For more information, see Editing Cipher Usage, on page 20.

In addition, you can change the preference order of the standard set of ciphers, based on your system
requirements. By default, the standard ciphers are listed according to the preference order.

Cisco UCS Director currently supports the use of "limited" and "strong" Java Cryptograpy Extension (JCE)
Policy files for Java SE Runtime Environment. If you want to change these policies to "unlimited" and "strong"
JCE policies, then you must download and install the latest JCE policy files from the Oracle website. For
more information, see Installing the Latest Java Cryptograpy Extension (JCE) Policy Files , on page 20.

Editing Cipher Usage
CipherSuites are maintained in the defaultEnabledCipherSuites.properties file. You can edit
the list of ciphers in this file, based on the application requirements for your network.

We recommend that you always use the standard ciphers and not enable any broken or risky ciphers for your
application.

Step 1 Open the defaultEnabledCipherSuites.properties file.

It is available in the opt/infra/inframgr/ directory.

Step 2 To use a broken cipher, locate the cipher in the file, and uncomment it.
Step 3 Save the file.
Step 4 Restart the service.

Installing the Latest Java Cryptograpy Extension (JCE) Policy Files
Complete the following procedure to download and install the latest JCE policy files:
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Step 1 Take a backup of the following files in the $JAVA_HOME/jre/lib/security folder:

• local_policy.jar

• US_export_policy.jar

Step 2 Access the oracle Java SE download page at http://www.oacle.com/technetwork/java/javase/downloads.index.html.
Step 3 Scroll to theAdditional Resources section to locate the Java Cryptography Extension (JCE)Unlimited Strength Jurisdiction

Policy File.
Step 4 Download theJava Cryptography Extension (JCE) Unlimited Strength Jurisdiction Policy

Files for JDK/JRE 8 zipped file.
Step 5 Extract the contents of the zipped file.
Step 6 Replace the local_policy.jar and US_export_policy.jar in the $JAVA_HOME/jre/lib/security

folder.
Step 7 Restart the application.
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C H A P T E R 3
Managing Users and Groups

This chapter contains the following sections:

• User Roles, on page 23
• Adding a User Role, on page 25
• Adding Users, on page 26
• Managing User Types, on page 28
• Default User Permissions, on page 28
• Managing User Account Status, on page 48
• MSP Administrator Role, on page 50
• Managing Groups, on page 51
• Configuring the Administration Profile, on page 61
• Managing User Access Profiles, on page 64
• Branding for Customer Organizations, on page 85
• Branding User Groups, on page 86
• Branding Customer Organizations, on page 87
• Login Page Branding, on page 88

User Roles
Cisco UCS Director supports the following user roles:

• All Policy Admin

• Billing Admin

• Computing Admin

• Group Admin—An end user with the privilege of adding users. This user can use the End User Portal.

• IS Admin

• MSP Admin

• Network Admin

• Operator

• Service End User—This user can only view and use the End User Portal.
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• Storage Admin

• System Admin

These user roles are system-defined and available in Cisco UCS Director by default. You can determine if a
role is available in the system by default, if the Default Role column in the Users page is marked with Yes.

As an administrator in Cisco UCS Director, you can assign users to system-provided user roles or to
custom-defined user roles. In addition, at a later point in time, you can view information on the role that a
user is assigned to. For more information, see Viewing User Role Information for Users.

Note

As an administrator in the system, you can perform the following tasks with user roles:

• Create a custom user role in the system, and create user accounts with this role or assign the role to
existing users.

When you create a new user role, you can specify if the role is that of an administrator or an end user.
For more information on creating a user role, see Adding a User Role, on page 25. For information on
creating user accounts for a role, see Adding Users, on page 26.

• Modify existing user roles, including default roles, to change menu settings and read/write permissions
for users associated with that role.

The procedure to modify menu settings and permissions for a role is the same as the procedure to add a
user role.

Defining Permissions to Perform VM Management Tasks to Users

Previously, user permissions for VMmanagement tasks could only be created by defining them in an end-user
self-service policy. As an administrator in the system, you can now map permissions to perform VM
management tasks to any user role. Users that are mapped to the given role can complete the selected VM
management related tasks. However, to assign VM management tasks to end users using the end-user self
service policy, you must first disable all VM management actions for this user role, and then enable all other
management tasks.

For any user in the system, the capability to perform VM management tasks is determined by the following:

• The permissions assigned to the user role that the user is mapped to

• The end user self-service policy that is mapped to the VDC.

If you have upgraded to the current release, then the permissions to performVMmanagement tasks is retained
in the end user self service policy that was created with the previous release version. However, the permissions
that you defined or set for the user role after upgrading to the current release, takes precedence.

You can provide permissions to perform VMmanagement tasks to other administrators, such as MSP Admin
or Group Admin, by defining them in the user role only.

Note
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Adding a User Role
You can create any number of user roles in Cisco UCS Director and define the menu settings for the users
created with these roles.

Step 1 Choose Administration > System.
Step 2 On the System page, click User Roles.
Step 3 Click Add.
Step 4 In the Add User Role screen, complete the required fields, including the following:

DescriptionName

Name of the user role.User Role field

Choose the type of role that you are adding. It can be one
of the following:

• Admin

• End user

Role Type drop-down list

The description of the role being added.Description field

Click Select to view a list of user roles in the Deny Role
List screen.

Check the roles that you want to deny for users created with
this role and click Select.

For example, as an administrator, you are creating a new
group admin role in the system using the clone feature, and
this group admin role must include the capability to create
users with privileges higher than the group admin role.
However, by default, the Group Admin role does not allow
creating users with privilege higher than the group admin.
So in this situation, as the administrator, you will need to
select the default group admin role in the deny list.

Deny Role List

Step 5 Click Next.
Step 6 In theMenu Settings pane, check the menu options that will be visible to users who are defined in this role.
Step 7 Click Next.
Step 8 In the User Permissions pane, choose the read or write permissions associated with various available user tasks.
Step 9 Click Submit.

What to do next

Create a user account with this role type.
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Adding Users
Before you begin

Ensure that you have created a group before you add a user to it.

Step 1 Choose Administration > Users and Groups.
Step 2 On the Users and Groups page, click Users.

The Users page displays the following information for all user accounts currently available in the system:

• Status

• Login name and access level

• Email address

• Date when the user account will be disabled

• Current status of the password, and the date on which the password will expire

Step 3 Click Add.
Step 4 On the Add User screen, complete the required fields, including the following:

DescriptionField Name

Choose the role type for the user.User Role drop-down list

Select the group that the user will have access to. You can
either select a group already available, or you can add a
new group.

This field is visible only when you select Service
End-User or Group Admin as the user role.

Note

User Group drop-down list

Select the MSP organization that the user will manage.

You can either select an organization that is currently
available, or you can add a new organization.

This field is visible only when you selectMSP
Admin as the user role.

Note

MSP Organization drop-down list

The login name.

You can include special characters such as ( ). & - _ `~ $%
^ {}! ' @

Login Name field
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DescriptionField Name

The password.

If Lightweight Directory Access Protocol
(LDAP) authentication is configured for the user,
the password is validated only at the LDAP
server, and not at the local server.

Note

Password field

The password is entered again for confirmation.Confirm Password field

The email address.

The email address is required to notify the group
owner about the service request status and to
request approval.

Note

User Contact Email field

The first name.First Name field

The last name.Last Name field

The phone number of the user.Phone field

The office address of the user.Address field

Check to set the date and time when the user account must
be disabled in the system. Disabling a user account means
that the user can no longer log in into the system.

A week prior to this date, an email message stating that the
account will be disabled is sent to the user. This automatic
email message is generated and sent by the
PeriodicNotificationToUserTask system task.

On the specified date and time, the user account is disabled
automatically. If the user is logged in to the system on the
date specified, then the login session is terminated
automatically.

Set user disable date check box

Choose a language for the system specifically for this user.
By default, the language is set to English.

When this user logs in, the user interface is displayed in the
language you selected. This locale selection applies only to
this user.

Locale drop-down list

Step 5 Click Add.

What to do next

Click a row with a user and clickManage Profiles, to optionally assign multiple roles for that user.
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Managing User Types
As the system administrator, you have full privileges to manage Cisco UCS Director, including adding users,
viewing users and user permissions, and modifying individual user read/write permissions for different system
components.

Most users access the Administrative portal when they log in.

Default User Permissions
Each admin user has a set of permissions to access Cisco UCS Director. The types of user permissions are as
follows:

• Read—An admin user with Read permission has the ability to only read a file.

• Write—An admin user with Write permission has the ability to read, write, and modify a file. This
permission includes the ability to delete or rename files.

• Read/Write—An admin user with Read/Write permission has the ability to read and write a file.

User Roles and Permissions
The following table shows a list of the permissions that are mapped to each user role:

Storage
Admin

Service
End
User

OperatorNetwork
Admin

MSP
Admin

IS
Admin

Group
Admin

Computing
Admin

Billing
Admin

All
Policy
Admin

Permission

ReadRead
/
Write

ReadReadWriteReadRead /
Write

ReadReadVirtual
Computing

WriteWriteWriteWriteWriteWriteWriteWriteWriteVM Label

WriteWriteWriteAssign
VM to
vDC

ReadReadReadReadReadReadVirtual
Storage

ReadReadReadReadReadReadVirtual
Network

ReadReadReadReadReadRead /
Write

Read /
Write

Physical
Computing

Read /
Write

ReadReadReadReadRead /
Write

ReadRead /
Write

Physical
Storage
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Storage
Admin

Service
End
User

OperatorNetwork
Admin

MSP
Admin

IS
Admin

Group
Admin

Computing
Admin

Billing
Admin

All
Policy
Admin

Permission

ReadRead /
Write

Read /
Write

ReadReadRead /
Write

Physical
Network

ReadRead
/
Write

Read /
Write

ReadRead /
Write

ReadRead /
Write

ReadReadRead /
Write

Group
Service
Request

WriteWriteWriteWriteWriteCreate
Service
Request

Read /
Write

Read
/
Write

ReadRead /
Write

Read /
Write

Read /
Write

Read
/Write

Read /
Write

Read /
Write

Approver
Service
Request

ReadReadReadRead /
Write

ReadReadRead /
Write

ReadBudgeting

ReadReadReadReadReadReadReadReadReadReadResource
Accouting

ReadReadReadReadReadReadReadReadReadReadChargeback

ReadReadReadReadReadReadSystem
Admin

ReadReadReadReadReadReadUsers and
Groups

ReadReadReadReadReadReadVirtual
Accounts

ReadReadReadReadReadReadReadReadReadCatalogs

ReadReadReadReadReadRead /
Write

ReadReadReadvDC

ReadReadReadReadRead /
Write

Read /
Write

Computing
Policy

Read /
Write

ReadReadReadReadRead /
Write

Storage
Policy

ReadReadRead /
Write

ReadReadRead /
Write

Network
Policy

ReadReadReadRead /
Write

ReadWriteDeployment
Policy

ReadReadReadRead /
Write

ReadRead /
Write

Service
Delivery
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Storage
Admin

Service
End
User

OperatorNetwork
Admin

MSP
Admin

IS
Admin

Group
Admin

Computing
Admin

Billing
Admin

All
Policy
Admin

Permission

ReadReadReadReadReadReadReadReadReadReadResource
Limit
Report

ReadReadReadRead /
Write

ReadRead /
Write

ReadReadGroup
Users

ReadReadReadReadReadRead /
Write

ReadRead /
Write

ReadCloudsense
Reports

ReadReadReadRead /
Write

ReadCloudsense
Assessment
Reports

Read /
Write

Read /
Write

Read /
Write

Read /
Write

Read /
Write

Orchestration

Read /
Write

Read /
Write

WriteReadReadReadDiscovery

Open
Automation
Modules

ReadReadRead /
Write

CS Shared
Reports

Read /
Write

CS Shared
Assessments

Remote
VM
Access

Mobile
Access
Settings

ReadReadReadEnd User
Chargeback

UCSD
Cluster

Read /
Write

Read /
Write

Read /
Write

Read /
Write

Resource
Groups

Read /
Write

Read /
Write

Read /
Write

Read /
Write

Tag
Library
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Storage
Admin

Service
End
User

OperatorNetwork
Admin

MSP
Admin

IS
Admin

Group
Admin

Computing
Admin

Billing
Admin

All
Policy
Admin

Permission

TrueTrueTrueTrueTrueTrueTrueTrueTrueTrueAllow
Deployability
Assessment

Read /
Write

Read
/
Write

Read /
Write

Read /
Write

Read /
Write

Read /
Write

Read /
Write

Read /
Write

Read /
Write

Read /
Write

Write
CloupiaScript

Read /
Write

Read
/
Write

Read /
Write

Read /
Write

Read /
Write

Read /
Write

Read /
Write

Read /
Write

Read /
Write

Read /
Write

Execute
CloupiaScript

Permissions for Server Management
In prior releases, to manage physical servers, Cisco UCS Director only provided the following options:

• Read Physical Computing

•Write Physical Computing

As an administrator, if you enabled the write permission, then users had the capability to manage all Cisco
UCS physical servers in the environment.With this release, within theWrite Physical Computing permission,
the following new categories of permissions have been introduced:

• Physical Server Management

• Other Physical Compute Management

Enabling Physical Server Management implies enabling management of Cisco UCS Servers only. This
category includes the following actions:

• Power Management (Power On and Power Off)

• Group Management (Assign Group and Unassign Group)

• Inventory Management

• Server Management

• Server Access

If you enable these tasks for users, then those users can view these actions or tasks in the portal. However,
for end users, even if you enable these tasks, they can only perform the following tasks on Cisco UCS servers:

• Power on and off servers

• Associate and disassociate groups

• KVM console
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EnablingOther Physical ComputeManagement implies enabling management tasks for other UCS servers
in the environment. Uses from whom this permission is enabled can perform tasks such as working with
service profiles or VLANs.

All Policy Admin
The following table shows a list of operations that an All Policy admin can perform:

PermissionsOperations

WriteRead

YesVirtual Computing

YesVM Label

YesAssign VM to vDC

YesVirtual Storage

YesVirtual Network

YesYesPhysical Computing

YesYesPhysical Storage

YesYesPhysical Network

YesYesGroup Service Request

YesCreate Service Request

YesYesApprover Service Request

YesBudgeting

YesResource Accounting

YesChargeback

YesSystem Admin

YesUsers and Groups

YesVirtual Accounts

YesCatalogs

YesvDC

YesYesComputing Policy

YesYesStorage Policy

YesDeployment Policy

Cisco UCS Director Administration Guide, Release 6.6
32

Managing Users and Groups
All Policy Admin



PermissionsOperations

YesYesNetwork Policy

YesYesService Delivery

YesResource Limit Report

YesGroup Users

YesCloudsense Reports

YesCloudsense Assessment
Reports

YesYesOrchestration

YesDiscovery

Open Automation Modules

CS Shared Reports

CS Shared Assessments

Remote VM Access

Mobile Access Settings

End User Chargeback

Write Resource Accounting

UCSD Cluster

Resource Groups

Tag Library

TrueAllow Deployability
Assessment

Billing Admin
The following table show a list of operations that a Billing admin can perform:

PermissionOperation

WriteRead

Virtual Computing

VM Label

Assign VM to vDC
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PermissionOperation

Virtual Storage

Virtual Network

Physical Computing

Physical Storage

Physical Network

YesGroup Service Request

Approver Service Request

YesYesBudgeting

YesResource Accounting

YesChargeback

System Admin

Users and Groups

Virtual Accounts

Catalogs

vDC

Computing Policy

Storage Policy

Deployment Policy

Network Policy

Service Delivery

YesResource Limit Report

Group Users

YesYesCloudsense Reports

YesYesCloudsense Assessment
Reports

Orchestration

YesDiscovery

Open Automation Modules
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PermissionOperation

CS Shared Reports

CS Shared Assessments

Remote VM Access

Mobile Access Settings

End User Chargeback

YesWrite Resource Accounting

UCSD Cluster

Resource Groups

Tag Library

TrueAllow Deployability
Assessment

Computing Admin
The following table shows a list of operations that a Computing admin can perform:

PermissionOperation

WriteRead

YesVirtual Computing

YesVM Label

Assign VM to vDC

YesVirtual Storage

YesVirtual Network

YesYesPhysical Computing

YesPhysical Storage

YesPhysical Network

YesGroup ServiceRequest

YesYesApprover Service
Request

YesBudgeting

YesResource Accounting
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PermissionOperation

YesChargeback

YesSystem Admin

YesUsers and Groups

YesVirtual Accounts

YesCatalogs

YesvDC

YesYesComputing Policy

YesStorage Policy

YesDeployment Policy

YesNetwork Policy

YesService Delivery

YesResource Limit Report

YesGroup Users

YesCloudsense Reports

YesCloudsense
Assessment Reports

YesYesOrchestration

YesDiscovery

Open Automation
Modules

CS Shared Reports

CS Shared
Assessments

Remote VM Access

Mobile Access
Settings

End User Chargeback

Write Resource
Accounting

UCSD Cluster
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PermissionOperation

YesYesResource Groups

YesYesTag Library

TrueAllow Deployability
Assessment

Group Admin
The following table shows a list of operations that a Group admin can perform:

PermissionTask

WriteRead

YesYesVirtual Computing

YesVM Label

Assign VM to vDC

Virtual Storage

Virtual Network

Physical Computing

YesYesPhysical Storage

Physical Network

YesYesGroup Service Request

YesCreate Service Request

YesYesApprover Service Request

Budgeting

YesResource Accounting

YesChargeback

System Admin

Users and Groups

Virtual Accounts

YesCatalogs

YesvDC

Computing Policy
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PermissionTask

Storage Policy

Deployment Policy

Network Policy

Service Delivery

YesResource Limit Report

YesYesGroup Users

YesYesCloudsense Reports

Cloudsense Assessment
Reports

Orchestration

Discovery

Open Automation Modules

YesYesCS Shared Reports

CS Shared Assessments

Remote VM Access

Mobile Access Settings

YesEnd User Chargeback

Write Resource Accounting

UCSD Cluster

Resource Groups

Tag Library

TrueAllow Deployability
Assessment

IS Admin
The following table shows a list of operations that an IS admin can perform:

PermissionTask

WriteRead

YesVirtual Computing
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PermissionTask

YesVM Label

YesAssign VM to vDC

YesVirtual Storage

YesVirtual Network

YesPhysical Computing

YesPhysical Storage

YesPhysical Network

YesGroup Service Request

YesYesApprover Service Request

YesBudgeting

YesResource Accounting

YesChargeback

YesSystem Admin

YesUsers and Groups

YesVirtual Accounts

YesCatalogs

YesYesvDC

YesComputing Policy

YesStorage Policy

YesYesDeployment Policy

YesNetwork Policy

YesYesService Delivery

YesResource Limit Report

YesGroup Users

YesCloudsense Reports

YesCloudsense Assessment
Reports

YesYesOrchestration

Cisco UCS Director Administration Guide, Release 6.6
39

Managing Users and Groups
IS Admin



PermissionTask

YesDiscovery

Open Automation Modules

CS Shared Reports

CS Shared Assessments

Remote VM Access

Mobile Access Settings

End User Chargeback

Write Resource Accounting

UCSD Cluster

YesYesResource Groups

YesYesTag Library

TrueAllow Deployability
Assessment

Network Admin
The following table shows a list of operations that a Network admin can perform:

PermissionTask

WriteRead

YesVirtual Computing

YesVM Label

Assign VM to vDC

YesVirtual Storage

YesVirtual Network

YesPhysical Computing

YesPhysical Storage

YesYesPhysical Network

YesGroup Service Request

YesYesApprover Service Request

YesBudgeting
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PermissionTask

YesResource Accounting

YesChargeback

YesSystem Admin

YesUsers and Groups

YesVirtual Accounts

YesCatalogs

YesvDC

YesComputing Policy

YesStorage Policy

YesDeployment Policy

YesYesNetwork Policy

YesService Delivery

YesResource Limit Report

YesGroup Users

YesCloudsense Reports

YesCloudsense Assessment
Reports

YesYesOrchestration

YesYesDiscovery

Open Automation Modules

CS Shared Reports

CS Shared Assessments

Remote VM Access

Mobile Access Settings

End User Chargeback

Write Resource Accounting

UCSD Cluster

YesYesResource Groups
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PermissionTask

YesYesTag Library

TrueAllow Deployability
Assessment

Operator
The following table shows a list of operations that an Operator can perform:

PermissionTask

WriteRead

YesVirtual Computing

YesVM Label

YesAssign VM to vDC

YesVirtual Storage

YesVirtual Network

YesPhysical Computing

YesPhysical Storage

YesPhysical Network

YesYesGroup Service Request

YesCreate Service Request

YesYesApprover Service Request

YesBudgeting

YesResource Accounting

YesChargeback

YesSystem Admin

YesUsers and Groups

YesVirtual Accounts

YesCatalogs

YesvDC

YesComputing Policy

YesStorage Policy
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PermissionTask

YesDeployment Policy

YesNetwork Policy

YesService Delivery

YesResource Limit Report

YesGroup Users

YesCloudsense Reports

YesCloudsense Assessment
Reports

Orchestration

Discovery

Open Automation Modules

CS Shared Reports

CS Shared Assessments

Remote VM Access

Mobile Access Settings

End User Chargeback

Write Resource Accounting

UCSD Cluster

Resource Groups

Tag Library

TrueAllow Deployability
Assessment

Service End User
The following table shows a list of operations that a Service End User can perform:

PermissionTask

WriteRead

YesYesVirtual Computing

YesVM Label
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PermissionTask

Assign VM to vDC

Virtual Storage

Virtual Network

YesPhysical Computing

YesPhysical Storage

Physical Network

YesYesGroup Service Request

YesCreate Service Request

YesYesApprover Service Request

Budgeting

YesResource Accounting

YesChargeback

System Admin

Users and Groups

Virtual Accounts

YesCatalogs

YesvDC

Computing Policy

Storage Policy

Deployment Policy

Network Policy

Service Delivery

YesResource Limit Report

Group Users

YesCloudsense Reports

Cloudsense Assessment
Reports

Orchestration
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PermissionTask

Discovery

Open Automation Modules

YesCS Shared Reports

CS Shared Assessments

Remote VM Access

Mobile Access Settings

YesEnd User Chargeback

Write Resource Accounting

UCSD Cluster

Resource Groups

Tag Library

TrueAllow Deployability
Assessment

Storage Admin
The following table shows a list of operations that a Storage admin can perform:

PermissionTask

WriteRead

YesVirtual Computing

YesVM Label

Assign VM to vDC

YesVirtual Storage

YesVirtual Network

YesPhysical Computing

YesYesPhysical Storage

YesPhysical Network

YesGroup Service Request

YesYesApprover Service Request

YesBudgeting
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PermissionTask

YesResource Accounting

YesChargeback

YesSystem Admin

YesUsers and Groups

YesVirtual Accounts

YesCatalogs

YesvDC

YesComputing Policy

YesYesStorage Policy

YesDeployment Policy

YesNetwork Policy

YesService Delivery

YesResource Limit Report

YesGroup Users

YesCloudsense Reports

YesCloudsense Assessment
Reports

YesYesOrchestration

YesYesDiscovery

Open Automation Modules

CS Shared Reports

CS Shared Assessments

Remote VM Access

Mobile Access Settings

End User Chargeback

Write Resource Accounting

UCSD Cluster

YesYesResource Groups
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PermissionTask

YesYesTag Library

TrueAllow Deployability
Assessment

Viewing User Role Information for Users
As an administrator in the system, you can assign users to system-provided user roles or to custom-defined
user roles. You can view this information at a later point in time for all users in a group.

Step 1 Choose Organizations > Summary.
Step 2 On the Summary page, choose the user group.
Step 3 Click Users.

From this page, you can view detailed information on the users that belong to the selected group. The Access Level
column displays the roles, system-defined or custom-defined roles, that the users are assigned to. Optionally, you can
choose Administration > User and Groups > Users to view all user information. If you are a group administrator, then
to view this information, choose Organizations > Users.

If you are a group administrator, then this page displays the password expiry date and time for each user. This information
is derived from the Password policy that is configured in the system. This page also graphically represents the password
expiry status for each user. The column titled Password Expiry Status displays a green icon for passwords that have
not yet expired, and a red icon for passwords that have expired.

Reviewing Recent Login History of Users
As an administrator in the system, you can review the login history for all users. The system records the
following details for every login attempt:

• Login Name—The user name of the logged in user.

• Remote Address—The IP address of the system or the server that the user has logged in from.

• Client Detail—The browser information.

• Client Type—Information on whether the user logged in to the brower or the REST API.

• Authentication Status—Information on whether the login action resulted in success or failure.

• Comments—The cause for authentication failure.

• Accessed On—The date and time of the login activity for the user.

Step 1 Choose Administration > Users and Groups.
Step 2 On the Users and Groups page, click All Users Login History.
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Step 3 Review the information displayed on the screen.

Configuring Session Limits for Users
You can configure the number of user interface sessions and REST API requests that users can initiate on the
system.

Step 1 Choose Administration > Users and Groups.
Step 2 On the Users and Groups page, click Session Management.
Step 3 In the Session Management screen, complete the required fields, including the following:

DescriptionName

The maximum number of concurrent GUI sessions that are
supported for each user. Enter a number between 1 and 128.

The default value is 16.

Maximum Concurrent Sessions Per User field

The maximum number of concurrent REST API requests
that are supported for each user. Enter a number between
1 and 256.

The default value is 128.

Maximum Concurrent REST API Requests Per User
field

Step 4 Click Submit.

What to do next

When users initiate a GUI session or a REST API request to exceed the limit specified on this screen, an error
message is displayed in the SystemMessages screen. In this scenario, either users should clear their sessions
and API requests, or as an administrator, you can use the Shell utility and clear the sessions and requests for
a user. For more information, see Cisco UCS Director Shell Guide, Release 6.5.

Managing User Account Status
Cisco UCS Director provides you with the capability to enable and disable users in the system. When you
disable a user record, the user cannot log in to the system, and cannot use the APIs. In addition, the disabled
user record is no longer present in any of the User fields that are displayed while performing administrative
actions, such as assigning VMs or port groups. However, the records of all system users, whether enabled or
disabled, are listed in the Users tab. In this tab, view the Status column to see if a user account status is
Disabled or Enabled.

You can disable a user in one of the following ways:

• At account creation, you can set a date for disabling the user. For more information, see Adding Users,
on page 26.
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• Disable a user from the Users page. For more information, see Disabling a User Account in Cisco UCS
Director, on page 49.

• Disable all users in anMSPOrganization or a Customer Organization. For more information, see Disabling
User Accounts within a Group, on page 50.

After you disable a user account, you can re-enable the account at a later point.Note

Unassigning Resources From a User
Cisco UCS Director allows you to unassign resources from a user.

You can unassign resources from a user prior to disabling the user account in the system.Note

Step 1 Choose Administration > Users and Groups.
Step 2 On the Users and Groups page, click Users.
Step 3 Choose a user from the report, and click View.
Step 4 From the User Details screen, choose the resources you want to unassign from the user.

You can select multiple resources.

Step 5 Click Unassign.
Step 6 In the Unassign Resource screen, click Unassign.
Step 7 Click OK.

What to do next

You can assign this resource to another user in the system.

Disabling a User Account in Cisco UCS Director
Perform this procedure to disable a specific user account in Cisco UCS Director.

Step 1 On the menu bar, choose Administration > Users and Groups.
Step 2 Click the Users tab.
Step 3 Choose the user account from the table.

You can choose multiple users.

Step 4 On the toolbar, choose Disable.
Step 5 In the Disable User dialog box, click Disable.
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Step 6 Click OK.

If the user whose account that you disabled is currently logged in to the system through the graphical user interface or
the API, then that user session is terminated immediately. The disabled user cannot log in to the application.

What to do next

You can choose to enable the user's account at a later point in time. To do so, return to the Users page, select
the user and click Enable.

Disabling User Accounts within a Group
Perform this procedure to disable user accounts within an MSP organization or a customer organization.

Step 1 On the menu bar, choose Administration > Users and Groups.
Step 2 Click theMSP Organizations tab or the Customer Organizations tab.

These tab names are only indicative. If you have enabled the Service Provider Feature, you have to specify the names
of the organization at the first and second level. The names that you specify are displayed as tabs in the interface.

Step 3 Select a group from the table.

You can select multiple groups.

Step 4 Click Disable Users.
Step 5 In the Disable Users dialog box, click Disable Users.
Step 6 Click OK.

What to do next

You can enable all the user accounts in this group by returning toMSP Organizations tab or the Customer
Organizations tab, selecting the group, and clicking Enable Users.

MSP Administrator Role
A Managed Service Provider (MSP) organization is a type of customer group in Cisco UCS Director. It can
be considered as a parent organization in the system. Within this MSP organization, multiple sub-categories
or child organizations can be grouped. For example, a company name such as 'Cisco Systems' would represent
an MSP organization. Within this MSP organization, you can create multiple customer groups, such as HR,
Finance, and Operations. These groups would be considered as customer groups within an MSP organization.

An administrator is required for each MSP in Cisco UCS Director. This administrator is referred to as the
MSP Admin. This administrator manages the MSP organization and all the customer organizations within
the MSP organization.

If you are a global administrator in Cisco UCS Director, following is the recommended sequence of steps to
create an MSP organization and an MSP administrator:
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1. Enable the Service Provider Feature in Cisco UCS Director. For more information, see Enabling the
Service Provider Feature, on page 123.

2. Create the MSP organization. For more information, see Creating an MSP Organization, on page 53.

3. Create the customer groups within the MSP organization. For more information, see Creating a Customer
Organization, on page 54.

4. Create a user account with MSP administrator role privileges in Cisco UCS Director. While creating this
user account, you can also select the MSP organizations that this user can manage and you can create a
newMSP organization. For information on creating a user account with a specific role, see Adding Users,
on page 26.

The role defines the menus and tabs that this user can view in Cisco UCS Director. Typically, an MSP
administrator will require the following menus:

• Organization

• Policies

• CloudSense

In addition to creatingMSP organizations andMSP administrator roles, you can also brand these organizations
with customized logos and application labels. For more information, see Branding Customer Organizations,
on page 87.

Cisco UCS Director supports branding at the global level, MSP organization level, and customer organization
level. However, the branding details visible to a user are limited by certain guidelines. For more information,
see Branding for Customer Organizations, on page 85.

Note

If you are an MSP administrator, then the following table lists the tasks that you can perform in Cisco UCS
Director. It also lists sections in this guide where you can find procedural information.

Link to the information in the guideTask

Creating a Customer Organization, on page 54Create customer organizations to manage

Branding Customer Organizations, on page 87Apply specific branding to customer organizations.

Managing Policies, on page 169Create and manage policies to provision VMs

Managing CloudSense Analytics, on page 365Use CloudSense Analytics to generate reports

Managing Groups

Creating a User Group

Step 1 Choose Administration > Users and Groups.
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Step 2 On the Users and Groups page, click User Groups.
Step 3 Click Add.
Step 4 On the Add Group screen, complete the following fields:

DescriptionField Name

The name of the group or the customer organization.

You can include special characters such as ( ). & - _ `~ $% ^ {}! '@

Name field

The description of the group or the customer organization, if required.Description field

A shorter name or code name for the group. This name is used in VM and hostname
templates.

Code field

(Optional) The cost center name or number if required. This name or number
represents a cost center that a group is associated with. This name can be used in a
VMware System policy for the VM naming convention.

For more information about using a cost center for naming conventions, seeManaging
Policies, on page 169.

Cost Center field

The email used to notify the group owner about the status of service requests and
request approvals if necessary.

Contact Email field

The contact’s first name.First Name field

The contact’s last name.Last Name field

The contact’s phone number.Phone field

The contact’s address.Address field

Choose the group share policy for the users in this group.

This drop-down list is populated only when you have created group share policies.

For more information on creating this policy, see Creating a Group Share Policy, on
page 179.

Group Share Policy drop-down
list

If checked, the users of this group can have resources assigned to them and can own
these resources. Also, these users can view resources belonging to the group. However,
the resources among these users cannot be shared.

Allow Resource Assignment To
Users check box

Step 5 Click Add.

What to do next

Repeat this procedure if you want to add more groups. For each group that you add, you can edit resource
limits, manage tags, and customize the logo and application labels.
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Using the Global Dashlet Setup Option
This procedure describes how you can customize the number of dashlets that all end users in all groups can
view in the End User Portal. In addition, you can customize the number of dashlets that end users in a specific
group can view. For more information on customizing the dashlets for a specific group, see Configuring
Dashlets, on page 103.

Step 1 Choose Administration > Users and Groups.
Step 2 On the Users and Groups page, click Global Dashlet Setup.
Step 3 In the Dashlets Report screen, click Select.
Step 4 In the Dashlet Name screen, uncheck the check boxes of the dashlets that should not be displayed for all end users of all

groups in the system.
Step 5 Click Select.
Step 6 In the Dashlets Report screen, click Submit.

Creating an MSP Organization

Step 1 Choose Administration > Users and Groups.
Step 2 ClickMSP Organizations.

These tab names are only indicative. If you have enabled the Service Provider Feature, you must specify the names of
the organization at the first and second level. The names that you specify are displayed as tabs in the interface.

Step 3 Click Add.
Step 4 In the Add MSP Organizations screen, complete the required fields, including the following:

DescriptionField Name

The name of the MSP organization.

You can include special characters such as ( ). & - _ `~ $% ^ {}! '

Name field

The description of the MSP organization, if necessary.Description field

A shorter name or code name for the group. This name is used in VM and hostname
templates.

Code field

The cost center name or number if required. This name or number represents a cost
center that a group is associated with. This name can be used in a VMware System
policy for the VM naming convention.

For more information about using a cost center for naming conventions, seeManaging
Policies, on page 169.

Cost Center field

The email used to notify the MSP administrator about the status of service requests
and request approvals, if necessary.

Contact Email field

The contact’s first name.First Name field
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DescriptionField Name

The contact’s last name.Last Name field

The contact’s phone number.Phone field

The contact’s address.Address field

Step 5 Click Add.

What to do next

For each MSP organization that you create, you can edit resource limits, manage tags, and customize the logo
and application labels. You can also create customer organizations within each MSP organization.

Creating a Customer Organization
You can follow this procedure to create a customer organization within an MSP organization.

Step 1 Choose Administration > Users and Groups.
Step 2 Click Customer Organizations.

This tab name is only indicative. If you have enabled the Service Provider Feature, you must specify the names of the
organization at the first and second level. Those names are displayed as tabs in the interface. If you have disabled the
Service Provider Feature, then only the Customer Organizations tab is displayed.

Step 3 Click Add.
Step 4 In the Add Group screen, complete the required fields, including the following:

DescriptionField Name

The name of the group or the customer organization.

You can include special characters such as ( ). & - _ `~ $% ^ {}! '

Name field

The description of the group or the customer organization, if necessary.Description field

Select the MSP organization name from the drop-down list.

This list includes all the groups that you can currently manage. For example, if you
are a global administrator of the system, then this list displays all the organizations
that you manage. But, if you are an MSP administrator, then this list displays only
the organization that you have administrative privileges for.

MSP Group Name field

A shorter name or code name for the group. This name is used in VM and hostname
templates.

Code field
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DescriptionField Name

(Optional) The cost center name or number if required. This name or number
represents a cost center that a group is associated with. This name can be used in a
VMware System policy for the VM naming convention.

For more information about using a cost center for naming conventions, seeManaging
Policies, on page 169.

Cost Center field

The email used to notify the group owner about the status of service requests and
request approvals, if necessary.

Contact Email field

The contact’s first name.First Name field

The contact’s last name.Last Name field

The contact’s phone number.Phone field

The contact’s address.Address field

Choose the group share policy for the users in this group.

This drop-down list is populated only when you have created group share policies.
For more information on creating this policy, see Creating a Group Share Policy, on
page 179.

Group Share Policy drop-down
list

If checked, the users of this group can have resources assigned to them and can own
these resources. Also, these users can view resources belonging to the group. However,
the resources among these users cannot be shared.

Allow Resource Assignment To
Users check box

Step 5 Click Add.

What to do next

Repeat this procedure to add more customer organizations. For each customer organization that you add, you
can edit resource limits, manage tags, and customize the logo and application labels.

Password Policy
The password policy applies to all users and is enforced when you add a user or change the password for all
user types. This policy enables the following password constraints:

• Password length

• Whether the password can be the same as the username

• Whether a user can set the current password as a new password

• Whether certain regular expressions are disallowed in a password
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Creating a Password Policy

Step 1 Choose Administration > Users and Groups.
Step 2 On the Users and Groups page, click Password Policy.
Step 3 In the Password Policy screen, complete the required fields, including the following:

DescriptionName

Choose the minimum number of characters for the
password.

The minimum length of a password cannot be
lesser than 4 characters.

Note

Minimum Password Length drop-down list

Choose the maximum number of characters for the
password.

The maximum length of a password can be up
to 127 characters.

Note

Maximum Password Length drop-down list

Choose the minimum number of character classes, such as
uppercase, lowercase, numbers, and special characters.

Minimum Character Classes drop-down list

Check the check box to disallow passwords that are the
same as the login ID.

Disallow Login in Password check box

Check the check box to disallow the previous password
from being used as the new password.

Disallow Previous Password check box

Choose the number of previous passwords that must be
stored in the system.

Previous Passwords Counts drop-down list

The regular expressions (one per line) that are not allowed
for passwords. For example,.*abc.* specifies that a given
password cannot contain the string “abc”.

DisallowPasswords thatmatchRegular Expression field

Specify the number of days for which the password will
remain active. By default, the value for this field is set to
180.

Password expiry (in days) field

Specify the number of days prior to the password expiration
that a warning message is sent to the user.

Warn Password expiry (in Days) drop-down list

Specify the number of days, after password expiration, that
a user can use the password to log in to the system.

Grace Period for Password (in Days) drop-down list

Step 4 Click Submit.
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Group Budget Policy
Resources are accounted for by using the Chargeback feature. For resource usage by a group or customer
organization, you associate the entity with a budget policy.

You can configure a group or customer organization with a budget watch, and configure a group or customer
organization to stay within or exceed the provisioned budget.

Viewing and Editing a Group Budget Policy

Step 1 Choose Administration > Users and Groups.
Step 2 On the Users and Groups page, click User Groups.
Step 3 Choose a group from the list.
Step 4 From theMore Actions drop-down menu, click Budget Policy.
Step 5 In the Budget Policy screen, complete the required fields, including the following:

DescriptionName

Check the check box to monitor the budget usage for the
group. Uncheck the box to ignore all budget entries for this
group.

Enable Budget Watch check box

Check the check box to allow group members to exceed the
provisioned budget. Uncheck the box to reject requests,
once the budget is exhausted, until a new budget is added.

Allow Over Budget check box

Step 6 Click Save.

Resource Limits
You can configure resource limits for a group, a customer organization, or a tenant, to manage resource
utilization. You can specify limits for the following:

• Virtual resources

• Operating system resources

• Physical resources

Configuration of operating system resource and physical resource limits are not supported for public clouds.Note

Guidelines for Resource Limits with Service Provider Enabled

If you have enabled the Service Provider feature in Cisco UCS Director, keep in mind the following
considerations while configuring resource limits:
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• The limit set for the parent organization determines the limits that you can set for customer groups and
containers within the parent organization.

• If you have not added resource limits to a specific customer group but have specified limits for containers
within that group, you must consider the total resource limits before setting a limit for another customer
group within the parent organization.

• The total number of resource limits configured for all customer groups and containers within those groups
cannot exceed the resource limit set for the parent organization.

• If you do not add resource limits to a specific customer group but do specify resource limits for containers
within that group, you must consider the total of all container resource limits before you set a limit for
the parent organization.

For example, the parent organization, Tenant 1, includes three customer groups: Group A, Group B, and
Group C. If you configure a resource limit of ten for Tenant 1, the cumulative resource limits specified for
all customer groups within Tenant 1 must not exceed ten. The cumulative resource limits include resource
limits applied to customer groups and containers.

Group A includes containers C1 and C2, and has a resource limit of 4 assigned to the customer group. Group
B includes containers C3 and C4, and each of these containers has a resource limit of two. This configuration
means that two is the maximum available resource limit you can configure for Group C and all its containers
(the resource limit for Tenant 1, minus the total resource limits for Group A, Group, B, and containers C1,
C2, C3, and C4).

Guidelines for Resource Limits with Service Provider Disabled

If you have disabled the Service Provider feature, there is only one parent organization. Therefore, if you set
a resource limit for the parent organization, the total of the limits specified for all customer groups must not
exceed the parent resource limit.

For example, the parent organization includes two customer groups: Group A and Group B. If you set a limit
of ten for the parent organization and five for Group A. The resource limit that you set for Group B, must not
exceed five (the resource limit for the parent organization minus the resource limit for Group A).

Viewing Resource Limits

Step 1 Choose Organizations > Summary.
Step 2 On the Summary page, choose the user group.
Step 3 Click Resource Limits to view the current limit, usage, pending SR usage, and status of the resources for the selected

group.

Editing Resource Limits

Step 1 Choose Administration > Users and Groups.
Step 2 If you are editing a resource limit for an organization or a customer group, choose Customer Organization, orMSP

Organization.
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These tab names are only indicative. If you have enabled the Service Provider Feature, you have to specify
the names of the organization at the first and second level. The names that you specify are displayed as tabs in
the interface.

Important

Step 3 To edit the resource limit for a user group, choose User Groups.
Step 4 Choose a group from the table, and click Edit Resources Limits. The Resource Limit screen appears.
Step 5 In theResource Limit screen, check Enable Resource Limits and complete the required fields, including the following:

DescriptionField Name

The group name that you selected.Group field

Check the check box to enable the resource limits or
uncheck the check box to disable the resource limits.

If checked, the user is provided with the option to set
resource limits for a group and all nonzero resource limits
are applied.

Enable Resource Limits check box

The maximum number of active VMs.Maximum Active VM Count field

The total number of VMs.Maximum Total VM Count field

The total number of VDCs.

While provisioning a VM, if the number of VDCs you
specify exceeds the number you specify in this field, then
an error message is displayed.

Maximum Total VDC Count field

The maximum number of provisioned vCPUs.Provisioned vCPUs Limit field

The provisioned memory limit, in gigabytes.Provisioned Memory (GB) Limit field

The provisioned limit for disks, in gigabytes.Provisioned Disk (GB) Limit field

The reserved limit of CPUs, in gigahertz.Reserved CPU (GHz) Limit field

The reserved memory limit, in gigabytesReserved Memory (GB) Limit field

The maximum limit for snapshots, in gigabytes.Maximum Snapshot (GB) Limit field

Check the box to include the group's inactive VM CPU or
memory data in the computation of resource limits. Uncheck
the box to exclude inactive VM CPU or memory data from
the computation of resource limits.

Count CPU and Memory for Inactive VMs check box

OS Resource Limits

The configuration of OS resource limits and physical resource limits is not supported for public clouds.Note

The maximum number of CentOS (Community Enterprise
Operating System) servers.

CentOS field

The maximum number of Windows 2003 servers.Windows Server 2003 field
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DescriptionField Name

The maximum number of Windows 2008 servers.Windows Server 2008 field

The maximum number of Windows 2012 servers.Windows Server 2012 field

The maximum number of Windows 2016 servers.Windows Server 2016 field

The maximum number of Windows 7 machines.Windows 7 field

The maximum number of Windows XP machines.Windows XP field

The maximum number of Red Hat machines.Red Hat field

The maximum number of Ubuntu machines.Ubuntu field

The maximum number of FreeBSD machines.FreeBSD field

The maximum number of other Linux OS.Other Linux field

The maximum number of other OS.Other field

Physical Resource Limits

The maximum number of servers.Maximum Physical Server Count field

The maximum number of full length physical servers.

The number of servers specified in this field, when added
with the number of servers specified for theMaximum
HalfWidth Physical Server Count field must be less than
or equal to the number of servers specified in theMaximum
Physical Server Count field.

This field is applicable only for Cisco UCS blade
servers.

Important

Maximum Full Width Physical Server Count field

The maximum number of half length physical servers.

The number of servers specified in this field, when added
with the number of servers specified for theMaximumFull
Width Physical Server Count field must be less than or
equal to the number of servers specified in theMaximum
Physical Server Count field.

This field is applicable only for Cisco UCS blade
servers.

Important

Maximum Half Width Physical Server Count field

The maximum amount of server memory.Maximum Physical Server Memory (GB) field

The maximum number of server CPUs.Maximum Physical Server CPU Count field

The maximum number of vFilers.Maximum vFiler Count field

The maximum amount of storage space.Maximum Physical Storage Space (GB) field
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Step 6 Click Save.

Configuring the Administration Profile

Creating the Admin Profile

Step 1 Choose Administration > Users and Groups.
Step 2 On the Users and Groups page, click Users.
Step 3 Click Add.
Step 4 In the Add User screen, complete the required fields, including the following:

DescriptionField Name

Choose the user type option as SystemAdmin. The system
administrator has full privileges.

User Type drop-down list

The login name. The default is admin.Login Name field

The admin password.Password field

The admin password that is entered again for confirmation.Confirm Password field

The administrator’s email address.User Contact Email field

The administrator’s first name.First Name field

The administrator’s last name.Last Name field

The administrator’s phone number.Phone field

The administrator’s address.Address field

Check to set the date and time when the user account must
be disabled in the system. Disabling a user account means
that the user can no longer log in into the system.

A week prior to this date, an email message stating that the
account will be disabled is sent to the user. This automatic
email message is generated and sent by the
PeriodicNotificationToUserTask system task.

On the specified date and time, the user account is disabled
automatically. If the user is logged in to the system on the
date specified, then the login session is terminated
automatically.

Set user disable date check box
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DescriptionField Name

Choose a language for the system specifically for this user.
By default, the language is set to English.

When this user logs in, the user interface is displayed in the
language you selected. This locale selection applies only to
this user.

Locale drop-down list

Check to launch the Classic user interface when this user
logs in to the system.

Login with Classic View check box

Step 5 Click Add.

Editing Your Administrative Profile
As an administrator in the system, you can edit your own profile in the system.

Step 1 Mouse-over your login name on the top right corner of the screen.
Step 2 Choose Edit My Profile.

All information that was specified while creating the account is displayed.

Step 3 In the Edit My Profile screen, complete the required fields, including the following:

DescriptionName

Choose a new language for the user interfaceLanguage drop-down list

Enter your current password.Old Password field

Enter your new password.New Password field

Re-enter your new password.Confirm Password field

Choose a new profile as the default profile.Access Profiles

Check this check box to view the Dashboard screen soon
after logging into the system.

Enable Dashboard check box

Step 4 Click Show Advanced Settings and complete the required fields, including the following:

DescriptionName

Choose eitherCopyKeyValue orRegenerateKey option.REST API Access Key field

Check this check box to enable the Developer menu on the
system.

You must restart the system for this change to take effect.

Enable Developer Menu check box
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DescriptionName

CheckLogin with Classic View to launch the Classic view
of the user interface on subsequent logins.

The capability to set the system to launch the
Classic view for your subsequent logins is
available only in Release 6.5. The Classic view
will be removed in a subsequent release.

Important

UI Preference field

Enter a message that must be broadcast on the system.System Broadcast Message field

Step 5 Click Save.
Step 6 Restart the system.

All changes that require a system restart are available in the interface.

Sending a Broadcast Message
As an administrator on the system, you can send a broadcast message to all the users that are currently logged
into Cisco UCS Director. While configuring this message, you can either choose to have this message set
with or without a timer.

Step 1 Move the cursor over your login name on the top right corner of the screen.
Step 2 Choose Edit My Profile.
Step 3 Choose Show Advanced Settings and complete the required fields, including the following:

DescriptionName

Enter the message that you want to send as a broadcast to
all users.

System Broadcast Message field

Check this check box to dismiss the message automatically
after a specific period of time. If you do not check this check
box, the user will necessarily have to close the message.

Dismiss Message Automatically check box

Choose the number of minutes that the message must be
visible to users, after which it automatically closes.

Number of Minutes to Display drop-down list

Step 4 Click Send.

Changing the Admin Password

Step 1 Choose Administration > Users and Groups.
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Step 2 On the Users and Groups page, click Users.
Step 3 Choose the administrator user account from the list of accounts.
Step 4 From theMore Actions drop-down menu, click Change Password.
Step 5 In the Change Password screen, enter a new password for the admin user and confirm it.
Step 6 Click Save.

Viewing Current Online Users

SUMMARY STEPS

1. Choose Administration > Users and Groups.
2. Choose Current Online Users to view a list of online users. The list displays each user's username, IP

address, session start time, last data access, and client.

DETAILED STEPS

Step 1 Choose Administration > Users and Groups.
Step 2 Choose Current Online Users to view a list of online users. The list displays each user's username, IP address, session

start time, last data access, and client.

Managing User Access Profiles

Multi-Role Access Profiles
A user can be assigned to more than one role, which is reflected in the system as a user access profile. For
example, a user might log into Cisco UCSDirector as a group administrator and as an all-policy administrator,
if both types of access are appropriate.

Access profiles also define the resources that can be viewed by a user. With Cisco UCS Director Release 5.4,
support for multiple profiles for a single user was introduced. So when you install version 5.4, and if a user
account is associated with multiple groups, the system creates multiple profiles for the user account. But if
you upgrade the system from a prior version to version 5.4, and if the LDAPSyncTask system task is not yet
run, then, by default, only one profile is listed for a user account in the system.

When LDAP users are integrated with Cisco UCS Director, if a user belongs to more than one group, then
the system creates a profile for each group. But by default, the domain users profile is added for LDAP users.

TheManage Profiles feature enables you to add, log into, edit, or delete a user access profile.Note
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Creating a User Access Profile

Step 1 Choose Administration > Users and Groups.
Step 2 On the Users and Groups page, click Users.
Step 3 Choose a user from the list.
Step 4 From theMore Actions drop-down menu, clickManage Profiles.
Step 5 In theManage Profile screen, click Add.
Step 6 In the Add Entry to Access Profiles screen, complete the required fields, including the following:

DescriptionField Name

The profile name.Name field

The description of the profile.Description field

Choose the user role type.Type drop-down list

Choose the organization to which this user profile applies.Customer Organizations drop-down list

Select this checkbox to specify that the user can view
resources from all other groups that they have access to or
are a part of.

Show Resources From All Other Groups the User Has
Access check box

Click Select to choose the groups to which the user profile
applies.

The user will be able to access all the resources associated
with the selected groups.

Shared Groups field

Check the check box if this is the default user access profile.
Uncheck the check box if it is not the default.

Default Profile check box

Step 7 Click Submit.

What to do next

Create additional user access profiles as needed.

Logging in to a Profile
As a user in the system, if you have multiple profiles for your account, then you can log in to the system with
a specific profile.

SUMMARY STEPS

1. In the Cisco UCS Director login dialog box, enter your username in the Username field, in the format
Username: Access Profile Name.

2. In the Password field, enter your password.
3. Click Login.
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DETAILED STEPS

Step 1 In theCisco UCSDirector login dialog box, enter your username in theUsername field, in the format Username: Access
Profile Name.

For example, Alex: GrpAdmin

Step 2 In the Password field, enter your password.
Step 3 Click Login.

Default Profile
The default profile is the first profile that you created in the system. You can change the default to another
profile. Using the new default profile, you log in by entering the username and password.

Changing a Default Profile

Step 1 In the user interface, click the username displayed on the top right corner.
Step 2 In the drop-down menu, click Edit My Profile.
Step 3 In the Edit My Profile screen, select the profile that you want to set as a default profile.

A profile can also be set as default while it is being added, or being edited.Note

Authentication and LDAP Integration
As an administrator, you can specify an authentication mechanism for the user accounts in the system. You
can configure an authentication preference with a fallback choice for LDAP. You can also configure a preference
with no fallback for Verisign Identity Protection (VIP) authentication.

Starting with Release 6.6, configuring an LDAP authentication preference using the Verisign Identity Protection
authentication service is no longer supported. This option is currently displayed in the user interface of the
administrative portal, and will be removed from a subsequent release.

Important

DescriptionName

Authentication is done first at the local server (Cisco
UCS Director). If the user record is not found in the
local server, then the authentication process shifts to
the LDAP server.

Local First, fallback to LDAP

VIPAuthentication Service (two-factor authentication)
is enabled.

Verisign Identity Protection
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Configuring Authentication Preferences

Step 1 Choose Administration > Users and Groups.
Step 2 On the Users and Groups page, click Authentication Preferences.
Step 3 In the Authentication Preferences screen, complete the required field:

DescriptionName

Choose the authentication preference.

• Local First, fallback to LDAP

If you select this option, then you must configure the
LDAP servers. For more information, see Configuring
LDAP Servers, on page 71.

• Verisign Identity Protection

If you select this option, continue to Step 4.

Starting with Release 6.6, configuring an LDAP
authentication preference using the Verisign
Identity Protection authentication service is no
longer supported. This option is currently displayed
in the user interface of the administrative portal,
and will be removed from a subsequent release.

Important

Authentication Preferences drop-down list

Step 4 If you selected Verisign Identity Protection, complete the following steps:
a) Click Browse to upload a VIP certificate. Locate and select the certificate, and click Upload.
b) Enter the Password.

Step 5 Click Save.

LDAP Integration
You can use LDAP integration to synchronize the LDAP server’s groups and users with Cisco UCS Director.
LDAP authentication enables synchronized users to authenticate with the LDAP server. You can synchronize
LDAP users and groups automatically or manually. While adding an LDAP account, you can specify a
frequency at which the LDAP account is synchronized automatically with Cisco UCS Director. Optionally,
you can manually trigger the LDAP synchronization by using the LDAPSyncTask system task.

After you configure an LDAP account and after the synchronization process is run, either manually or
automatically, the recently added LDAP information is displayed in Cisco UCS Director. This information
is displayed in a tree view that depicts the hierarchical structure of all organizational units (OUs), groups, and
users that have been added to the system. You can view this information by choosing Administration >
LDAP Integration. You can select and expand an OU in the left pane to view all the groups within it. If you
select a group in this left pane, you can view a list of users that are associated with that group. If an OU has
several sub OUs within it, then you can click the Organization tab in the right pane to view detailed
information. In addition, the Groups and Users tabs in the right pane display groups and users respectively
that are synchronized within the selected OU.
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In addition to running a system task, Cisco UCS Director also provides an additional option for you to
synchronize the LDAP directory with the system:

• Cleanup LDAPUsers system task—This system task determines if the synchronized users in the system
are deleted from the LDAP directories or not. If there are user records that have been deleted from the
LDAP directories, then after this system task is run, these user accounts are marked as disabled in the
system. As an administrator, you can unassign resources of these disabled user accounts. By default, this
task is in the enabled state. After the second system restart, this system task is changed to the disabled
state. This applies to both, a standalone and multi-node setup.

In a multi-node setup, this system task runs only on the primary node, even if there is a service node
configured.

Users that do not belong to a group or to a domain user’s group display in LDAP as Users with No Group.
These users are added under the domain user’s group in Cisco UCS Director.

You can add LDAP users with the same name in different LDAP server accounts. The domain name is
appended to the login user name to differentiate multiple user records. For example: abc@vxedomain.com.
This rule is applicable to user groups as well.

Appending the domain name to the user name to login to the system is only applicable to LDAP users. It does
not apply to local users. All local users can login to the system with the user names.

When a single LDAP account is added, and a user logs in by specifying only the user name, Cisco UCS
Director first determines if the user is a local user or is an LDAP user. If the user is identified as a local user
and as an external LDAP user, then at the login stage, if the user name matches the local user name, then the
local user is authenticated into Cisco UCSDirector. Alternatively, if the user namematches that of the external
user, then the LDAP user is authenticated into Cisco UCS Director.

Important

LDAP Integration Rules and Limitations

Group Synchronization Rules

• If a chosen LDAP group already exists in Cisco UCS Director and the source is type Local, the group
is ignored during synchronization.

• If a chosen LDAP group already exists in Cisco UCS Director and the group source is type External,
the group’s description and email attributes are updated in Cisco UCS Director.

• While adding an LDAP server, you can now specify user filters and group filters. When you specify a
group filter, all users that belong to the specified group are added to the system. In addition, the following
actions are also performed:

• If the specified group includes sub-groups, then the group, the sub-groups and the users in those
sub-groups are added to the system (only applicable when you manually synchronize the LDAP
directory).

• If the user is part of multiple groups, and the other groups do not match the group specified as the
group filter, then those additional groups are not added to the system.

• A user can be part of multiple user groups. However, the group that is mentioned first in the list of groups
that the user is part of is set as the default primary group for the user. If the user is not part of any group,
then the default primary group is set as Domain Users.
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You can view information on all the groups that a user is part of only after the
LDAPSyncTask system task is run.

Note

• When an LDAP group is synchronized, all users that are in the group are first added to the system. Also,
if users in the specified LDAP group are associated with other groups that are in the same OU or in a
different OU, then those groups are also retrieved and added to the system.

• The LDAP synchronization process will retrieve the specified LDAP groups for the system, along with
nested groups, if any.

• Prior to this release, a user was part of only one group. After an upgrade to the current release, and only
after the LDAPSyncTask system task is run, theManage Profiles dialog box displays the other groups
that the user is part of. This is applicable only when the other groups match the group filters that you
specified while configuring the LDAP server.

User Synchronization Rules

• LDAP users that have special characters in their names are now added to Cisco UCS Director.

• While adding an LDAP server, you can now specify user filters and group filters. When you specify a
user filter, all the users that match the filter you specified, and the groups that they belong to, are retrieved
for the system.

• An LDAP user can have multiple group memberships. When the LDAP user is synchronized with the
system, this multiple group membership information is retained. Cisco UCS Director provides you with
an option to view this information for every user. For more information, see Viewing GroupMembership
Information, on page 78. In addition, multiple access profiles are also automatically created for the user.

You can view this information only when the groups match the filter you specified
while configuring the LDAP server, and when the groups have been assimilated
into the system.

Note

• Cisco UCS Director now displays the User Principal Name (UPN) for each user that is added into the
system. This is applicable for users that have been added into the system in prior releases. Users can log
in to the system using their login name or their user principal name. Logging in using the user principal
name along with the profile name is not supported.

• If a chosen LDAP user already exists in Cisco UCS Director and the source type is External, then that
user is ignored at synchronization. The user’s name, description, email, and other attributes are not
updated again.

• If a user account is created in two different LDAP directories, then the user details of the LDAP directory
that was synchronized first are displayed. The user details from the other LDAP directory are not displayed.

• After multiple LDAP directories are synchronized, the LDAP external users must log in to Cisco UCS
Director by specifying the complete domain name along with their user name. For example:
vxedomain.com\username. However, this rule does not apply if there is only one LDAP server directory
added to Cisco UCS Director.
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After an LDAP synchronization process, verify that the user is assigned to the correct group.Note

Managing LDAP Integration

Step 1 Choose Administration > LDAP Integration.
Step 2 Required: Choose an LDAP server and click the following buttons, as needed, to manage LDAP integration:

DescriptionName

Enables you to choose a distinguished domain name to
search. All users and groups from the chosen organization
units are fetched into Cisco UCS Director when the LDAP
synchronization process is completed. This action is also
considered to be an automatic synchronization process.

You can initiate LDAP server synchronization
as a system task. For more information, see
Executing the LDAP Synchronization System
Task, on page 75.

Note

Search BaseDN button

Displays a dialog box that enables you to specify either
basic or advanced search criteria to fetch LDAP users and
groups.

Request Manual LDAP Sync

Step 3 (Optional) If you chose Request Manual LDAP Sync, complete the following fields:

DescriptionName

Enables search on the manually added organization units.

When you check this check box, the manually added OUs
are displayed.

Manual Search Base check box

Enables basic search by organization unit.Basic Search check box

Enables advanced search.Advanced Search check box

When you use either of the search options, if users and groups that match the search criteria already exist in
Cisco UCS Director, then they are not displayed as part of the search results.

Important

Step 4 For basic search, click Select to specify the search base.
Step 5 Choose the search base DN, click Select, and continue to Step 9.
Step 6 For advanced search, in the Advanced Filtering Options pane add or edit attribute names for User Filters and Group

Filters.
Step 7 Click Next.
Step 8 In the Select Users and Groups pane, complete the following fields:
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DescriptionName

The LDAP groups from which the users must be
synchronized.

LDAP Groups field

The LDAP users that must be synchronized.LDAP Users field

Step 9 Click Submit to synchronize the LDAP server.

Configuring LDAP Servers

You can configure multiple LDAP servers and accounts in Cisco UCSDirector. While adding LDAP accounts,
you can specify the following:

• An organization unit (OU) that is part of the search base DN.

• A frequency at which the LDAP account is automatically synchronized with the system.

• A group or user filter to narrow down the results, and specify an LDAP role filter on the groups and users

Soon after an LDAP server account is added, a system task for this account is created automatically, and it
immediately begins to synchronize the data. All the users and groups in the LDAP server account are added
to the system. By default, all the users from the LDAP account are automatically assigned to the service
end-user profile.

Before you begin

You should have set the authentication preferences to the following:

• Local First, fallback to LDAP

Step 1 Choose Administration > LDAP Integration.
Step 2 Click Add.
Step 3 In the LDAP Server Configuration screen, complete the required fields, including the following:

DescriptionName

The name of the account.

This name must be unique.

Account Name field

The type of LDAP server. It can be one of the following:

• OpenLDAP

• MSAD - Microsoft Active Directory

Server Type field

The IP address or the host name of the LDAP server.Server field

Enables a secure connection to the LDAP server.Enable SSL check box
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DescriptionName

The port number.

It is automatically set to 636 for SSL, and 389 for
non-secure mode.

Port field

The domain name.

If you selectedOpenLDAP as the LDAP Directory Type,
then this domain name must match the domain specified
with the user name.

You must specify the complete domain name.
For example: vxedomain.com.

Important

Domain Name field

The user name.

You can specify the user name in one of the following
formats:

• <username>@domain.com

• Distinguished Name of the user in the following
format:

CN=PowerUser,CN=Users,DC=domain,DC=com

If you selectedOpenLDAP as the LDAP Directory Type,
then specify the user names in the following format:

uid=users,ou=People,dc=ucsd,dc=com

where ou specified is the one all the other users are placed
in the directory hierarchy.

User Name field

The user password.Password field

Select the frequency (hours) at which the LDAP server
must be synchronized. It can be one of the following:

• 1

• 4

• 12

• 24

Synchronization Frequency drop-down list

Check this check box to manually enter the search base
organization units (OU).

If you do not check this check box, then the search base
organization units (OU) are retrieved from the LDAP
server automatically.

Enable Manual Search Base check box

Step 4 Click Next.
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Step 5 If you checked the Enable Manual Search Base check box, the Add Entry to Search Base screen is displayed. In
this screen, enter the organization units (OU) and click Submit.

You can enter multiple organization units (OU) from this screen.

a) After the OU is added to the system, click Next to configure user and group filters.

Step 6 If you did not check the Enable Manual Search Base check box, the LDAP Search Base pane is displayed. In this
pane, click Select to specify LDAP search base entries and click Select.

All organization units (OU) that are available in Cisco UCS Director are displayed in this list.

Step 7 Click Next.
Step 8 In the Configure User and Group Filters pane, complete the following fields:

DescriptionName

Click the + sign to select specific users that must be
synchronized with the system.

All groups that the selected users are part of are retrieved
and added into the system.

User Filters

Click the + sign to select groups that must be synchronized
with the system.

All users that are part of the selected group filters are
retrieved and added into the system. However, if the users
in the selected group are also part of other groups, then
those groups are not retrieved and added to the system
unless you select them.

Group Filters

Add Entry to Group Filters dialog box

Choose either Group Name or User Name.Attribute Name drop-down list

Choose the filter to retrieve groups and users. It can be one
of the following:

• Equals to

• Starts with

Operator drop-down list

Specify a keyword or a value that must be included in the
search.

Attribute Value field

Based on the filters, the groups or users are retrieved.

Step 9 Click Next.
Step 10 In the LDAP User Role Filter pane, click the (+) sign to add a user role filter.
Step 11 In the Add Entry to User Role Filters dialog box, complete the following fields:

DescriptionName

The name of the attribute. It can be Group Name.Attribute Name field
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DescriptionName

It can be one of the following:

• Equal to

• Starts with

Operator drop-down list

Specify a value in this field.

All users that match the values of the Operator field and
theAttribute Value field are assigned to the user role you
select in theMap User Role drop-down list.

Attribute Value field

Select a user role that you want the users mapped to. You
can choose a role that was available by default, or you can
choose a role that you created in the system.

Following are the roles that are available by default in
Cisco UCS Director:

• All Policy Admin

• Billing Admin

• Computing Admin

• Service End-User

• Group Admin

• IS Admin

• Network Admin

• Operator Admin

• Storage Admin

• System Admin

Map User Role drop-down list

Step 12 Click Submit.
Step 13 Click OK.

The user role filters are added to the User Role Filters table.

If you have multiple user role filters specified, then the filter specified in the first row is processed.

If you manually update a user role for a user from the Login Users tab, then the user role that you mapped
the group to is no longer applied to the user.

Note
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What to do next

If you have not set the authentication preference to LDAP, then you are prompted to modify the authentication
preference. For more information on changing the authentication preference, see Configuring Authentication
Preferences, on page 67.

Testing LDAP Server Connectivity

Step 1 Choose Administration > LDAP Integration.
Step 2 In the LDAP Integration tab, choose an LDAP account name from the table.
Step 3 Click Test Connection.
Step 4 In the Test LDAP Connectivity screen, click Close.

Viewing LDAP Server Summary Information

Step 1 Choose Administration > LDAP Integration.
Step 2 In the LDAP Integration tab, choose an LDAP account name from the table.
Step 3 Click View.

The View LDAP Account Information screen displays summary information of the LDAP account.

Step 4 Click Close.

Adding LDAP Search BaseDN Entries

Step 1 Choose Administration > LDAP Integration.
Step 2 In the LDAP Integration tab, choose an LDAP account name from the table.
Step 3 Click Search BaseDN.
Step 4 If you have not checked Enable Manual Search Base while configuring the LDAP server, then in the LDAP Search

Base screen, click Select to view the list of search base entries that are currently added.
a) Check the check boxes of the search base entries you want to include.
b) Click Select.
c) Click Submit.

Step 5 If you have checked Enable Manual Search Base while configuring the LDAP server, then in the LDAP Search Base
screen, click + to add a new entry to the search base table.

For search base entries that are already added in the system, you can either edit, delete or re-order them using the options
displayed on the screen.

Step 6 Click Submit.

Executing the LDAP Synchronization System Task

Step 1 Choose Administration > System.
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Step 2 On the System page, click System Tasks.
Step 3 Enter LDAP in the Filter field.
Step 4 Select LDAPSyncTask from the System Tasks table.
Step 5 Click Run Now.
Step 6 (Optional) ClickManage Task to enable or disable the synchronization process.

What to do next

The results of the synchronization process are displayed in Cisco UCS Director. Select an LDAP account on
the LDAP Integration pane, and click Results to view the summary of the synchronization process.

Modifying LDAP Server Details

You can only modify the following details for a configured LDAP server:

• Port numbers and SSL configuration

• User name and password

• Synchronization frequency

• Search BaseDN selections

• User roles and groups that are mapped

Step 1 Choose Administration > LDAP Integration.
Step 2 In the LDAP Integration tab, choose an LDAP account name from the table.
Step 3 ClickModify.
Step 4 In theModify LDAP Server Configuration screen, edit the required fields, including the following:

DescriptionName

Enables a secure connection to the LDAP server.Enable SSL check box

The port number.

It is automatically set to 636 for SSL, and 389 for
non-secure mode.

Port field

The user name.

If you selectedOpenLDAP as the LDAP Directory Type,
then specify the user names in the following format:

uid=users,ou=People,dc=ucsd,dc=com

where ou specified is the one all the other users are placed
in the directory hierarchy.

User Name field

The user password.Password field
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DescriptionName

Choose the frequency (in hours) at which the LDAP server
is synchronized with the system database. It can be one of
the following:

• 1

• 4

• 12

• 24

Synchronization Frequency drop-down list

Step 5 Click Next.
Step 6 In the LDAP Search Base pane, click Select to specify LDAP search base entries and click Select.
Step 7 Click Next.
Step 8 In the Configure User and Group Filters pane, complete the following fields:

DescriptionName

Click the + sign to select specific users that must be
synchronized with the system.

User Filters

Click the + sign to select groups that must be synchronized
with the system.

Group Filters

Step 9 Click Next.
Step 10 In the LDAP User Role Filter pane, click the (+) sign to add a user role filter.
Step 11 In the Add Entry to User Role Filters dialog box, complete the following fields:

DescriptionName

The name of the attribute. It can be Group Name.Attribute Name field

It can be one of the following:

• Equal to

• Starts with

Operator drop-down list

Specify a value in this field.

All users that match the values of the Operator field and
theAttribute Value field are assigned to the user role you
select in theMap User Role drop-down list.

Attribute Value field
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DescriptionName

Select a user role that you want the users mapped to. You
can choose a role that was available by default, or you can
choose a role that you created in the system.

Following are the roles that are available by default in
Cisco UCS Director:

• All Policy Admin

• Billing Admin

• Computing Admin

• Service End-User

• Group Admin

• IS Admin

• Network Admin

• Operator Admin

• Storage Admin

• System Admin

Map User Role drop-down list

Step 12 Click Submit.
Step 13 Click OK.

The user role filters are added to the User Role Filters table.

If you have multiple user role filters specified, then the filter specified in the first row is processed.Note

Viewing Group Membership Information

Any user in the system can be part of multiple user groups. When a user is added to the system, all groups
that the user is part of are also added to the system. However, the group that the user was most recently added
to is set as the default primary group for the user. If the user is not part of any group, then the default primary
group is set as Domain Users. While you can use theManage Profiles option to view and modify group
membership for users, Cisco UCS Director also provides you with an additional option to view a list of all
groups that a specific user is part of.

Step 1 Choose Administration > Users and Groups.
Step 2 On the Users and Groups page, click Users.
Step 3 Select a user from the table.
Step 4 From theMore Actions drop-down menu, click Group Membership.

TheMemberOf screen displays all the groups that the user is part of.
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Step 5 Click Close.

Deleting LDAP Server Information

When you delete an LDAP server account, the following actions are initiated:

• Resources that have been assigned to LDAP users are un-assigned.

• VMs that have been assigned to the LDAP users are un-assigned.

• Resources that have been assigned to LDAP groups are un-assigned.

• VMs that have been assigned to the LDAP groups are un-assigned.

• VM share policies that have been assigned to LDAP users are un-assigned.

• Tags that have been applied to the LDAP users and groups are cleared

• Users and groups are immediately deleted from the database.

• The LDAP server details are removed from the tree view.

Step 1 Choose Administration > LDAP Integration.
Step 2 In the LDAP Integration tab, choose an LDAP account name from the table.
Step 3 Click Delete.
Step 4 In the Delete LDAP Account screen, click Delete.
Step 5 Click OK.

This initiates the deletion of the LDAP account in Cisco UCS Director. Based on the number of users and groups in the
LDAP account, this deletion process could take a few minutes to complete. During such time, the LDAP account may
still be visible in Cisco UCS Director. Click Refresh to ensure that the account has been deleted.

Single Sign On
Cisco UCS Director provides a Single Sign-On (SSO) service based on SAML 2.0. To enable SSO, Cisco
UCS Director must be registered as a Service Provider (SP) with the OneLogin Identity Provider (IDP). SSO
enables users to access multiple systems seamlessly without having to log in to individual systems. With SSO
configured and enabled between the SP and IDP, a user can log in to the OneLogin portal and then access
Cisco UCS Director without having to log in again.

To enable Single Sign-On, you must complete the following:

1. Create a user account at the OneLogin site.

2. Map the Cisco UCS Director appliance details in the OneLogin site.

For more information, see Mapping the Cisco UCS Director Appliance at the OneLogin Site, on page 80

3. Generate a Single Sign-On certificate at the OneLogin site.

For more information, see Generating a OneLogin Certificate, on page 81.
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4. Create a user account in Cisco UCS Director with the same credentials as the account created at the
OneLogin site. The user account must be created on the same appliance that was mapped in the OneLogin
site.

For information on adding a user, see Adding Users, on page 26.

5. Enable Single Sign-on by uploading the certificate on the appliance that you referenced in the OneLogin
site.

For more information, see Enabling Single Sign-On, on page 82.

After you complete this procedure, when you return to the OneLogin site and click on Cisco UCS Director,
the user will no longer be prompted to enter their user name and password information.

Mapping the Cisco UCS Director Appliance at the OneLogin Site

To enable Single Sign-On, you must first map the system that is running Cisco UCS Director.

Before you begin

You must have a OneLogin account.

Step 1 Access the OneLogin site from the following link: https://www.onelogin.com.
Step 2 Log in to the site using your account details.
Step 3 From the menu bar, choose Apps > Add Apps.
Step 4 In the Find Applications field, enter SAML.
Step 5 In the search results that are displayed, select and double-click OneLogin SAML Test (IdP) SAML 2.0.

The Info pane is displayed.

Step 6 In the Info pane, enter the following information:

DescriptionField

Enter a unique name for the system that is running Cisco
UCS Director.

This name is displayed on the home page of the OneLogin
portal. You can register multiple Cisco UCS Director
appliances at this portal. Be sure to enter a name that helps
you identify the system accurately.

Display Name field

Step 7 Click Save.
Step 8 Choose Configuration from the menu bar, and enter the following information:
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DescriptionField

Enter the URL of the system that is running Cisco UCS
Director.

Enter the URL that is displayed after a user logs
into the Cisco UCS Director user interface. It
should look similar to the following:
https://<ip_address>/app/cloudmgr/cloudmgr.jsp.
For example:
https://10.10.10.10/app/cloudmgr/cloudmgr.jsp.

For releases 6.0 and later, the URL should look
similar to the following:
https://<ip_address>/app/ux/index.html. For
example: https://10.10.10.10/app/ux/index.html.

Important

SAML Consumer URL field

Step 9 Click Save.

On the home page of this site, an icon is created for the server details that you specified. For every appliance that you
register at the OneLogin site, an icon is displayed on the home page. If you click this icon, you are automatically directed
to the Cisco UCS Director user interface.

What to do next

Generate a OneLogin certificate and enable SSO on the Cisco UCS Director appliance.

Generating a OneLogin Certificate

Before you begin

• You must have a OneLogin account

• The Cisco UCS Director application must be registered with the OneLogin website.

Step 1 Access the OneLogin site from the following link: https://www.onelogin.com.
Step 2 Log in to the site using your account details.
Step 3 From the menu bar, choose Settings > SAML.
Step 4 Select Standard Strength Certificate (2048-bit).
Step 5 Click Download.
Step 6 Click OK.

A file with the name onelogin.pem is downloaded to your system.

What to do next

You must upload this certificate on the Cisco UCS Director appliance.
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Enabling Single Sign-On

Step 1 Choose Administration > Users and Groups.
Step 2 On the Users and Groups page, click Single Sign-On.
Step 3 Check Enable Single Sign-On.
Step 4 In the File field, either drag and drop a file, or click Select a File to browse and select the OneLogin certificate file on

your system.

The OneLogin certificate file is saved on your system with the name onelogin.pem.

Step 5 Click Upload.
Step 6 When the upload is complete, click Submit.

When you launch Cisco UCS Director from the OneLogin site, you are not prompted to log in to the system.

Single Sign-on with Ping Federate

You can enable Single Sign-on (SSO) for Cisco UCSDirector with Ping Federate. SSO enables users to access
multiple systems seamlessly without having to log in to individual systems.

To enable Single Sign-On with Ping Federate, you must complete the following:

1. Create an adaptor.

See Creating an Adapter in Ping Federate, on page 83

2. Create Service Provider (SP) connectors.

See Creating Service Provider Connections, on page 84

3. Upload the certificate on the Cisco UCS Director appliance.

4. Navigate to the URL specified while creating the SP connection, and login using the credentials you had
specified.

Creating a User in Ping Federate

Step 1 Launch the Ping Federate user interface.
Step 2 Click Server Configuration.
Step 3 Click Password Credential Validators displayed under Authentication.
Step 4 Click Create New Instance and complete the following:

a) In the Type tab, enter unique values for INSTANCE NAME and INSTANCE ID fields.
b) In the TYPE drop-down list, choose Simple Username Password Credential Validator.
c) In the PARENT INSTANCE drop-down list, choose None.
d) In the Instance Configuration tab, click Add a new row to Users.

Step 5 Add a new user and click Update.
Step 6 Click Next.
Step 7 Review the summary.
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Step 8 Click Done.

Creating LDAP Users

Step 1 Launch the Ping Federate user interface.
Step 2 Click Server Configuration.
Step 3 Click Password Credential Validators link displayed below Authentication.
Step 4 Click Create New Instance and complete the following fields:

a) In the Type tab, enter unique values for INSTANCE NAME and INSTANCE ID fields and click Next.
b) In the TYPE drop-down list, choose LDAP Username Password Credential Validator.
c) In the Parent Instance drop-down list, choose None.
d) In the Instance Configuration tab, clickManage Data Stores displayed at the botton of the page.
e) Choose Add New Data Store.
f) In the Data Store Type drop-down list, choose LDAP.
g) Add appropriate values for the LDAP configuration fields.
h) Click Done.

Creating an Adapter in Ping Federate

Before you begin

You must create a user in Ping Federate with the same credentials of the user created in Cisco UCS Director.
You can create a user in multiple ways in Ping Federate. Following are the commonly used procedures to
create a user:

• Create a single user.

See Creating a User in Ping Federate, on page 82

• Configure LDAP users.

See Creating LDAP Users, on page 83

Step 1 Launch the Ping Federate user interface.
Step 2 Choose Adapter > Type.
Step 3 Complete the following fields on the Type screen:

a) Enter unique values for the INSTANCE NAME and INSTANCE ID fields.
b) Choose HTML Form IDP Adapter or LDAP from the Type drop-down list.
c) Choose None from the Parent Instance drop-down list.
d) Click Next.

Step 4 Complete the following fields on the IDP Adapter screen:
a) Click Add a new row to Credential Validators and select the form that you created earlier.
b) Click Update.
c) Click Next.
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Step 5 In the Extended Contract screen, click Next.
Step 6 In the Adapter Attributes screen, choose the user name as the pseudonym.
Step 7 Click Next.
Step 8 In the Adapter Contract Mapping screen, click Next.
Step 9 Review the information displayed in the Summary screen, and click Done.
Step 10 Click Save.

What to do next

Configure Service Provider (SP) connections.

Creating Service Provider Connections

Step 1 Launch the Ping Federate user interface.
Step 2 Click SP Connections.
Step 3 Click Create New.
Step 4 In the Connection Type tab, check the Browser SSO Profiles check box and click Next.
Step 5 In the Connection Options tab, check the Browser SSO check box and click Next.
Step 6 In the Import Metadata tab, click the None radio button for theMETADATA field.
Step 7 In the General Info tab, enter the values for the following fields:

• Connection ID

• Connection Name

• BASE URL—Enter the URL of Cisco UCS Director.

Step 8 Click Next.
Step 9 In the Browser SSO tab, choose Configure Browser SSO and complete the following:

a) In the SAML Profiles tab, check the IDP-INITIATED SSO checkbox and click Next.
b) In the Assertion Lifetime tab, retain the default values and settings, and click Next.
c) In the Assertion Creation tab, choose Configure Assertion Creation and complete the following:

1. In the Identity Mapping tab, choose the Standard option and click Next.

2. In the Attribute Contract tab, retain the default values and click Next.

3. In the Authentication Source Mapping tab, chooseMap New Instance tab.

You must select the adapter instance you previously created, and and click Next.

4. In theMapping Method tab, retain the default values and click Next.

5. In theAttributes Contract Fulfillment tab, chooseAdapter in the Source column and username in theValue
column. Retain the default values for other columns, and and click Next.

Step 10 In the Protocol Setting tab, choose New Protocol, and complete the following:
a) In the Assertion Consumer Service URL screen, choose POST in the Binding column and enter the Cisco UCS

Director URL in the Endpoint URL column and click Next.
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b) Choose the default values in the subsequent screen and click Done.

Step 11 In the Credentials tab, create a certificate and download it. Click Next.
Step 12 In the Activation and Summary screen, choose Active as the Connection Status and click Done.
Step 13 Upload the certificate in Cisco UCS Director.

The user name you specify must be the same as the user name specified in Ping Federate.

Step 14 Navigate to the URL you specificed as the SSO Application Endpoint and login to complete enabling single sign-on.

Branding for Customer Organizations
Cisco UCS Director supports branding and customizing the portal at the following levels:

• Global level—This system-level branding can be modified by the global administrator.

• MSP Organization level or the tenant level—The branding at this level can be modified by the
administrator or the MSP administrator.

• Customer organization level—Customer organizations are usually grouped with an MSP organization.
An MSP administrator or a global administrator can modify the branding details.

With the introduction of branding support at the MSP organization level, certain rules apply to what branding
changes users may view. The settings that are applied depend on the following:

• User role—Is the user an end user, a group administrator, or an MSP administrator?

• User's customer organization and the branding set for it.

• MSP Organization branding settings.

The following table elaborates the branding behavior in Cisco UCS Director.

Table 1: Branding Behavior in Cisco Cisco UCS Director

End UserGroup AdministratorMSP AdministratorBranding set at
Customer
Organization Level

Branding set at MSP
Organization Level

Branding details set
at the customer
organization level to
which this user
belongs to is
displayed.

Branding details set
at the customer
organization level is
displayed.

Branding details set
at the MSP
organization level
are displayed.

YesYes

Branding details set
at the customer
organization level to
which this user
belongs to is
displayed.

Branding details set
at the customer
organization level is
displayed.

Global branding
details are displayed.

YesNo
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End UserGroup AdministratorMSP AdministratorBranding set at
Customer
Organization Level

Branding set at MSP
Organization Level

Branding details set
at the MSP
organization level to
which the customer
organization belongs
to is displayed.

Branding details set
at the MSP
organization level to
which this customer
organization belongs
to is displayed.

Branding details set
at the MSP
organization level
are displayed.

NoYes

Global branding
details are displayed.

Global branding
details are displayed.

Global branding
details are displayed.

NoNo

Branding User Groups

Step 1 Choose Administration > Users and Groups.
Step 2 On the Users and Groups page, click User Groups.
Step 3 Choose the group to brand.
Step 4 From theMore Actions drop-down menu, click Branding.

The Group Branding screen displays the options that you can customize.

Step 5 Check Logo image to customize the image that is displayed on the top left corner of the user interface.
a) Click Upload to browse to a logo image file and choose it.

Make sure that the logo image is in PNG, JPG, or GIF format. The optimal image size is 200 pixels in width
and 100 pixels in height. We recommend that you use a small file size to enable faster download.

Note

b) Click Submit.

Step 6 Check Application Labels to specify a label that is displayed on the top header of the user interface.
a) Enter at least one application label in the Label 1 and Label 2 fields.

Step 7 Check URL Forwarding on Logout to re-direct users to a specific URL after logging out of the user interface.
a) In the URL field, enter the URL.

Step 8 Required: Check Custom Links to specify the links that appear on the top right corner of the user interface.
a) Complete at least the first two fields.

DescriptionName

The label for custom link 1.Custom Link 1 Label field

The URL for custom link 1.Custom Link 1 URL field

The label for custom link 2.Custom Link 2 Label field

The URL for custom link 2.Custom Link 2 URL field
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Step 9 Click Submit.

Branding Customer Organizations
You can customize the logo and application labels for customer organizations in Cisco UCS Director.

Step 1 Choose Administration > Users and Groups.
Step 2 Choose the Customer Organizations tab or theMSP Organizations tab.

These tab names are only indicative. If you have enabled the Service Provider Feature, you have to specify the names
of the organization at the first and second level. The names that you specify are displayed as tabs in the interface. If you
have disabled the Service Provider Feature, then only the Customer Organizations tab is displayed.

Step 3 Choose the customer organization to brand.
Step 4 From theMore Actions drop-down menu, click Branding.

The Group Branding screen displays the options that you customize.

Step 5 Check Logo image to customize the image that is displayed on the top left corner of the user interface.
a) Click Upload to browse to a logo image file and choose it.

Make sure that the logo image is in PNG, JPG, or GIF format. The optimal image size is 200 pixels in width
and 100 pixels in height. We recommend that you use a small file size to enable faster download.

Note

b) Click Submit.

Step 6 Check Application Labels to specify a label that is displayed on the top header of the user interface.
a) Enter at least one application label in the Label 1 and Label 2 fields.

Step 7 Check URL Forwarding on Logout to re-direct users to a specific URL after logging out of the user interface.
a) In the URL field, enter the URL.

Step 8 Required: Check Custom Links to specify the links that appear on the top right corner of the user interface.
a) Complete at least the first two fields.

DescriptionName

The label for custom link 1.Custom Link 1 Label field

The URL for custom link 1.Custom Link 1 URL field

The label for custom link 2.Custom Link 2 Label field

The URL for custom link 2.Custom Link 2 URL field

Step 9 Click Submit.
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Login Page Branding
A login page can be configured to display a logo that is associated with a domain name. When the end user
logs in from that domain, the user sees the custom logo on the login page. The optimal image size for a logo
is 890 pixels wide and 470 pixels high, with 255 pixels allowed for white space. Cisco recommends that you
keep the image size small to enable faster downloads.

The group or customer organization login page must first be configured (enabled) for branding.Note

Configuring a Custom Domain Logo

Step 1 Choose Administration > Users and Groups.
Step 2 On the Users and Groups page, click Login Page Branding.
Step 3 Click Add.
Step 4 In the Domain Branding screen, complete the required fields, including the following:

DescriptionName

The domain name to brand.Domain Name field

Check the check box to enable login page branding from a
specified domain name.

Custom Domain Logo check box

The logo file to upload. You can either drag and drop a file
in this field, or you can click Select a File to browse and
select the file to upload.

The optimal image size for a logo is 890 pixels
wide by 470 pixels high, with 255 pixels for
white space. We recommend that you keep the
image size small to enable faster downloads.

Note

File field

Step 5 Click Submit.
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C H A P T E R 4
Setting Up the End User Portal

• End User Portal, on page 89
• Summary of Tasks to Set Up the End User Portal, on page 89
• Setting Up User Accounts for the End User Portal, on page 90
• Setting Permissions for the End User Portal, on page 93
• Setting Up the User Interface of the End User Portal, on page 102

End User Portal
The End User Portal is a self-service portal that includes a catalog of services that you provide to the user.
After an end user requests one of the services available, the End User Portal completes the service request
workflow that you have configured for the user. This workflow may include approvals of the self-service
provisioning request, assignment of the necessary compute, storage and network resources, and configuration
of security and performance settings. After the service is provisioned, the end user can track the status of the
services using the summary dashlets and summary reports on the landing page and through the reports available
within the End User Portal.

Following are tasks that an end user can perform in the End User Portal:

• Provision virtual machines (VMs), application specific infrastructure, and bare metal servers

• Review and manage your service requests

• Upload and deploy OVFs and other images

• Monitor and create reports for your provisioned virtual and physical resources

• Approve service requests to provision infrastructure

Summary of Tasks to Set Up the End User Portal
As an administrator, following are the tasks you must complete to set up the End User Portal:

• Add user groups

• Add user accounts

• Set up end user permissions for specific tasks
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• Set up the user interface of the portal

Setting Up User Accounts for the End User Portal

Creating a User Group

Step 1 Choose Administration > Users and Groups.
Step 2 On the Users and Groups page, click User Groups.
Step 3 Click Add.
Step 4 On the Add Group screen, complete the following fields:

DescriptionField Name

The name of the group or the customer organization.

You can include special characters such as ( ). & - _ `~ $% ^ {}! '@

Name field

The description of the group or the customer organization, if required.Description field

A shorter name or code name for the group. This name is used in VM and hostname
templates.

Code field

(Optional) The cost center name or number if required. This name or number
represents a cost center that a group is associated with. This name can be used in a
VMware System policy for the VM naming convention.

For more information about using a cost center for naming conventions, seeManaging
Policies, on page 169.

Cost Center field

The email used to notify the group owner about the status of service requests and
request approvals if necessary.

Contact Email field

The contact’s first name.First Name field

The contact’s last name.Last Name field

The contact’s phone number.Phone field

The contact’s address.Address field

Choose the group share policy for the users in this group.

This drop-down list is populated only when you have created group share policies.

For more information on creating this policy, see Creating a Group Share Policy, on
page 179.

Group Share Policy drop-down
list

If checked, the users of this group can have resources assigned to them and can own
these resources. Also, these users can view resources belonging to the group. However,
the resources among these users cannot be shared.

Allow Resource Assignment To
Users check box
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Step 5 Click Add.

What to do next

Repeat this procedure if you want to add more groups. For each group that you add, you can edit resource
limits, manage tags, and customize the logo and application labels.

Adding Users

Before you begin

Ensure that you have created a group before you add a user to it.

Step 1 Choose Administration > Users and Groups.
Step 2 On the Users and Groups page, click Users.

The Users page displays the following information for all user accounts currently available in the system:

• Status

• Login name and access level

• Email address

• Date when the user account will be disabled

• Current status of the password, and the date on which the password will expire

Step 3 Click Add.
Step 4 On the Add User screen, complete the required fields, including the following:

DescriptionField Name

Choose the role type for the user.User Role drop-down list

Select the group that the user will have access to. You can
either select a group already available, or you can add a
new group.

This field is visible only when you select Service
End-User or Group Admin as the user role.

Note

User Group drop-down list

Select the MSP organization that the user will manage.

You can either select an organization that is currently
available, or you can add a new organization.

This field is visible only when you selectMSP
Admin as the user role.

Note

MSP Organization drop-down list
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DescriptionField Name

The login name.

You can include special characters such as ( ). & - _ `~ $%
^ {}! ' @

Login Name field

The password.

If Lightweight Directory Access Protocol
(LDAP) authentication is configured for the user,
the password is validated only at the LDAP
server, and not at the local server.

Note

Password field

The password is entered again for confirmation.Confirm Password field

The email address.

The email address is required to notify the group
owner about the service request status and to
request approval.

Note

User Contact Email field

The first name.First Name field

The last name.Last Name field

The phone number of the user.Phone field

The office address of the user.Address field

Check to set the date and time when the user account must
be disabled in the system. Disabling a user account means
that the user can no longer log in into the system.

A week prior to this date, an email message stating that the
account will be disabled is sent to the user. This automatic
email message is generated and sent by the
PeriodicNotificationToUserTask system task.

On the specified date and time, the user account is disabled
automatically. If the user is logged in to the system on the
date specified, then the login session is terminated
automatically.

Set user disable date check box

Choose a language for the system specifically for this user.
By default, the language is set to English.

When this user logs in, the user interface is displayed in the
language you selected. This locale selection applies only to
this user.

Locale drop-down list

Step 5 Click Add.
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What to do next

Click a row with a user and clickManage Profiles, to optionally assign multiple roles for that user.

Setting Permissions for the End User Portal
After you create user accounts for the End User Portal, you must provide these accounts with permissions to
perform specific tasks. The subsequent sections list out the permissions that you need to able for end users to
perform tasks such as managing catalogs or managing VMs.

Permissions Required for Approvals
The following table shows a list of the available approval actions and permissions required:

End User PermissionsTask

DefaultViewing Service Request Details

DefaultApproving a Service Request

DefaultRejecting a Service Request

DefaultCanceling a Service Request

DefaultResubmitting a Service Request

DefaultArchiving a Service Request

DefaultAdding Notes to a Service Request

DefaultRolling Back a Service Request

Permissions Required for Catalogs
The following table shows a list of the available catalog actions and permissions required:

End User PermissionsTask

DefaultViewing Catalog Details

DefaultCreating a Service Request for a Standard Catalog

DefaultCreating a Service Request for an Advanced Catalog

DefaultCreating a Service Request for a Service Container
Catalog

DefaultCreating a Service Request for a Bare Metal Catalog

DefaultRunning a Deployability Assessment

Additional permissions requiredAdding a Standard Catalog Item
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End User PermissionsTask

Additional permissions requiredAdding an Advanced Catalog Item

Additional permissions requiredAdding a Service Container Catalog Item

Additional permissions requiredAdding a Bare Metal Catalog Item

Additional permissions requiredCloning a Catalog Item

Additional permissions requiredEditing a Catalog

Additional permissions requiredDeleting a Catalog

Permissions Required for Budget Entries
You can perform actions on the budget entries. For some actions, additional permissions are required. The
following table shows a list of the available budget entry management actions and permissions required:

End User PermissionsTask

Additional permissions requiredAdding a Budget Entry

Additional permissions requiredViewing a Budget Entry

Physical Resources

Permissions Required for CloudSense Reports
The following table shows a list of the available CloudSense management actions and permissions required:

End User PermissionsTask

DefaultGenerating a CloudSense Report

Additional permissions requiredOpening a CloudSense Report

Additional permissions requiredEmailing a CloudSense Report

Additional permissions requiredDeleting a CloudSense Report

Permissions Required for Rack Servers
The following table shows a list of the available rack server management actions and permissions required:

End User PermissionsTask

Additional permissions requiredPowering a Rack Server On or Off

Additional permissions requiredShutting Down a Rack Server

Additional permissions requiredPerforming a Hard Reset on a Rack Server
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End User PermissionsTask

Additional permissions requiredPower Cycling a Rack Server

Additional permissions requiredLaunching the KVM Console for a Rack Server

Permissions Required for Servers
The following table shows a list of the available server management actions and permissions required:

End User PermissionsTask

Additional permissions requiredPowering a Server On or Off

Additional permissions requiredAssociating a Server with a Service Profile

Additional permissions requiredDisassociating a Server

Additional permissions requiredLaunching the KVM Console for a Server

Permissions Required for Service Profiles
The following table shows a list of the available service profile management actions and permissions required:

End User PermissionsTask

DefaultViewing Service Profile Details

Additional permissions requiredDisassociating a Service Profile from a Server

Additional permissions requiredRequesting an Inventory Collection

Permissions Required for SnapMirrors
The following table shows a list of the available SnapMirror actions and permissions required:

End User PermissionsTask

DefaultViewing SnapMirror Details

Permissions Required for Storage Virtual Machines
The following table shows a list of the available SVM management actions and permissions required:

End User PermissionsTask

DefaultViewing SVM Details
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Permissions Required for vFilers
The following table shows a list of the available NetApp vFiler actions and permissions required:

End User PermissionsTask

DefaultViewing vFiler Details

Additional permissions requiredSetting up a vFiler

Additional permissions requiredSetting up CIFS on a vFiler

Permissions Required for SVM Initiator Groups
The following table shows a list of the available SVM initiator group actions and permissions required:

End User PermissionsTask

Additional permissions requiredCreating an SVM Initiator Group

Additional permissions requiredRenaming an SVM Initiator Group

Additional permissions requiredBinding a Port Set to an SVM Initiator Group

Additional permissions requiredUnbinding a Port Set from an SVM Initiator Group

Permissions Required for SVM LUNs
The following table shows a list of the available SVM LUN actions and permissions required:

End User PermissionsTask

DefaultViewing SVM LUN details

Additional permissions requiredCreating an SVM LUN

Additional permissions requiredResizing an SVM LUN

Additional permissions requiredCloning an SVM LUN

Additional permissions requiredTaking an SVM LUN Offline or Online

Additional permissions requiredMapping an SVM LUN to an Initiator Group

Additional permissions requiredUnmapping an SVM LUN from an Initiator Group

Additional permissions requiredToggling the Space Reservation on an SVM LUN

Permissions Required for SVM CIFS Shares
The following table shows a list of the available CIFS share actions and permissions required:

End User PermissionsTask

Additional permissions requiredCreating a CIFS Share on an SVM
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End User PermissionsTask

Additional permissions requiredSetting CIFS Share Access on an SVM

Permissions Required for SVM Export Policies
The following table shows a list of the available SVM export policy actions and permissions required:

End User PermissionsTask

Additional permissions requiredCreating an Export Policy for an SVM

Permissions Required for SVM Export Rules
The following table shows a list of the available SVM export rule actions and permissions required:

End User PermissionsTask

Additional permissions requiredCreating an SVM Export Rule

Permissions Required for SVM Initiators
The following table shows a list of the available SVM initiator actions and permissions required:

End User PermissionsTask

Additional permissions requiredCreating an SVM Initiator

Permissions Required for SVM Port Sets
The following table shows a list of the available SVM port set actions and permissions required:

End User PermissionsTask

Additional permissions requiredCreating an SVM Port Set

Additional permissions requiredDestroying an SVM Port Set

Additional permissions requiredAdding a Port to an SVM Port Set

Additional permissions requiredRemoving a Port from an SVM Port Set

Permissions Required for SVM SIS Policies
The following table shows a list of the available SVM SIS policy actions and permissions required:

End User PermissionsTask

Additional permissions requiredCreating an SIS Policy for an SVM
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Permissions Required for SVM Snapshot Policies
The following table shows a list of the available SVM snapshot policy actions and permissions required:

End User PermissionsTask

DefaultViewing SVM Snapshot Policy Details

Additional permissions requiredCreating a Snapshot Policy on an SVM

Additional permissions requiredEnabling and Disabling a Snapshot Policy on an SVM

Additional permissions requiredCreating a Snapshot Policy Schedule for an SVM
Snapshot Policy

Permissions Required for SVM WWPN Aliases
The following table shows a list of the available SVMWWPN alias actions and permissions required:

End User PermissionsTask

Additional permissions requiredCreating a WWPN Alias on an SVM

Permissions Required for SVM Volume Snapshots
The following table shows a list of the available SVM volume snapshot actions and permissions required:

End User PermissionsTask

Additional permissions requiredCreating a Snapshot for an SVM Volume

Additional permissions requiredRestoring an SVM Volume from a Snapshot

Additional permissions requiredUsing a Snapshot to Restore a File on an SVM
Volume

Additional permissions requiredUsing a Snapshot to Partially Restore a File on an
SVM Volume

Permissions Required for SVM Volumes
The following table shows a list of the available SVM volume actions and permissions required:

End User PermissionsTask

DefaultViewing SVM Volume Details

Additional permissions requiredCreating an SVM Volume

Additional permissions requiredTaking an SVM Volume Offline or Online

Additional permissions requiredResizing an SVM Volume

Additional permissions requiredCloning an SVM Volume
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End User PermissionsTask

Additional permissions requiredCreating a Multi-Volume Snapshot

Additional permissions requiredMoving an SVM Volume

Additional permissions requiredMounting and Unmounting an SVM Volume

Additional permissions requiredEnabling and Disabling Deduplication on an SVM
Volume

Additional permissions requiredStarting Deduplication on an SVM Volume

Additional permissions requiredStopping Deduplication on an SVM Volume

Additional permissions requiredCreating a Qtree on an SVM Volume

Additional permissions requiredRunning Inventory Collection on an SVM Volume

Additional permissions requiredSetting the Snapshot Reserve for an SVM Volume

Additional permissions requiredAssigning an SVM Volume to a Group

Additional permissions requiredUnassigning an SVM Volume from a Group

Permissions Required for vFiler Volumes
The following table shows a list of the available vFiler volume actions and permissions required:

End User PermissionsTask

DefaultViewing vFiler Volume Details

Additional permissions requiredCreating a vFiler Volume

Additional permissions requiredResizing a vFiler Volume

Additional permissions requiredTaking a vFiler Volume Offline or ONline

Additional permissions requiredEnabling and Disabling Deduplication on a vFiler
Volume

Additional permissions requiredExporting a vFiler Volume using NFS

Additional permissions requiredCreating a vFiler Volume Snapshot

Additional permissions requiredResizing the Snapshot Reserve for a vFiler Volume

Additional permissions requiredCreating a CIFS Share on a vFiler Volume

Additional permissions requiredSetting CIFS Share Access on a vFiler Volume

Additional permissions requiredCreating a Qtree on a vFiler Volume
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Services

Permissions Required for Payment Information
The following table shows a list of the available payment actions and permissions required:

End User PermissionsTask

Additional permissions requiredViewing Payment Information Details

Additional permissions requiredMaking a Payment

Additional permissions requiredUpdating Payment Details

Additional permissions requiredChecking Funds

Permissions Required for Service Requests
The following table shows a list of the available service request actions and permissions required:

End User PermissionsTask

DefaultViewing Service Request Details

DefaultCreating a Service Request for a Standard Catalog

DefaultCreating a Service Request for an Advanced Catalog

DefaultCreating a Service Request for a Service Container

DefaultCreating a Service Request for a Bare Metal Catalog

DefaultCanceling a Service Request

DefaultResubmitting a Service Request

DefaultArchiving a Service Request

DefaultAdding Notes to a Service Request

DefaultRolling Back a Service Request

Permissions Required for User OVF Management
The following table shows a list of the available OVF management actions and permissions required:

End User PermissionsTask

DefaultUploading an OVF File

DefaultDeploying an OVF File
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Virtual Resources

Permissions Required for Application Containers
The following table shows a list of the available application container actions and permissions required:

End User PermissionsTask

DefaultViewing Application Container Details

DefaultViewing Application Container Reports

DefaultManaging an Application Container's Power

DefaultDecommissioning an Application Container

DefaultCloning an Application Container

DefaultAdding a VM to an Application Container

DefaultAdding a Bare Metal Server to a Deployed APIC
Application Container

DefaultDeleting an Application Container

DefaultAccessing a VM Console

DefaultEditing Resource Limits

DefaultEditing a Cost Model

DefaultAdding an Application Container Contract

Permissions Required for VMs
The following table shows a list of the available VM lifecycle management actions and permissions required:

End User PermissionsTask

DefaultViewing VM Details

DefaultRequesting Inventory Collection on a VM

Additional permissions requiredLaunching the VM Client

Additional permissions requiredLaunching the VNC Console

Additional permissions requiredLaunching the VMRC HTML5 Console

Additional permissions requiredConfiguring the Lease Time for a VM

Additional permissions requiredManaging a VM's Power

Additional permissions requiredCreating a Snapshot
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End User PermissionsTask

Additional permissions requiredReverting a Snapshot

Additional permissions requiredMarking a Snapshot as Golden

Additional permissions requiredCloning a VM

Additional permissions requiredResizing a VM

Additional permissions requiredResynchronizing a VM

Additional permissions requiredCreating a VM Disk

Additional permissions requiredAdding a vNIC to a VM

Additional permissions requiredAssigning a VM to a VDC

Additional permissions requiredMoving a VM to a VDC

Additional permissions requiredCloning a VM as an Image

Additional permissions requiredConverting a VM as an Image

Additional permissions requiredEnabling and Disabling the VMRCConsole on a VM

Additional permissions requiredMounting an ISO Image as a CD/DVD Drive

Additional permissions requiredUnmounting an ISO Image as a CD/DVD Drive

Permissions Required for Images
The following table shows a list of the available image actions and permissions required:

End User PermissionsTask

Additional Permissions RequiredConverting an Image to a VM

Additional Permissions RequiredDeploying a VM from a Template

Setting Up the User Interface of the End User Portal
In addition to enabling permissions for end users, you can also enable certain elements in the End User Portal.
These include:

• Configuring dashlets

• Configuring colors of dashlet reports

• Selecting catalogs
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Configuring Dashlets
A dashlet is a report that you can display on the dashboard of End User Portal.

The available dashlets include:

• VMs

• UCS Servers

• Orders

• Catalogs

• Approvals

As an administrator, you can choose to display some or all of dashlets on the End User Portal to all users in
all groups in the system, or to all users in specific user groups in the system. This procedure describes how
to configure the dashlets for users within a specific group. To configure dashlets for all user groups, see Using
the Global Dashlet Setup Option, on page 53.

All available dashlets are added to a user group only when the user group contains a user. When a user group
does not have even one user, dashlets do not appear for the user group.

Note

To configure dashlets for a specific user group, do the following:

Step 1 Choose Administration > Users and Groups.
Step 2 On the Users and Groups page, click User Groups.
Step 3 Click the row with the user group for which you want to configure the dashlets.
Step 4 From theMore Actions drop-down list, choose Dashlet Setup.

The Dashlets Report screen appears with all the available dashlets.

When the user group does not have any users, dashlets do not appear in the Dashlets Report screen. Add a
user to the user group to configure the dashlets.

Note

Step 5 On the Dashlets Report screen, select the dashlet you do not want for the user group and click the X (Delete) icon.
Step 6 To add a dashlet to the user group, click the + (Add) icon. On the Add Entry screen, do the following:

a) From the Dashlet Name list, select the dashlet type.
b) In the Dashlet Data Report section, click the + (Add) icon.
c) In the Add Entry to Dashlet Data Report, select the entry (status, type, or state depending on the dashlet type you

chose), assign a color to the entry, and click Submit.
d) Assign colors to the rest of the entries.
e) After assigning colors to the entries for the dashlet, click Submit.

Step 7 On the Dashlets Report screen, make sure the Publish to end users box is checked.

This option enables the dashlets to appear on the End User Portal for users of this group.

Step 8 Click Submit.
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Changing Colors of Dashlet Reports
As an administrator, you can choose to change the color for each entry in the dashlet reports that appear on
the End User Portal. An entry might be a status (In Progress or Completed), a category type (Standard or
Advanced), or a power state (on or off) depending on the dashlet. For example, for the VMs dashlet, you can
assign red for the ON state and gray for the Off state.

To change colors for entries in a dashlet report, do the following:

Step 1 Choose Administration > Users and Groups.
Step 2 On the Users and Groups page, click User Groups.
Step 3 Click the row with the user group for which you want to configure the dashlet.
Step 4 From theMore Actions drop-down list, choose Dashlet Setup.

The Dashlets Report screen appears with all the available dashlets.
Step 5 On the Dashlets Report screen, select the dashlet and click Edit.

The Add Entry screen appears.
Step 6 On the Add Entry screen, do the following:

a) In the Add Entry to Dashlet Data Report area, select the entry, assign a color to the entry, and click Submit.
b) Assign colors for the rest of the entries.
c) After assigning colors to the entries for the dashlet, click Submit.

Step 7 Make sure the Publish to end users box is checked.

This option enables the changes in the dashlet to appear on the End User Portal for users of this group.

Step 8 Click Submit.

Selecting Catalogs for End User Portal
As an administrator, you can enable folders and catalogs within these folders to appear on the dashboard of
the end user portal. You can enable a maximum of 25 catalog folders and a maximum of 25 catalogs within
a folder to appear on the dashboard of the end user portal.

To configure catalogs to appear on the dashboard of the end user portal, do the following:

Step 1 Choose Administration > Users and Groups.
Step 2 On the Users and Groups page, click User Groups.
Step 3 If you have MSP-mode enabled, then choose the Customer Organizations tab.
Step 4 Click the row with the user group for which you want to configure the catalogs.
Step 5 From theMore Actions drop-down list, choose Catalog Setup.

The Configure Catalog screen appears with the list of catalogs available for the user group.

If catalogs have not been assigned to the user group, the Configure Catalog screen is empty.Note

Step 6 On the Configure Catalog screen, check the catalogs that must appear on the End User Portal dashboard.
Step 7 Click Submit.
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When users that belong to the group login to the end user portal, the dashboard is populated with the selected catalogs
and catalog folders.
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C H A P T E R 5
Managing System Administration Settings

This chapter contains the following sections:

• Setting up the Outgoing Mail Server, on page 107
• Working with Email Templates, on page 108
• Configuring System Parameters (Optional), on page 110
• Running an Object Search, on page 112
• Updating the License, on page 113
• Replacing a License, on page 113
• Verifying License Utilization, on page 114
• Viewing License Utilization History, on page 114
• Viewing Resource Usage Data, on page 115
• Viewing Deactivated License Information, on page 115
• Application Categories, on page 115
• Customizing the Portal, on page 117
• Customizing Reports, on page 121
• Enabling Advanced Controls, on page 122
• Enabling the Service Provider Feature, on page 123
• User Menus, on page 123
• Setting User Permissions, on page 124
• System Tasks, on page 124
• Managing Icons in the Cisco UCS Director User Interface, on page 130
• Tag Library , on page 133
• Support Information, on page 135
• Database Audit Logging, on page 137
• Device Connector, on page 138
• Launching Cisco UCS Director from Cisco Intersight, on page 139
• Connector Pack Management, on page 141

Setting up the Outgoing Mail Server
All outgoing emails from Cisco UCS Director require an SMTP server.

Step 1 Choose Administration > System.
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Step 2 On the System page, clickMail Setup.
Step 3 On theMail Setup screen, complete the following fields:

DescriptionName

The outgoing SMTP server address.Outgoing Email Server (SMTP) field

The outgoing SMTP server port number.Outgoing SMTP Port field

The user ID.Outgoing SMTP User field

The user password.Outgoing SMTP Password field

The sender’s email addressOutgoing Email Sender Email Address field

The IP address or DNS name of the Cisco UCS Director
virtual appliance. This field is used to create proper links
in emails for user workflow actions.

Server IP address field

Check this check box to test the current email settings.Send Test Email check box

Step 4 Click Save.

Working with Email Templates
Cisco UCS Director has a notification mechanism that enables you to configure emails to be sent to an
administrator when specific events occur, such as when a VM is provisioned. In addition, if approvals are
required for any task, an email notification can be sent to an administrator or to the group administrator.

You can specify multiple recipients for an email notification. Use a comma as a separator for multiple email
addresses.

Note

Cisco UCS Director provides a set of email templates in the HTML format that cover different scenarios. The
following are some of the tasks that you can perform with email templates library:

• Add a new email template

• Edit an existing email template—You can edit the subject and message details, or the formatting and
presentation fields of an email template. Do not modify any Java-related information in the template.

• Preview an email template—You can preview the email content and determine if the email template
needs modification.

• Set an email template as default—You can set email notifications to be sent based on the default email
template.

• Delete an email template—You can delete the templates that you have added. However, you cannot
delete a template if it meets one of the following criteria:

• You added a template and set it as a default template.
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• It is a system-provided template.

Adding an Email Template

Step 1 Choose Administration > System.
Step 2 On the System page, click Email Templates.
Step 3 Click Add.
Step 4 On the Add Template screen, complete the following fields:

DescriptionName

The name of the email template.Email Template Name field

The description of the email template.Template Description field

Select the type of email template that you are adding. This
drop-down list is populated with the system-provided
templates.

Template Type drop-down list

The subject line for the email template.Subject field

If you check this check box, the subject line you entered is
cleared, and the system-provided subject line is populated
in the Subject field.

Reset to Default Subject check box

The HTML code that defines the email template, such as
the email content, font size and color, the notification
triggers, and so on.

Body field

If you check this box, the HTML code used in the
system-provided email template is populated in the Script
field.

After the HTML code is populated, to retain the changes
you made to the code, you must uncheck this box.

Reset to Default Body check box

Step 5 Click Submit.

What to do next

Preview the email template to determine if you need to make more changes.

Previewing an Email Template
After you create a new email template in Cisco UCS Director, you can preview the email content to determine
if you need to make any additional changes.
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Step 1 Choose Administration > System.
Step 2 On the System page, click Email Templates.
Step 3 Expand the folder with the email template type, and click the row with the email template that you want to preview.
Step 4 Click Preview Template.
Step 5 On the Launch Report screen, click Submit.

The preview mode of an email template displays only static information. Dynamic information such as the
customer name, or resources, is not displayed.

Note

What to do next

If necessary, you can return to the email template to make additional changes.

Setting a Default Email Template
Usually, a system template is set as the default email template. If you have added multiple templates for a
specific scenario, you can choose to select one of these templates as a default template. Setting a template as
default means that the selected template is used for notification.

Step 1 Choose Administration > System.
Step 2 On the System page, click Email Templates.
Step 3 Expand the folder with the email template type, and click the row with the email template that you want to set as the

default.
Step 4 Click Set As Default Email Template.

Configuring System Parameters (Optional)

Configuring System Parameters
You should edit the system parameters only if you need to change the default values.

Step 1 Choose Administration > System.
Step 2 On the System page, click System Parameters.
Step 3 On the System sreen, complete the following fields:

DescriptionName

The user-defined number of days that the system retains
VM data.

Number of Days to Keep Deleted VMs Data field
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DescriptionName

The user-defined number of days that the system retains all
events.

Events older than the specified time period are
deleted.

Note

Number of Days to Keep Events field

The user-defined number of days that the system retains
trend data or historical data of the inventory (such as CPU,
storage, and memory usage).

This data is used for reporting.Note

Number of Days to Keep Trend Data field

Choose the number of days that the system retains VM
metering records.

This data is specific to VMs and their resources.Note

Number of Days to Keep Metering Data drop-down list

The URL of the VM locking controls file that is hosted on
a server that is accessible from the system that is running
Cisco UCS Director.

This file must be in XML format. For more
information on creating this VM locking controls
file, see Locking VMs in Cisco UCS Director,
on page 348.

Note

Download VM Locking Controls from URL field

Choose the type of currency to use.

Available currencies are US, EURO, GBP, KRW, CAD,
CHF, CLP, NR, JPY, AUD, NZD, SGD, HKD, MYR,
MXN, BRL, AED, DKK, SEK, KWD, CYN, RUB, ZAR,
and Other.

Currency drop-down list

Enter the currency name (one only).

This field appears when Other is chosen as the
currency.

Note

Currency field

Choose the currency precision in decimal points. Available
precision is from 0 to 5 decimal points.

Currency Precision drop-down list

Choose a time interval to check the availability of funds.Funds Availability Check Interval (mins) drop-down list

Step 4 Click Save.

Configuring Infrastructure System Parameters (Optional)
You can set parameters for polling the virtual and physical system infrastructure resources.
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Step 1 Choose Administration > System.
Step 2 On the System page, click Infrastructure System Parameters.
Step 3 On the Infrastructure SystemParameters screen, enter the number of days to keep trend data for the system infrastructure.

The default is 30 days.
Step 4 Click Save.

Configuring Proxy Settings
Perform this procedure when you want to configure proxy settings.

Step 1 Choose Administration > System.
Step 2 On the System page, click Proxy Configuration.
Step 3 Complete the required fields, including the following, to configure proxy on the system:

DescriptionField

(Optional) Check this check box to enable proxy and complete the following:

• Host Name field - Enter a host name for the proxy configuration.

• Port field - Enter the port for the proxy configuration.

Enable Proxy Configuration check
box

(Optional) Check this check box to enable proxy authentication and complete
the following:

• Proxy User Name field - Enter a proxy user name for the proxy
authentication.

• Proxy Password field - Enter the password for the proxy user name.

Enable Proxy Authentication check
box

Step 4 Click Save.

Running an Object Search
Use the object search feature to locate a specific report from the following screens in the user interface:

• Physical

• Virtual

•Workflows

• Custom Tasks
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Step 1 Choose Sitemap.
Step 2 On the Sitemap screen, click Object Search.
Step 3 To determine the tabs that the search should run on, choose Advanced Search.

Any report that contains the searchable objects in the Physical and Virtual screens are displayed, along with the options
to chooseWorkflows and Custom Tasks.

By default, all these options are selected.

Step 4 Clear the check boxes of the tabs that you do not want the search to include.
Step 5 In the Search field, we recommend that you enter 3 characters of the object you want to locate.

The search field is case sensitive.

Step 6 Click the Search icon or press Enter on your keyboard.
All reports that match the search criteria are displayed.

Updating the License
You can update the license using the Product Authorization Key (PAK).

Step 1 Choose Administration > License.
Step 2 On the License page, click License Keys.
Step 3 Click Update License.

The Update License screen is displayed.
Step 4 Click Select a File to navigate and to choose the PAK license file.
Step 5 Click Upload to upload the PAK license file.

If the license file does not upload, check the check box and copy and paste the license text into the license text
field.

Note

Step 6 Click Submit.
The license is updated.

Replacing a License
You can use this procedure to replace a license in the system. This action will deactivate all other existing
licenses on the systems.

Step 1 Choose Administration > License.
Step 2 On the License page, click License Keys.
Step 3 Choose Replace License.
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Step 4 In the File field, you can either drag and drop a PAK file or click Select a File to browse and select a file.
Step 5 (Optional) Check Enter License Text to copy and paste the license text.
Step 6 Click Submit.

All existing licenses are replaced with the new license.

Verifying License Utilization
The License Utilization page shows the licenses in use and details about each license, including license limit,
available quantity, status, and remarks. License audits can also be run from this page.

Step 1 Choose Administration > License.
Step 2 On the License page, click License Utilization.
Step 3 Click the row with the license that you want to verify.
Step 4 (Optional) To run a license audit, click Run License Audit.
Step 5 On the Run License Audit screen, click Submit.

This process takes several minutes to run.

Viewing License Utilization History
The number of licensed network and storage controllers, servers, server and desktop VMs, and small and
medium pods can be tracked over time to see how network resources are being utilized.

Step 1 Choose Administration > License.
Step 2 On the License page, click License Utilization History.

The license utilization history is displayed for the following resource categories, with timestamp:

• Network Controllers

• Storage Controllers

• Servers

• Server VMs

• Desktop VMs

• Small pods

• Medium pods
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Viewing Resource Usage Data
You can view how resources are being utilized in your environment.

Step 1 Choose Administration > License.
Step 2 On the License page, click Resource Usage Data.

Following are the available report categories:

• Resource Name—Name of the available resources associated with Cisco UCS Director.

• Resource Count—Quantity of each available resource.

Viewing Deactivated License Information
You can view the list of deactivated licenses from the user interface. You can view the following information
on deactivated licenses:

• PAK file name

• File ID

• License Entry

• Licence Value

• Expiry Date

• Deactivated Time

• Name of user who deactivated the license

Step 1 Choose Administration > License.
Step 2 On the License page, click Deactivated Licenses.
Step 3 Review the information displayed for all the deactivated licenses.

Application Categories
Application categories are an optional configuration that enable you to define the type of workload for a VM.
If you do not use application categories, Cisco UCS Director assumes that all VMs provisioned for your users
are generic VMs and configures them to handle CPU-intensive workloads. Whether you choose to use the
default application categories or to create your own, you can provide your users with a pre-defined set of
workloads that match their application needs.

The workload options for application categories include the following:
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• CPU intensive

• Network I/O intensive

• Disk I/O intensive

• Memory intensive

• Any combination of the above

After you create your application categories, you can go to the desired cloud account and assign the vDC
policies to the application categories. This assignment determines the boundaries of the infrastructure where
the application can be provisioned. You can also use application categories to allocate clusters based on the
type of application. For example, Cluster 1 is allocated for Web applications and Cluster 2 is allocated for
database applications.

When an application category is chosen by a user, Cisco UCS Director uses the vDC assignment to determine
which location, within the boundary of the vDC, best meets the application's workload needs. For example,
if the user chooses a CPU-intensive application category, Cisco UCS Director provisions the application in
the available infrastructure with the least CPU utilization.

Adding Application Categories
By default, Cisco UCS Director provides the following application categories for you to use or edit:

• Discovered VM

• Generic VM

• Web Server

• Application Server

• Database

• App—CPU Intensive

• App—Memory Intensive

• App—Disk Intensive

• App—Network Intensive

• Other App 1

• Other App 2

• Other App 3

Cisco UCS Director allows you to create application categories for multiple virtual data centers at a system
level. This capability eliminates the repetitive task of selecting individual virtual data centers and assigning
policies for categories.

Step 1 Choose Administration > System.
Step 2 On the System page, click Application Categories.
Step 3 Click Add.
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Step 4 On the Add Category screen, complete the following fields:

DescriptionName

A unique name for the category.Category Label field

Specify a code for the category. You can use this code in
the VM or host name templates.

Category Code field

A description of the category.Category Description field

Check this check box to enable the category. Enabling a
category implies that you can select this category during
VDC assignment.

If you do not check this check box, then this category cannot
be used in the system.

Category Enabled check box

Choose a default algorithm that must be applied during VM
provisioning.

Default Smart Allocation Algorithm drop-down list

Step 5 Click Submit.

The application category is displayed when you click theManage Categories option for a virtual data center.

What to do next

After you have created an application category, you can perform the following tasks:

• Edit or clone the application category

• Assign the application category to multiple virtual data centers. For more information, see Managing
Application Categories in a Virtual Data Centers, on page 211.

Customizing the Portal
Organizations can customize the EndUser Portal. The logo, login page, home page, and so on can be customized
for branding and user interface-related changes.

Customizing the Login Page and Background Images
You can change the login page and background images by uploading custom images.

Step 1 Choose Administration > User Interface Settings.
Step 2 On the User Interface Settings page, click Login Page.
Step 3 Check Use customizable Login page.
Step 4 In the Logo Images section, click Add and complete the following fields:
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DescriptionField

A name for the image.Image Label field

A description for the image that you upload.Description field

Click Browse to search and select an image file.

An optimal image is 200 pixels in width and 100
pixels in height and is in the PNG format.

Important

Select a file for upload field

Click this option to upload the image.

This option is enabled only after you have browsed and
selected an image.

Upload option

Click Submit after the image is uploaded.Submit option

Step 5 In the Background Images section, choose an item or click Add and complete the following fields:

DescriptionField

A name for the image.Image Label field

A description for the image that you upload.Description field

Click Browse to search and select an image file.

An optimal image is 890 pixels in width, 470
pixels in height, and has 255 pixels of white
space. In addition, the image must be in the PNG
format.

Important

Select a file for Upload field

Click this option to upload the image.

This option is enabled only after you have browsed and
selected an image.

Upload option

Step 6 Click Submit.

Customizing the Application Logo
You can customize the application logo on the home page by uploading a custom image.

Step 1 Choose Administration > User Interface Settings.
Step 2 On the User Interface Settings page, click Application Logo.
Step 3 In the Images section, click Add to add a new image that is not listed, and complete the following fields:
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DescriptionField

A name for the image.Image Label field

A description for the image that you upload.Description field

Click Browse to search and select an image file.

Supported image formats are PNG, JPG, and
GIF. An optimal image size is 100 pixels in
width and 50 pixels in height.

Important

Select a file for upload field

Click this option to upload the image.

This option is enabled only after you have browsed and
selected an image.

Upload option

Step 4 Click Submit.

Customizing Favicons
You can customize a favorites icon (Favicon) that is displayed in the browser’s address bar or next to the page
name, if it is bookmarked.

Step 1 Choose Administration > User Interface Settings.
Step 2 On the User Interface Settings page, click Favicon.
Step 3 In the Images section, click Add to add a new image not listed and complete the following fields:

DescriptionField

A name for the image.Image Label field

A description for the image that you upload.Description field

Click Browse to search and select an image file.

Supported image format is PNG. An optimal
image size is 16x16 pixels.

Important

Select a file for upload field

Click this option to upload the image.

This option is enabled only after you have browsed and
selected an image.

Upload option

Step 4 Click Submit.
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Customizing Application Header
You can customize the End User Portal labels, next to the customer logo, by modifying existing labels.

Step 1 Choose Administration > User Interface Settings.
Step 2 On the User Interface Settings page, click Application Header.
Step 3 Complete the following fields:

DescriptionName

Check to hide the header section. If checked, the header
that contains the logo image, application name, and links,
such as Logout, are hidden.

Hide Entire Header check box

The product name that must be displayed in the header.Product Name field

The second title of the product.Product Name 2nd Line field

Check to enable the About link in the header. Uncheck to
disable the About link in the header.

Enable About Dialog check box

Administrator Portal

The custom link label 1 for the administrator portal.Custom Link 1 Label field

The custom link URL 1 for the administrator portal.Custom Link 1 URL field

The custom link label 2 for the administrator portal.Custom Link 2 Label field

The custom link URL 2 for the administrator portal.Custom Link 2 URL field

End User Portal

The custom link label 1 for the End User Portal.Custom Link 1 Label field

The custom link URL 1 for the End User PortalCustom Link 1 URL field

The custom link label 2 for the End User Portal.Custom Link 2 Label field

The custom link URL 2 for the End User Portal.Custom Link 2 URL field

Step 4 Click Save.

Customizing Date Display
Numerous data display formats are supported.

Step 1 Choose Administration > User Interface Settings.
Step 2 On the User Interface Settings page, click Date Display.
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Step 3 Edit the date format.
Step 4 If required, check Hide Timezone to hide the time zone display from the user interface.
Step 5 Click Save.

Customizing the Color Theme

Step 1 Choose Administration > User Interface Settings.
Step 2 On the User Interface Settings page, click Color Theme.
Step 3 From the drop-down list, choose from the available theme styles.
Step 4 Click Save.

Customizing Logout Redirect

Step 1 Choose Administration > User Interface Settings.
Step 2 On the User Interface Settings page, click Logout Redirect.
Step 3 In the Logout Redirect field, enter the URL.
Step 4 Click Save.

Customizing Reports
Report customization enables you to make a custom label or hide the available reports.

You cannot customize or hide reports for users and groups. You can customize the report table on all other
pages. You can customize only those reports that are identified as Tabular with actions.

Note

Step 1 Choose Administration > User Interface Settings.
Step 2 On the User Interface Settings page, click Reports Customization.
Step 3 Click the row with the report that you want to customize.
Step 4 Click Edit.
Step 5 On the Customize Report screen, complete the following fields:

DescriptionName

Check to hide the report. Uncheck to show the report.Hide Report check box

A new label for the report, if required.New Label field
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Step 6 Click Save.

Enabling Advanced Controls

Step 1 Choose Administration > System.
Step 2 On the System page, click Advanced Controls.
Step 3 Check the required fields:

DescriptionName

Check to enable virtual infrastructure monitoring, physical
infrastructure monitoring, and external cloud monitoring.

Check all additional check boxes under this category, as
needed.

Performance Monitoring check box

Check to enable monitoring of VM metering functions.

If the VM metering function is disabled,
chargeback does not work.

Note

Resource Metering check box

Check to enable virtual and physical infrastructure events.Event Monitoring check box

Check to enable automatic support.Auto Support check box

Check to enable generation of heat map reports for the
virtual infrastructure.

Heat Map Report Computing check box

Check to generate reports on virtual assessment.Automatic Assessment check box

Check to enable and compute the load indices for hosts for
various host parameters every 4 hours.

These indices are used in adaptive provisioning of the
catalogs. A lower index indicates a better chance for the
host being chosen for provisioning. This process works
according to the computing policy of a specific VDC.

Adaptive Provisioning Indexing check box

Check to enable and delete the inactive (powered off) VMs
under a VDC after a time that is specified by the
administrator. The deletion of these inactive VMs is also
based on the VM management policy defined by the
administrator. Before an inactive VM is is deleted, an email
notification is sent to the user.

This property is associated with the Delete after inactive
VM days field in the VM management policy.

By default, the property box is not checked.Note

Delete Inactive VMs Based on VDC Policy check box
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DescriptionName

Check to administratively enable the remote execution.System Task Remoting check box

Step 4 Click Submit.

Enabling the Service Provider Feature

Step 1 Choose Administration > System.
Step 2 On the System page, click Service Provider Feature.
Step 3 Complete the following fields:

DescriptionName

Check to enable service providers in Cisco UCS Director.Enable Service Provider Feature (Requires System
Restart) check box

The name of the parent organization for which this feature
should be enabled.

Organization Name (First Level) field

The name of the child organization for which this feature
should be enabled.

Organization Name (Second Level) field

Step 4 Click Submit.

User Menus
You can enable customized menu operations for individual user roles. The menu settings that users can view
and access in the application is dependent on the user roles that they have been assigned, and the menu
operations that you set for the roles.

Setting User Menus

Step 1 Choose Administration > System.
Step 2 On the System page, click User Roles.
Step 3 Click the row with the user role for which you want to edit the user menus.
Step 4 Click Edit.
Step 5 On the Edit User Role screen, click Next.
Step 6 On theMenu Settings screen, you can view the menu settings for the chosen user role.
Step 7 Check or uncheck the menu check boxes to allow menus for that role, or check Reset to Defaults.
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Step 8 Click Submit.

Setting User Permissions

Step 1 Choose Administration > System.
Step 2 On the System page, click User Roles.
Step 3 Click the row with the user role for which you want to edit the user permissions.
Step 4 Click Edit.
Step 5 On the Edit User Role screen, click Next.
Step 6 On the User Permissions screen, you can view the read and write operations for the chosen user role.
Step 7 Check or uncheck the check boxes to allow read and write operations for an individual role, or check Reset to Defaults.
Step 8 Click Submit.

System Tasks
The System Tasks screen displays all the system tasks that are currently available in Cisco UCS Director.
However, this list of system tasks is linked to the type of accounts that you have created in Cisco UCSDirector.
For example, if you have logged in for the first time, then only a set of general system-related tasks or VMware
related tasks are visible on this page. When you add accounts, such as rack accounts or Cisco UCS Manager
accounts, system tasks related to these accounts are populated on this page.

Following are the tasks that you can complete from the System Tasks screen:

• View the available systems tasks—You can use the Expand andCollapse options to view all the system
tasks that are available on this page. The tasks are categorized according to the accounts available in
Cisco UCS Director. For example: Cisco UCS Tasks or NetApp Tasks.

• Manage system tasks—You can select a system task on the System Tasks screen, and clickManage
Task. From thisManage Task screen, you can perform the following tasks:

• Disable and enable system tasks—In circumstances when there are multiple processes or tasks
running on the appliance, you can choose to disable a system task. If you do so, then until such time
that you manually enable it, the system task will not run. This will affect the data populated in other
reports. For example, if you disable an inventory collection system task, then reports that require
this data may not display accurate data. In this case, you will have to manually run an inventory
collection process, or enable the system task.

For more information, see Disabling or Enabling a System Task, on page 128.

• Modify the schedule for the system task—You can modify the schedule type for a system task, or
you can configure a custom frequency for the task. For more information, see Scheduling a System
Task, on page 128
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In a single-node setup, where there is only one server, all system tasks run on this server. In a multi-node
setup, where there are multiple servers configured, all system tasks run on the primary server by default.
However, you can specify system tasks to run on the secondary servers. Following are the recommended steps
to perform this task:

1. Ensure that the secondary servers are available in Cisco UCS Director as nodes. If the servers are not
available, then you must add the servers as nodes. See Creating a Service Node, on page 126.

2. Create a node pool from the available servers. See Creating a Node Pool, on page 125.

3. Create a system task policy, and associate it with a node policy. See Creating a System Task Policy, on
page 125.

4. Associate a node pool with the system task policy. See Assigning a Node Pool to a System Task Policy,
on page 126.

5. Select a system task, and associate it with a system-task policy. See Assigning a System Policy to a System
Task, on page 127.

Creating a Node Pool

Step 1 Choose Administration > System.
Step 2 On the System page, click Service Nodes.
Step 3 Click Service Node Pools.
Step 4 On the Service Node Pool screen, click Add.
Step 5 On the Add Entry to Service Node Pools screen enter the node pool name in the Name field.
Step 6 (Optional) In the Description field, enter a description of the node pool name.
Step 7 Click Submit. The node pool is created.

Creating a System Task Policy
As an administrator, you can choose to combine a few policies and create a system task policy, in addition to
the default system task policy. You can group system tasks into a system task policy to later determine which
system tasks are running on which node.

Step 1 Choose Administration > System.
Step 2 On the System page, click System Task Policy.
Step 3 Click Add.
Step 4 On the Add screen, enter the name that you gave the system task policy in the Name field.
Step 5 (Optional) In the Description field, enter a description of the system task policy.
Step 6 From the Node Pool drop-down list, choose the node pool to which this system task policy belongs.
Step 7 Click Submit.
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The selected node pool now belongs to the newly created system task policy.

Assigning a Node Pool to a System Task Policy

Step 1 Choose Administration > System.
Step 2 On the System page, click System Task Policy.
Step 3 Click the row with the system task policy to which you want to assign a node pool.
Step 4 Click Edit.

If the default system task policy is used, you can assign service nodes to this policy. See Creating a System
Task Policy, on page 125, if you want to configure a policy that is different from the default.

Note

Step 5 From the Node Pool drop-down list, choose a node pool that you want to assign to the system task policy.
Step 6 Click Submit.

The selected node pool now belongs to the system task policy.

Creating a Service Node

Step 1 Choose Administration > System.
Step 2 On the System page, click Service Nodes.
Step 3 Click Add.
Step 4 On the Service Node screen, complete the following fields:

DescriptionName

The name of the service node.Node Name field

You cannot edit this field. By default, this field displays
Service as the role of this node.

Role field

By default, the default-service-node-pool is displayed.Service Node Pool drop-down list

Enter either the DNS name or IP address of the service node.

This field cannot use the Primary Node’s IP
address. Ensure that a valid Service Node DNS
name or IP address is entered.

Note

DNS Name field

The description of the of the service node.Description field

Choose either http (default) or https.Protocol drop-down list
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DescriptionName

The default TCP port for the Hypertext Transfer Protocol
(HTTP) 80 is entered by default. Enter a different TCP port
if necessary.

Port field

The infraUser user name is entered by default.

The infraUser is a user account created by default. To find
this user account on themenu bar, chooseAdministration >
Users and Groups.

Click Login Users to find the infraUser user account in
the Login Name column.

The InfraUser user name is not the default
administrator user to login to the system.

Note

Another user name can be added to this field. This user’s
API key is used to authenticate with the Service Node.

UserName field

Step 5 Click Submit.

Assigning a System Policy to a System Task

Step 1 Choose Administration > System.
Step 2 On the System page, click System Tasks.
Step 3 Choose a folder that contains system tasks. Click the folder arrow to expand its tasks.

128 system tasks are available.Note

Step 4 Choose the task and clickManage Task.

TheManage Task screen appears.

Step 5 From the Task Execution drop-down list, choose Enable.
Step 6 From the System Task Policy drop-down list, choose a system policy.
Step 7 Click Submit.

The system task is assigned to the selected system policy.

Executing System Tasks
Cisco UCS Director includes a few system tasks that cannot be run remotely on a service node. Also, you can
assign a system policy remotely from the local host or the primary node.

In addition, you can search and select a specific system task, and run it immediately in the system.
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Step 1 Choose Administration > System.
Step 2 On the System page, click System Tasks.
Step 3 Choose a task from the list.
Step 4 Click Run Now.

The result of the executed system task is updated in the user interface.

Disabling or Enabling a System Task

Step 1 Choose Administration > System.
Step 2 On the System page, click System Tasks.
Step 3 Choose a folder that contains one or more system tasks. Click the folder arrow to expand its tasks.

128 system tasks are available.Note

Step 4 Choose the task and click Manage Task.

TheManage Task screen appears.

Step 5 To disable a system task, from the Task Execution drop-down list, choose Disable.
Step 6 To enable a system task, from the Task Execution drop-down list, choose Enable.
Step 7 Click Submit.

Scheduling a System Task

Step 1 Choose Administration > System.
Step 2 On the System page, click System Tasks.
Step 3 Choose a system task and clickManage Task.
Step 4 In theManage Task screen, complete the following fields to schedule the system task:
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DescriptionName

Specify the schedule type for the system task. It can be one
of the following options:

• Fixed Delay—Implies the time period between the
completion of one task execution and the initiation of
the next task execution.

• Fixed Rate—Implies the time period between
successive tasks executions. If there is a delay in the
execution of one task or if one task takes longer to
execute than its scheduled time, it results in delays in
subsequent task executions. Systems tasks that are
configured with this setting will not run concurrently.
These tasks will not run concurrently.

Schedule Type drop-down list

Choose a number from the dropdown list.

If you chose Fixed Delay as the schedule type, then this
number indicates the time gap, in hours, between the
completion of one task exection and the initiation of the
next task execution.

IF you chose Fixed Rate, then this number indicates time
period, in hours, between successive task executions.

Hours

Check this check box to enable a custom frequency for the
system task.

Enable Custom Frequency check box

Specify the recurrence schedule for the system task.It can
be one of the following:

• No End

• Only Once

Recurrence Type drop-down list

Specify the date and time for the recurrence schedule.Start Time field

Choose a frequency for the system task. It can be one of
the following:

• Hourly

• Daily

•Weekly

• Monthly

This field is displayed only when you select No
End in the Recurrence Type drop-down list.

Note

Frequency drop-down list
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DescriptionName

Choose a frequency interval from the drop-down list. The
values in this list vary depending on the frequency you have
specified.

Frequency Interval drop-down list

Step 5 Click Submit.

System Tasks with Fixed Rate Option
The following table lists the system tasks that run only with the Fixed Rate option.

System Task LabelCategory

Deleted UCSCentralAccount CleanUp TaskCompute

UCS Daily Historical DataPurge Task

Deleted UCSAccount CleanUp Task

UCS Historical Data Aggregator Task

UCS Monthly Historical DataPurge Task

UCS Event Record Purge Task

UCS Event Subscription Task

UCS Fault Record Purge Task

UCS Server Transition State Manager

Virtual SAN Ready Node Qualification Task

VM Metering Data Aggregator TaskAdmin

VM Metering Task

VM LifeCycle Manager

UsageData AggregatorVirtualization

Performance Data Collector

Managing Icons in the Cisco UCS Director User Interface
Cisco UCS Director supports customization and management of catalog icons, action-related icons, and
status-related icons. Each icon set in the system contains several images that are available by default. You
can change the icons that are displayed for either the catalogs, actions or status. You can either upload a new
image and set it as the icon, or you can choose a different icon from the set of system-provided icons
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• While uploading an icon, ensure that the icon is in either the .SVG format or in the .PNG format. If you
are uploading a .SVG image, ensure that the pixel compression is as follows:

• For action icons— 24px x 24px

• For table icons—16px x 16px

• For status icons—16px x 16px

• For header icons— 20px x 20px (except for the alert icon)

• After you select an icon, you must log out and log in again to the system for the new icon to be visible
in the user interface.

Important

Following are the pre-populated icon sets in Cisco UCS Director:

• Standard Catalog Icon Set

• Status Icon Set

• Bare Metal Catalog Icon Set

• Advanced Catalog Icon Set

• Container Catalog Icon Set

• Catalog Folder Icon Set

• Action Icon Set

In addition to modifying an icon in the user interface, you can also revert to the default icon.

Modifying an Icon in the Cisco UCS Director User Interface

Step 1 Choose Administration > User Interface Settings.
Step 2 On the User Interface Settings page, click Icon Management.
Step 3 Select an icon set category.

It can be one of the following:

• Standard Catalog Icon Set

• Status Icon Set

• Bare Metal Catalog Icon Set

• Advanced Catalog Icon Set

• Container Catalog Icon Set

• Catalog Folder Icon Set

• Action Icon Set
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Step 4 Click Icon Images.
Step 5 Expand Icon Images.
Step 6 Select an icon image from the list of icons.
Step 7 Click edit.
Step 8 In the Edit Icon Images Entry page, complete one of the following steps:

a) Choose an image that currently exists in the system using the Use Existing icon drop-down list.
b) Upload a new image to the system by either dragging the image into the File field or by browsing and selecting an

image using the Select a File option.

While uploading an icon, ensure that the icon is in either the .SVG format or in the .PNG format. If you
are uploading a .SVG image, ensure that the pixel compression is as follows:

• For action icons— 24px x 24px

• For table icons—16px x 16px

• For status icons—16px x 16px

• For header icons— 20px x 20px (except for the alert icon)

Important

Step 9 Click Submit.

What to do next

You must log out and log in again to the system for the new icon to be visible in the user interface.

Editing an Icon

Step 1 Choose Administration > User Interface Settings.
Step 2 On the User Interface Settings page, click Icon Management.
Step 3 Choose the row with the icon category that contains the icon that you want to edit.
Step 4 Click Icon Images.
Step 5 On theManage Icon Images screen, choose an icon image to edit.
Step 6 Click Edit.
Step 7 On the Edit Icon Images Entry screen, edit the Description.
Step 8 Choose a replacement file to upload by clicking Browse and browsing to an image.
Step 9 Click Upload.
Step 10 Once the upload is finished, click Submit.

Deleting an Icon

Step 1 Choose Administration > User Interface Settings.
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Step 2 On the User Interface Settings page, click Icon Management.
Step 3 Choose the row with the icon category that contains the icon that you want to delete.
Step 4 Click Icon Images.
Step 5 On theManage Icon Images screen, choose an icon image and click Delete.
Step 6 Click Submit.

Previewing an Icon

Step 1 Choose Administration > User Interface Settings.
Step 2 On the User Interface Settings page, click Icon Management.
Step 3 Choose the row with the icon category that you want to preview.
Step 4 Click Icon Images.
Step 5 On theManage Icon Images screen, choose an icon image to preview.
Step 6 Click the Information icon to preview the image.

Tag Library
Tagging is when you assign a label to an object. As an administrator, you can decide to tag objects such as
resource groups and user groups, in Cisco UCS Director. You can assign tags to a category such as Compute,
Storage, Network, and Virtual. You can also apply a tag to a specific type of account in the selected category.
For information on how to apply and remove tags on resource groups, see theManaging Tags of a Resource
Group section in the Cisco UCS Director APIC Management Guide.

Once the tag is created, based on the defined applicability rules, the tags are filtered and displayed in an object
report. You can associate the tag to an object such as resource group. To view the resource entities that are
associated with a tag, choose the tag and click View Details. Alternatively, you can double click the tag.

If resource entity is not associated with the tag, the table is empty.Note

Creating a Tag
You can use the Create action on the Tag Library screen to create a tag that can be assigned to one or more
objects in report page.

Step 1 Choose Policies > Tag Library.
Step 2 Click Create.
Step 3 On the Create Tag screen, complete the following fields:
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DescriptionName

The name for the tag.Name field

The description of the tag.Description field

Choose INTEGER or STRING as the type of the tag.Type drop-down list

The possible values for the tag.Possible Tag Values field

Step 4 Click Next.
Step 5 On the Applicability Rules screen, complete the following fields:

DescriptionName

Checko make the tag visible to end user.Visible to End User field

Choose the entities on which the tag need to be applied.

To add an entity, do the following:

1. Click the + icon.

2. From theCategory drop-down list, choose the category.
It can be one of the following:

• Virtual_Compute

• Virtual_Storage

• Virtual_Network

• Physical_Compute

• Physical_Storage

• Physical_Network

• Administration

3. Choose the taggable entities.

4. Click Submit.

The tags are displayed under the respective
category according to the set taggable entities.

Note

Taggable Entities field

Step 6 Click Submit.

What to do next

After creating a tag, you can edit, clone and delete it by selecting the respective option in the user interface.
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Support Information
Cisco UCS Director support provides basic and advanced system information, including the license status,
database tables, version, resource usage, logs, and debugging processes for troubleshooting.

The Support Information page lets you perform the following actions:

• View system information (Basic)

• View system information (Advanced)

• Show logs

• Download all logs

• Start and stop debug logging

• Start and stop API logging

Viewing System Information
Cisco UCS Director allows you to access system information from the user interface. You can access the
following types of system information:

• Basic system information

• Advanced system information

Basic system information includes the following:

• Software version

• Uptime

• Service status

• System license status

• System usage

• Compute accounts status

• Compute server status

• Storage account status

• System catalogs

• Network device status and

• Cloud status

The advanced system information includes the following:

• Basic system information

• Database tables summary
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• Product configuration

• Top process information

• Information on processors, memory, disks, log files, network, and login

• System task status

• Cloud inventory

• Monitoring status

Step 1 Choose Administration > Support Information.
Step 2 From the System Information drop-down list, choose the type of system information you want to view.
Step 3 Click Submit.

The System Information page opens in a new tab and displays information about the Cisco UCS Director appliance.

Showing Logs
Cisco UCS Director collates the following logs in the system:

• Infra Manager

• Web Context Cloud Manger

• Tomcat Log

• Authenticator Log

• Mail Delivery Log

• Patch Log

Step 1 Choose Administration > Support Information.
Step 2 From the System Information drop-down list, choose Show Log.
Step 3 From the Show Log drop-down list, choose the log file that you want to view.
Step 4 Click Show Logs.

The log file opens in a new tab or browser window and displays any available information, warning, and error logs.

Downloading Logs
You can download all the log files as a zipped file.

Step 1 Choose Administration > Support Information.
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Step 2 From the System Information drop-down list, choose Download All Logs.
Step 3 Click Download.

Starting the Debug Log
Debug logging enables you to record a maximum of 30 minutes debug logging to a log file.

Step 1 Choose Administration > Support Information.
Step 2 From the System Information drop-down list, choose Debug Logging.
Step 3 Click Start Debug Logging.
Step 4 Click Stop Debug Logging to stop the recording.

The recording will automatically stop once it reaches the 30 minute limit.

Step 5 Click Download Debug Logs from HH.MM.SS (time) to download the zipped log file.

Generating API Logs

Step 1 Choose Administration > Support Information.
Step 2 From the System Information drop-down list, choose API Logging.
Step 3 Click Start API Logging.
Step 4 Perform any tests that you want to run.
Step 5 Click Stop API Logging to stop the recording.
Step 6 Click Download API Debug Logs from HH.MM.SS (time) to download the zipped file.

A compressed (zip) file is generated and downloaded on to your desktop. This zipped file contains a text file that lists all
the REST APIs that invoked on the appliance, along with the timestamp.

Database Audit Logging
Database audit logging lets the system record information on login events and query events. These events are
logged in the /var/lib/mysql/data/audit.log file. By default, database audit logging is disabled.
To enable database audit logging, use the dbAuditLog.sh command. For more information, see Enabling
Audit Logging, on page 138.

You can disable database audit logging if the system encounters performance issues due to a heavy audit log
output.

Note
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Enabling Audit Logging

Step 1 Login as root on the Cisco UCS Director appliance directly or by using an SSH client.
Step 2 Run the following commands to stop all services running on the system.

[root@localhost infra]# pwd
/opt/infra
[root@localhost infra]# ./stopInfraAll.sh
[root@localhost infra]# ./statusInfra.sh

Step 3 Run the following command to enable audit logging.
[root@localhost infra]# cd bin
[root@localhost bin]# pwd
/opt/infra/bin
[root@localhost bin]# ./dbAuditLog.sh ON

Step 4 Run the following commands to restart the services:
[root@localhost infra]# pwd
/opt/infra/bin
[root@localhost infra]#./startInfraAll.sh

Step 5 Run the following command to check the status of audit logging.
[root@localhost bin]# ./dbAuditLog.sh STATUS
audit-log= ON

If you see a message that states that there is an issue with the database startup, youmust remove or rename the audit.log
file and restart the Cisco UCS Director database server.

Device Connector
The device connector connects Cisco UCS Director to Cisco Intersight, the cloud-hosted server management
system. It enables Cisco UCS Director to be managed and monitored through Cisco Intersight.

To register a device with Cisco Intersight in the cloud, you must do the following:

1. Configure the device connector proxy settings to connect Cisco UCS Director with Cisco Intersight.

This is required only if you have proxy configuration enabled.

2. Validate your access to the device from Cisco Intersight using the device serial number and the security
code and claim the device.

After a system running Cisco UCS Director is claimed in Cisco Intersight, you must refresh the information
displayed on theDevice Connector screen. ChooseAdministration >Device Connector to view the updated
information.

Note
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Configuring Device Connector

Step 1 Choose Administration > Device Connector.
Step 2 Expand All > Device Connector.
Step 3 (Optional) Click HTTPS Proxy Settings.

The HTTPS Proxy Settings window is displayed. By default, it is Off.

Step 4 (Optional) To enable and configure HTTPS proxy settings, clickManual. and enter the following information:
a) Enter the proxy hostname or IP address in the Proxy Hostname/IP field.
b) Enter the proxy port number in the Proxy Port field.
c) To authenticate access to the proxy server, turn theAuthenticationmode on and enter theUsername and Password.
d) Click Save.

Based on the connectivity to Cisco Intersight, the Status field displays one of the following messages:

• When the connection to Cisco Intersight is successful, the status messages could be one of the following:

• Unclaimed—Implies that the connection is successful but the device is not claimed. You can claim an unclaimed
connection through Cisco Intersight.

For information on claming a device, see the integrated guided walkthrough titled Learn How to Claim a Device
available within the Online Help menu in the Cisco Intersight user interface.

• Claimed—Implies that the connection to Cisco Intersight is successful and you have claimed the device.

• When the connection to Cisco Intersight is unsuccessful, the status messages could be one of the following:

• Administratively disabled—Implies that the administrator has disabled managing the device from Cisco
Intersight.

• Certification Validation Error—Implies that an invalid certificate exists on the system.

• Not Claimed—Indicates that the device is registered, but not claimed in Cisco Intersight.

• DNS is not configured or DNS is mis-configured.

• Unable to resolve DNS name of the service—Indicates that although DNS is configured, the DNS name of
the Cisco Intersight platform cannot be resolved.

• NTP is not configured

• Unable to establish a network connection—Indicates that Cisco UCS Director cannot connect to Cisco
Intersight.

Launching Cisco UCS Director from Cisco Intersight
After the device connector is configured and the device is claimed, you can launch the Cisco UCS Director
user interface from Cisco Intersight.
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If any of the Cisco UCS Director services are down, you cannot launch Cisco UCS Director from Cisco
Intersight.

A message stating that there is no service is displayed.

Important

Although you can launch Cisco UCS Director from Cisco Intersight, following are some of the restrictions
that you need to be aware of:

• You cannot edit a user profile.

• You cannot perform any import and export actions.

• The main menu and the Dashboard are disabled.

• The Device Connector tab is not visible.

• You cannot perform any launch actions.

• You cannot upgrade connector packs.

• You cannot generate any summary reports.

• The user name is displayed as Cisco Intersight user when you launch Cisco UCS Director.

• All service requests and audit log details are logged as Admin user.

Step 1 Log into the Cisco Intersight user interface.
Step 2 Choose Devices.

The Devices screen appears that displays a list of available Cisco UCS Director systems.
Step 3 Select a Cisco UCS Director device from the list, and click .....

You must scroll to the far right of the list of devices to see the .... option.

The IP address displayed for the Cisco UCS Director device in Cisco Intersight is determined by the IP address
you entered for the Server IP address field while configuring the outgoingmail server for Cisco UCSDirector.

If you modify the server IP address after the Device Connector process is up, you must restart the Device
Connector process. To do so, login to the Cisco UCS Director device, and run the following commands:
/opt/infra/bin/stopdc.sh
/opt/infra/bin/startdc.sh

Refresh the Devices screen in Cisco Intersight to view the updated server IP address.

Note

Step 4 Choose Launch UCSD.

Cisco Intersight is connected to the Cisco UCS Director system and the Cisco UCS Director user interface opens in a
new tab.

Users with read-only permissions created in Cisco Intersight cannot perform any actions. These users can only
view reports.

Note
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Connector Pack Management
Connector packs help you perform connector level upgrade in Cisco UCS Director without impacting other
connectors. After a system running Cisco UCSDirector is claimed in Cisco Intersight, as a system administrator,
you can view information on new versions of connector packs that are available for upgrade. The top header
pane of the user interface displays a notification indicating that new connector pack versions are available.
You can select and upgrade the connector packs on the system. For more information, see Upgrading Connector
Packs, on page 142.

Following are the connectors that are available in this release:

• Cisco UCS which includes Cisco UCS Central and Cisco UCS Manager

• ACI APIC

• ACI Multi-Site Controller

• F5 Load Balancer

• Network Devices

• EMC Isilon

• EMC RecoverPoint

• EMC VMAX

• EMC VNX

• EMC VNXe

• EMC VPLEX

• EMC Unity

• EMC XtremIO

• IBM

• NetApp ONTAP

• VCE VisionIO

• Microsoft Hyper-V

• RedHat KVM

• Vmware

• Bare Metal Agent

• Cisco IMC

• Cisco BigData Express

• Cisco HyperFlex
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Latest versions of these connectors are made available to Cisco UCS Director only through Cisco Intersight.
So Cisco UCS Director must be claimed in Cisco Intersight.

Important

Upgrading Connector Packs
As a system administrator, you can upgrade connector packs using the Cisco UCS Director graphical user
interface. When new connector pack versions are available, the header pane of the user interface displays an
alert with a down arrow image and a number. This number indicates the number of connector packs that are
available for upgrade. This notification in the header pane is visible only when Cisco UCS Director has been
claimed in Cisco Intersight. For information on establishing a connection with Cisco Intersight, see Configuring
Device Connector, on page 139.

You can upgrade connector pack versions only in a standalone setup. You cannot upgrade connector pack
versions in a multi-node setup.

Note

Before you begin

• You have system administrator privileges.

• Cisco UCS Director has been claimed in Cisco Intersight.

• Cisco UCS Director is successfully connected to Cisco Intersight.

Step 1 On the header, click Available Connector Packs for Upgrade.

TheAvailable Connector Packs for Upgrade screen appears that displays a list of available connector packs for upgrade
along with the version information.

The Available Connector Packs for Upgrade icon is visible on the header only when new versions of the
current running connector packs are available for upgrade.

Note

Step 2 Check the check box of a connector pack from the list.

You can check the check boxes of multiple connector packs.

Step 3 Click Upgrade.
Step 4 In the Confirm Upgrade dialog box, click Yes.

After you confirm that the connector version must be upgraded, the validation process is initiated. If the validation process
completes successfully, the upgrade process is initiated and the Connector Pack Upgrade Status screen displays the
upgrade status. After the upgrade process is successful, the Logout option is enabled. Proceed to step 5.

Following are some of the possible outcomes of the validation and upgrade process:

• If the validation process fails due to issues in the connector pack, theConnector Pack Validation screen is displayed
with error details and corrective measures.

Review the information and click Close.
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• If the connector pack upgrade process fails, click Logout.

If any of the connector pack upgrade fails, the connector pack is rolled back to the earlier version.Note

• The validation process fails if other users have logged in to the system or if workflows are in progress. An upgrade
failure error message with appropriate corrective action is displayed.

Review the corrective action, and click Force Upgrade to proceed with the connector pack upgrade.

TheConnector Pack Upgrade Status screen is displayed with current status for the connector pack upgrade request.
The other users are automatically logged out of the system with a system broadcast message about the upgrade and
are redirected to the login page.

When a connector pack upgrade is in progress, and if another user with system administrator privileges
logs in to the system, the Connector Pack Upgrade Status screen is displayed with the status of the
upgrade process. When a connector pack upgrade is in progress, and if an end user logs in to the system,
the system startup page is displayed.

Note

Step 5 Click Logout.
You can login to Cisco UCS Director after the upgrade process is complete.

What to do next

You can view the upgrade reports by choosing Administration > System > Connector Pack Upgrades.
From this screen, you can double-click on a report, and view additional details on the upgrade process. For
more information, see Viewing Connector Pack Upgrade Information, on page 143.

Viewing Connector Pack Upgrade Information

Step 1 Choose Administration > System.
Step 2 On the System page, click Connector Pack Upgrades.

Information such as upgrade request ID, user that initiated the upgrade, upgrade start time and end time, and the upgrade
status are displayed.

Step 3 Select a connector pack and choose View Details to view details such as connector pack name, upgraded version, and
prior version.

Step 4 Click State History to view the various states of the connector pack upgrade process. For example, upgrade request
received, upgrade process initiated or upgrade process completed.

Step 5 Click Stages to view the entire lifecycle of the connector pack upgrade request.
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C H A P T E R 6
Managing Integration Settings

This chapter contains the following sections:

• About Integration Settings, on page 145
• Configuration Management Database Integration, on page 145
• Metering Data Export, on page 146
• Change Records, on page 147
• System Logs, on page 147
• Storage and OVF Upload, on page 148
• Multiple Language Support, on page 148

About Integration Settings
Using this menu, you can perform the following actions in Cisco UCS Director:

• Monitor application storage information

• Set up the CMDB integration

• Manage the OVF

• Export metering reports

• View System Logs

Configuration Management Database Integration
The ConfigurationManagement Database (CMDB) is used to track andmanage changes in the system. CMDB
typically displays ADD, DELETE, or MODIFY event types on resources such as virtual machines (VMs),
service requests, groups, and so on.

Setting Up CMBD Integration

Step 1 Choose Administration > Integration.
Step 2 On the Integration page, click CMDB Integration Setup.
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Step 3 In the CMDB Integration Setup screen, complete the required fields, including the following:

DescriptionName

Check the check box to export change records to an FTP
server.

Export to FTP Server check box

Choose the type of export format: CSV or XML.Export Format drop-down list

The FTP server address.FTP Server field

The FTP server port number.FTP Port field

The FTP user ID.FTP User field

The FTP user password.FTP Password field

Choose how often the change records are exported to the
FTP server.

FTP Export Frequency drop-down list

The filename for the exported change records. The following
variables can be used to create new filenames each time
that a file is exported to the target FTP server:

MONTH, WEEK, DAY, YEAR, HOUR, MIN, SEC,
MLLIS.

Example: XYZ-$DAY-$HOUR-$MIN-$SEC

FTP File Name field

Check the check box to test FTP settings.Test FTP check box

Step 4 Click Save.

Metering Data Export
You can export trend data, such as VM resource usage and resource accounting details, by setting up a metering
data export to a target server.

Setting Up Metering Data Export

Step 1 Choose Administration > Integration.
Step 2 On the Integration page, clickMetering Data Export Setup.
Step 3 Complete the fields that are used in setting up the Configuration Management Database (CMDB).

For more information, see Setting Up CMBD Integration, on page 145.

Step 4 Click Save.
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Change Records

Viewing Change Records
You can view a maximum of 1000 records. The reports are listed in descending order, wherein the recent
reports are displayed in the top row.

Step 1 Choose Administration > Integration.
Step 2 On the Integration page, click Change Records.

System Logs
You can forward system log (syslog) information to configured servers. Each system message is associated
with a severity level. You can determine the severity level of the system logs that you want forwarded to the
target server.

Setting up System Logs

SUMMARY STEPS

1. Choose Administration > Integration.
2. On the Integration page, click Syslogs.
3. Check the Enable Syslog Forward check box and complete the required fields, including the following:
4. Click Save.

DETAILED STEPS

Step 1 Choose Administration > Integration.
Step 2 On the Integration page, click Syslogs.
Step 3 Check the Enable Syslog Forward check box and complete the required fields, including the following:

DescriptionField

Choose a threshold below which any severity messages are
not forwarded to the syslog server.

Minimum Severity drop-down list

Primary Syslog Server

The primary server address.Server Address field

Choose the protocol: UDP or TCP.Protocol drop-down list

The port number.Port field
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DescriptionField

Choose the message format: XML or plain text.Syslog Message Format drop-down list

Secondary Syslog Server

The secondary server address.Server Address field

Choose the protocol: UDP or TCP.Protocol drop-down list

The port number.Port field

Choose the message format: XML or plain text.Syslog Message Format drop-down list

Step 4 Click Save.

Storage and OVF Upload
You can configure the storage location for files that are uploaded by the administrator, group administrator,
or the end user. The uploaded files can either be stored locally or configured to go to an external NFS share
mount point. As an administrator in the system, you can configure the Network File System (NFS) location.

The Upload files feature provides an option for administrators, group administrators, or the end-user (service
end-user portal) to upload Open Virtualization Format (OVF) files to the local storage or to an external NFS
share mount point. For more details, see the Cisco UCS Director OVF File Upload Guide.

Multiple Language Support
Cisco UCS Director supports the following languages for concurrent display and input:

• English (United States)

• Japanese (Japan)

• Spanish (Latin America)

• French (France)

• Korean (Korea)

• Chinese (China)

• Russian (Russia)

All input fields support entering text in the user’s language of choice.

As an administrator, you can set a language preference for specific users while you are adding them to the
system. For more information, see Adding Users, on page 26. In addition, each user in the system can select
a language for the user interface. For more information, see Setting a Locale for the User Interface, on page
149
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Choosing a Language for Cisco UCS Director
You can choose a language for the Cisco UCS Director user interface.

Step 1 Choose Administration > User Interface Settings.
Step 2 On the User Interface Settings page, click Language.
Step 3 From the Language drop-down list, choose a language.
Step 4 Click Save.

You must restart the system for the language change to take effect.Important

Setting a Locale for the User Interface
As a user in the system, you can select a specific language for the user interface. This language preference is
set only for your login session, and does not impact the language selected for other users.

Step 1 Click your user name that is displayed on the top right corner of the screen, and choose Edit My Profile.
Step 2 In the Edit My Profile screen, choose a language from the Language drop-down list.
Step 3 Click Save.

The language in the user interface is changed immediately.

If the Language drop-down list and Save option is not visible, then you must clear browser cache and launch
Cisco UCS Director again.

Note
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C H A P T E R 7
Managing a Physical Infrastructure

This chapter contains the following sections:

• About Managing a Physical Infrastructure, on page 151
• Testing Connectivity, on page 158
• Enabling Device Discovery, on page 159

About Managing a Physical Infrastructure
Cisco UCS Director enables you to manage both physical and virtual infrastructures. While managing a
physical account, you would need to first create a site, and add a pod to the site. After you create this account,
Cisco UCS Director discovers all components within the newly created physical account. Typically, the
discovery process takes about 5 minutes. In the system, you can either add a new pod or you can use the
default pod that is available. A physical account can be associated with the default pod or with one that you
add.

As an administrator, you can create either a physical account or a virtual account first in the system. A physical
account in Cisco UCS Director has no dependency on a virtual (cloud) account.

Note

Using the Converged View
The Converged view provides you with a graphical representation of the sites, and pods that you have
configured in Cisco UCS Director. To access this view, choose Converged from the side navigation bar. If
you have configured a site or multiple sites in the system, then thisConverged view page displays a drop-down
list from where you can select a site and view the pods that are associated with the site. However, you cannot
add a site from this page. For information on adding a site, see Adding a Site, on page 152. After you have
added a site in the system, you can either add a pod from the Converged page, or you can add a pod from the
Administration > Physical Accounts > Pods screen.

The Converged page, in addition to letting you view the pods associated with each site, also provides the
following options:

• Search—If your site has several pods, then you can use the search feature to locate a specific pod using
the name as the search criteria.

• Add, Edit and Delete—Use these options to add, modify or delete pods.
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• Collapse and expand the row of pods displayed for a site.

• View specific account information of each pod:

• If you select a pod, and mouse over an account, then all account details are displayed. Alternatively,
you can click an account to view the detailed information.

• Power status of the account - the power icon on the account indicates if the account is powered on
or powered off. Green color indicates that it is powered on, and red color indicates that it is powered
off.

Adding a Site

Step 1 Choose Administration > Physical Accounts.
Step 2 On the Physical Accounts page, click Site Management.
Step 3 Click Add.
Step 4 On the Add Site screen, complete the following fields:

DescriptionName

A descriptive name for the site.Site Name field

The description of the site, such as the location, significance,
and so on.

Description field

The name of the person responsible for this site.Contact Name field

Step 5 Click Submit.

Adding a Pod

Step 1 Choose Administration > Physical Accounts.
Step 2 On the Physical Accounts page, click Pods.
Step 3 Click Add.
Step 4 On the Add Pod screen, complete the following fields:

DescriptionName

A descriptive name for the pod.Name field
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DescriptionName

Choose the type of pod that you want to add. This can be one of the
following:

• Flexpod

• VersaStack

• Generic

• ExpressPod Medium

• VSPEX

• ExpressPod Small

• Vblock

• HyperFlex

• Virtual SAN Pod

The nongeneric pod types accommodate only specific physical and virtual
components. A generic pod does not require a specific pod license. You can
add any type of physical or virtual component to a generic pod. For more
information about bundled pod licenses (FlexPod, Vblock, and VSPEX),
which include the necessary individual device licenses to run a pod, see the
Cisco UCS Director Installation and Upgrade Guides.

Only VersaStack and Generic pods are supported in the IBM
accounts in Cisco UCS Director.

Note

Type drop-down list

Choose the site where you want to add the pod. If your environment does
not include sites, you can omit this step.

Site drop-down list

(Optional) A description of the pod.Description field

The physical location of the pod. For example, this field could include the
city or other internal identification used for the pod.

Address field

Check to hide the pod if you do not want it to show in the Converged Check
View. You can continue to add or delete accounts from the pod.

For example, you can use this check box to ensure that a pod that does not
have any physical or virtual elements is not displayed in the Converged
View.

Hide Pod check box

Step 5 Click Add.

What to do next

Add one or more accounts to the pod.
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Adding a Physical Account

Step 1 Choose Administration > Physical Accounts.
Step 2 On the Physical Accounts page, click Physical Accounts.
Step 3 Click Add.
Step 4 On the Add Account screen, complete the following fields:

DescriptionName

Choose the pod to which this physical account belongs.Pod drop-down list

Choose the category type (Computing or Storage). If you
chose Storage, continue to Step 6.

Category drop-down list

Choose from the following account types for this physical
account:

• UCSM

• HP ILO

• Cisco Rack Server (CIMC)

• IPMI

Account Type drop-down list

Step 5 Click Submit.
Step 6 On the Add Account screen, complete the following fields:

DescriptionName

Choose from the following authentication types to be used
for this account:

• Locally Authenticated—A locally authenticated user
account is authenticated directly through the fabric
interconnect and can be enabled or disabled by anyone
with admin or AAA privileges.

• Remotely Authenticated—A remotely authenticated
user account is any user account that is authenticated
through LDAP, RADIUS, or TACACS+.

Authentication Type drop-down list

Choose how servers are managed by this account by
selecting one of the following options:

• All Servers

• Selected Servers

Server Management drop-down list

A unique name for the physical account that you want to
add.

Account Name field

The IP address of the server.Server Address field
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DescriptionName

Check this check box if you want to use a credential policy
for this account rather than enter the information manually.

Use Credential Policy check box

If you checkedUseCredential Policy, choose the credential
policy that you want to use from this drop-down list.

This field is only displayed if you choose to use a credential
policy.

Credential Policy drop-down list

The username for accessing this account.

This field is not displayed if you choose to use a credential
policy.

User ID field

The password associated with the username.

This field is not displayed if you choose to use a credential
policy.

Password field

Choose the transport type that you want to use for the
account.

This can be one of the following:

• HTTP

• HTTPS

This field is not displayed if you choose to use a credential
policy.

Transport Type drop-down list

The server port number.

This field is not displayed if you choose to use a credential
policy.

Port field

The description of the account.Description field

The contact email address for the account.Contact Email field

The location.Location field

The service provider’s name, if any.Service Provider field

Step 7 If this account is Storage, choose the appropriate account type: NetApp ONTAP, NetApp OnCommand, EMC VNX,
EMC VMAX Solutions Enabler orWHIPTAIL.

Step 8 Click Add.

Adding a Multi-Domain Manager Account
You can add the following types of multi-domain manager accounts:

• PNSC—Cisco Prime Network Services Controller account
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• DCNM—Cisco Prime Data Center Network Manager account

• UCS Central—Cisco UCS Central account

• APIC—Cisco Application Policy Infrastructure Controller account

• EMC RecoverPoint account

• EMC VPLEX account

Before you begin

You must be logged in to the appliance to complete this task.

Step 1 Choose Administration > Physical Accounts.
Step 2 On the Physical Accounts page, clickMulti-Domain Managers.
Step 3 Click Add.
Step 4 On the Add Account screen, choose the account type from the drop-down list.
Step 5 Click Submit.
Step 6 On theMulti-Domain Manager Account screen, complete the following fields:

DescriptionName

Choose the account name to which this multi-domain
manager account belongs.

Account Name field

(Optional) The description of the account.Description field

Enter the IP address of the server managing the
multi-domain manager account.

Server Address field

A unique name for the physical account that you want to
add.

Account Name field

The IP address of the server.Server Address field

The username for accessing this account.User ID field

The password associated with the username.Password field

Choose the transport type that you want to use for the
account. This can be one of the following:

• http

• https

Transport Type drop-down list

The server port number. The default port is 443.Port field

(Optional) The contact email address for the account.Contact Email field

(Optional) The location.Location field
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Step 7 Click Submit.

Adding a Network Element
In order to create a virtual server that supports load balancing, first add a network element in Cisco UCS
Director. After a Load Balancer is added as a network element in Cisco UCS Director, it appears on the
Managed Network Element screen.

Before you begin

You must be logged in to the appliance to complete this task.

Step 1 Choose Administration > Physical Accounts.
Step 2 On the Physical Accounts page, clickManaged Network Elements.
Step 3 Click Add Network Element.
Step 4 On the Add Network Element screen, complete the following fields:

DescriptionName

Choose the pod to which the network element belongs.Pod drop-down list

Choose the device category for this network element. For
example: F5 Load Balancer.

Device Category drop-down list

The IP address for this device.Device IP field

Choose the protocol to be used. The list may include the
following:

• Telnet

• SSH

• HTTP

• HTTPS

When working with an F5 load balancer device,
HTTP and HTTPS are the only valid selections.

Note

Protocol drop-down list

The port to use.Port field

The login name.Login field

The password associated with the login name.Password field

Step 5 Click Submit.
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Adding the F5 Load Balancer triggers the system task inventory collection. The polling interval configured
on the System Tasks screen specifies the frequency of inventory collection.

What to do next

To modify or edit a virtual server, choose the server, and then clickModify. To remove a virtual server,
choose the server, and then click Delete.

Enabling DHCP Logging

Before you begin

You must be logged in to the appliance to complete this task.

Step 1 Choose Administration > Physical Accounts.
Step 2 On the Physical Accounts page, choose the Network Service Agents.
Step 3 Click Embedded Network Services.
Step 4 On the Embedded Network Services screen, check the Enable DHCP Logging.

Testing Connectivity
You can test connectivity for managed network elements, virtual accounts, and physical accounts.

Testing Connectivity of Managed Network Elements

Step 1 Choose Administration > Physical Accounts.
Step 2 On the Physical Accounts page, clickManaged Network Elements.
Step 3 Click the row with the pod for which you want to test connectivity.
Step 4 Click Test Connection.

Testing the Connection to a Physical Account
You can test the connection at any time after you add an account to a pod.

Step 1 Choose Administration > Physical Accounts.
Step 2 On the Physical Accounts page, clickMulti-Domain Managers.
Step 3 On theMulti-Domain Managers screen, click the row of the account for which you want to test the connection.
Step 4 Click Test Connection.
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Step 5 When the connection test has completed, click Close.

What to do next

If the connection fails, verify the configuration of the account, including the username and password. If the
username and password are correct, determine whether there is a network connectivity problem.

Enabling Device Discovery

Step 1 Choose Administration > Physical Accounts.
Step 2 On the Physical Accounts page, click Discovered Devices.
Step 3 Click Setup Discovery.
Step 4 On the Setup Discovery screen, check Enable Discovery.
Step 5 On the Setup Discovery screen, complete the IP address range field and determine if the default values for the following

fields are adequate for your environment:

DescriptionName

The check box is checked by default to enable device
discovery for this account.

Enable Discovery check box

The IP address range for device discovery. (For example,
10.1.1.1-10.1.1.12 )

IP Range field

The TCP timeout (ms) (default value is 2000 ms).TCP Timeout (ms) field

The SNMP timeout (ms) (default is 1500 ms).SNMP Timeout (ms) field

The SNMP community string (default is public).SNMP Community Strings field

Step 6 Click Submit.
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C H A P T E R 8
Managing a Virtual Infrastructure

This chapter contains the following sections:

• About Managing VMware Clouds, on page 161
• Verifying Cloud Discovery and Connectivity, on page 166
• Viewing vCenter Plug-ins, on page 166
• Provisioning Virtual Machines in Cisco UCS Director, on page 167

About Managing VMware Clouds
Cisco UCS Director supports VMware through vCenter (ESX 3.5, ESX/ESXi 4.x, 5.x, 6.0 and 6.5). Cisco
UCS Director automatically discovers all existing virtual machines (VMs) and images in the newly added
cloud account. Typically, the discovery process takes about 5 minutes. You can also add VMware clouds

The term “cloud” refers to one vCenter installation.Note

Cisco UCSDirector supports inventory collection and VMprovisioning usingmultiple datacenters and clusters.
When creating a VMware cloud, you can choose the option to discover and select multiple datacenters and
clusters. Once you add a discovered datacenter and cluster to a cloud, you cannot de-select them from the
cloud by editing it. However, you can edit the cloud to add extra datacenters and clusters.

Cisco UCS Director does not support the creation of clouds that use the same vCenter account. If there are
duplicate accounts, you cannot create a VMware Cloud. In addition, if there are duplicate accounts, VM
provisioning fails and an error appears in the status for the virtual account. The Test Connectivity function
also fails with the error message. This error also occurs if the same server with the same combination of
clusters is used in different clouds.

To disable this functionality, you can manually modify the vmware.properties file in the cd
/opt/infra/inframgr directory to allow duplicate account IDs by setting the allowDuplicateClouds
field to true. By default the field is set to false.

Note

When upgrading from a previous release, all duplicate accounts display a failed connection status. Though
an error message displays, all the actions can still be executed on the VMs.
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Creating a VMware Cloud
When creating a VMware cloud, you can specify a datacenter and clusters in one of the following ways:

• Within the credential policy

• In the VMware Datacenter and VMware Cluster fields

• From the Discover Datacenters / Clusters check box

Either a datacenter within the credential policy or the VMware datacenter and VMware cluster can be selected.
Specifying the datacenter in the Add Cloud screen and in the credential policy form results in an error.

Note

Step 1 Choose Administration > Virtual Accounts.
Step 2 On the Virtual Accounts page, click Virtual Accounts.
Step 3 Click Add.
Step 4 On the Add Cloud screen, complete the required fields, including the following:

DescriptionName

Displays the available cloud types. Choose VMware.

The following fields are displayedwhenVMware
is chosen. Other cloud types display fields that
are specific to that cloud type.

Note

Cloud Type drop-down list

The cloud name. The name cannot include single quotes.

Each cloud requires a unique name in Cisco UCS
Director. Once a cloud has been added, all
reports refer to the cloud using the Cloud Name.

Note

Cloud Name field

The vCenter server addressServer Address field

Check this check box if you want to use a credential policy
for this account rather than enter the information manually.

Use Credential Policy check box

If you checkedUseCredential Policy, choose the crednetial
policy that you want to use from this drop-down list.

This field is only displayed if you choose to use a credential
policy.

Use Credential Policy drop-down list

The vCenter server username.Server User ID field

The vCenter server password.Server Password field

The server port number.Server Access Port field

The server access URL.Server Access URL field
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DescriptionName

The data center name on the vCenter account.VMware Datacenter field

Check this check box to discover and use any VMware
datacenters and associated VMware clusters.

Discover Datacenters / Clusters check box

The name of the VMware cluster in the vCenter account.

This name allows you to discover, monitor, and manage
the specified pod's resources. Leave the field blank if the
entire vCenter account is managed by Cisco UCS Director.

VMware Cluster field

Check the associated datacenters and clusters you want to
use.

This field is visible only when you check the
Discover Datacenters / Clusters check box.

Note

Select Datacenters / Clusters field

Check this check box to enable Site Recovery Manager
(SRM) for the account.

Enable SRM check box

The IP address of the primary SRM server.

This field is visible only when you check the
Enable SRM check box.

Note

Primary SRM Server Address field

The user ID for the primary SRM server.

This field is visible only when you check the
Enable SRM check box.

Note

Primary SRM Server User ID field

The password of the user for the primary SRM server.

This field is visible only when you check the
Enable SRM check box.

Note

Primary SRM Server Password field

The port number for the primary SRM server. For SRM
version 6.0, enter 9086 as the port number.

This field is visible only when you check the
Enable SRM check box.

Note

Primary SRM Server Access Port field

The user ID for the remote SRM server.

This field is visible only when you check the
Enable SRM check box.

Note

Remote SRM Server User ID field

The password of the user ID for the remote SRM server.

This field is visible only when you check the
Enable SRM check box.

Note

Remote SRM Server Password field

Cisco UCS Director Administration Guide, Release 6.6
163

Managing a Virtual Infrastructure
Creating a VMware Cloud



DescriptionName

Check this check box to use Single Sign-On (SSO) for
authentication.

The SSO option is only available for Virtual SAN (VSAN).
SSO credentials are required for VM provisioning using
storage profiles on the Virtual SAN cluster.

Use SSO check box

The IP address of the Single-Sign On server.

This field is visible only when you check theUse
SSO check box.

Note

SSO Server Address field

The user ID for the SSO server.

This field is visible only when you check theUse
SSO check box.

Note

SSO Server User ID field

The password of the user ID for the SSO server.

This field is visible only when you check theUse
SSO check box.

Note

SSO Server Password field

The URL for SSO server access.

This field is visible only when you check theUse
SSO check box.

Note

SSO Server Access URL field

The port number. For vCenter version 5.x, enter 7444 as
the port number.

This field is visible only when you check theUse
SSO check box.

Note

SSO Server Access Port field

The URL for server access.Server Access URL field

The description of the cloud.Description field

The contact email address for the cloud.Contact Email field

The location.Location field

Choose the converged infrastructure pod.

When you choose a pod name, the VMware cloud account
is made available in the converged infrastructure stack.

You cannot add more than one virtual account
to a virtual SAN pod.

Note

Pod drop-down list

The service provider’s name.Service Provider field
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Step 5 Click Add.

Downloading the PowerShell Agent Installer
The PowerShell Agent is installed on Windows Server 2008 R2 or Windows Server 2012 64-bit virtual
machines.

Step 1 Choose Administration > Virtual Accounts.
Step 2 On the Virtual Accounts page, click PowerShell Agents.
Step 3 Click Download Installer.
Step 4 In the Download Agent Installer screen, check if your system meets the listed installation requirements.
Step 5 If the requirements are met, click Submit.

The Opening PSASetup. exe dialog box prompts you to save the executable file.

Step 6 Click Save File.

The file is saved to your system’s download location.

Step 7 Install the PSASetup. exe file on your Windows Server 2008 R2 or Windows Server 2012 64-bit virtual machine (VM).

Creating a PowerShell Agent

Step 1 Choose Administration > Virtual Accounts.
Step 2 On the Virtual Accounts page, click PowerShell Agents.
Step 3 Click Add.
Step 4 In the Add Agent screen, complete the required fields, including the following:

DescriptionName

The agent name.Agent Name field

The agent address.Agent Address field

The agent access port number.Agent Access Port field

The access key.Access Key field

The description of the agent.Description field

Step 5 Click Submit.
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Verifying Cloud Discovery and Connectivity

Testing the Connection

SUMMARY STEPS

1. Choose Administration > Virtual Accounts.
2. On the Virtual Accounts page, click Virtual Accounts.
3. Choose the VMware account that you want to test.
4. Click Test Connectivity.
5. Choose Virtual > Compute.
6. Click Summary.
7. Choose the cloud name to view its status details.

DETAILED STEPS

Step 1 Choose Administration > Virtual Accounts.
Step 2 On the Virtual Accounts page, click Virtual Accounts.
Step 3 Choose the VMware account that you want to test.
Step 4 Click Test Connectivity.

There is no progress bar that displays the results of the connectivity test. Use the Summary tab to verify that the cloud
account is added and its data is collected.

Step 5 Choose Virtual > Compute.
Step 6 Click Summary.

It can take a few minutes to complete autodiscovery and populate the data.

Step 7 Choose the cloud name to view its status details.

Viewing vCenter Plug-ins

Step 1 Choose Administration > Virtual Accounts.
Step 2 On the Virtual Accounts page, click Plugins.
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Provisioning Virtual Machines in Cisco UCS Director
Provisioning virtual machines in Cisco UCSDirector is a multi-step process. It involves steps such as creating
a virtual account, creating policies, and creating catalogs and service requests. Prior to starting this task, as
an administrator, determine the following:

• The cluster in which the VM must be deployed

• The datastores within the cluster that are available for VM provisioning

• The available network within the cluster in which the VM must be deployed

In the absence of this information, if you select invalid datastores or an incorrect network for a cluster, VM
provisioning in Cisco UCS Director fails.

Attention

The process of provisioning a VM in Cisco UCS Director can be summarized as:

1. Create a user group.

For more information, see Creating a User Group, on page 51.

2. Create a virtual account.

A VM is provisioned within a virtual account in Cisco UCS Director. For more information, see Creating
a VMware Cloud, on page 162.

3. Create a VMware system policy.

This policy defines the system-specific information for the VM. Youmust specify the VM naming template
to use, the OS to be configured, and the domain in which the VM must be provisioned. For more
information, see Configuring a System Policy, on page 196.

4. Create a VMware computing policy.

Computing policies determine the compute resources that can be used during provisioning to satisfy group
or workload requirements. The cluster that you specify in this policy determines the choices you make in
subsequent policies. For more information, see Creating a Computing Policy, on page 170.

5. Create a storage policy.

A storage policy defines resources such as the datastore scope, type of storage to use, minimum conditions
for capacity, latency, and so on. For more information, see Adding and Configuring a Storage Policy, on
page 180.

6. Create a network policy.

The network policy defines resources such as network settings, DHCP or static IP, and the option to add
multiple vNICs for provisioning VMs. For more information, see Configuring a Network Provisioning
Policy, on page 193.

7. Create a virtual data center.

A Virtual Data Center (VDC) is an environment that combines virtual resources, operational details, rules,
and policies.While creating a VDC, select the user group that you created for VM provisioning, and select
the cloud that you specified while creating the policies. Based on the cloud account that you select, all
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the subsequent policy-related fields are populated. For more information, see Adding a Virtual Data
Center, on page 207.

8. Create a catalog to select a template.

You can self-provision virtual machines (VMs) using predefined catalog items. A catalog defines parameters
such as the cloud name and the group name to which the VM is bound. For more information, see Publishing
a Catalog, on page 258.

9. Create and submit a service request.

You can use the self-service provisioning feature to create a service request to provision virtual machines
(VMs), services, or applications. The service request process produces a provisioning workflow for VM
creation. For more information, see Creating a Service Request with Catalog Type—Standard, on page
272.

After you submit a service request, a workflow is triggered, and the VM is provisioned.

The following image illustrates the workflow to provision a VM in Cisco UCS Director.
Figure 3: Workflow for Provisioning a Virtual Machine in Cisco UCS Director
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C H A P T E R 9
Managing Policies

This chapter contains the following sections:

• Policies, on page 169
• Computing Policies, on page 170
• Configuring a Bare Metal Server Provisioning Policy, on page 172
• Data Collection Policy, on page 176
• About Group Share Policy, on page 179
• Storage Policies, on page 180
• Credential Policies, on page 187
• Network Policies, on page 188
• System Policies, on page 195
• End User Self-Service Policy, on page 202
• Configuring a VM Management Policy, on page 203

Policies
Cisco UCS Director provides an End User Portal in which resources, such as virtual machines (VMs) or bare
metal servers, are provisioned from a pool of assigned resources using predefined policies set by administrators.

A policy is a group of rules that determine where and how a new resource, be it a virtual machine or a bare
metal server, is provisioned within the infrastructure, based on available system resources.

Cisco UCS Director requires that you set up the following policies to provision resources:

• Computing

• Storage

• Network

• System

• Bare Metal

Create a cloud account prior to setting up policies to provision VMs.Important
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Computing Policies
Computing policies determine the compute resources that can be used during provisioning to satisfy group
or workload requirements.

As an administrator, you can define advanced policies by mixing and matching various conditions in the
computing policy.

We recommend that you thoroughly understand all the fields in the computing policy. Some combinations of
conditions can result in no host machines being available during self-service provisioning.

Note

Creating a Computing Policy

Step 1 Choose Policies > Virtual/Hypervisor Policies > Computing.
Step 2 On the Computing page, click VMware Computing Policy.
Step 3 Click Add.
Step 4 On the Add Computing Policy screen, complete the following fields:

DescriptionName

The name of the policy.

This name is used during catalog definition.Note

Policy Name field

The description of the policy.Policy Description field

Choose the cloud where resource allocation occurs.Cloud Name drop-down list

Choose the scope of deployment.

You can narrow the scope of deployment by
specifying whether to use all, include chosen, or
exclude chosen options. Depending on the
choices, a new field appears where the required
hosts or clusters can be chosen.

Note

Host Node/Cluster Scope drop-down list

Choose the resource pool.Resource Pool drop-down list

Choose the ESX installation type: ESX, ESXi, or both.ESX Type drop-down list

Choose the version of ESX.ESX Version drop-down list

Check one or more conditions that should match. Any hosts
that do not meet these criteria are excluded from
consideration. If more than one condition is chosen, all of
the chosen conditions must match.

Filter Conditions check boxes
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DescriptionName

Deployment Options

Check to override the template properties. You are provided
with options to enter custom settings for CPU and memory.

Override Template check box

A custom number of vCPUs. The specified number of
vCPUs for a VM should not exceed the total cores for the
chosen scope of host nodes or clusters.

This option appears if you checked Override
Template.

Note

Number of vCPUs field

The CPU reservation for the VM. The reservation depends
upon the number of vCPUs specified.

This option appears if you checked Override
Template.

Note

CPU Reservation (MHz) field

The CPU limit for the VM. The CPU limit is based on the
chosen scope of host nodes or clusters.

CPU Limit (MHz) field

Choose the CPU shares: low, normal, or high. The CPU
shares determine which VMgets CPU resources when there
is competition among VMs.

This option appears if you checked Override
Template.

Note

CPU Shares drop-down list

The custom memory for the VM.

This option appears if you checked Override
Template.

Note

Memory field

The memory reservation for the VM. The reservation
depends upon the memory specified.

This option appears if you checked Override
Template.

Note

Memory Reservation (MB) field

The memory limit for the VM. The memory limit is based
on the chosen scope of host nodes or clusters.

This option appears if you checked Override
Template.

Note

Memory Limit (MB) field

Choose the memory shares: low, normal, or high.1Memory
shares determine which VM gets memory resources when
there is competition among VMs.

This option appears if you checked Override
Template.

Note

Memory Shares drop-down list
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DescriptionName

Resizing Options

Check to allowVM resizing before provisioning or to resize
an existing VM.

Allow Resizing of VM check box

The range of vCPUs to use while provisioning a VM or
resizing an existing VM. A range of more than 8 is visible
during VM provisioning or resizing only if the chosen cloud
(vCenter) is 5 or above and has VM version 8. Only the
values specified in the box are visible.

This option appears if you checked Allow
Resizing of VM.

Note

Permitted Values for vCPUs field

The number of permitted cores per socket. The number of
cores per socket can be configured when creating a service
request, deploying a VM, cloning a VM, or provisioning a
VM using an orchestration workflow. If this field is empty,
you will not have the option to specify the cores per socket
while provisioning a VM and other actions.

Permitted Values for cores per socket

The range of memory to use while provisioning a VM or
resizing an existing VM. For example: 512, 768, 1024,
1536, 2048, 3072, 4096, and so on. Only the values
specified in the box are visible.

This option appears if you checked Allow
Resizing of VM.

Note

Permitted Values for Memory in MB field

Step 5 Click Submit.

Configuring a Bare Metal Server Provisioning Policy
Before you begin

• A Bare Metal Agent (BMA) account must be added and configured with Bare Metal OS images.

• A Cisco UCS Manager account must be added.

• A Cisco UCS Central account must be added.

• If you need a specific cost associated with the bare metal server, then you must create a bare metal server
cost model prior to creating this policy.

Step 1 Choose Policies > Physical Infrastructure Policies > Bare Metal Servers.
Step 2 On the Bare Metal Servers page, click Bare Metal Server Provisioning Policy.
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Step 3 Click Add.
Step 4 On the Add Bare Metal Server Provisioning Policy screen, complete the required fields, including the following:

DescriptionName

Enter a unique name for the policy.Policy Name field

Enter a description for the policy.Policy Description field

Choose an account type from the drop-down list. It can be
one of the following:

• UCS Central

• UCS Manager

Account Type drop-down list

Choose a Cisco UCS Central account name.

This field is displayed only if you selected UCS
Central in the Account Type drop-down list.

Note

UCS Central Account Name drop-down list

Choose an account name from the drop-down list.Account Name drop-down list

Choose the scope for the policy. It can be one of the
following:

• Include Servers

• Include Server Pools

Server Selection Scope drop-down list

Expand the list to check the UCS domain groups to be
included in this policy. After checking the domain groups,
click Validate.

This field is displayed only if you selected UCS
Central in the Account Type drop-down list.

Note

Domain Group(s) list

Check this check box to populate theDomain Name(s) list
with ungrouped domains along with the domain names
included in the selected domain groups.

This field is displayed only if you selected UCS
Central in the Account Type drop-down list
and if you have selected a domain group from
the Domain Group(s) list.

Note

Include Ungrouped Domains check box

Expand the list to check the UCS domain names to be
included in this policy. After checking the domain name,
click Validate.

This field is displayed only if you selected UCS
Central in the Account Type drop-down list.

Note

Domain Name(s) list
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DescriptionName

Check the servers for this policy.

This field is visible only if you selected Include Servers
in the Server Selection Scope drop-down list.

Servers field

Check the server pools for this policy.

This field is visible only if you selected Include Server
Pools in the Server Selection Scope drop-down list.

Server Pools field

Choose a service profile template.Service Profile Template drop-down list

Check to include servers that contain at least one FCoE
capable interface card.

Use for SAN Boot check box

Specify the minimum number of CPUs that the server must
contain.

Minimum Number of CPUs field

Specify the minimum amount of memory that must be
available on the server.

Minimum Amount of Memory (MB) field

Specify the number of cores that must be enabled on the
server.

Minimum Number of Cores Enabled field

Check to allow users to select servers while using this policy
to provision bare metal servers. If you do not check this
check box, a bare metal server is provisioned based on the
parameters you specify in this policy.

Allow User to Choose Servers check box

Check to have the system resources displayed when
provisioning bare metal servers. You can choose any of the
following resources:

• CPU

• Memory

• Storage

Show Server Resources to User check box

Select a bare metal agent for the PXE setup.Target BMA drop-down list

Check this check box to view a list ofWindows images that
you can select.

Use Windows Images check box

Check the check boxes of the OS images. If you checked
Use Windows Images, then a list of Windows images are
displayed. If you did not checkUseWindows Images, then
a list of Windows and CentOS images are displayed.

While creating a service request for provisioning bare metal
servers, you are prompted to select a Windows image.

OS Image Selection
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DescriptionName

Choose a boot manager from the drop-down list. It can be
one of the following:

• PXE

• iPXE-BIOS

• iPXE-EUFI

Network Boot Manager drop-down list

Choose the type of IP configuration from the drop-down
list. It can be one of the following:

• DHCP

• Static

IP Configuration Type drop-down list

Expand this list to map a domain to a specific BMA, or OS
image.

Click + to add a domain mapping. You will need to specify
information for the following fields:

• Domain Name—check the names of the domains that
you want to map.

• Target BMA—Choose a target BMA from the
drop-down list.

• OS Image—Check an OS image.

This field is displayed only if you selected UCS
Central in the Account Type drop-down list.

Note

Domain Mapping list

Network Management

Check to select a static IP pool policy for provisioning a
bare metal server.

If you check this check box, an IP address is automatically
assigned to the bare metal server from the IP range provided
in the static IP pool policy.

Use Static IP Pool Policy check box

Specify an IP address range.Server IP Address field

Specify the server netmask.Server Netmask field

Specify the server gateway IP addressServer Gateway field

Specify the name server IP addressName Server field

Specify the management VLAN. By default, it is set to 0.Management VLAN field

System Parameters
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DescriptionName

Specify the server host name.Server Host Name field

Choose a policy from the drop-down list.

The server host name is validated against the policy that
you select in this field before it is applied on the bare metal
server.

Host Name Validation Policy drop-down list

Specify the password for the server host name.Password field

Confirm the password for the server host name.Confirm Password field

Set the time zone for the servers.Timezone drop-down list

Choose a cost model for the servers.Cost Model drop-down list

Step 5 Click Submit.

What to do next

You can validate the policy.

Validating a Bare Metal Server Provisioning Policy
To ensure that the parameters specified in the bare metal server provisioning policy are accurate, you can run
this validation process on the policy.

Before you begin

You should have created a bare metal server provisioning policy.

Step 1 Choose Policies > Physical Infrastructure Policies > Bare Metal Servers.
Step 2 On the Bare Metal Servers page, click Bare Metal Server Provisioning Policy.
Step 3 Choose a policy from the list of policies.
Step 4 From theMore Actions drop-down list, choose Validate.

The validation process is initiated, and the results are displayed in the Status column on the Bare Metal Server
Provisioning Policy screen.

Data Collection Policy
A data collection policy can be created to control the parameters that can be retrieved from the vCenter server
for each VMware account. Each of the parameters mentioned in a data collection policy is collected and used
in specific trend reports in Cisco UCS Director.
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VMware is the only supported virtual account type. When a VMware account is added, it is automatically
associated with the default-data-collection-policy.

Note

Configuring a Data Collection Policy for a Virtual Account

Step 1 Choose Policies > Virtual/Hypervisor Policies > Service Delivery.
Step 2 On the Service Delivery page, click Data Collection Policy.
Step 3 Click Add.
Step 4 On the Add screen, complete the following fields:

DescriptionName

The name of the data collection policy.

This name is used during catalog definition.Note

Name field

The description of the policy.Description field

The VMware virtual account is selected.Account Type drop-down list
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DescriptionName

Choose a data collection group containing vCenter
parameters. For example: CPU.

Click the pencil icon to edit the data collection group. On
the Edit Resource Entry screen, you can enable or disable
data collection by checking or unchecking Enable
Collection.

To view the datastore-specific performance data in the Cisco
UCS Director GUI, select the following resources:

• Datastore throughput in kilobytes per second

• Datastore number of read average

• Datastore number of write average

• Disk total latency in milliseconds

For a Disk Latency report, in addition to selecting the
resources listed above, set the vCenter Server performance
data statistics collection level to 3.

For a Throughput report, in addition to selecting the
resources listed above, set the vCenter Server performance
data statistics collection level to 4.

Increasing the statistics collection to level 2 and
above in the vCenter server could have an impact
on the performance of the vCenter server and of
Cisco UCS Director.

For more information, see
https://kb.vmware.com/selfservice/microsites/
search.do?language=en_
US&cmd=displayKC&externalId=2003885.

Important

Resource window

Step 5 Click Submit.

Associating the Data Collection Policy for a Virtual Account

Step 1 Choose Policies > Virtual/Hypervisor Policies > Service Delivery.
Step 2 On the Service Delivery page, click Data Collection Policy Association.
Step 3 Choose the Data Collection Policy Association tab.
Step 4 Click the row with the virtual (VMware) account for which you want to associate the data collection policy, and click

Edit.
Step 5 In the Edit dialog box, choose the data collection policy from the Policy drop-down list that you configured.
Step 6 Click Submit.
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The VMware account is now associated with the data collection policy.

About Group Share Policy
A group share policy provides more control to the users on resources and on what they can share with other
users.With this policy, users can view resources that are currently assigned only to them or can view resources
that are assigned to all groups that the users are part of.

While you are creating a group, you can define a group share policy and determinewhich groups have read/write
permissions. Later, when users are added to this group, their access to resources is defined by the group share
policy.

Creating a Group Share Policy

Step 1 Choose Administration > Users and Groups.
Step 2 On the Users and Groups page, click Group Share Policy.
Step 3 Click Add.
Step 4 On the Add Group Share Policy screen, complete the following fields:

DescriptionName

The name of the group share policy.Policy Name field

The description of the policy.Policy Description field

Check to apply this policy to one or more MSP
organizations.

MSP Group Share Policy check box

Click Select to choose the MSP organizations that have
read/write permissions for the resources defined with this
policy.

This file is only available if you checkMSP Group Share
Policy.

MSP Organizations field

Click Select to choose the organizations that have read/write
permissions for the resources defined with this policy.

Customer Organizations field

Step 5 Click Submit.

What to do next

You can associate this group share policy with user groups in the system. Based on the permissions, users
within those groups inherit read/write permissions to resources.
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Storage Policies
A storage policy defines resources such as the datastore scope, type of storage to use, minimum conditions
for capacity, latency, and so on.

The storage policy also provides options to configure additional disk policies for multiple disks, and to provide
datastore choices for use during a service request creation.

Cisco UCS Director supports datastore choice during a service request creation for VM provisioning. You
can enable or disable datastore choices for the end user during service request creation. The datastores listed
depend upon the scope conditions specified in the storage policy that is associated with the VDC during the
service request creation.

To use the datastore selection feature while creating a service request, the template for VM provisioning must
have the disk type assigned as System. This is applicable for templates with single or multiple disks.

Note

Storage Policies for Multiple VM Disks
Cisco UCS Director supports VM provisioning with multiple disks on multiple datastores.

Disks are classified into five types: system, data, database, swap, and log. The system disk policy is configured
first, and the other disks can be configured depending on requirements. You can configure the disk policy
individually for each disk type or choose the default system disk policy for each disk.

For information on creating a storage policy for a template with multiple disks, see Multiple Disk VM
Provisioning, on page 293.

Note

Adding and Configuring a Storage Policy

Step 1 Choose Policies > Virtual/Hypervisor Policies > Storage.
Step 2 On the Storage page, click VMware Storage Policy.
Step 3 Click Add.
Step 4 On the Add Storage Resource Allocation Policy screen, complete the following fields:

DescriptionName

Storage Policy - System Disk Policy

Enter the cloud in which resource allocation occurs.Policy Name field
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DescriptionName

Enter the description of the policy.

If you want to narrow the scope of deployment, choose
whether to use all data stores, include selected data stores,
or exclude selected data stores.

Policy Description field

Choose the cloud account for this resource allocation.

If you choose an SRM account, the Enable Protection
check box is displayed. For more information about how
to enable protection groups for Site Recovery Manager,
see the Cisco UCSDirector VMwareManagement Guide.

Cloud Name drop-down list

Check to ensure that VMs are deployed using
ReadyClones.

This option is available only if the cloud account you chose
is an HyperFlex (HX) cloud.

Use ReadyClone check box

Check if you want to protect the VMs using HyperFlex
cloud.

This field is displayed only when the VM is enabled with
Hyperflex Dataprotection.

Enable HX Protection check box

Choose the protection group to protect the VM. Click
Select to choose the protection group.

This field is displayed only when you check the Enable
HX Protection check box.

Select Protection Group field

System Disk Scope

Check if you want to use a linked clone.

If you do not check this box, the configuration uses a full
clone.

Use Linked Clone check box

Choose a storage profile if you want to provision one or
more VMs with the associated storage profile.

Storage Profile drop-down list
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DescriptionName

To define the scope of deployment, choose one of the
following options:

• All

• Include Selected Datastores

• Exclude Selected Datastores

• Include Selected Datastore Clusters

• Exclude Selected Datastore Clusters

Depending on which option you choose, additional fields
may display.

The option that you choose determines which
datastores or datastore clusters are available
when you create a VM disk.

Note

Data Stores/Datastore Clusters Scope drop-down list

If you chose Include Selected Datastores or Exclude
Selected Datastores, expand Selected Data Stores to
choose the appropriate datastores.

Selected Data Stores field

Check to use only shared datastores.

This option is available only if you chose to include or
exclude selected datastores.

Use Shared Data Store only check box

If you chose Include Selected Datastore Clusters or
Exclude Selected Datastore Clusters, expand Selected
Datastore Clusters to choose the appropriate datastore
clusters.

Selected Datastore Clusters field

If you chose to include or exclude selected datastore
clusters, choose one of the following SDRS rule types:

• Keep VMDKs Together—You need to select an
existing rule on the filtered clusters. The newly
provisioned VM is added to the VM anti-affinity rule.

• Separate VMDKs—If the newly provisioned VM
contains more than one disk, a new VM affinity rule
is created on the datastore cluster.

Select SDRS Rule Type drop-down list

If you chose Keep VMDKs Together, you must choose
the VMs to which you want to apply the rule.

Select SDRS Rule field

Storage Options

By default, the option is checked. Uncheck if you do not
want to use local storage.

Use Local Storage check box
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DescriptionName

By default, the option is checked. Uncheck if you do not
want to use NFS storage.

Use NFS check box

By default, the option is checked. Uncheck if you do not
want to use SAN storage.

Use SAN check box

To add one more conditions to filter the datastores, do the
following for each desired condition:

• Check the appropriate box.

• Choose the desired option from the drop-down list.

• Enter the criteria by which you want to filter the
datastores.

Any datastores that do not meet these criteria are excluded
from consideration. If more than one condition is chosen,
all conditions must match.

Filter Conditions check boxes

Check to override the template properties. You are
provided with options to enter custom settings, such as
using thin provisioning or setting a custom disk size.

Override Template check box

Check to use thin provisioning during VM storage
provisioning.

Thin provisioning enables dynamic allocation of physical
storage capacity to increase VM storage utilization.

This option is available only if you choose Override
Template.

Use Thin Provisioning check box

Check to use a custom disk size that overrides the disk size
of the template used for VM provisioning.

This option is available only if you choose Override
Template.

Manual Disk Size check box

Resizing Options for VM Lifecycle

Check to provide the end user with an option to choose
the VM disk size before provisioning.

Allow Resizing of Disk check box
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DescriptionName

Specify the disk size values that can be chosen while
provisioning a VM.

You can specify these values in one of the following
formats:

• Range such as 10-1000

• Comma separated values such as 1, 5, 10, 50, 100,
500, 1024, 5120, 10240.

• Combination of range and comma separated values
such as 1,5,10, 10-1000.

This option is available only if you chooseAllowResizing
of Disk.

Permitted Values for Disk in GB field

Check to provide the end user with an option to choose
the datastore during the service request creation.

Allow user to select datastores from scope check box

If you use this storage policy for OVF deployment, then the deployed OVF VM is created without thin
provisioning.

Note

Step 5 Click Next.
Step 6 On the Additional Disk Policies screen, do one of the following:

• Expand Disk Policies to choose a disk type to configure if you do not want to use the same disk policy for that
disk type as you configured in the System Disk Policy.

• Click Next if you want to use the System Disk Policy options for all disk types.

By default, the disk policy for the disk is the same as in the System Disk Policy that you configured on the
Add Storage Resource Allocation Policy screen.

Note

Step 7 If you chose to configure a custom system disk policy for a specific disk type, do the following:
a) Click Edit to edit the disk type.
b) On the Edit Disk Policies Entry screen, uncheck Same As System Disk Policy.
c) On theEdit Entry screen, complete the fields.

All the fields displayed here are the same as the fields displayed on the Add Storage Resource Allocation Policy
screen.

This configuration determines which datastores are available for the disk type when you create a VM
disk.

Note

d) Click Submit.
e) Repeat these steps to configure the other disk types, if desired.

To use the storage policy created with additional disk policies, you must associate the policy with the VDC
that is used for the VM provisioning

Note

Step 8 Click Next.

Cisco UCS Director Administration Guide, Release 6.6
184

Managing Policies
Adding and Configuring a Storage Policy



Step 9 On theHard Disk Policy screen, specify the number of physical disks that you want to create during VM provisioning.
a) Expand Disks to add a disk by completing the following fields:

DescriptionField

Enter a descriptive label for the disk you are adding.Disk Label field

Enter the size of the disk.Disk Size (GB) field

Choose the disk type.

The options that you see in this drop-down list depends
on whether you checked Same as System Policy earlier
in this procedure.

Disk Type drop-down list

Controller Options

Choose a controller type from the drop-down list.

Based on the availability of ports, a controller is mapped
to the VM disks.

Controller Type drop-down list

Check this box to create a new controller.

The type of controller that is created is based on the
selection you made in the Controller Type drop-down
list.

Create Disk on new Controller check box

Disk Provisioning Options

Click the radio button of the type of provisioning you
want to specify. You can specify one of the following:

• Thin Provision

• Thick Provision lazy zeroed

• Thick Provision eager zeroed

Disk Provisioning Options radio buttons

Resizing Options for VM Lifecycle

Check to enable editing of the VM disk size before
provisioning.

Allow Resizing of Disk check box
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DescriptionField

Specify the disk size values that can be chosen while
provisioning a VM.

You can specify these values in one of the following
formats:

• Range such as 10-1000

• Comma separated values such as 1, 5, 10, 50, 100,
500, 1024, 5120, 10240.

• Combination of range and comma separated values
such as 1,5,10, 10-1000.

This option appears if Allow Resizing of Disk is
checked.

Permitted Values for Disk in GB field

Check to provide the user with an option to choose the
datastore during the service request creation.

Allow user to select datastores from scope check box

Step 10 Click Submit.

• If you use a storage policy for OVF deployment, then the deployed OVF VM is created without thin
provisioning.

• To use the storage policy created with additional disk policies, you need to associate the policy with the
VDC that is used for the VM provisioning.

• When using the Additional Disks Policies configured in a policy, make sure to uncheck Provision all
disks in a single database during catalog creation for the multiple disk template. For more information
about catalog creation, see Managing Catalogs, on page 257.

Note

Virtual Storage Catalogs
You can use a virtual storage catalog to customize storage policies. Using the virtual storage catalog, you can
choose more than one storage policy and give it a custom storage entry name.

Youmap a storage catalog to a catalog by enabling it during catalog creation.When you raise a service request
using the catalog, you are provided with the Storage Tier choice.

Configuring a Virtual Storage Catalog

Step 1 Choose Policies > Virtual/Hypervisor Policies > Storage.
Step 2 On the Storage page, click Virtual Storage Catalog.
Step 3 Click Add.
Step 4 On the Add Catalog screen, complete the following fields:
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DescriptionName

The name of the catalog.

This name is used during catalog custom actions definition.

Catalog Name field

The description of the catalog.Catalog Description field

Select the cloud account.Cloud Name drop-down list

Choose the number of entries. The range is from 1 to 10.
Depending on the choice, storage entry options are provided
in the subsequent dialog box.

Choose No of Entries drop-down list

Step 5 Click Next.
Step 6 On the Add Entries screen, complete the following fields:

DescriptionName

Storage Entry #1

The name of the storage entry.Storage Entry Name field

Choose the storage policy.Storage Policy drop-down list

Storage Entry # 2

The storage entry name of the second policy.Storage Entry Name field

Choose the storage policy.Storage Policy drop-down list

Step 7 Click Submit.

What to do next

• You can map the virtual storage catalog during catalog creation.

See Managing Catalogs.

• You can view the storage tier options during the Service request creation.

See Using Self-Service Provisioning.

Credential Policies
A policy comprises a set of rules that controls access to a system or network resource. A credential policy
defines password requirements and account lockouts for user accounts. Credential policies that are assigned
to user accounts control the authentication process in Cisco UCS Director. After you add a credential policy,
you can assign the new policy as the default policy for a credential type or to an individual application.
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Configuring a Credential Policy

Step 1 Choose Policies > Physical Infrastructure Policies > Credential Policies.
Step 2 On the Credential Policies page, click Credential Policies.
Step 3 Click Add.
Step 4 On the Add Credential Policy screen, check the check the account type.
Step 5 Click Select.
Step 6 On the Add Credential Policy screen, complete the required fields, including the following:

DescriptionName

A unique name for the policy.Policy Name field

A description for the policy.Description field

The user name for the account.Username field

The password for the user account.Password field

Select the protocol.Protocol drop-down list

The port number.Port field

The fields displayed in this screen vary depending on the type of account that you are creating the policy for.

Step 7 Click Submit.

At a later point in time, if you modify the credentials in this policy, the changes are automatically applied to accounts
configured with the policy. These changes are applied when Cisco UCS Director attempts to connect with these accounts.

Network Policies
The network policy includes resources such as network settings, DHCP or static IP, and the option to add
multiple vNICs for VMs provisioned using this policy.

Adding a Static IP Pool Policy
You can optionally configure a static IP pool policy that can be used with a network policy.

Step 1 Choose Policies > Virtual/Hypervisor Policies > Network.
Step 2 On the Network page, click Static IP Pool Policy.
Step 3 Click Add.
Step 4 On the Static IP Pool Policy Information screen, complete the following fields:
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DescriptionName

Name of the IP pool policy.Policy Name field

Description of the IP pool policy.Policy Description field

Indicate whether IP overlap is allowed or not. By default,
overlapping IP is not enabled.

Enabling overlapping of IP implies the following:

• You can create an IP pool and have IP addresses
overlap within that pool.

• You can create two static IP pools and have the IP
addresses overlap between the pools.

Allow IP Overlap drop-down list

The scope of the IP pool overlap.

The options are:

• MSP Organization

This option is visible only if you have enabled MSP.

• Group/Customer Organization

• Container

This option is visible only if you select Yes in
the Allow IP Overlap drop-down list.

Note

Scope drop-down list

Choose Select to check the user group for the policy. All
the user groups created in the system are displayed.

User Group ID field

Choose Select to check the container.Container ID field

Step 5 Expand the Static IP Pools section section and click (+) to add and configure multiple static IP pools.
Step 6 On the Add Entry to Static IP Pools screen, complete the following fields:

DescriptionName

The static IP pool.

For example: 10.5.0.1 - 10.5.0.50, 10.5.0.100, 10.5.1.20
-10.5.1.70.

Static IP Pool field

The subnetwork mask for the pool. For example:
255.255.255.0.

Subnet Mask field

The IP address of the default gateway for this network.Gateway IP Address field

The VLAN ID to be used for the network. Enter a valid
VLAN ID range.

VLAN ID field

Step 7 Click Submit.
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Step 8 Click Submit on the Static IP Pool Policy Informationscreen.

Configuring a IP Subnet Pool Policy

Step 1 Choose Policies > Virtual/Hypervisor Policies > Network.
Step 2 On the Network page, click IP Subnet Pool Policy.
Step 3 Click Add.
Step 4 On the IP Subnet Pool Policy Information screen, complete the following fields:

DescriptionField

The name of the policy.Policy Name field

The description of the policy.Policy Description field

The network supernet address.Network Supernet Address field

The network supernet mask.Network Supernet Mask field

Choose the number of subnets required for your
configuration.

Number of Subnets Required drop-down list

Choose a gateway address index:Gateway Address drop-down list

Indicate whether IP overlap is allowed or not. By default,
overlapping IP is not enabled.

Enabling overlapping of IP implies the following:

• You can create an IP pool and have IP addresses
overlap within that pool.

• You can create two IP subnet pools and have the IP
addresses overlap between the pools.

Allow IP Overlap drop-down list

The scope of the IP subnet pool overlap. The options are:

• MSP Organization

This option is visible only if you have enabled MSP.

• Group/Customer Organization

• Container

This option is visible only if you select Yes in
the Allow IP Overlap drop-down list.

Note

Scope drop-down list
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While creating a policy with overlapping IP enabled, you must first determine if there are any other IP subnet
pool policies created with the same IP range. If those other policies also have overlapping IP enabled, then you
can create an additional policy with no errors. However, if a previously created IP subnet pool policy, which
uses the same IP range that you want to specify for the policy you are creating, does not have overlapping IP
enabled, then you cannot proceed. The same behavior holds true in the case of creating a policy without enabling
overlapping IP.

While creating this policy without enabling overlapping IP, you must first determine if there are any other
policies that are created with the same IP range. If previously created pool policies have overlapping IP enabled,
then you cannot specify the same IP range to create another policy with overlapping IP disabled.

Important

Step 5 Click Submit.

Adding a Network Policy

Step 1 Choose Policies > Virtual/Hypervisor Policies > Network.
Step 2 On the Network page, click VMware Network Policy.
Step 3 Click Add.
Step 4 On the Network Policy Information screen, complete the following fields:

DescriptionName

The name of the network policy.Policy Name field

The description of the network policy.Policy Description field

Choose the cloud account to which the policy applies.Cloud Name drop-down list

Check if you want to provide vNICs selection during the
creation of a service request-deployment configuration.

Allow end user to select optional NICs check box

Expand the VMNetworks table to add a new entry to the
VM network.

VM Networks field

Step 5 Click Add in the VM Networks section to add and configure multiple vNICs. These vNICs are applicable to the VM
that is provisioned using this policy.

To add or replace vNICs for provisioned or discovered VMs using VM actions, you must configure the vNICs.Note

Step 6 On the Add Entry to VM Networks screen, complete the following fields:

DescriptionName

The name for the new NICNIC Alias field
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DescriptionName

If Allow end user to select optional NICs is checked on
the Network Policy Information screen, this box is
pre-selected. If theAllow end user to select optional NICs
box was not checked, and this check box is not selected,
then the NIC Alias field is optional.

At least one of the NICs should have the
Mandatory option selected. TheNICs that have
theMandatory option selected are used in VM
provisioning and there will be no option for the
user during VM service request creation.

Note

Mandatory check box

Check to allow the end user to choose port groups during
provisioning.

Allow end user to choose portgroups check box

Checking this check box along with the Allow end user
to choose portgroups check box lists all the selected
portgroups of NICs in the policy.

Show policy level portgroups check box

Check if you do not need custom settings. Clear this check
box for custom settings.

TheAdapter Type drop-down list is not visible when you
check this check box.

Copy Adapter from Template check box

Check to allow users to override the IP address.Allow the end user to override IP Address check box

Choose the adapter type. Select this option if the user wants
to have the same Adapter Type that is available in the
template.

This option is not visible if the Copy Adapter
from Template option is chosen.

Note

Adapter Type drop-down list

Step 7 Click Add (+) in the Port Groups section. The Add Entry to Port Groups screen appears.
Step 8 Click Select to choose the port group name.
Step 9 From the Select IP Address Type drop-down field, choose DHCP (default) or Static.

a) If you choose Static, you must choose IP Pool Policy (default) or Inline IP Pool.

If you choose IP Pool Policy, click Select to choose a static IP pool. On the Select screen, choose from the list
of preconfigured static IP pool(s). If no preconfigured static IP pools exist, see Adding a Static IP Policy for more
information.

b) If you choose Inline IP Pool, complete the following fields:

DescriptionName

The static IP pool. For example: 10.5.0.1 - 10.5.0.50,
10.5.0.100, 10.5.1.20-10.5.1.70

Static IP Pool field

The subnetwork mask for the pool. For example:
255.255.255.0

Subnet Mask field
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DescriptionName

The IP address of the default gateway for this network.Gateway IP Address field

Indicate whether IP overlap is allowed or not. By default,
overlapping IP is not enabled.

Enabling overlapping of IP implies the following:

• You can create an IP pool and have IP addresses
overlap within that pool.

• You can create two static IP pools and have the IP
addresses overlap between the pools

Allow IP Overlap drop-down list

The scope of the IP pool overlap. The options are:

• MSP Organization

This option is visible only if you have enabledMSP.

• Group/Customer Organization

• Container

This option is visible only if you select Yes
in the Allow IP Overlap drop-down list.

Note

Scope drop-down list

Choose Select to check the user group. All the user
groups created in the system are displayed.

User Group ID field

Choose Select to check the container.Container ID field

Step 10 Check IPv6 to configure IPv6.

You must configure the identical fields that you specified for IPv4 configuration.

Step 11 Click Submit.
Step 12 Click Submit on the Add Entry to VM Networks screen.
Step 13 Click Submit on the Network Policy Information screen.

Networking Provisioning Policies
A network provisioning policy is used during orchestration workflow tasks. This policy defines Layer 2
network configuration and access control lists (ACLs) for switches in the network.

Configuring a Network Provisioning Policy

Step 1 Choose Policies > Virtual/Hypervisor Policies > Network.
Step 2 On the Network page, click Network Provisioning Policy.
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Step 3 Click Add.
Step 4 On the Add Policy screen, complete the following fields:

DescriptionName

General Information

The name of the policy.Policy Name field

The description of the policy.Policy Description field

L2 Network Configuration VLAN

If checked, the following fields are automatically populated:

• Private VLAN Type: community

• Primary VLAN ID: 0

• Secondary VLAN Range—Starting ID 500

• Secondary VLAN Range—Ending ID 1000

Use Private VLAN check box

A starting ID for the VLAN range. 500 is the default ID
start range.

VLAN Range - Starting ID field

An ending ID for the VLAN range. 1000 is the default ID
end range.

VLAN Range - Ending ID field

The VLAN base profile name. This is the profile that
contains one or more nested profile assignments.

Base Profile Name field

Access Control List

By default, it is set to Simple. This is the only option
available currently.

ACL Type drop-down list

Check to allow ICMP on the VLAN.Allow ICMP check box

The following options are available:

• FTP

• SSH

• Telnet

• SMTP

• POP3

• HTTP

• HTTPS

• MySQL

Permit Incoming Traffic to TCP Ports field

Cisco UCS Director Administration Guide, Release 6.6
194

Managing Policies
Configuring a Network Provisioning Policy



DescriptionName

The following options are available:

• SNMP

• Syslog

Permit Incoming Traffic to UDP Ports field

Step 5 Click Submit.

VLAN Pool Policies
A VLAN pool policy defines the VLAN range for a pod. This policy is used in the orchestration workflow
for generating a free VLAN ID from the defined range specified in the policy.

Configuring a VLAN Pool Policy

Step 1 Choose Policies > Virtual/Hypervisor Policies > Network.
Step 2 On the Network page, click VLAN Pool Policy.
Step 3 Click Add.
Step 4 On the Add Policy screen, complete the following fields:

DescriptionName

Allows you to choose the pod.Pod drop-down list

The policy name. This policy name is used in orchestration
workflows.

Policy Name field

The description of the policy.Policy Description field

The VLAN range. For example: 1,3, 5—15.VLAN Range field

Step 5 Click Submit.

System Policies
A system policy defines system-specific information, such as the template to use, time zone, OS-specific
information, and so on.
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Configuring a System Policy

When you use the system policy to provision virtual machines by deploying an OVF, enter only the VM
Name Template and the Host Name Template fields. The remaining fields in the system policy are not
applicable.

Note

Step 1 Choose Policies > Virtual/Hypervisor Policies > Service Delivery.
Step 2 On the Service Delivery page, click VMware System Policy.
Step 3 Click Add.
Step 4 On the System Policy Information screen, complete the following fields:

DescriptionName

The name of the policy. This name is used during catalog
definition.

Policy Name field

The description of the policy.Policy Description field

The VM name template to use.

Cisco UCS Director allows automatic creation of VM
names. VM names can be automatically created using a set
of variable names. Each variable must be enclosed in
${VARIABLE_NAME}. For example:
vm-${GROUP_NAME}-SR${SR_ID}.

VM Name Template field

Check to disable the VM name uniqueness check when the
VM is provisioned.

Disabling the VM name uniqueness check allows you to
disable the VM name validation across Cisco UCSDirector
and use the same VM name in a multi-tenant and
multi-domain environment.

If this field is unchecked, the VM name uniqueness check
runs and only allows the same VM name if it is provisioned
in a different folder or datacenter.

Disable VM Name Uniqueness Check check box

Allows you to choose a VM name validation policy. This
list is populated with the policies that you created
previously.

VM Name Validation Policy drop-down list

Step 5 Choose from the following optional VM Name Template features:

DescriptionName

Check to allow the user to add a VM name or VM prefix
during a service request creation for VM provisioning.

End User VM Name or VM Prefix check box
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DescriptionName

Check to automatically power on all VMs deployed using
this policy.

Power On after deploy check box

The VM hostnames that can be automatically created using
set of variable names. Each variable must be enclosed in
${VARIABLE}.

Host Name Template field

Check to disable the host name uniqueness check when the
VM is provisioned with guest OS customizations.

Disabling the host name uniqueness check allows you to
disable the host name validation across Cisco UCSDirector
and use the same host name in a multi-tenant and
multi-domain environment.

If this field is unchecked, the host name uniqueness check
runs and only allows the same host name if the VM is going
to be provisioned in a different tenant, domain, or
workgroup.

Disable Host Name Uniqueness Check check box

Choose a host name validation policy. This list is populated
with the policies that you created earlier on.

Host Name Validation Policy drop-down list

Step 6 Complete the following fields:

DescriptionName

Choose the time zone.Linux Time Zone drop-down list

Choose the maximum waiting period for the Linux VM to
boot.

Linux VMMax Boot Wait Time drop-down list

The IP domain to use for the VM.DNS Domain field

The DNS suffixes to configure for the DNS lookup. Use
commas to separate multiple entries.

DNS Suffix List field

The list of DNS server IP addresses. Use commas to
separate multiple entries.

DNS Server List field

Choose the OS of the image that is installed on the VM.
You can choose between:

• Windows and Linux

• Linux Only

VM Image Type drop-down list

Windows

The Windows product ID or license key. The product ID
or license key can be provided here or at the OS license
pool. The key entered in the OS license pool overrides the
key provided here.

Product ID field
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DescriptionName

The Windows license owner name.License Owner Name field

The organization name to configure in the VM.Organization field

Choose per-seat or per-server.License Mode drop-down list

The number of license users or connections.Number of License Users

The WINS server IP addresses. Use commas to separate
multiple entries.

WINS Server List field

Choose the maximumwaiting period for the Windows VM
to boot.

Windows VMMax Boot Wait Time drop-down list

Check to create a unique SID for the system.Create a unique SID check box

Check to enable auto logon.Auto Logon check box

The number of times to perform auto logon.Auto Logon Count field

The password for the administrator's account.Administrator Password field

Choose the time zone that must be set for theWindows VM.Windows Time Zone drop-down list

Choose either Domain orWorkgroup.Domain/Workgroup drop-down list

The name for the workgroup.

This option appears ifWorkgroup is chosen as the value
in the Domain/Workgroup drop-down list.

Workgroup field

The name of the Windows domain.

This option appears if Domain is chosen as the
value in the Domain/Workgroup drop-down
list.

Note

Domain field

The Windows domain administrator’s username.

This option appears if Domain is chosen as the
value in the Domain/Workgroup drop-down
list.

Note

Domain Username field

The Windows domain administrator’s password.

This option appears if Domain is chosen as the
value in the Domain/Workgroup drop-down
list.

Note

Domain Password field
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DescriptionName

Define VM Annotation check box
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DescriptionName

Check to specify annotations to the VM.

You can specify a note and custom attributes as part of the
annotation. After you select this check box, complete the
following fields:

• VM Annotation field

Enter a description for the VM.

• Custom Attributes

Click Add (+) to specify the Name, Type, and Value.

Following are some of theCustomAttributes that you can
add:

• ${VM_HOSTNAME}

• ${VM_HOSTNAME_SHORT}

• ${VM_HOSTNAME_DOMAIN}

• ${VM_IPADDRESS}

• ${VM_ID}

• ${VM_NAME}

• ${VM_STATE}

• ${VM_STATE_DETAILS}

• ${VM_PARENT}

• ${VM_CLOUD}

• ${VM_GROUP_NAME}

• ${VM_GROUP_ID}

• ${VM_VDC_NAME}

• ${VM_VDC_ID}

• ${VM_SR_ID}

• ${VM_SCHED_TERM}

• ${VM_TYPE}

• ${VM_COMMENTS}

• ${VM_CATALOG_ID}

• ${ INITIATING_USER}

• ${SUBMITTER_EMAIL}

• ${SUBMITTER_FIRSTNAME}
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DescriptionName

• ${SUBMITTER_LASTNAME}

• ${SUBMITTER_GROUPNAME}

• Variables for VM creation:

• ${SR_ID}

• ${GROUP_NAME}

• ${USER}

• ${APPCODE}

• ${COST_CENTER}

• ${UNIQUE_ID}

• ${LOCATION}

• ${PROFILE_NAME}

• ${COMMENTS}

• ${CATALOG_NAME}

• ${CLOUD_NAME}

The information that you add as part of the VM
Annotation is displayed for the VM in the VM
Details page.

Note

Step 7 Click Submit.

OS Licenses
Cisco UCS Director provides an option for users to add Windows OS licenses. These licenses are mapped to
Windows images during the creation of a catalog. You have an option to provide the Windows OS license
for a Windows image in VMware System Policy or choose the key from the OS version field during catalog
creation.

Adding an OS License

Step 1 Choose Policies > Virtual/Hypervisor Policies > Service Delivery.
Step 2 On the Service Delivery page, click OS License.
Step 3 Click Add.
Step 4 On the Add License Details screen, complete the following fields:
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DescriptionName

The Windows version name.Windows Version Name field

The Windows product ID or license key. This field accepts
KMS client set-up keys.

License field

The Windows license owner name.License Owner Name field

The organization name to configure in the VM.Organization field

Allows you to choose per-seat or per-server.License Mode drop-down list

The number of license users or connections.Number of Licensed Users field

Step 5 Click Submit.

End User Self-Service Policy
An End User Self-Service Policy controls the actions or tasks that a user can perform on a VDC. The starting
point for creating this policy is to specify an account type (for example, VMware). After you specify an
account type, you can continue with creating the policy. After you create the policy, you must assign the
policy to a vDC that is created with the same account type. For example, if you have created an end user
policy for VMware, then you can specify this policy when you create a VMware vDC. You cannot view or
assign policies that have been created for other account types.

In addition to creating an end user self-service policy, Cisco UCSDirector allows you to perform the following
tasks:

• View—Displays a summary of the policy.

• Edit—Opens the End User Policy screen from which you can modify the description or the end user
self-service options.

• Clone—Opens the End User Policy screen through which you can create an additional policy using the
parameters defined in an existing end user self-service policy.

• Delete—Deletes the policy from the system. You cannot delete a policy that has a VDC assigned to it.

The tasks that a user can perform on a VDC are defined by the role that the user is mapped to and by the end
user self-service policy assigned to the VDC. If you have upgraded to the current release, then the permissions
to perform VM management tasks are retained in any pre-existing end user self-service policy. However, the
permissions defined in the user role to which the user belongs takes precedence.

Important
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Creating an End User Policy

Step 1 Choose Policies > Virtual/Hypervisor Policies > Service Delivery.
Step 2 On the Service Delivery page, click End User Self-Service Policy.
Step 3 Click Add.
Step 4 On the Add End User Policy screen, select an account type from the drop-down list.
Step 5 Click Submit.
Step 6 On the End User Policy screen, complete the following fields:

DescriptionName

The name of the policy.Policy Name field

The description for the policy.Policy Description field

A list of tasks that a user can perform on a VDC that is
assigned with this policy.

The list of tasks varies according to the Account Type.

End User Self-Service Options field

Step 7 Click Submit.

What to do next

Assign this end-user policy to a VDC. For more information, see Adding a Virtual Data Center, on page 207.

Configuring a VM Management Policy
This policy defines how VMs are managed in the VDC.

Step 1 Choose Policies > Virtual/Hypervisor Policies > Service Delivery.
Step 2 On the Service Delivery page, click VMManagement Policy.
Step 3 Click Add.
Step 4 On the Add VMManagement Policy screen, complete the following fields:

DescriptionField

A unique name for the policy.Policy Name field

A description for the policy.Policy Description field

VM Lease Expiry Notification Settings

Check to set notification parameters for VMs configured
with lease time.

Configure VM Lease Notification check box
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DescriptionField

Enter a number.

This number indicates the number of days prior to VM lease
expiry that an email notification is sent to the VM owner.

How many days before VM Lease expiry should
notifications be sent field

Enter a number.

This number indicates the number of email notifications
that will be sent informing the user of the VM lease
expiration.

How many notifications should be sent field

Choose a number from the drop-down list.

This number defines the time gap or interval between the
notification emails that are sent.

Interval between notifications drop-down list

Inactive VMManagement Settings

Enter a number.

This number indicates the number of days after which an
inactive VM is deleted from the system.

Inactive VMs are deleted only if the Delete
Inactive VMs Based on vDC Policy option is
selected in the Properties pane. This option is
displayed when you select Administration >
System > Advanced Controls.

Note

Delete after inactive VM days field

Enter a number.

This number indicates the number of days that the system
waits before deleting an inactive VM from the system.

When the time period specified in the Delete
after inactive VM days and Additional grace
period for deleting expired VMs fields elapse,
VMs discovered through Cisco UCS Director
are deleted, and service requests for VMs
provisioned through Cisco UCS Director are
rolled back. A new email template for rolled back
Service Requests (SR) for these
system—provisioned VMs has been introduced.

Note

Additional grace period for deleting expired VMs field
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DescriptionField

Select an action to be taken when a service request (SR)
roll back task fails for VMs provisioned through Cisco UCS
Director. You can choose one of the following options:

• Send notification and delete the VM

• Send notification and do not delete the VM

In the VM Automatic Deletion email template,
a new field titled Rollback SR ID has been
introduced. This field is populated for VMs
provisioned through Cisco UCS Director and is
blank for VMs discovered through Cisco UCS
Director.

Note

Action to be takenwhen a service request (SR) roll back
task fails for VMs provisioned through Cisco UCS
Director drop-down list

Check to set notification parameters for VMs that are to be
deleted.

Configure VM Delete Notification check box

Enter a number.

This number indicates the number of days prior to VM
deletion that an email notification is sent to the user.

Howmany days before VMdeletion should notifications
be sent field

Enter a number.

This number indicates the number of notification emails
that are sent to the user.

How many notifications should be sent field

Choose a number from the drop-down list.

This number defines the time gap or interval between the
notification emails that are sent.

Interval between notifications drop-down list

Step 5 Click Submit.

What to do next

You can map this policy to a virtual data center.
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C H A P T E R 10
Managing Virtual Data Centers

This chapter contains the following sections:

• Virtual Data Centers, on page 207
• VDC Actions, on page 207
• Virtual Data Center Service Profiles, on page 212

Virtual Data Centers
A Virtual Data Center (VDC) is a logical grouping that combines virtual resources, operational details, rules,
and policies to manage specific group requirements.

A group or organization can manage multiple VDCs, images, templates, and policies. Organizations can
allocate quotas and assign resource limits for individual groups at the VDC level.

You can also define approvers specific to a VDC. The approvers assigned to a particular VDC must approve
all service requests from users for VM provisioning.

There is a default VDC in Cisco UCSDirector, and all discovered VMs are part of this default VDC. Discovered
VMs are VMs that are created outside of Cisco UCS Director or were already created on VMware vCenter
before Cisco UCS Director was installed. Cisco UCS Director automatically discovers such VMs and adds
them to the default VDC.

Note

A VM that is provisioned using a service request can be associated with a specific VDC. When you create a
service request, you can choose the VDC on which this VM is provisioned. You can view a list of the VDCs
that are available for a particular group and choose the required VDC when provisioning VMs.

VDC Actions

Adding a Virtual Data Center

Step 1 Choose Policies > Virtual/Hypervisor Policies > Virtual Data Centers.
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Step 2 On the Virtual Data Centers page, click vDC.
Step 3 Click Add.
Step 4 On the VDC Add screen, select an account type from the drop-down list.

The account type that you select determines the list of cloud names that are displayed on the Add VDC screen.

Step 5 Click Submit.
Step 6 On the Add VDC screen, complete the following fields:

DescriptionName

The name of the VDC.

You can include special characters such as ( ). & - _ `~ $%
^ {}! ' @

A name cannot be edited after it is entered.Note

VDC Name field

Check the check box to deny the use of the VDC for any
further deployments. Uncheck the check box to allow the
use of the VDC for further deployments.

VDC Locked check box

The VDC-specific description.VDC Description field

Click Select to check the check box of the group for which
the VDC is being set up.

Group drop-down list

Choose the cloud on which the VDC is being set up.

The options available in this drop-down list are determined
by the account type you specified.

Cloud Name drop-down list

Approvers and Contacts

First Level Approver(s)

Check this check box to select the groups of users that need
to approve the service request at the first level.

Approval required from Groups check box

Click Select to check the check boxes of the user groups.
You can select multiple groups.

This field is displayed only when you have
checked the Approval required from Groups
check box.

Note

User Group

The users who must approve the service request at the first
level.

Click Select and check the check boxes of the users. You
can select multiple users.

This field is displayed when you have not
checked the Approval required from Groups
check box.

Note

User field
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DescriptionName

Second Level Approver(s) field

Check this check box to select the groups of users that need
to approve the service request at the second level.

Approval Required from Groups

Click Select to check the check boxes of the user groups.
You can select multiple groups.

This field is displayed only when you have
checked the Approval required from Groups
check box.

Note

User Group

The users who must approve the service request at the
second level.

Click Select and check the check boxes of the users. You
can select multiple users.

This field is displayed when you have not
checked the Approval required from Groups
check box.

Note

User field

Check this check box to indicate that approval is required
from all users who have been selected as first-level and
second-level approvers.

Approval Required from all users check box

The number of times the reminder email to approve the
service request is sent to the approvers.

By default, the system sends a reminder email once in every
24 hours until the service request is approved or rejected.

Number of Approval Requests Reminders field

The time interval between the reminder emails that are sent
to the approvers.

By default, the system sends a reminder email every 24
hours.

Reminder Interval (Hours) field

The contact or user’s email address. The person who is
notified about VM provisioning using this VDC.

Provider Support Email Address field

The second contact’s email address for copying notifications
about this VDC.

Copy Notifications to Email Address field

Policies

Choose the system policy applicable to the VDC.System Policy drop-down list

Choose the computing policy applicable to the VDC.Computing Policy drop-down list

Choose the network policy applicable to the VDC.Network Policy drop-down list

Choose the storage policy applicable to the VDC.Storage Policy drop-down list
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DescriptionName

Choose the ISO image mapping policy applicable to the
VDC.

ISO Image Mapping Policy drop-down list

Choose the cost model applicable to the VDC.Cost Model drop-down list

Check the check box to disable displaying cost details in
the following pages for this VDC:

• Create Service Request wizard

The cost information is not displayed in the
Deployment Configuration pane, Custom
Specification pane and the Summary pane.

• Specific VM action pages - VM resize, Resize VM
disk, and Create VM disk.

• Email notifications

Disable displaying cost details check box

Choose the policy that is used for execution of orchestration
workflow post provisioning of the VMs. The chosen
workflow appears as an action button for VMs within the
VDC.

User Action Policy drop-down list

Choose the VM management policy for the VDC.

This policy defines how VMs are managed in the VDC.

VMManagement Policy drop-down list

Check the check box to clone the VM using RCU.

This option is only available for some VDC types.

Enable Storage Efficiency check box

Select a self-service policy for the VDC. The policy defines
the tasks or actions that can be performed on the VDC.

This drop-down list is populated with policies
that are relevant to the account type that you are
creating the VDC for.

The tasks that a user can perform on a VDC are
defined by the role that the user is mapped to and
by the end user self-service policy assigned to
the VDC. If you have upgraded to the current
release, then the permissions to perform VM
management tasks are retained in any
pre-existing end user self-service policy.
However, the permissions defined in the user
role to which the user belongs takes precedence.

Note

End User Self-Service Policy

Step 7 Click Add.
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The following tasks can no longer be performed by users on a VM:

• Migrate a VM

• Use Stack View

• Assign a VM

Note

What to do next

After adding a VDC, you can edit, clone, or delete it by selecting the respective option in the user interface.

Viewing a Virtual Data Center

Step 1 Choose Policies > Virtual/Hypervisor Policies > Virtual Data Centers.
Step 2 On the Virtual Data Centers page, choose the VDC group.
Step 3 On the Virtual Data Centers page, click vDC.
Step 4 Click the row with the VDC that you want to view.
Step 5 Click View to open the VDC Details screen.

Managing Application Categories in a Virtual Data Centers

Step 1 Choose Policies > Virtual/Hypervisor Policies > Virtual Data Centers.
Step 2 On the Virtual Data Centers page, choose the VDC group.
Step 3 On the Virtual Data Centers page, click vDC.
Step 4 Click the row with the VDC that you want to edit.
Step 5 ClickManage Categories.
Step 6 On the Edit App Category screen, edit the appropriate fields that apply to modify the system policy, computing policy,

network policy, or storage policy. You can also change the cost model and the smart allocation policy.
Step 7 Click Save.

Assigning an Application Category to Multiple VDCs
You can assign application categories to multiple VDCs.

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click Application Categories.
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Step 4 Click the row with the application category that you want to assign to one or more VDCs.
Step 5 Click Assign App Category.
Step 6 On the Assign Application Category screen, click + to map policies to multiple VDCs.

TheAssign Application Category screen lists all the application categories that have been previously assigned to VDCs.
You can select an assigned application category, and either edit it or delete it from the VDC.

Step 7 On the Add Entry to Map Policies to Multiple VDCs screen, complete the following fields:

DescriptionName

Policies

Choose a system policy from the drop-down list.System Policy drop-down list

Choose a computing policy from the drop-down list.Computing Policy drop-down list

Choose a storage policy from the drop-down list.Storage Policy drop-down list

Choose a smart allocation policy from the drop-down list.Smart Allocation Policy drop-down list

Choose a network policy from the drop-down list.Network Policy drop-down list

Choose a cost model from the drop-down list.

All cost models for the cloud are displayed in this
drop-down list.

Cost Model drop-down list

VDC

Click Select to check the check boxes of the VDCs that you
want to map the policies to.

The system displays VDCs that are part of the
cloud you selected.

If the VDC you selected has policies mapped to
it previously, a warning message is displayed.

Note

Select VDCs field

Check this check box to overwrite policies that have been
previously mapped to the VDC you selected.

Overwrite policies for mapped VDCs check box

Step 8 Click Submit.
Step 9 On the Assign Application Category screen, click Submit.

Virtual Data Center Service Profiles
A Virtual Data Center Service Profile is similar to a VDC. However, you only need to create a VDC service
profile if you plan to create VDCs from workflow tasks, such as Gold, Silver, and Bronze VDCs.
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Adding a Virtual Data Center Service Profile

Step 1 Choose Policies > Virtual/Hypervisor Policies > Virtual Data Centers.
Step 2 On the Virtual Data Centers page, click vDC Service Profiles.
Step 3 Click Add.
Step 4 On the Add VDC Service Profile screen, complete the following fields:

DescriptionName

The name of the VDC profile.

A name cannot be edited after it is entered.

VDC Profile Name field

Check the check box to deny the use of the VDC for any
further deployments. Actions on existing VMs, within this
VDC, are disabled. Uncheck the check box to allow the use
of the VDC for further deployments.

VDC Locked check box

The VDC-specific description.VDC Description field

Choose the group for which the VDC is being set up.Group drop-down list

Choose the cloud on which the VDC is being set up.Cloud Name drop-down list

Approvers and Contacts

The users who must approve the service request at the first
level.

Click Select and check the check boxes of the users. You
can select multiple users.

First Approver User Name field

The users who must approve the service request at the
second level.

Click Select and check the check boxes of the users. You
can select multiple users.

Second Approver User Name field

Check this check box to indicate that approval is required
from all users who have been selected as first-level and
second-level approvers.

Approval Required from all users check box

The number of times the reminder email to approve the
service request is sent to the approvers.

By default, the system sends a reminder email once in every
24 hours until the service request is approved or rejected.

Number of Approval Requests Reminders field

The time interval between the reminder emails that is sent
to the approvers.

By default, the system sends a reminder email every 24
hours.

Reminder Interval (Hours) field
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DescriptionName

The contact or user’s email address. The person who is
notified about VM provisioning using this VDC.

Provider Support Email Address field

The second contact’s email for copying notifications about
this VDC.

Copy Notifications to Email Address field

Policies

Choose the system policy applicable to the VDC service
profile.

System Policy drop-down list

Choose the computing policy applicable to the VDC service
profile.

Computing Policy drop-down list

Choose the network policy applicable to the VDC service
profile.

Network Policy drop-down list

Choose the storage policy applicable to the VDC service
profile.

Storage Policy drop-down list

Choose the cost model applicable to the VDC service
profile.

Cost Model drop-down list

Check the check box to disable displaying cost in the SR
summary and email page for this VDC service profile.

Disable displaying cost in the SR summary and email
page check box

Choose the policy that is used for execution of orchestration
workflow after provisioning of the VMs. The chosen
workflow appears as an action button for VMs within the
VDC.

User Action Policy drop-down list

End User Self-Service Options

Check the check box to enable all VM power management
actions for VMs that belong to this VDC.

VM Power Management check box

Check the check box to enable the VM resize action for
VMs that belong to this VDC.

VM Resize check box

Check the check box to enable all storage snapshot actions
for VMs in this VDC.

VM Snapshot Management check box

Check the check box to enable the VM delete action for
VMs in this VDC.

VM Deletion check box

Check the check box to enable the VM disk management
for VMs in this VDC.

VM Disk Management check box

Check the check box to enable network management for
the VM that belongs to this VDC.

VM Network Management check box
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DescriptionName

Choose the number of days to wait before deleting an
inactive VM. The VM in the inactive state is when it is not
in the power-on state.

Delete after Inactive VM days drop-down list

Step 5 Click Add.
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C H A P T E R 11
Managing Resource Groups

This chapter contains the following sections:

• Resource Groups, on page 217
• Tenant, on page 239
• Service Offerings, on page 239
• Tenant Profiles, on page 249

Resource Groups
You can use a resource group to select the appropriate resources for a tenant based on the requirements of an
application. Additional concepts, such as a service offering, tenant profile, application profile, and resource
group, are all required. Using these resource group concepts, you can onboard tenants and deploy applications
based on a dynamic selection of resources. You can share resources in a resource group across tenants or you
can dedicate them to a specific tenant.

A resource group is a pool of resources. Each group can contain physical infrastructure resources, virtual
infrastructure resources, or a combination of physical and virtual infrastructure resources. Resource groups
enable you to onboard tenants into Cisco UCS Director with minimum intervention.

As an infrastructure administrator or system administrator, you can add physical or virtual accounts to a
resource group one at a time. Also, you can assign a pod to a resource group where all the accounts in the pod
are added to the resource group. For more information about assigning a pod to a resource group, see Adding
a Pod to a Resource Group, on page 236.

When an account is added to a resource group, the resource group by default announces all the capabilities
and capacities for objects for that account as resource group entity capacities and capabilities. With Cisco
UCS Director, you can selectively disable certain capacities or capabilities from the resource group.

Environment Variables
You can configure the environment variable for each resource. These environment variables are used during
provisioning of the tenant onboarding and application deployment.

You can set the following default environment variables for both virtual and physical accounts. Also, you can
add an environment variable in Cisco UCS Director and use the environment variable in the resource group.
For more information on how to add an environment variable, see Adding a Custom Environment Variable,
on page 226.

Cisco UCS Director Administration Guide, Release 6.6
217



The listed environment variables are not required for every workflow. The subset of required environment
variables depends on the use case and the specific workflow(s) being executed.

Note

Virtual Compute Environment Variables

Sample ValueDescriptionEnvironment Variable

APICThe folder to which you want to add the
newly created container.

Container Parent Folder

IP-PoolTheAPIC container uses an IP subnet pool
policy that is defined in Cisco UCS
Director. Each tier inside the container gets
a unique subnet address from the IP subnet
pool policy. This environment variable is
used for container provisioning.

IP Subnet Pool Policy

Virtual Storage Environment Variables

No environment variables are required for virtual storage.

Virtual Network Environment Variables

Sample ValueDescriptionEnvironment Variable

ACI-Bldg4-1-vCenterVMware vCenter is configured
ACI-vCenter with the Virtual
MachineManager (VMM) domain.
When VMware vCenter is
associated with Cisco APIC, a
distributed virtual switch (DVS)
with the same name is created in
VMware vCenter. This
environment variable is used for
tenant onboarding.

Choose VMM domain with Cisco
AV switch to support AVS in
VXLAN mode.

Cisco UCS Director offers AVS
support in both VLAN and
VXLAN mode. The VM gets the
VLAN ID or VXLAN ID from the
pool assigned to the VMMdomain.

VMM Domain for VMware
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Sample ValueDescriptionEnvironment Variable

virt_switchChoose either DV switch or Cisco
AV switch according to the
requirement.

The DV switch is available on the
vCenter account and is used to
connect the selected host during
onboarding.

The Cisco AV switch is used to
support AVS in VXLAN mode.

This environment variable is used
for tenant onboarding.

DV Switch

Physical Compute Environment Variables

Sample ValueDescriptionEnvironment Variable

PhysThe physical domain for Cisco
UCS. This environment variable is
used for bare metal provisioning.

Physical Domain for UCS

ACI3-Eng-VLAN-PoolThe VLAN pool from which you
want to assign a VLAN ID for the
account.

VLAN Pool

DR_UCSM;org-root;org-root/l
s-ACI-DR-Hosts

The template used for creating the
host service profile on which you
want to provision bare metal. This
environment variable is used for
bare metal provisioning on a
NetApp storage system.

iSCSI PXE Boot Service Profile
Template

VNX_UCSM;org-root/ls-PSC-
FullBlade-Template

The service profile template is used
to create a service profile. When a
service profile is created, the
software identifies and selects free
servers from the server pool that is
associated with the service profile
template. This environment
variable is used for the VNX tenant
onboarding.

Service Profile Template for Full
Width Blade
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Sample ValueDescriptionEnvironment Variable

VNX_UCSM;org-root/ls-PSC-
HalfBlade-Template

The service profile template is used
to create a service profile. When a
service profile is created, the
software identifies and selects free
servers from the server pool that is
associated with the service profile
template. This environment
variable is used for the VNX tenant
onboarding.

Service Profile Template for Half
Width Blade

IQN_PoolThe IQN pool that contains the
iSCSI Qualified Names (IQNs)
used as initiator identifiers by
iSCSI vNICs in a Cisco UCS
domain. The IQN pool is used to
create a service profile iSCSI boot
policy. This environment variable
is used for bare metal provisioning
on a NetApp storage system.

IQN Pool

VNX_UCSM;org-root;org-root//
boot-policy-SAN_NEW

Boot policy for the physical
compute account. This environment
variable is used for a VNX-type
account.

Boot Policy

VNX_UCSM;fabric/lan/net-MGT
-ACI-POOL

VLAN for the physical compute
account. This environment variable
is used for a VNX-type account.

VLAN

Physical Storage Environment Variables

Sample ValueDescriptionEnvironment Variable

topology/pod-1/paths-201/pathep-
[eth1/36]

• Pod-1—The pod ID of the
APIC account.

• Paths-201—The node ID of
the leaf to which the NetApp
controller is connected.

• Pathep-[eth1/36]—The port
on which the NetApp
controller is connected.

The physical domain that is used to
connect the NetApp account to the
APIC. This environment variable
is used for tenant onboarding.

Physical Domain for NetApp
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Sample ValueDescriptionEnvironment Variable

topology/pod-1/node-302/sys
/cdp/inst/if-[eth1/47]adj-1

The static path defines the port on
the APICwhere the NetApp cluster
node is connected. This
environment variable is used to add
the static path to the endpoint group
(EPG) during tenant onboarding.

NetApp Static Path

Vlan_poolThe VLAN pool that is used to
create the cluster vServer. This
environment variable is used for
tenant onboarding.

Vlan pool

VNX-POD;VNX_BLOCK;A-
0;50:06:01:60:88:60:1B:6A:
50:06:01:60:08:60:1B:6A
,VNX-POD;VNX_BLOCK;A-
1;50:06:01:60:88:60:1B:6A:
50:06:01:61:08:60:1B:6A

The storage processor (SP) port for
the physical storage account. This
environment variable is used for
VNX type account.

SP Port

The replication storage group for
the physical storage account. This
environment variable is used for
VNX type account.

Replication Storage Group

NetApp-vlan-poolThis environment variable is used
to define a VLAN pool. Individual
VLANs are then assigned to a
physical storage account
dynamically from the pool.

NFS Vlan Pool

NetApp-vlan-poolThe VLAN pool for management
of Storage VirtualMachine (SVM).

SVM mgmt Vlan Pool

NetApp-vlan-poolThe VLAN pool from which a
VLAN is chosen as iSCSI_A
VLAN.

iSCSI_A VLAN Pool

NetApp-vlan-poolThe VLAN pool from which a
VLAN is chosen as iSCSI_B
VLAN.

iSCSI_B VLAN Pool

topology/pod-1/path-101/pathep-
[PGr-FAS-A]

The static path of virtual port
channel (vPC) for node 1.

APIC vPC Static Path for Node 1

topology/pod-1/path-101/pathep-
[PGr-FAS-B]

The static path of virtual port
channel (vPC) for node 2.

APIC vPC Static Path for Node 2

ip_nfs_subnet_poolThe subnet IP pool policy for NFS.NFS IP Subnet Pool Policy

NetApp_ISCSI_A_Subnet_poolThe IP subnet pool policy to be
used for the first iSCSI VLAN.

iSCSI_A IP Subnet Pool Policy
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Sample ValueDescriptionEnvironment Variable

NetApp_ISCSI_B_Subnet_poolThe IP subnet pool policy to be
used for the second iSCSI VLAN.

iSCSI_B IP Subnet Pool Policy

netapp_svm_subnet_poolThe subnet IP pool policy for SVM
management.

SVM mgmt IP Subnet Pool Policy

VMNet_IP_Subnet_pool_policyThe subnet IP pool policy for VM
network.

VMNet IP Subnet Pool Policy

NetApp-PoolThe APIC VLAN pool from which
the VLAN ID needs to be assigned
for node 1.

APIC Vlan Pool for Node 1

NetApp-PoolThe APIC VLAN pool from which
the VLAN ID needs to be assigned
for node 2.

APIC Vlan Pool for Node 2

ACI2-CMODE-01The identity of the first Netapp
C-mode account node.

Cluster Node 1 Identity

ACI2-CMODE-02The identity of the second Netapp
C-mode account node.

Cluster Node 2 Identity

RPThe recovery point attached to the
VNX account.

Default Recovery Point

RP@1649417791The identity of the recovery point
attached to the VNX account.

Recovery Point Cluster Identity

Physical Network Environment Variables

Sample ValueDescriptionEnvironment Variable

IP_poolThe IP pool that is used to assign
the IP addresses between the
NetApp datastore and host
vmkernel. This environment
variable is used for tenant
onboarding.

IP Pool

pxe_ip_new11The IP pool of the Preboot
eXecution Environment (PXE)
server. This environment variable
is used for bare metal provisioning.

PXE Server IP Pool

VNX_APIC185@common@BMA-
AP@PSC_BMA

The Cisco UCS Director Bare
Metal Agent endpoint group (EPG)
entity. This environment variable
is used for bare metal provisioning.

BMA EPG Entity
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Sample ValueDescriptionEnvironment Variable

YesWhen configuring the physical
setup for FlexPod, VSAN is created
for the Fabric Interconnect (FI) A
- NXOS switch 1 connection and
FI B - NXOS switch 2 connection.
In BMA provisioning, zoning is
configured for FI A - NXOS
controller. Choose this environment
variable to specify whether a Cisco
Nexus switch is connected to Cisco
UCS FI A. This environment
variable appears for the MDS
switch.

Connected to FI A

Phy_LB_DomainThe physical domain that you need
to use for the load balancer service.

Physical domain for LB

topology/pod-1/node-101/sys/cdp
/inst/if-[eth1/12]/adj-1

The physical path of the load
balancer service.

Physical LB Path

topology/pod-1/paths-302/
pathep-[PC_Policy_1Gb]

The static path of the first Direct
Port Channel (DPC).

DPC Static path 1

topology/pod-1/paths-303/
pathep-[PC_Policy_1Gb]

The static path of the second DPC.DPC Static path 2

topology/pod-1/protpaths-
103-104/pathep-[ifs-n3k-b_PolGrp]

The first transit path from the ACI
leaf to an external router.

Path 1 to L3Out

topology/pod-1/protpaths-
103-104/pathep-[ifs-n3k-a_PolGrp]

The second transit path from the
ACI leaf to an external router.

Path 2 to L3Out

L2-2960The physical domain for Layer 2.
This environment variable is used
for configuring EPG transit.

L2 Physical Domain

IpsubnetpoolpolicyThe pool policy to be used to get
the IP addresses for sub-interfaces.

IP Subnet Pool Policy

L3out_PoolThe pool to be used to get the
VLAN ID that is used to
communicate between the external
router and ACI fabric. This
environment variable is used to
configure the external routed
network.

L3 Vlan Pool

L2out_PoolThe pool to be used to get the
VLAN ID for the transit EPG. This
environment variable is used for
creating a transit EPG.

L2 Transit Vlan Pool
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Sample ValueDescriptionEnvironment Variable

topology/pod-1/node-302The leaf nodes of the APIC
account. This environment variable
is used for creating a transit EPG.

Node

topology/pod-1/paths-303/pathep-
[eth1/47],
topology/pod-1/paths-303/pathep-
[eth1/48],
topology/pod-1/paths-302/pathep-
[eth1/47]
topology/pod-1/paths-302/pathep-
[eth1/48]

The sub-interface routed path based
on the leaf node selection.

Routed Sub-Interface Path

192.0.232.166, 192.0.232.167The Nexus switches for the APIC
account.

Nexus Switches

loop_back_ip_pool_policyThe pool policy to be used to get
the IP address for Loop Back.

Loop Back IP Subnet Pool Policy

Phy_L3out_domainThe Layer 3 domain of the APIC
account. This environment variable
is used to configure the external
routed network.

L3 Domain

IP_poolThe IP pool to configure router ID
for routers on an external Layer 3
network. This environment variable
is used to configure the external
routed network.

Router IP Pool

IP_poolThe IP pool to provide the cluster
management IP address for the load
balancer device cluster.

LB Cluster IP Pool

topology/pod-1/protpaths-101-102
/pathep-[vpcPG_ec1acifwi001-2_DATA

The interface connecting APIC to
a router on an external Layer 3
network. This environment variable
is used to configure the external
routed network.

SVI Path

IP_poolThe subnet for configuring a switch
virtual interface (SVI) on APIC
leaves. This environment variable
is used to configure the external
routed network.

SVI IP Pool

The following environment variable are not supported in Cisco UCS Director Release 5.4: IP Subnet Pool
Policy, iSCSI PXE Boot Service Profile Template, IQN Pool, Replication Storage Group, PXE Server IP
Pool, BMA EPG Entity, Physical domain for LB, and Physical LB Path.

Note
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The environment variable that need to be defined for VNX tenant onboarding are:

• Physical Compute—Cisco UCS Manager

• Service Profile Template for Full Width Blade

• Service Profile Template for Half Width Blade

• EMC VNX Unified

• SP Port

• VMware Account

• DV Switch-Virtual Network

• VMM Domain for VMware-Virtual Network

• APIC (Physical Network)

• DPC Static Path 1 (for L2 configuration)

• DPC Static Path 2 (for L2 configuration)

• L2 Physical Domain (for L2 configuration)

• IP Subnet Pool Policy (for L3 configuration)

• L3 VLAN Pool (for L3 configuration)

• Routed Sub-Interface Path (for L3 configuration)

• Node (for L3 configuration)

• Nexus Switches (for L3 configuration)

• Loop Back IP Subnet Pool Policy (for L3 configuration)

The environment variable that need to be defined for FlexPod tenant onboarding as per the Cisco UCSDirector
and FlexPod Cisco validated design (CVD) are:

• APIC Account

• IP Pool

• NetApp

• Vlan Pool

• Physical Domain for NetApp

• NFS Vlan Pool

• SVM mgmt Vlan Pool

• APIC vPC Static Path for Node 1

• APIC vPC Static Path for Node 2

• NFS IP Subnet Pool Policy
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• SVM mgmt IP Subnet Pool Policy

• VMNet IP Subnet Pool Policy

• APIC Vlan Pool for Node 1

• APIC Vlan Pool for Node 2

• Cluster Node 1 Identity

• Cluster Node 2 Identity

• iSCSI_A VLAN Pool

• iSCSI_B VLAN Pool

• iSCSI_A IP Subnet Pool Policy

• iSCSI_B IP Subnet Pool Policy

• VMware Account

• DV Switch

• VMM Domain for VMware-Virtual Network

The environment variable that need to be defined for NetApp tenant onboarding (obsolete) are:

• APIC Account

• IP Pool

• NetApp

• Vlan Pool

• NetApp Static Path

• Physical Domain for NetApp

• Virtual Network

• DV Switch

• VMM Domain for VMware

Adding a Custom Environment Variable
You can define an environment variable that you want to use in the resource group and workflow. The type
of the user-defined environment variable is custom.

Step 1 Choose Policies > Resource Groups.
Step 2 On the Resource Groups page, click Environment Variables.
Step 3 Click the row with anenvironment variable and click View to view the name, variable type, and identity type of the

environment variable.
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Step 4 Click the row with the environmental variable and click Delete to delete the environment variable.

You can delete only the user-defined environment variable that is categorized as custom.

Step 5 Click Add.
Step 6 On the Resource Group Environment Variable screen, complete the following fields:

DescriptionName

The name of the environment variable.Custom Environment Name field

The description of the environment variable.Description field

Choose one of the following as the resource type for the
environment variable:

• VIRTUAL_COMPUTE

• VIRTUAL_NETWORK

• VIRTUAL_STORAGE

• PHYSICAL_COMPUTE

• PHYSICAL_STORAGE

• PHYSICAL_NETWORK

The environment variable is categorized under the chosen
resource type.

Resource Type drop-down list

Expand Input Type and check the variable type that you
want to use for the environment variable. The variable type
can be text, list of variable (LoV), multiple selection, table,
and popup table.

Input Type field

Step 7 Click Submit.
The added custom environment variable is listed on the Environment Variables page. You can add this custom
environment variable in the Resource Group.

Adding a Resource Group

Before you begin

Ensure that the IP subnet pool policy and VLAN pool policy are defined to use the policy in the environment.
Also, you can add a policy on the Add Entry to Environment Variables screen when adding a resource
group.

Step 1 Choose Policies > Resource Groups.
Step 2 On the Resource Groups page, click Resource Groups.
Step 3 Click the row with a resource group and click View to view the name and description of the resource group.
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Step 4 Click the row with a resource group and click View Details to view the resources that are associated with a resource
group.

The ID, pod, account name, category, account type, resource type, and resource name of the resources in the resource
group are displayed.

Step 5 Click the row with a resource and click View Details to view the capacities and capabilities of a resource.
Step 6 Click Add.
Step 7 On the Create Resource Group screen, complete the following fields:

DescriptionName

The name of the resource group.Name field

The description of the resource group.Description field

Check to enable the disaster recovery service support for
the resource group.

The disaster recovery service support is enabled
based on the use case and the workflow being
executed.

Note

Enable DR check box

This field appears only when Enable DR is checked. By
default, Primary is selected to set the resource group as
primary. If you want to set the resource group as secondary,
choose Secondary.

Accounts Priority drop-down list

Choose a resource group as a disaster recovery service
resource group for handling failover and recovering data
during disaster.

DRS Resource Group drop-down list

The primary and secondary resource groups must each have an equal number of accounts in order to support
the disaster recovery service.

Note

Step 8 Click Next.
Step 9 (Optional) On the Virtual Compute screen, choose the virtual compute account and the interested capabilities and

capacities:
a) Expand Virtual Accounts and click the + icon to add a virtual account.
b) On the Add Entry to Virtual Accounts screen, expand Accounts, check the virtual account that you want to use,

and then click Validate.

You can choose either a VMware account or a Hyper-V account from the account list. According to the
chosen virtual account, you need to choose environment variable, capabilities, and capacities. If the
required environment variable is not available in the drop-down list, you can create a new environment
variable. For more information on how to create an environment variable, see Adding a Custom
Environment Variable, on page 226.

Note

c) Expand Environment Variables and click the + icon.

1. On the Add Entry to Environment Variables screen, choose an environment variable from the Name
drop-down list.
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2. In theRequired Value field, choose the value according to the selected environment variable.When you choose
IP Subnet Pool Policy from the Name drop-down list, expand Required Value and check the policy that you
want to use. You can also add a policy by clicking the + icon.

3. Click Submit.

d) In the Selected Capabilities field, the capabilities of the chosen virtual account appear by default.

You can opt to disable the capabilities by unchecking the capability in the edit window that appears on clicking
the Edit icon. You can remove the capability from the list by clicking the Delete icon.

e) In the Selected Capacities field, the capacities of the chosen virtual account appear by default.

You can opt to disable the capacities by unchecking the capacity in the edit window that appears on clicking the
Edit icon. You can remove the capacity from the list by clicking the Delete icon.

f) Click Submit on the Add Entry to Virtual Accounts screen.

An account that is added to a resource group cannot be added to another resource group and cannot be
deleted from Cisco UCS Director.

Note

Step 10 Click Next.
Step 11 On the Virtual Storage screen, expand Virtual Accounts click the row with the virtual compute account and the

interested capabilities and capacities.
a) Click the + icon to add a virtual account.
b) On the Add Entry to Virtual Accounts screen, expand Accounts, check the virtual account you want to use, and

click Validate.

You can choose either a VMware account or a Hyper-V account from the account list. According to the
chosen virtual account, you need to choose environment variable, capabilities, and capacities. If the
required environment variable is not available in the drop-down list, you can create a new environment
variable. For more information on how to create an environment variable, see Adding a Custom
Environment Variable, on page 226.

Note

c) Expand Environment Variables and click the + icon.

1. On theAddEntry to EnvironmentVariables screen, choose an environment variablefrom theName drop-down
list.

2. In the Required Value field, choose the value according to the selected environment variable.

3. Click Submit.

d) In the Selected Capabilities field, the capabilities of the chosen virtual account appear by default.

You can opt to disable the capabilities by unchecking the capability in the edit window that appears on clicking
the Edit icon. You can remove the capability from the list by clicking the Delete icon.

e) In the Selected Capacities field, the capacities of the chosen virtual account appear by default.

You can opt to disable the capacities by unchecking the capacity in the edit window that appears on clicking the
Edit icon. You can remove the capacity from the list by clicking the Delete icon.

f) Click Submit on the Add Entry to Virtual Accounts screen.

An account that is added to a resource group cannot be added to another resource group and cannot be
deleted from Cisco UCS Director.

Note

Cisco UCS Director Administration Guide, Release 6.6
229

Managing Resource Groups
Adding a Resource Group



Step 12 Click Next.
Step 13 On the Virtual Network screen, expand Virtual Accounts and click the row with the virtual network account and the

interested capabilities and capacities:
a) Click the + icon to add a virtual account.
b) On the Add Entry to Virtual Accounts screen, expand Accounts, check the virtual account that you want to use,

and click Validate.

You can choose either a VMware account or a Hyper-V account from the account list. According to the
chosen virtual account, you need to choose environment variable, capabilities, and capacities. If the
required environment variable is not available in the drop-down list, you can create a new environment
variable. For more information on how to create an environment variable, see Adding a Custom
Environment Variable, on page 226.

Note

c) Expand Environment Variables and click the + icon.

1. On the Add Entry to Environment Variables screen, choose an environment variable from the Name
drop-down list.

2. Expand Required Value field and check the value according to the selected environment variable that you
want to use in the environment.

3. Click Submit.

d) In the Selected Capabilities field, the capabilities of the chosen virtual account appear by default.

You can opt to disable the capabilities by unchecking the capability in the edit window that appears on clicking
the Edit icon. You can remove the capability from the list by clicking the Delete icon.

e) In the Selected Capacities field, the capacities of the chosen virtual account appear by default.

You can opt to disable the capacities by unchecking the capacity in the edit window that appears on clicking the
Edit icon. You can remove the capacity from the list by clicking the Delete icon.

f) Click Submit on the Add Entry to Virtual Accounts screen.

An account that is added to a resource group cannot be added to another resource group and cannot be
deleted from Cisco UCS Director.

Note

Step 14 Click Next.
Step 15 (Optional) On the Physical Compute screen, expandCompute Accounts and click the row with the physical compute

account and the interested capabilities and capacities:
a) Click the + icon to add a compute account.
b) On the Add Entry to Compute Accounts screen, check the compute account that you want to use, and click

Validate.
c) Expand Environment Variables and click the + icon.

1. On the Add Entry to Environment Variables screen, choose an environment variable from the Name
drop-down list.

2. Expand Required Value field, and check the value according to the selected environment variable. When you
choose Vlan pool from the Name drop-down list, expand Required Value and check the policy that you want
to use. You can also add a policy by clicking the + icon.

3. Click Submit.
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d) Expand Selected Capabilities and click on the row with the resource and resource capability that you want to use.
e) Expand Selected Capacities and click on the row with the resource and resource capacities that you want to use.
f) Click Submit on the Add Entry to Compute Accounts screen.

An account that is added to a resource group cannot be added to another resource group and cannot be
deleted from Cisco UCS Director.

Note

Step 16 Click Next.
Step 17 (Optional) On the Physical Storage screen, expand Storage Accounts and click the row with the physical storage

account and the interested capabilities and capacities:
a) Click the + icon to add a storage account.
b) On theAdd Entry to Storage Accounts screen, check the storage account that you want to use, and clickValidate.
c) Expand Environment Variables and click the + icon.

1. In the Add Entry to Environment Variables dialog box, choose an environment variable from the Name
drop-down list.

2. ExpandRequired Value and check the value according to the selected environment variable.When you choose
Vlan pool from the Name drop-down list, expand Required Value and check the policy that you want to use.
You can also add a policy by clicking the + icon.

3. Click Submit.

The IP address and subnet mask of the storage device must be within the IP address range specified based on
the policy.

d) Expand Selected Capabilities and click on the row with the resource and resource capability that you want to use.
e) Expand Selected Capacities and click on the row with the resource and resource capacities that you want to use.
f) Click Submit on the Add Entry to Storage Accounts screen.

An account that is added to a resource group cannot be added to another resource group and cannot be
deleted from Cisco UCS Director.

Note

Step 18 Click Next.
Step 19 (Optional) On the Physical Network screen, expand Network Accounts and click the row with the physical network

account and the interested capabilities and capacities:
a) Click the + icon to add a network account.
b) On the Add Entry to Network Accounts screen, choose the storage account.
c) Expand Environment Variables and click the + icon.

1. On the Add Entry to Environment Variables screen, choose an environment variable from the Name
drop-down list.

2. ExpandRequired Value and check the value according to the selected environment variable.When you choose
IP Pool from the Name drop-down list, expand Required Value and check the policy that you want to use.

3. Click Submit.

d) Expand Selected Capabilities and click the + icon.

1. On the Add Entry to Selected Capabilities screen, choose FC Capability on MDS or Zone Support from
the Select Resource drop-down list.
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2. In the Resource Capability field, choose a value from the list of values that are displayed according to the
selected resource.

3. Click Submit.

e) Expand Selected Capacities and click on the row with the resource and resource capacities that you want to use.
f) Click Submit on the Add Entry to Network Accounts screen.

An account that is added to a resource group cannot be added to another resource group and cannot be
deleted from Cisco UCS Director.

Note

Step 20 Click Next.
Step 21 On the L4L7 Devices screen, choose the firewall specification and load balancer specification:

a) Expand Firewall Specification and click the + icon.
On the Add Entry to Firewall Specification screen, complete the following fields:

DescriptionName

ChooseVIRTUAL or PHYSICAL as the firewall type.Firewall Type drop-down list

The following fields appear when you choose VIRTUAL as the firewall type:

ExpandVirtual Accounts and check the virtual account
you want to use.

Virtual Accounts field

Choose a VM deployment policy. Click the + icon to
add a VM deployment policy. For more information
about how to add a VM deployment policy, see the
Adding an ASAv VMDeployment Policy section in the
Cisco UCS Director Application Container Guide.

VM Deployment Policy drop-down list

Expand Firewall Management Port Group and check
the port group of vCenter that you want to use. The
management interface will be placed in the chosen port
group during ASAv deployment.

Firewall Management Port Group field

ExpandManagement IP Pool and check the IP pool
that you want to use for assigning management IP
address.

Management IP Pool field

Expand Regular HA IP Pool and check the IP pool
(private IP range) to allocate IP address from the pool.
This pool is used as failover link between primary and
secondary ASA devices. This pool is used when the
firewall HA is enabled in the Layer 4 through Layer 7
service policy.

Regular HA IP Pool field
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DescriptionName

Expand Stateful HA IP Pool and check the IP pool
(private IP range) to allocate IP address from the pool.
This pool is used as state link between primary and
secondary Cisco ASA devices. This pool is used when
the stateful failover is enabled in the Layer 4 through
Layer 7 service policy. The stateful HA IP pool and
regular HA IP pool must be in different subnets to avoid
network IP conflict.

Stateful HA IP Pool field

The following fields appear when you choose PHYSICAL as the firewall type.

Expand APIC Accounts and check the APIC account
that you want to use.

APIC Accounts field

CheckMulti Context Enabled if the multiple context
configuration is enabled on the Cisco ASA device.

Multi Context Enabled check box

This field appears only whenMulti Context Enabled
is checked. The IP address of the physical Cisco ASA
device. This IP address is configured as the Admin
Context IP address.

Firewall Cluster IP field

This field appears only whenMulti Context Enabled
is checked. The username of the cluster that is used by
APIC to access ASA.

Cluster Username field

This field appears only whenMulti Context Enabled
is checked. The password of the cluster that is used by
APIC to access ASA.

Cluster Password field

The IP address that is used to reach the firewall device.
IfMulti Context Enabled is checked, this field collects
the User Context IP address of the virtual ASA device
that is configured on Day 0.

Firewall/Context IP field

The port number of the firewall device.Port field

The username that is used to access the firewall device.
IfMulti Context Enabled is checked, this field collects
the username of the user context.

Username field

The password that is used to access the firewall device.
IfMulti Context Enabled is checked, this field collects
the password of the user context.

Password field

ExpandPhysical Domain and check the physical domain
that you want to use. Click the + icon to add a physical
domain.

Physical Domain field

Expand Static Path and check the static path that you
want to use. Cisco UCSDirector displays the path types,
such as VPC and leaf, in the table.

Static Path field
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DescriptionName

The port channel interface of the Cisco ASA device
which is connected to leaf (for example, Po1,
Port-channel1).

Port Channel Name field

The unique ID of the channel group. This field appears
only whenMulti Context Enabled is unchecked.

Channel Group Id field

The interface name(s) of the port channel member. This
field appears only whenMulti Context Enabled is
unchecked.

Enter the interface name without space. If
there are more than one interfaces, enter the
interface names separated by comma.

Note

Port Channel Member Interfaces field

b) Click Submit.

If the multiple context is enabled on the Cisco ASA device, repeat the firewall specification to add the
details for each context.

Note

c) Expand Load Balancer Specification, click the + icon.
On the Add Entry to Load Balancer Specification screen, complete the following fields:

DescriptionName

Choose Virtual or Physical as the load balancer type.Load Balancer Type drop-down list

This field appears when you choose the load balancer
type as Virtual. Expand Virtual Accounts and check
the virtual account that you want to use.

Virtual Accounts field

This field appears when you choose the load balancer
type as Physical. Expand APIC Accounts and check
the APIC account that you want to use.

APIC Accounts field

The IP address that is used to reach the NetScalar device.Load Balancer IP field

The port number of the NetScalar device.Port field

The gateway IP address of the NetScalar device.Load Balancer Gateway field

The username that is used to access the NetScalar device.Username field

The password that is used to access the NetScalar device.Password field

Optional. Expand Function Profile and check the
function profile that you want to use.

Function Profile field

This field appears when you choose the load balancer
type as Virtual. Expand VMs and check the VM that
you want to use.

VMs field
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DescriptionName

This field appears when you choose the load balancer
type as Physical. Expand Physical Domain and check
the physical domain that you want to use. Click the +
icon to add a physical domain.

Physical Domain field

This field appears when you choose the load balancer
type as Physical. The interface that is used for the device
cluster configuration (for example, LA_1).

Interface field

This field appears when you choose the load balancer
type as Physical. Expand Static Path and check the
static path that you want to use.

Static Path field

d) Click Submit.

Step 22 Click Submit.

Editing a Resource Group
When editing a resource group, you can add accounts to the resource group, edit the accounts that are added
to the resource group, and delete accounts from the resource group.

You can delete an account from a resource group only when the account is not associated with other resource
group objects, such as a tenant profile.

Step 1 Choose Policies > Resource Groups.
Step 2 On the Resource Groups page, click Resource Groups.
Step 3 Click the row with the resource group that you want to edit.
Step 4 Click Edit.
Step 5 On the Edit Resource Group screen, complete the following fields for the resource group:

DescriptionName

The name of the resource group.Name field

The description of the resource group.Description field

Check to enable the disaster recovery service support for
the resource group.

The disaster recovery service support is enabled
based on the use case and the workflow being
executed.

Note

Enable DR check box

This field appears only when Enable DR is checked. By
default, Primary is selected to set the resource group as
primary. If you want to set the resource group as secondary,
choose Secondary.

Accounts Priority drop-down list
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DescriptionName

Choose a resource group as a disaster recovery service
resource group for handling failover and recovering data
during disaster.

DRS Resource Group drop-down list

Step 6 Click Next.
Step 7 (Optional) The Virtual Compute screen displays the virtual compute accounts added to the resource group. Expand

Virtual Accounts, click the row of an account, and click the edit icon to edit the environment variable, capabilities,
and capacities of the account. You can also add an account using the add icon and delete the account using the delete
icon.

Step 8 Click Next.
Step 9 TheVirtual Storage screen displays the virtual storage accounts added to the resource group. ExpandVirtual Accounts,

click the row of an account, and click the edit icon to edit the environment variable, capabilities, and capacities of the
account. You can also add an account using the add icon and delete the account using the delete icon.

Step 10 Click Next.
Step 11 The Virtual Network screen displays the virtual network accounts added to the resource group. Expand Virtual

Accounts, click the row of an account, and click the edit icon to edit the environment variable, capabilities, and capacities
of the account. You can also add an account using the add icon and delete the account using the delete icon.

Step 12 Click Next.
Step 13 The Physical Compute screen displays the physical compute accounts added to the resource group. ExpandCompute

Accounts, click the row of an account, and click the edit icon to edit the environment variable, capabilities, and capacities
of the account. You can also add an account using the add icon and delete the account using the delete icon.

Step 14 Click Next.
Step 15 The Physical Storage screen displays the physical storage accounts added to the resource group. Expand Storage

Accounts, click the row of an account, and click the edit icon to edit the environment variable, capabilities, and capacities
of the account. You can also add an account using the add icon and delete the account using the delete icon.

Step 16 Click Next.
Step 17 The Physical Network screen displays the physical network accounts added to the resource group. Expand Network

Accounts, click the row of an account, and click the edit icon to edit the environment variable, capabilities, and capacities
of the account. You can also add an account using the add icon and delete the account using the delete icon.

Step 18 Click Next.
Step 19 On the L4L7 Devices screen, edit the firewall specification and load balancer specification as required.
Step 20 Click Submit.

Adding a Pod to a Resource Group
To add all accounts in a pod to a resource group, add the pod itself to the resource group.

You can also add amulti-domainmanager account to a resource group using theAdd Pod to ResourceGroup
option, provided that the multi-domain manager account is associated with a pod.

Note

Cisco UCS Director Administration Guide, Release 6.6
236

Managing Resource Groups
Adding a Pod to a Resource Group



Step 1 Choose Policies > Resource Groups.
Step 2 On the Resource Groups page, click Resource Groups.
Step 3 Click Add Pod to Resource Group.
Step 4 On the Resource Group screen, complete the following fields:

DescriptionName

Choose one of the following:

• Existing Resource Group—To add a pod to the
existing resource group.

• Name drop-down list—Choose the resource
group.

• AddNewResourceGroup—To create a new resource
group and add a pod to the newly added resource
group.

• Name field—The name of the resource group.

• Description field—The description of the
resource group.

Select drop-down list

Expand Pod and check the pod that you want to add to the
resource group.

Pod field

Step 5 Click Submit.

Managing Tags of a Resource Group
You can add a tag to a resource group, edit the assigned tag, and delete the tag from the resource group.

TheManage Tag dialog box displays tags according to the Taggable Entities that are assigned during creation.
For more information on how to create a tag, see the Cisco UCS Director Administration Guide.

Note

The resources need to be grouped based on the resource capabilities. Use a tag to group the resources. You
can create the tag library based on the resource type, capacity, quality, and capability of each resource, so as
to group the resources in a proper pattern.

Step 1 Choose Policies > Resource Groups.
Step 2 On the Resource Groups page, click Resource Groups.
Step 3 Click the row with the resource group for which you want to manage the associated tags.
Step 4 From theMore Actions drop-down list, chooseManage Tags.
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Step 5 On theManage Tags screen, expand Tag and click the + icon to add a tag.

Alternatively, you can click Add Tags on the Resource Groups page.

a) On the Add Entry to Tag screen, complete the following fields:

DescriptionName

Choose the name of the tag.Tag Name drop-down list

Choose the value of the tag.Tag Value drop-down list

b) Click Submit.

Step 6 On theManage Tags screen, click the row with the tag you want to edit and click the pencil icon.
a) On the Edit Tag Entry screen, complete the following fields:

DescriptionName

Choose the name of the tag.Tag Name drop-down list

Choose the value of the tag.Tag Value drop-down list

b) Click Submit.

Step 7 On theManage Tags screen, click the row with the tag you want to delete and click the delete icon.

Alternatively, you can click Delete Tags on the Resource Groups page.

a) On the Delete Tag Entry screen, expand Tag Name, check the tag you want to delete, and click Submit.

Step 8 Click Submit.

Deleting a Resource Group

You cannot delete a resource group that is in use.Note

Step 1 Choose Policies > Resource Groups.
Step 2 On the Resource Groups page, click Resource Groups.
Step 3 Click the row with the resource group that you want to delete.
Step 4 Click Delete.

The Delete Resource Group screen appears.

Step 5 Click Submit.
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Tenant
A tenant is a customer who uses resources in Cisco UCS Director to deploy and manage their application.

When a customer wants to deploy an application in Cisco UCSDirector, the customer is onboarded as a tenant
and the infrastructure is provided to deploy the application, using the APIC use case workflows.

To view the list of tenants that are onboarded in Cisco UCS Director choose Policies > Resource Groups.
Click the row with a tenant and click View Details to view the service offerings of the tenant. Click the row
with a service offering and click View Details to view the resource groups of a tenant.

If the disaster recovery support is enabled for the tenant, the resource groups of the primary site and the disaster
recovery site are displayed.

Note

To view the resource entity, reserved resources, and resources available for use in tenant and container, click
the row with the resource group and click View Details. The following information appears:

• Resource Entity—Displays the details of the entity in the resource group. The details include name,
type, component, resource group, tenant resource allocation type, application resource allocation type,
container, and state of the resource entity.

• Tenant Resource Limits—Displays availability of both virtual and physical resources in a tenant. The
resources reserved during tenant onboarding are displayed along with the used and available resource
values. The VDCs Limit column specifies the maximum number of containers that are reserved for the
tenant. The Available Number of VDCs column represents the number of containers that are available
for provisioning. The physical resource limits display the blades that are reserved as part of tenant
onboarding, along with the number of blades used for bare metal provisioning.

• Container Resource Limits—Displays availability of both virtual and physical resources in a container.
The resource limits that are set during container creation are displayed along with the used and available
resources.

If a container is created without a resource limit, the value of the virtual resources
is displayed as Not Set.

Note

• Private Network—Displays the private networks created for the tenant. Click the row of a private
network and click View Details to view the supernet and subnet pools of the private network. The
Supernets screen lists the supernets available for the tiers. The Subnets screen displays the sub-network
pool that is used for load balancer configuration during the container deployment.

The tenant-specific and container-specific resource limits assist in provisioning VMs and BMs.

Service Offerings
A service offering defines the resources required to provision an application. Each service offering must
include one or more service classes that represents the capacity and capability needed for the following resource
layers:
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• Virtual Compute

• Virtual Storage

• Virtual Network

• Physical Compute

• Physical Storage

• Physical Network

• Layer 4 to Layer 7 Services

When you define a service offering, you can specify the usage of resource groups as one of the following:

• Shared—The resources are shared among the applications or tenants.

• Dedicated —The resources are dedicated to a single application or tenant.

Based on the capacity, capability, and resource tags defined in the service offering, the resource groups are
filtered and the matching resource groups are selected for further processing in the tenant onboarding and
application deployment.

Adding a Service Offering

Before you begin

If tag-based resource selection is required for any of the resources, ensure that the tags are created in the tag
library and are associated with the respective object. So that, the tags are listed when you define resource tag
for service class. For more information on how to create a tag, see the Cisco UCS Director Administration
Guide.

Step 1 Choose Policies > Resource Groups.
Step 2 On the Resource Groups page, click Service Offering.
Step 3 Click the row of a service offering and click View to view the name, description, and service classes of the service

offering.
Step 4 Click the row of a service offering and click View Details to view the service classes of the service offering.
Step 5 Click the row of a service class and click View Details to view the capabilities, capacity, and resource-group tag of the

service class.
Step 6 Click Add.
Step 7 On the Add Service Offering screen, complete the following fields:

DescriptionName

The name of the service offering.Name field

The description of the service offering.Description field
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DescriptionName

If checked, the user can define any number of resource
types (minimum of one resource type to maximum of six
resource types) for the service class according to the
topology.

If unchecked, the user has to define all the six resource
types (physical compute, physical storage, physical
network, virtual compute, virtual storage, and virtual
network) for the service class. Even if the user does not
define all the virtual and physical infrastructure resource
types, Cisco UCS Director looks for resources for the
missing resource types along with the defined resource
types.

To create a service offering that is used for
onboarding a tenant using APIC account and
VMware account, check this check box and
create a service offering with service class for
four resource types (physical network, virtual
compute, virtual storage, and virtual network).
This service offering needs to be chosen during
creation of a tenant profile. The tenant profile
will be used for onboarding a tenant using APIC
account and VMware account (for example,
tenant onboarding with private networks).

Note

OverrideMandatory Service Class Requirement check
box

Step 8 Click Next.
Step 9 On the Service Class screen, expand Service Class and click the + icon to define the service class that the service

offering has to provide.
Step 10 On the Add Entry to Service Class screen, complete the following fields:

DescriptionName

The name of the service class.Name field

The description of the service class.Description field

Choose the type of resource allocation for the tenant.

It can be one of the following:

• Dedicated—To dedicate the resources for a tenant.

• Shared—To share the resources among the tenants.

Resource Allocation type for Tenant drop-down list
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DescriptionName

Choose the type of resource allocation for the application.

It can be one of the following:

• Dedicated—To dedicate the resources for an
application.

• Shared—To share the resources among the
applications.

Resource Allocation type for Application drop-down
list

Choose the type of resource that you are adding to the
service class. It can be one of the following:

• Virtual_Compute

• Virtual_Storage

• Virtual_Network

• Physical_Compute

• Physical_Storage

• Physical_Network

The user can define a minimum of two resource types
(physical or virtual compute, and physical or virtual
network) and a maximum of six resource types (virtual
compute, virtual storage, virtual network, physical
compute, physical storage, and physical network) during
the addition of the service class, only when Override
Mandatory Service Class Requirement is unchecked.

Resource Type drop-down list

ExpandResource Tag and click the row with the resource
tag that you want to use. For more information about the
tag library, see the Cisco UCS Director Administration
Guide.

You can add the data store tags with multiple
tag values (for example, gold, silver, bronze)
in the virtual storage service class level.

Note

You can add the ESXi cluster tag with multiple
tag values in the virtual compute service class
level.

Note

You can modify only the required values of the
tags defined in this table. You cannot add new
tags to this table. For information on how to
create a tag, see the Tag Library section in the
Cisco UCS Director Administration Guide.

Important

Resource Tag field
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DescriptionName

By default, the capabilities that are applicable for the
VMware and Hyper-V account are displayed according to
the chosen resource type. You can edit the value of the
resource capability using the Edit icon. You can remove
a resource capability from the service offering using the
Delete icon.

All the resource capabilities related to the
resource type are prepopulated with the default
value as false. You can modify the capability
value.

Important

Resource Capability field

The available resource capacity for the service offering.

To add a resource capacity, expand Resource Capacity
and click the Add icon and choose the capacity type from
the list of capacities that are applicable for the VMware
and Hyper-V account. The capacities are displayed based
on the chosen resource type. Choose the capacity matching
criteria and set the required capacity value.

To remove the resource capacity, click the Delete icon. To
modify the values of the capacity, click the Edit icon.

Resource Capacity field

The tag is used along with resource capability and capacity for filtering the resources in the resource group.Note

Step 11 Click Submit.
The service class information is added to the table. You can define multiple service classes for the service offering.

Step 12 Click Submit.

Cloning a Service Offering

Before you begin

Ensure that the tags are created in the tag library and the tags are associated with the respective object. So
that, the tags are listed when you define resource tag for service class. For more information on how to create
a tag, see the Cisco UCS Director Administration Guide.

Step 1 Choose Policies > Resource Groups.
Step 2 On the Resource Groups page, click Service Offering.
Step 3 Click the row with the service offering that you want to clone.
Step 4 Click Clone Service Offering.
Step 5 On the Clone Service Offering screen, complete the following fields:
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DescriptionName

The name of the service offering.Name field

The description of the service offering.Description field

If checked, the user can define any number of resource
types (minimum of one resource type to maximum of six
resource types) for the service class according to the
topology.

If unchecked, the user has to define all the six resource
types (physical compute, physical storage, physical
network, virtual compute, virtual storage, and virtual
network) for the service class. Even if the user does not
define all the virtual and physical infrastructure resource
types, Cisco UCS Director looks for resources for the
missing resource types along with the defined resource
types.

To create a service offering that is used for
onboarding a tenant using APIC account and
VMware account, check this check box and
create a service offering with service class for
four resource types (physical network, virtual
compute, virtual storage, and virtual network).
This service offering needs to be chosen during
creation of a tenant profile. The tenant profile
will be used for onboarding a tenant using APIC
account and VMware account (for example,
tenant onboarding with private networks).

Note

OverrideMandatory Service Class Requirement check
box

Step 6 Click Next.
Step 7 On the Service Class screen, expand Service Class and click the + icon to define the service class that the service

offering has to provide.
Step 8 On the Add Entry to Service Class screen, complete the following fields:

DescriptionName

The name of the service class.Name field

The description of the service class.Description field

Choose the type of resource allocation for the tenant.

It can be one of the following:

• Dedicated—To dedicate the resources for a tenant.

• Shared—To share the resources among the tenants.

Resource Allocation type for Tenant drop-down list
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DescriptionName

Choose the type of resource allocation for the application.

It can be one of the following:

• Dedicated—To dedicate the resources for an
application.

• Shared—To share the resources among the
applications.

Resource Allocation type for Application drop-down
list

Choose the type of resource that you are adding to the
service class. It can be one of the following:

• Virtual_Compute

• Virtual_Storage

• Virtual_Network

• Physical_Compute

• Physical_Storage

• Physical_Network

The user can define a minimum of two resource types
(physical or virtual compute, and physical or virtual
network) and a maximum of six resource types (virtual
compute, virtual storage, virtual network, physical
compute, physical storage, and physical network) during
the addition of the service class, only when Override
Mandatory Service Class Requirement is unchecked.

Resource Type drop-down list

ExpandResource Tag and click the row with the resource
tag that you want to use. For more information about the
tag library, see the Cisco UCS Director Administration
Guide.

You can add the data store tags with multiple
tag values (for example, gold, silver, bronze)
in the virtual storage service class level.

Note

You can add the ESXi cluster tag with multiple
tag values in the virtual compute service class
level.

Note

You can modify only the required values of the
tags defined in this table. You cannot add new
tags to this table. For information on how to
create a tag, see the Tag Library section in the
Cisco UCS Director Administration Guide.

Important

Resource Tag field
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DescriptionName

By default, the capabilities that are applicable for the
VMware and Hyper-V account are displayed according to
the chosen resource type. You can edit the value of the
resource capability using the Edit icon. You can remove
a resource capability from the service offering using the
Delete icon.

All the resource capabilities related to the
resource type are prepopulated with the default
value as false. You can modify the capability
value.

Important

Resource Capability field

The available resource capacity for the service offering.

To add a resource capacity, expand Resource Capacity
and click the Add icon and choose the capacity type from
the list of capacities that are applicable for the VMware
and Hyper-V account. The capacities are displayed based
on the chosen resource type. Choose the capacity matching
criteria and set the required capacity value.

To remove the resource capacity, click the Delete icon. To
modify the values of the capacity, click the Edit icon.

Resource Capacity field

Step 9 (Optional) Click the pencil icon to edit the values of an already configured service class.
Step 10 (Optional) Click the trash icon to delete an already configured service class from the service offering.
Step 11 Click Submit.

Editing a Service Offering

Do not edit the service offering that is mapped to a resource group and tenant profile. If you edit the service
offering that is mapped to a resource group and tenant profile, the tenant that is onboarded using the service
offering will be affected.

Note

Before you begin

Ensure that the tags are created in the tag library and the tags are associated with the respective object. So
that, the tags are listed when you define resource tag for service class. For more information on how to create
a tag, see the Cisco UCS Director Administration Guide.

Step 1 Choose Policies > Resource Groups.
Step 2 On the Resource Groups page, click Service Offering.
Step 3 Click the row with the service offering that you want to edit.
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Step 4 Click Edit.
Step 5 On theModify Service Offering screen, complete the following fields:

DescriptionName

The name of the service offering.Name field

The description of the service offering.Description field

If checked, the user can define any number of resource types
(minimum of one resource type to maximum of six resource
types) for the service class according to the topology.

If unchecked, the user has to define all the six resource types
(physical compute, physical storage, physical network,
virtual compute, virtual storage, and virtual network) for
the service class. Even if the user does not define all the
virtual and physical infrastructure resource types, Cisco
UCS Director looks for resources for the missing resource
types along with the defined resource types.

To create a service offering that is used for
onboarding a tenant using APIC account and
VMware account, check this check box and
create a service offering with service class for
four resource types (physical network, virtual
compute, virtual storage, and virtual network).
This service offering needs to be chosen during
creation of a tenant profile. The tenant profile
will be used for onboarding a tenant using APIC
account and VMware account (for example,
tenant onboarding with private networks).

Note

Override Mandatory Service Class Requirement check
box

Step 6 Click Next.
Step 7 On the Service Class screen, expand Service Class and click the + icon to define the service class that the service offering

has to provide.
Step 8 On the Add Entry to Service Class screen, complete the following fields:

DescriptionName

The name of the service class.Name field

The description of the service class.Description field

Choose the type of resource allocation for the tenant.

It can be one of the following:

• Dedicated—To dedicate the resources for a tenant.

• Shared—To share the resources among the tenants.

Resource Allocation type for Tenant drop-down list
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DescriptionName

Choose the type of resource allocation for the application.

It can be one of the following:

• Dedicated—To dedicate the resources for an
application.

• Shared—To share the resources among the
applications.

Resource Allocation type for Application drop-down list

Choose the type of resource that you are adding to the
service class. It can be one of the following:

• Virtual_Compute

• Virtual_Storage

• Virtual_Network

• Physical_Compute

• Physical_Storage

• Physical_Network

The user can define a minimum of two resource types
(physical or virtual compute, and physical or virtual
network) and a maximum of six resource types (virtual
compute, virtual storage, virtual network, physical compute,
physical storage, and physical network) during the addition
of the service class, only when Override Mandatory
Service Class Requirement is unchecked.

Resource Type drop-down list

Expand Resource Tag and click the row with the resource
tag that you want to use. For more information about the
tag library, see the Cisco UCS Director Administration
Guide.

You can add the data store tags with multiple tag
values (for example, gold, silver, bronze) in the
virtual storage service class level.

Note

You can add the ESXi cluster tag with multiple
tag values in the virtual compute service class
level.

Note

You can modify only the required values of the
tags defined in this table. You cannot add new
tags to this table. For information on how to
create a tag, see the Tag Library section in the
Cisco UCS Director Administration Guide.

Important

Resource Tag field
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DescriptionName

By default, the capabilities that are applicable for the
VMware and Hyper-V account are displayed according to
the chosen resource type. You can edit the value of the
resource capability using the Edit icon. You can remove a
resource capability from the service offering using the
Delete icon.

All the resource capabilities related to the
resource type are prepopulated with the default
value as false. You can modify the capability
value.

Important

Resource Capability field

The available resource capacity for the service offering.

To add a resource capacity, expand Resource Capacity
and click the Add icon and choose the capacity type from
the list of capacities that are applicable for the VMware and
Hyper-V account. The capacities are displayed based on
the chosen resource type. Choose the capacity matching
criteria and set the required capacity value.

To remove the resource capacity, click the Delete icon. To
modify the values of the capacity, click the Edit icon.

Resource Capacity field

Step 9 Click Submit.

Deleting a Service Offering

You cannot delete a service offering that is in use.Note

Step 1 Choose Policies > Resource Groups.
Step 2 On the Resource Groups page, click Service Offering.
Step 3 Click the row with the service offering that you want to delete.
Step 4 Click Delete.
Step 5 On the Service Offering screen, click Delete.

Tenant Profiles
Tenant profiles represent the pairing of one or more service offerings with one or more resource groups. Each
tenant profile defines the characteristic of infrastructure requirements and application requirements.
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You can create a tenant profile to meet each possible combination of customer and application. You can
associate a tenant profile with multiple service offerings and choose a resource group for each service offering.
A tenant profile can be shared by more than one tenant.

Adding a Tenant Profile

Before you begin

If the DR service support is enabled for the tenant profile, the resources that satisfy the following are displayed
for choosing a resource group for a specific service offering:

• The DR service is enabled.

• The resource group is configured as primary.

• The primary resource group is mapped with the secondary resource group.

• The primary and secondary resource groups have same number of accounts.

• The resources required for the tenant are available in both the primary and secondary resource groups.

For more information on how to enable DR service and set the resource group as primary or secondary, see
Adding a Resource Group, on page 227.

Step 1 Choose Policies > Resource Groups.
Step 2 On the Resource Groups page, click Tenant Profile.
Step 3 Click the row with a tenant profile and click View to view the name, description, and service offering of the tenant

profile with the resource limit added to the tag.
Step 4 Click the row with a tenant profile and click View Details to view the tenants that are associated with a tenant profile.

The name, resource group, service offering, APIC account, service request ID, and customer assigned for the tenants
in the tenant profile are displayed.

Step 5 Click the row with a tenant and click View Details to view the service offering.
Step 6 Click the row with a service offering and click View Details to view the resource entity of a tenant.
Step 7 Click Add.
Step 8 On the Add Tenant Profile screen, complete the following fields:

DescriptionName

The name of the tenant profile.

Once specified, you cannot edit the name of the profile.

Name field

The description of the tenant profile.Description field

Check to enable the disaster recovery service support for
the tenant profile. If checked, the tenant is allocated with
resources from both the primary resource group and the
secondary resource group.

Enable DR check box
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DescriptionName

The service offerings to be associated with the tenant
profile.

Expand Service Offering , check the service offering that
you want to use, and then click Validate. The service
offerings are displayed based on the matching resource
group availability. To create a new service offering, click
the + icon. For more information about how to create a
service offering, see Adding a Service Offering, on page
240.

If you receive an error message instead of the
service offerings list, take action according to
the error message. For more details, see
Troubleshooting a Service Offering List, on
page 251.

Note

Service Offering field

Choose how the resource group selection will be made for
the tenant profile:

• Admin Selection—The resource group is selected
by the administrator.

• ResourceGroupTag based selection—The resource
group is selected based on the tag.

Resource Group Selection drop-down list

Step 9 Click Next.
Step 10 Expand Resrouce Group and click the Add (+) icon to choose a resource group for a specific service offering. For

each service offering selected for the tenant profile, you can select the resource group.

The resource groups that match the specified requirement of the tenant profile are displayed.

If there is no matching resource group for the resource requirements defined in a service offering, Cisco UCS
Director will not list any resource group.

Note

Step 11 Click Submit.

Troubleshooting a Service Offering List
While creating a tenant profile, you associate a tenant profile with multiple service offerings. The service
offerings list is displayed based on the matching resource group availability. If you receive an error message
instead of the service offerings list, take action according to the error message.

For example, on receiving the error message: Host is not mounted on UCS servers, check for the following:
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Procedure

PurposeCommand or Action

Verify that the Cisco UCS server is managed by Cisco UCS
Director. To check the status of the Cisco UCS servers,

Step 1

choose Physical > Compute, choose the Cisco UCS
Manager account, and click theUCSDiscovered Servers.

Verify that the vCenter account and Cisco UCS Manager
account are in the same resource group, and host in the

Step 2

vCenter account is mounted on the Cisco UCS Manager
account.

Verify that the Cisco UCS Manager accounts that are
available in Cisco UCS Director each have a unique IP

Step 3

address. If more than one account exists with the same IP
address, remove one of the accounts that is not part of the
resource group.

Cloning a Tenant Profile

Step 1 Choose Policies > Resource Groups.
Step 2 On the Resource Groups page, click Tenant Profile.
Step 3 Click the row with the tenant profile that you want to clone.
Step 4 Click Clone.
Step 5 On the Clone Tenant Profile screen, complete the following fields:

DescriptionName

The name of the tenant profile.Name field

The description of the tenant profile.Description field

The service offerings to be associated with the tenant profile.

Expand Service Offering, check the service offering you
want to use, and then click Validate. The service offerings
are displayed based on the matching resource group
availability. To create a new service offering, click the +
icon. For more information about how to create a service
offering, see Adding a Service Offering, on page 240.

If you receive an error message instead of the
service offerings list, take action according to
the error message. For more details, see
Troubleshooting a Service Offering List, on page
251.

Note

Service Offering field
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DescriptionName

Choose how the resource group selection will be made for
the tenant profile:

• Admin Selection—The resource group is selected by
the administrator.

• Resource Group Tag based selection—The resource
group is selected based on the tag.

Resource Group Selection drop-down list

Step 6 Click Next.
Step 7 Expand Resource Group and click the Add (+) icon to choose a resource group for a specific service offering. For each

service offering selected for the tenant profile, you can select the resource group.

The resource groups that match the specified requirement of the tenant profile are displayed.

If there is no matching resource group for the resource requirements defined in the service offering, Cisco UCS
Director will not list any resource group.

Note

Step 8 Click Submit.

Editing a Tenant Profile

Step 1 Choose Policies > Resource Groups.
Step 2 On the Resource Groups page, click Tenant Profile.
Step 3 Click the row with the tenant profile that you want to edit.
Step 4 Click Edit.
Step 5 On theModify Tenant Profile screen, complete the following fields:

DescriptionName

The name of the tenant profile.

Once specified, you cannot edit the name of the profile.

Name field

The description of the tenant profile.Description field
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DescriptionName

The service offerings to be associated with the tenant profile.

Expand Service Offering, check the service offering you
want to use, and then click Validate. The service offerings
are displayed based on the matching resource group
availability. To create a new service offering, click the +
icon. For more information about how to create a service
offering, see Adding a Service Offering, on page 240.

If you receive an error message instead of the
service offerings list, take action according to
the error message. For more details, see
Troubleshooting a Service Offering List, on page
251.

Note

Service Offering field

Choose how the resource group selection will be made for
the tenant profile:

• Admin Selection—The resource group is selected by
the administrator.

• Resource Group Tag based selection—The resource
group is selected based on the tag.

Resource Group Selection drop-down list

Step 6 Click Next.
Step 7 Expand Resource Group click the Add (+) icon to choose a resource group for a specific service offering. For each

service offering selected for the tenant profile, you can select the resource group.

The resource groups that match the specified requirement of the tenant profile are displayed.

If there is no matching resource group for the resource requirements defined in the service offering, Cisco UCS
Director will not list any resource group.

Note

Step 8 Click Submit.

Deleting a Tenant Profile

You cannot delete a tenant profile that is in use.Note

Step 1 Choose Policies > Resource Groups.
Step 2 On the Resource Groups page, click Tenant Profile.
Step 3 Click the row with the tenant profile that you want to delete.
Step 4 Click Delete.
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The tenant profile is deleted after confirmation.
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C H A P T E R 12
Managing Catalogs

This chapter contains the following sections:

• About Managing Catalogs, on page 257
• Publishing a Catalog, on page 258
• About Publishing Advanced Catalogs, on page 265
• Publishing Advanced Catalogs, on page 265
• Creating a Bare Metal Server Catalog, on page 266
• Reordering Catalogs Within a Folder, on page 268
• Accessing Hosts for Deployment, on page 268
• Reordering Catalog Folders, on page 269

About Managing Catalogs
You can self-provision virtual machines (VMs) and bare metal (BM) servers using predefined catalog items.
Only a system administrator can create a catalog. A catalog defines parameters, such as the cloud name and
the group name to which the VM is bound.

The following folders are available by default. You cannot edit or delete them.

• Standard

• Advanced

• Service Container

• Bare Metal

To aid in managing catalogs, Cisco UCS Director allows you to group similar catalogs within a folder. While
creating a catalog, you can choose to add it in a previously created folder, or create a new folder. A folder is
visible in the system only when it contains a catalog.

TheManage Folder option on the Catalog page allows you to perform the following tasks:

• Edit a folder—Modify the name of a user-created folder or the folder icon for all folders. You cannot
modify the name of a default folder.

• Delete a folder—Delete a folder from Cisco UCS Director. If this folder contains catalogs, then these
catalogs are automatically moved into the folders that are available by default, based on the catalog type.

Default folders cannot be deleted.
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• Re-order the list of folder—Change the order in which the folders are listed in the Catalog page. By
default, folders are listed alphabetically.

If you have upgraded Cisco UCS Director to the latest version, then all catalogs created in prior versions are
grouped into folders available by default, based on their catalog types.

By default, catalogs are displayed in a tile view format. You can choose to have the catalogs displayed in a
table view format as well. Use the options on the far right of the screen to switch between the table view and
the tile view format. In the table view format, you can use the options to expand or collapse all folders.

Important

Publishing a Catalog

Step 1 Choose Policies > Catalogs.
Step 2 On the Catalogs page, click Add.
Step 3 On the Add Catalog screen, choose the Catalog Type that you want to add.

It can be one of the following:

• Standard—Used to create catalogs for VM provisioning, using images from a list of clouds.

• Advanced—Used to publish orchestration workflows, such as catalog items.

• Service Container—Used to publish application containers as catalog items.

• Bare Metal—Used to create catalogs for bare metal server provisioning.

For information on how to create a bare metal catalog, see Creating a Bare Metal Server Catalog, on page 266.

Step 4 Click Submit.
Step 5 On the Add Catalog: Basic Information screen, complete the required fields, including the following:

DescriptionName

Enter a name for the catalog.

After created, a catalog name cannot be
modified.

Note

Catalog Name field

Enter a description of the catalog.Catalog Description field

Displays the type of catalog you previously chose. To
change the catalog type, you need to cancel and restart this
procedure.

Catalog Type drop-down list

Choose from a list of icons to associate this catalog with
an image. This icon is seen when you are creating a service
request using this catalog.

Catalog Icon drop-down list
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DescriptionName

Check the box to enable all groups to use this catalog.
Leave it unchecked to deny its use to other groups.

Applied to all groups check box

Enter the email address of the support contact who is
notified when a service request is created using this catalog
item.

Support Contact Email Address field

Click Select to the check the checkboxes of specific user
groups. The checked groups use this catalog to provision
new VMs. After checking the checkboxes of user groups,
click Select to return to the Add Catalog screen.

Selected Groups list

By default, this box is checked. Uncheck this box if you
do not want this catalog to be visible to users. If you do
not uncheck this box, then this catalog is visible to the
users of the system.

Publish to end users check box

Choose the cloud with the image for VM provisioning.Cloud Name drop-down list

Check this box to clone a new VM from a selected image.
If you do not check this check box, a blank VM is created.

Provision new VM for ISO mounting check box

Click Select to the check the checkboxes of the type of
image (any existing templates such as Windows, Linux,
and other files that make up the image) to use when VMs
are provisioned using this catalog. After checking the
checkboxes of the required images, click Select to return
to the Add Catalog screen.

If you are a group administrator, or a user in a group with
permissions to create catalogs, this field displays images
that are assigned to the group to which you belong.

If you are an MSP administrator, then this field displays
images that are assigned to your MSP organization, and
to the groups within the MSP organization.

Image list

Check this box to ensure that the new VM is provisioned
using the Content Library VM Template.

If you choose this option, the Image list is hidden.

Provision new VM using Content Library VM
Template check box

Choose the content library VM template.Content Library VM Template list

Enter the Windows License.

This field appears only when aWindows image
is chosen. This option is not supported in the
RHEV KVM Connector.

Note

Windows License Pool field
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DescriptionName

Check the box to ensure that VMs are deployed using
ReadyClones.

When this box is checked, the Use Linked Clone and
Provision all disks in single datastore check boxes are
not available for editing.

This checkbox is not visible if:

1. The selected image is not on the HX
datastore.

2. The VM has multiple disks.

Note

Use ReadyClone check box

Check the box if you want to use a linked clone.

Linked Clone or Full Clone depends on the Linked Clone
selection in the Storage Policy.

This field appears only when a Snapshot image
is chosen.

Note

Use Linked Clone check box

Check the box to provision all disks in a single datastore.
You can also choose to use the datastores configured for
each disk in the storage policy.

This field appears only if the chosen template
has multiple disks. This option is not supported
in the RHEV KVM Connector.

Note

Provision all disks in single datastore check box

Choose the template from the list.

This field appears only when the chosen Catalog
Type is Service Container.

Note

Service Container Template Name drop-down list

Choose the folder within which this catalog must be
created.

The drop-down list includes names of folders
that are available by default. You can either
choose a folder that is available, or clickCreate
New Folder.

On theAddNew Folder screen, enter a Folder
Name, choose a Folder Icon, and click Add.

Note

Select Folder drop-down list

This field appears only when the chosen Catalog
Type is Bare Metal.

NoteBare Metal Server Provisioning Policy drop-down list

Check this box to enable the user to set the support email
for sending service request status.

Configure Service Request Support Email check box
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Step 6 Click Next.
Step 7 On the Add Catalog: Application Details screen, complete the required fields, including the following:

DescriptionName

Expand the list to choose a VDC category and click Select.Category list

Check the box to enable the user to override the selected
category while provisioning a VM using a service request.

Override check box

Enter the email address of the contact who is notified when
a service request is created using this catalog item.

Support Contact Email Address field

Choose the type of OS installed on the VM when it is
provisioned.

This option is not supported in the RHEVKVM
Connector.

Note

Specify OS drop-down list

Enter an OS that is not available in the Specify OS
drop-down list.

This option is not supported in the RHEVKVM
Connector.

Note

Specify Other OS field

Check the appropriate boxes to specify applications that
are installed on the VM during provisioning.

This option is not supported in the RHEVKVM
Connector.

Note

Specify Applications check boxes

Enter other applications that are not available from the
Specify Applications check boxes.

This option is not supported in the RHEVKVM
Connector.

Note

Specify Other Applications field

Enter an application code that is used in the VM name.

The application code can be between 1 to 4 characters (for
example: W2K3, DB, WS). The application code can be
used in a system policy for the VM name by using the
variable ${APPCODE}.

For example, if the VM Name Template is
vm-${GROUP_NAME}-${APPCODE}, the VM
provisioned with the system policy has the name
vm-groupname-W2K3.

This option is not supported in the RHEVKVM
Connector.

Note

Application Code field

Step 8 Click Next.
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Step 9 On the Add Catalog: User credentials screen, complete the required fields, including the following:

These options are not supported in the RHEV KVM Connector.Note

DescriptionName

Choose to allow or disallow users to retrieve VM access
credentials (shared). The following options are available:

• Do not share

• Share after password reset

• Share template credentials

The Do not share option is chosen if the administrator
wants to send the credentials privately to another user
outside Cisco UCS Director.

Credential Options drop-down list

Enter the user ID.

This field is available only if a choice is made
to share under Credential Options.

Note

User ID field

Enter the password.

This field is available only if a choice is made
to share under Credential Options.

Note

Password field

Step 10 Click Next.
Step 11 On the Add Catalog: Customization screen, complete the required fields, including the following:

DescriptionName

Check the box to enable automatic guest customization.

If you do not check this check box, then Cisco UCS
Director does not configure the DNS, Network, and Guest
OS properties.

Automatic Guest Customization Enable check box

Check the Enable check box to enable execution of an
orchestration workflow before VM provisioning.

Pre Provisioning Custom Actions Enable

Click Select to check the compound workflow that should
be used in the orchestration workflow before VM
provisioning.

Check the check boxes of the required workflows, and
click Select to return to the Add Catalog screen.

This field appears when Pre Provisioning
Custom Actions Enable is checked.

Note

Workflow field

Check the box to enable execution of an orchestration
workflow after VM provisioning.

Post Provisioning Custom Actions Enable check box
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DescriptionName

Click Select to check the check boxes of the workflows
that need to be used in the orchestration workflow after
VM provisioning.

Check the check boxes of the required workflows, and
click Select to return to the Add Catalog screen.

This field appears when Post Provisioning
Custom Actions Enable is checked.

Note

Workflow drop-down list

Check the box to choose storage entries from the Virtual
Storage catalog.

Virtual Storage Catalog Enable check box

Chose a storage entry from the catalog.

This field appears when Virtual Storage
Catalog Enable is checked.

Note

Virtual Storage Catalog drop-down list

Cost Computation

Choose Hourly orMonthly.Charge Duration drop-down list

Enter the cost for the application that is included in the
template.

This option is not supported in the RHEVKVM
Connector.

Note

Active VM Application Cost USD field

Enter the cost to this catalog of a VM in inactive state, per
hour or month.

This option is not supported in the RHEVKVM
Connector.

Note

Inactive VM Application Cost USD field

VM Life Cycle Configuration

Check the box to define a lease time (in days and hours).Lease Time check box

Enter the number of days.

This field appears whenLease Time is checked.Note

Days field

Enter the number of hours.

This field appears whenLease Time is checked.Note

Hours field

Check the box to prevent service users from configuring
a lease time for VMs.

Hide end user lease configuration check box

Check the box to prevent service users from provisioning
VMs at a later time.

Hide end user VM provision later check box
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Step 12 Click Next.
Step 13 On the Add Catalog: VM Access screen, complete the required fields, including the following:

DescriptionName

Check the box to enable web access to the VM. By default,
this check box is unchecked which means that web access
to the VM is disabled.

Web Access Configuration Enable check box

Enter the URL of the VM.

This field appears whenWeb Access
Configuration Enable is checked.

Note

URL field

Enter the label that is defined for this URL.

This field appears whenWeb Access
Configuration Enable is checked.

Note

Label field

Check the box to enable remote desktop access to the VM.
By default, this check box is unchecked, which means that
remote desktop access to the VM is disabled.

Remote Desktop Access Configuration Enable check
box

Enter the IP address of the server for remote access.

This field appears when Remote Desktop
Access Configuration Enable is checked.

Note

Server field

Enter the port number on the server for remote access.

This field appears when Remote Desktop
Access Configuration Enable is checked.

Note

Port field

Enter the label that is defined for this remote access.

This field appears when Remote Desktop
Access Configuration Enable is checked.

Note

Label field

Check the box to enable VMRC console access to the VM.
By default, this check box is unchecked, which means that
the VMRC console access to the VM is disabled.

VMRC Console Configuration Enable check box

Step 14 Click Next.
Step 15 Review the catalog information on the Add Catalog: Summary screen.
Step 16 Click Submit.
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About Publishing Advanced Catalogs
When you choose the Advanced catalog type, you can provision workflow catalogs. End users can execute
workflows with these catalogs during a Service Request. You create an Advanced Catalog Item by defining
parameters such as Group Name and Workflow.

Publishing Advanced Catalogs

Step 1 Choose Policies > Catalogs.
Step 2 On the Catalog page, click Add.
Step 3 In the Catalog Add screen, from the Catalog Type drop-down list, select Advanced.
Step 4 Click Submit.
Step 5 In the Add Catalog screen, complete the required fields, including the following:

DescriptionName

Basic Information Pane

The name of the catalog.Catalog Name field

The description of the catalog.Catalog Description field

Choose Advanced.Catalog Type

Choose the icon to associate this catalog with an image.
The icon is seen when creating a service request using this
catalog.

Catalog Icon drop-down list

Check the check box to enable all groups to use this
catalog. By default, this check box is not checked, which
means that all groups cannot use this catalog.

Applied to all groups check box

The email address of the support contact person.Support Contact Email Address field

Click Select and complete the following:

1. (Optional) Click Check All to choose all of the
categories or click Check None to deselect all
categories.

2. From the Select Items dialog box, check the
appropriate groups to include. The checked groups can
use this catalog to provision new VMs.

3. Click Select to finish your selection of categories.

Selected Groups
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DescriptionName

By default, this check box is checked, which means that
the catalog is available to end users. Uncheck this check
box if you do not want this catalog to be visible to end
users.

Publish to end users check box

Choose the folder within which this catalogmust be created
in.

The drop-down list includes names of folders
that are already available. You can either select
a folder that is available, or click the + icon to
create a new folder.

To create a new folder in the Add New Folder
dialog box, specify a folder name, and select an
icon for the folder.

Note

Select Folder drop-down list

Check this check box to specify the email address to which
the service request status email must be sent to.

Configure Service Request Support Email field

Step 6 Click Next.
Step 7 In the vApp Workflow pane, clickWorkflow Select.
Step 8 In the Select pane, check the check box next to the appropriate workflow.
Step 9 Click Select.
Step 10 Review the catalog information on the Summary page.
Step 11 Click Submit.

Creating a Bare Metal Server Catalog
Before you begin

You should have created a bare metal provisioning policy.

Step 1 Choose Policies > Catalogs.
Step 2 On the Catalog page, click Add.
Step 3 In the Add Catalog screen, choose Bare Metal as the Catalog Type.
Step 4 Click Submit.
Step 5 In the Add Catalog screen, complete the required fields, including the following:

DescriptionName

Basic Information pane
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DescriptionName

Enter a name of the catalog.

Once created, a catalog name cannot be
modified.

Note

Catalog Name field

Enter a description of the catalog.Catalog Description field

This field cannot be edited. It displays Bare Metal.Catalog Type drop-down list

Choose from a list of icons to associate this catalog with
an image. This icon is seen when you are creating a service
request using this catalog.

Catalog Icon drop-down list

Check the check box to enable all groups to use this
catalog. Leave it unchecked to deny its use to other groups.

Applied to all groups check box

Specify the email address of the support contacts.

These users will receive email notifications on the status
of the bare metal server provisioning using the catalog.

This notification email is also sent to the user
who initiates the bare metal server provisioning.

Note

Support Contact Email Addresses field

Check the check boxes for included groups that are from
the Select Items dialog box. The checked groups use this
catalog to provision new bare metal servers.

Selected Groups check box list

By default, this check box is checked. Uncheck this check
box if you do not want this catalog to be visible to end
users. If you do not uncheck this check box, then this
catalog is visible to the end users of the system.

Publish to end users check box

Choose the folder within which this catalog must be
created.

The drop-down list includes names of folders
that are available by default. You can either
select a folder that is available, or click the +
icon to create a new folder.

To create a new folder in the Add New Folder
dialog box, specify a folder name, and select an
icon for the folder.

Note

Select Folder drop-down list

Choose a bare metal provisioning policy.Bare Metal Server Provisioning Policy drop-down list

By default, this check box is unchecked. Check this check
box to specify an email address to which the status of the
service request must be emailed to.

Configure Service Request Support Email check box

Step 6 Click Next.
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Step 7 In the Bare Metal Workflow pane, click Select to choose a bare metal server provisioning workflow.

To create a bare metal workflow, you will need to include the following set of tasks at a minimum:

• The Bare Metal Provisioning wrapper

• Select UCS Server

• Create UCS Service Profile from Template

• Associate UCS Service Profile

• Setup PXE Boot With BMA Selection

• Power On UCS Server

• Monitor PXE Boot

• Modify UCS Service Profile Boot Policy

• Power On UCS Server

• Assign UCS Server to Group

Step 8 Click Next.
Step 9 Review the catalog information in the Summary pane.
Step 10 Click Submit.

What to do next

Using this catalog, you can create a service request for bare metal servers.

Reordering Catalogs Within a Folder
By default the catalogs within a folder are listed alphabetically, but you can customize the order.

Step 1 Choose Policies > Catalogs.
Step 2 On the Catalog page, expand a folder to view the catalogs within it.
Step 3 Select a catalog from the list.
Step 4 Click theMove Up orMove Down options to reorder the catalogs.

Accessing Hosts for Deployment
You can choose a catalog item to assess deployable hosts and provide a reason for hosts that are excluded.
You can determine if you want to run this assessment on all configured VDCs, or on certain specific VDCs.
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Step 1 Choose Policies > Catalogs.
Step 2 On the Catalog page, choose a Catalog Entry to assess.
Step 3 Click Deployability Assessment.
Step 4 In the Select vDC screen, complete the required fields, including the following:

DescriptionField

By default, this check box is checked, which indicates that
this catalog item will be assessed with all VDCs. Uncheck
this check box to select specific VDCs.

Run Assessment Across all VDCs check box

Click Select to check the check boxes of the VDCs against
which you want the catalog item assessed.

The list displays all the vDCs associated with the user group
for the selected catalog.

Select VDC field

Step 5 Click Submit.
Step 6 View the Deployability Assessment report and the click Close.

Reordering Catalog Folders
By default the catalog folders are listed alphabetically, but you can customize the order.

Step 1 Choose Policies > Catalogs.
Step 2 ClickManage Folder.
Step 3 In theManager Folder screen, select a catalog folder and use the arrows to reorder the folders.
Step 4 Click Submit.
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C H A P T E R 13
Using Self-Service Provisioning

This chapter contains the following sections:

• Self-Service Provisioning, on page 271
• Service Requests, on page 271
• Service Request Workflow and Details, on page 281
• About Scheduling a Service Request, on page 285
• About Resubmitting a Service Request, on page 285
• Other Service Request Functions, on page 286
• Service Request Approval Process, on page 289
• Service Request Budgeting, on page 291

Self-Service Provisioning
You can provision virtual machines (VMs) or applications through self-service provisioning. To provision a
VM or an application using self-service provisioning, you must first create a service request. This action
initiates a VM-creation workflow that includes the following:

• Budget validation

• Dynamic resource allocation

• Approval

• Provisioning

• Lifecycle setup

• Notification about the status of service requests

Service Requests
You can use the self-service provisioning feature to create a service request to provision virtual machines
(VMs), services, or applications. The service request process produces a provisioning workflow for VM
creation that includes the following actions:

• Budget validation
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• Dynamic resource allocation

• Approvals

• Provisioning

• Lifecycle setup and notification

If you change the number of CPU Cores or memory allocation while in the Deployment Configuration
screen, the total cost is automatically updated and displayed.

Note

To provision a VM or execute an orchestration workflow, you must first create a service request. If desired,
you can require approval from one or two administrators or designated users before the VM is provisioned
or the workflow executed. VMs can be immediately approved or scheduled to be approved within a maximum
of 90 days from the original request.

Creating a Service Request with Catalog Type—Standard

Step 1 Choose Organizations > Service Requests.
Step 2 On the Service Requests page, click Service Requests.
Step 3 Click Create Request.
Step 4 On the Create Request screen, choose Standard as the catalog type.
Step 5 Click Submit.
Step 6 On the Create Service Request screen, complete the following fields:

DescriptionName

Catalog Selection Request Screen

VM Ownership

Select this radio button to choose the customer organization
for which a VM is provisioned.

Customer Organization radio button

Click Select to choose the customer organizations for
which you want to provision the VM.

Customer organizations that have valid vDCs are displayed.

This field is visible only when you select the
Customer Organizations radio button.

Note

If you chose Create Service Request from the Catalog
screen, then the group list that is displayed is dependent
on the user groups you select in the left pane

Customer Organizations field

Select this radio button to choose the users to whom you
want a VM is provisioned.

User radio button

Cisco UCS Director Administration Guide, Release 6.6
272

Using Self-Service Provisioning
Creating a Service Request with Catalog Type—Standard



DescriptionName

Click Select to choose the users to whom you want to
provision the VM. This list is populated with users from
groups which allow resource assignment to users.

Currently, only VMs that are in a VMware
cloud can be assigned to a specific end user.

Note

If you chose Create Service Request from the Catalog
screen, then the user list that is displayed is dependent on
the user groups you select in the left pane.

User field

VM Access Sharing

Click Select to choose users who can only access VM
information.

The selected users can only access the VM. They cannot
perform any administrative tasks.

Users with Access Privilege field

Click Select to choose users who can only manage the
VM.

The selected users can perform administrative tasks on the
VM.

Users with Manage Privilege field

Displays the catalog type. It can be one of the following:

• Standard

• Advanced

• Service Container

• VDI

Advanced is used for OrchestrationWorkflow.Note

Catalog Type drop-down list

Choose the catalog that is used for VM provisioning.

If you chose Create Service Request from the Catalog
screen, then you cannot select a catalog.

Select Catalog drop-down list

Check this check box to perform an assessment of the
budget allocation, resource limits and resource availability
prior to submitting a service request. After you check this
check box, the summary of the assessment is displayed in
the Deployment Assessment pane.

This option is visible only for VMware catalogs,
and for catalogs that are not ISO-based.

Important

Perform deployment assessment check box

Step 7 Click Next.
Step 8 On the Provisioning Configuration screen, complete the following fields:
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DescriptionName

Choose a vDC for the service request.Select vDC drop-down list

Specify a name for the VM.

If you do not specify a name, the systemwill automatically
generate a VM name.

VM Name field

Click Select to choose a Guest OS for the service request.Guest OS field

Choose the number of vCPUs from the drop-down list.

This field is populated and editable only if you checked
Allow Resizing of VM while creating the VMware
computing policy.

Number of vCPUs drop-down list

Choose the memory capacity from the drop-down list.

This field is populated and editable only if you checked
Allow Resizing of VM while creating the VMware
computing policy.

Memory drop-down list

Click Select to choose an application category that is
different from the one specified while creating the catalog.

Category field

Step 9 Click Next.
Step 10 On the Deployment Configuration screen, complete the following fields:

DescriptionName

The VDC on which the VM is provisioned.

VDCs are defined by the administrator.

Select VDC drop-down list

The VM name or prefix.VM Name or VM Prefix field

Any comments relating to the deployment configuration.Comment field

Choose either Now or Later.

Choose Now to set provisioning for any time within the
next 90 days. When you choose Later, a calendar for the
Day, drop-down lists for the Hour and Minute, and radio
buttons for AM or PM appear.

Provision drop-down list

The number of days after which the VM is terminated.

This option appears when PowerOFF the VM
After is checked.

Note

Days calendar

Choose the number of hours after which the VM is
terminated.

This option appears when PowerOFF the VM
After is checked.

Note

Hours drop-down list
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DescriptionName

Choose the number of minutes after which the VM is
terminated.

This option appears when PowerOFF the VM
After is checked.

Note

Minutes drop-down list

Check to indicate that a lease time is configured for the
VM.

Lease Time check box

Default Cost Computation Period Settings

If you checked the Disable displaying cost
details check box while adding or modifying
the VDC, then this information is not displayed.

Important

Choose a duration for which the cost is calculated. By
default, this duration is set toMonthly.

Charge Duration drop-down list

Specify the number of months to be included in the cost
computation

This field is displayed only when you select
Monthly in the Charge Duration drop-down
list.

Note

Month field

Specify the number of days to be included in the cost
computation

This field is displayed only when you select
Daily in the Charge Duration drop-down list.

Note

Day field

Specify the number of hours to be included in the cost
computation

This field is displayed only when you select
Hourly in the Charge Duration drop-down
list.

Note

Hours field

Step 11 Click Next.
Step 12 On the Custom Specification screen, complete the following fields:

DescriptionName

Choose the CPU cores for the VM being provisioned.

This list opens if the resizing option is chosen
on the Computing Policy screen.

Note

CPU Cores drop-down list
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DescriptionName

Choose the cores per socket for the VM being provisioned.
The number of cores per socket available is specified in
the VM computing policy.

The values displayed are based on the VM computing
policy and the CPU count selected. The values in theCores
Per Socket drop-down list are divisors of the CPU count.
For example, if the CPU count is 4, and the allowed sockets
per core specified in the VM computing policy are 1, 2, 3,
and 4, the Cores Per Socket drop-down list displays 1, 2,
and 4 as available options.

Cores Per Socket drop-down list

Choose the amount of memory for the VM being
provisioned.

This list opens if the resizing option is chosen
on the Computing Policy sreen.

Note

Memory drop-down list

Displays an approximate SR cost based on the values you
provided in the Default Cost Computation Period
Settings fields.

If you checkedDisable displaying cost details
while adding or modifying the VDC, then this
information is not displayed.

Important

Approximate SR Cost Estimate field

Choose an option to customize storage entries for the VM
being provisioned.

This custom list opens if the Virtual Storage
Catalog was enabled when the chosen catalog
was created.

See more information about the creation of a
virtual storage catalog in Policies, on page 169.
Seemore information about enabling this option
during catalog creation in About Managing
Catalogs, on page 257.

Note

Storage Tier drop-down list

Choose the preferred hard disk size for VM provisioning.
The list of available datastores depends upon the scope
conditions specified in the storage policy. You can enable
or disable this option in the storage policy.

Choose a disk from the table, and click the pencil icon to
select a datastore.

You can edit the size of the disk if you have
enabled the Allow Resizing of Disk option in
the storage policy.

Note

Disk Datastores table
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Step 13 To choose a datastore for a disk, choose a disk from the list and click the Pencil icon.
Step 14 Click Select to view available datastores.
Step 15 Choose a datastore from the list and click Select.
Step 16 Click Submit.
Step 17 (Optional) For templates with multiple disks, you must choose a datastore for each disk.
Step 18 On the Custom Specification screen, click Select to view available VM Networks.

This option is available only if Allow end user to select optional NICs or Allow end user to choose
portgroups are checked in the network policy associated with the VDC selected for this VM provisioning
service request. For more information, see Adding a Network Policy, on page 191.

Note

Step 19 Choose a VM Network from the list and click Select.
Step 20 Click Next.
Step 21 Complete the details on the Custom Workflow screen.

Custom workflow inputs apply if the catalog chosen for VM provisioning has Post Provisioning Custom
Actions enabled. In this procedure, the post-provisioning workflow allows users to specify custom inputs.

Note

Step 22 Click Next.

The list of available datastores depends upon the scope conditions specified in the storage policy. You can
choose only one datastore for each disk category (System, Data, Database, Swap, and Log).

Note

Step 23 Required: If you checked Perform deployment assessment, then review the report of the assessment displayed on the
Deployment Assessment screen.

If this assessment report identifies errors, then you must return to the previous panes and rectify the errors before
submitting the request. If the assessment report shows no errors, then click Next.

Step 24 Review the summary for the service request.
Step 25 Click Submit.

Creating a Service Request with Catalog Type—Advanced
By choosing the advanced catalog type during the creation of a service request, you can execute orchestration
workflows. The steps for creating an advanced catalog are much the same as those for creating a standard
catalog.

Step 1 Choose Organizations > Service Requests.
Step 2 On the Service Requests page, click Service Requests.
Step 3 Click Create Request.
Step 4 In the Create Request screen, choose Advanced as the catalog type.
Step 5 Click Submit.
Step 6 On the Catalog Selection screen, choose the Group, Catalog Type (Advanced), and the Catalog (workflow).
Step 7 Click Next.
Step 8 On the Custom Workflow screen, provide the custom workflow input values.
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If you want to provision a VM using this service request, then you must select a standard catalog in this screen. If you
select an advanced catalog, then VM provisioning will fail.

Step 9 Click Next.
Step 10 Review the summary of the service request.

All information that you entered in the previous screens is displayed in this summary screen.

While provisioning a VM with a service request using an advanced catalog, be sure to have included the
following information while creating the service request:

• Include the following workflow tasks in the VM provisioning workflow:

• VMware VM Provision Inputs

• Resource Allocation Configuration

• VM Provision Engine

• Include the following custom workflow inputs of respective input types:

• vDC

• Catalog or image

• The Disable displaying cost details check box is not checked.

If all of these conditions are met, the summary screen of the service request will display the approximate
service request cost.

Note

Step 11 Click Submit.

Creating a Service Request with Catalog Type—Bare Metal

Before you begin

You should have created a bare metal catalog, and a provisioning policy.

Step 1 Choose Organizations > Service Requests.
Step 2 On the Service Requests page, click Service Requests.
Step 3 Click Create Request.
Step 4 On the Create Request screen, choose Bare Metal as the catalog type.
Step 5 Click Submit.
Step 6 On the Create Service Request screen, complete the required fields, including the following:

DescriptionName

Catalog Selection pane
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DescriptionName

Select a user group from the list of groups that already
exist in the system.

Select Group drop-down list

You cannot edit this field. It displays Bare Metal.Catalog Type drop-down list

Select a catalog from the drop-down list. It displays the
list of bare metal catalogs you created.

Select Catalog drop-down list

Check to run a deployment assessment with the specified
information.

Perform Deployment Assessment check box

Step 7 Click Next.
Step 8 On the Bare Metal Deployment Configuration screen, complete the required fields, including the following:

The following table lists the fields displayed for Cisco UCS Manager accounts.

DescriptionName

While creating the bare metal provisioning policy, if you
checked Allow Users to Select Servers, then you can use
this drop-down list to choose the servers on which you
want the server provisioned.

After you select a server, resource information such as
CPU, memory and Storage details displayed. This
information is displayed only if you checked Show Server
Resources to User while creating the bare metal server
provisioning policy.

If you did not check Allow Users to Select
Servers, then this field is not editable. It is
populated with the server name that matches
the criteria specified in the provisioning policy.

Note

Server drop-down list

Choose a duration for which the cost is calculated. By
default, this duration is set toMonthly.

Charge Duration drop-down list

Specify the number of months to be included in the cost
computation.

This field is displayed only when you select
Monthly in the Charge Duration drop-down
list.

Note

Month field

Specify the number of days to be included in the cost
computation.

This field is displayed only when you select
Daily in the Charge Duration drop-down list.

Note

Day field
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DescriptionName

Specify the number of hours to be included in the cost
computation.

This field is displayed only when you select
Hourly in the Charge Duration drop-down
list.

Note

Hours field

Click the Compute SR Cost Estimate option to view the
cost estimate. This cost estimate calculated based on the
information that you have entered on this screen.

Approximate SR Cost Estimate field

If a cost model is not associated with the provisioning policy, then all cost-related fields such as Charge
Duration, and the Approximate SR Cost Estimate fields are not displayed. If a cost model is associated
with the policy, then these fields are displayed.

Attention

If you are creating a service request for Cisco UCS Central accounts, complete the required fields, including the
following:

DescriptionName

You can choose a domain group. The available groups are
determined by the domain groups selected in the bare metal
server provisioning policy.

Domain Group drop-down list

This list displays the domain names that were selected in
the bare metal server provisioning policy.

Domain Name drop-down list

This list displays the servers that are available in the chosen
domain name.

Server drop-down list

Displays the CPU details.CPU field

Displays memory information.Memory field

Displays storage-related information.

This field is not editable.

Storage field

Choose an OS image from the drop-down list.

This field is populated based on the domain mapping
parameters specified in the bare metal server provisioning
policy. By default, Target BMA and OS Image selected
in the policy are used for provisioning. However, if you
have specified any domain mapping parameters in the
policy, then the OS image selected in the mapped domains
takes preference over the default images.

OS image drop-down list

Step 9 On the Custom Workflow screen, specify a Service Profile name.
Step 10 Click Next.
Step 11 Review the deployment assessment summary for the service request.
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This information is displayed only if you checked Perform deployment assessment on the Catalog Selection screen.

Step 12 Review the summary for the service request.
Step 13 Click Submit.

What to do next

After you click Submit, the workflow is triggered, and the bare metal servers are provisioned. After the
workflow is completed, the bare metal server is displayed in the selected group. In addition, the chargeback
cycles are initiated for the servers.

If you want to change the cost model for the server, then you must edit the cost model selection in the bare
metal provisioning policy.

Service Request Workflow and Details
After you create a service request, you can check its status and workflow, cancel the request, resubmit the
request, and so on. These actions are controlled by the toolbar buttons at the top of the service request lists.

Service Request Workflow
TheWorkflow Status box displays details about the service request and the workflow steps. A typical service
request workflow to provision a VM includes the following steps:

1. Initiation—Service request is initiated by the user.

2. Resource Allocation—Required resources, such as virtual compute, are allocated to the VM.

3. Approval—VM provisioning is approved, if required. During this step, an email is sent to the approvers
defined in the catalog chosen for VM provisioning. If you selected user groups for approval, then an email
is sent to all users in the selected groups.

4. Provision—VM is created and provisioned.

5. Set Up Lifecycle Schedule—Lifecycle scheduling is configured with the setup, scheduled times, and
termination times.

6. Notify—User is notified by email that the VM has been created and provisioned.

Following is a graphical representation of the workflow.
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Figure 4: Catalog Service Request Workflow

Optional service request workflow steps include Budget Watch and Check Resource Limits:

• BudgetWatch—An administrator has to enable budgeting for a group. This step determines if a sufficient
budget is available for provisioning a new VM in that group.

• Check Resource Limits—Resource limits for a group must be enabled by an administrator. This step
determines if sufficient resources are available for provisioning a new VM in that group.

Any user who has been assigned the Read-Group Service Request permission can view the progress of a
service request.
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Service Request Details
Service Request details include items under Overview, Ownership, Catalog Information, and the Current
Status of the service request, as follows:

DescriptionName

Overview

The service request ID number.Request ID

The type of request (in this case, creating a VM).Request Type

The VDC where the VM is provisioned.VDC

The image from which the VM is provisioned.Image

The time of the service request creation.Request Time

The status of the service request as Complete,
Canceled, Failed, and so on.

Request Status

Any comments.Comments

Ownership

The group to which the service request initiating user
belongs.

Group

The user who has initiated the service request.Initiating User

The amount of time that the VM is active. If this time
is defined, the VM is deleted after the specified time.

Duration Hours

The time at which the VM is provisioned. If defined,
the VM is provisioned at 6 a.m. on the scheduled date.
If not defined, the VM is provisioned when the
workflow steps for the service request are complete.

Scheduled Time

Catalog Information

The email ID provided by the administrator when
creating a VDC.

VDC Owner Email

The user (if defined) who must approve the service
request for VM provisioning.

Approving Users

The catalog item name from which the VM is
provisioned.

Catalog Name

The catalog item description.Catalog Description

The cost (projected) of provisioning the VM. This
cost is determined based on the Cost Model that is
defined for the catalog item.

Service Request Cost
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You can view the status of each workflow step. Details such as warning or error messages and the time of the
request are also displayed. The workflow steps are color-coded to indicate their status:

DescriptionColor Code

The step is incomplete.Gray

The step completed successfully.Green

The step failed. The reason for failure is also
described.

Red

More input is required for the step to complete. For
example, an approver was defined for a service
request, and until the request is approved, this step is
incomplete.

Blue

Approvers may look under the Approvals tab to see their assigned service requests.Note

Viewing the Workflow Status of a Service Request

Step 1 Choose Organizations > Service Requests.
Step 2 Choose a user group.

The default is All User Groups, which lists all service requests.

Step 3 On the Service Requests page, click Service Requests.
Step 4 Click the row with the service request for which you want to view the workflow status.
Step 5 Click View Details and clickWorkflow Status to see the details and status of the service request.

Viewing Log Details for a Service Request

Step 1 Choose Organizations > Service Requests.
Step 2 Choose a user group.

The default is All User Groups, which lists all service requests.

Step 3 On the Service Requests page, click Service Requests.
Step 4 Click the row with the service request for which you want to view the service request log.
Step 5 Click View Details, and click Log.
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About Scheduling a Service Request
You can schedule VM provisioning for a later date using Deferred Provisioning. The default provisioning is
at 8.30 a.m. on the date of scheduling. Once a new date is set, the VM provisioning status in the workflow
displays the change.

Scheduling Service Requests

Step 1 Choose Organizations > Service Requests.
Step 2 On the Service Requests page, click Service Requests.
Step 3 Click Create Request.
Step 4 Choose the group, catalog type, and catalog. See Creating a Service Request with Catalog Type—Standard, on page 272.
Step 5 Click Next.
Step 6 Choose the Later option for the Provision field, and the provisioning date on the Service Request screen.
Step 7 Click Next until the Summary screen appears.
Step 8 Click Submit.

About Resubmitting a Service Request
You can resubmit a failed service request. A service request could fail for the following reasons:

• Budget limit (if defined by administrator) is exceeded for the group under which the VM is being
provisioned.

• Resource limits (if defined by administrator) are exceeded for the group under which the VM is being
provisioned.

• Provisioning could fail if a service request lacks relevant information.

When a service request is resubmitted, the process starts again from the workflow step that failed in the earlier
submissions. For example, if a service request fails in the Resource Allocation workflow (Step 2), when this
service request is resubmitted, the process is re-initiated from that step.

Resubmitting a Service Request

Step 1 Choose Organizations > Service Requests.
Step 2 Choose a user group.

The default is All User Groups, which lists all service requests.

Step 3 On the Service Requests page, click Service Requests.
Step 4 Click the row with the service request to that you want to resubmit.
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Step 5 Click Resubmit Request.

Other Service Request Functions

Canceling a Service Request
As an administrator in the system, you can cancel any service request that has been created. If you are anMSP
admin, or a group admin, you can cancel service requests that you have created, and those created by users
in member groups that you manage.

Step 1 Choose Organizations > Service Requests.
Step 2 Choose a user group.

The default is All User Groups, which lists all service requests.

Step 3 On the Service Requests page, click Service Requests.
Step 4 Click the row with the service request that you want to cancel.
Step 5 Click Cancel Request.
Step 6 Click Submit to cancel the service request.

Rolling Back a Service Request
You can roll back a service request when a service request is created using orchestration workflow or fenced
container deployment.

Step 1 Choose Organizations > Service Requests.
Step 2 Choose a user group.

The default is All User Groups, which lists all service requests.

Step 3 On the Service Requests page, click Service Requests.
Step 4 Click the row with the service request that you want to roll back.
Step 5 From theMore Actions drop-down list, choose Rollback Request.
Step 6 On the Rollback Service Request screen, select the tasks in the service requests that must be rolled back.

By default, all of the tasks in the service request are checked.

Step 7 (Optional) Check Abort rollback, if any rollback task fails.
Step 8 Click Submit.
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Archiving a Service Request

Step 1 Choose Organizations > Service Requests.
Step 2 Choose a user group.

The default is All User Groups, which lists all service requests.

Step 3 On the Service Requests page, click Service Requests.
Step 4 Click the row with the service request that you want to archive.
Step 5 Click Archive.
Step 6 On the Archive Request screen, click Archive.

On the Service Requests page, you can click Archived Service Requests to view all the archived requests.

What to do next

If you need to use this archived service request at a later time, you can re-instate it. For more information, see
Reinstating an Archived Service Request, on page 289.

Deleting Service Requests
You can delete archived service requests from Cisco UCS Director. The deleted service requests are removed
permanently from Cisco UCS Director.

You can enter archived service requests to delete in one of two ways:

• By selecting the service requests on theArchived Service Requests screen and clickingDelete Requests.

• By clicking Purge Requests and entering the IDs of the archived service requests.

Both methods result in the permanent removal of the specified service requests. The only difference is the
method of data entry.

You can delete only archived service requests. For information about archiving service requests, see the current
release of the Cisco UCS Director Administration Guide. Because active service requests cannot be archived,
you cannot delete service requests that are in progress, or that contain child service requests that are in progress.

You also cannot delete a service request that has a rollback that is in progress or that has failed. For example,
say that you submit a rollback for service request (SR) 100 that generates a rollback service request SR 101.
You cannot delete SR 100 while SR 101 is in progress. Furthermore, you cannot delete SR 100 if SR 101
fails.

To delete service requests, do the following:

Step 1 Choose Organizations > Service Requests.
Step 2 On the Service Requests page, click Archived Service Requests.
Step 3 You can either enter service request IDs using the keyboard or choose service requests from the Archived Service

Requests report.
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To enter service request IDs, skip to the next step. To choose service requests instead, do the following:

a) Choose all the service requests that you want to delete.

Select multiple items as you would in any other application on your system. For example, in Windows,
hold down the Ctrl key to choose more items or Shift to choose a range of items.

Note

When you choose one or more service requests, the Delete Request icon appears.

b) Click Delete Request.
c) On the Delete Request screen, click Delete.

Step 4 To enter service requests, do the following:
a) Click Purge Requests.
b) In SR IDs on the Delete Request screen, enter the IDs of the service requests that you want to delete . Use hyphens

to indicate ranges of IDs and commas to separate ranges or individual IDs; for example:101-111, 113, 116-118.
c) Click Delete.

Viewing Service Requests for a Particular Group

Step 1 Choose Organizations > Service Requests.
Step 2 Choose a user group.

The default is All User Groups, which lists all service requests.

Step 3 On the Service Requests page, click Service Requests.

All of the service requests for the selected user group are displayed.

Searching the Records of Service Requests for a Group

Step 1 Choose Organizations > Service Requests.
Step 2 On the Service Requests page, click Service Requests.
Step 3 Click Search and Replace.
Step 4 On the Search and Replace screen, enter the search terms in the search fields. You must enter the following information:

• Asset Identity

• Asset Type

• New Asset Identity

• Selected SRs

Step 5 Click Submit.
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Exporting a Report of Service Requests for a Group

Step 1 Choose Organizations > Service Requests.
Step 2 On the Service Requests page, choose the user group.
Step 3 On the Service Requests page, click Service Requests.
Step 4 Click Export Report.
Step 5 On the Export Report screen, choose the report format.

The report format can be PDF, CSV, or XLS.

Step 6 Click Generate Report.

After the report is generated, the Download option appears.

Step 7 Click Download to open the report and to save it on your system.

Reinstating an Archived Service Request

Step 1 Choose Organizations > Service Requests.
Step 2 On the Service Requests page, click Archived Service Requests.
Step 3 Click the row with the service request that you want to reinstate.
Step 4 Click Unarchive.

Service Request Approval Process
Before the VM is provisioned, a service request must be approved by a specified approver or approvers named
in the VDC. You have an option to define one or two approvers for a group.

• Once created, the service request workflow has a step requiring VM approval that displays the name of
the approver.

• A service request notification email is sent to the approvers. Approvers may view all pending requests
under the Approvals tab.

• Once approved is granted, VM provisioning is initiated.

For more information about defining approvers, see Virtual Data Centers, on page 207.Note
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Approving a Service Request

Step 1 Choose Organizations >My Approvals.
Step 2 Click the row with the service request that you want to approve.
Step 3 (Optional) To verify the details, click View Details.

You can view the Workflow and Input/Output information and click Close.

Step 4 Click Approve.
Step 5 Add comments on the Service Request screen if necessary.
Step 6 Click Approve.

Rejecting a Service Request

Step 1 Choose Organizations >My Approvals.
Step 2 Click the row with the service request that you want to reject.
Step 3 (Optional) Verify the details by clicking View Details and then click Close.
Step 4 Click Reject.
Step 5 Add comments on the Service Request screen if necessary.
Step 6 Click Reject.

Viewing Approval Information on Service Requests

Step 1 Choose Organizations >My Approvals.
Step 2 ClickMy Approvals.

All approvals that are either already approved or pending approval are listed.

Searching the Records of Service Request Approvals

Step 1 Choose Organizations >My Approvals.
Step 2 ClickMy Approvals.

All approvals that are either already approved or pending approval are listed.

Step 3 In the Search field, enter your search term.
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The service requests that match the search criteria are displayed.

Exporting a Report of Service Request Approvals

Step 1 Choose Organizations >My Approvals.
Step 2 Click the row with the service request for which you want to export a report..
Step 3 Click Export Report.
Step 4 On the Export Report screen, choose the report format.

The report format can be PDF, CSV, or XLS.

Step 5 Click Generate Report.

After the report is generated, the Download option appears.

Step 6 Click Download to open the report and to save it on your system.

Service Request Budgeting

Viewing the Current Month Budget Availability

Step 1 Choose Organizations > Service Requests.
Step 2 On the Service Requests page, choose the user group.
Step 3 On the Service Requests page, click Current Month Budget Availability.

Viewing Budget Entries

Step 1 Choose Organizations > Summary.
Step 2 On the Summary page, choose the user group.
Step 3 On the Summary page, click Budget Entries.

Adding a Budget Entry

Step 1 Choose Organizations > Summary.
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Step 2 On the Summary page, choose the user group.
Step 3 On the Summary page, click Budget Entries.
Step 4 Click Add.
Step 5 On the Add Budget Entry screen, complete the following fields:

DescriptionName

The name of the budget entry.Entry Name field

The amount of the budget per month.Budget Amount field

Choose the year.Year drop-down list

Choose the month.Month drop-down list

Choose the number of months for the same amount of
budget to repeat.

Repeat Entries drop-down list

Step 6 Click Add.
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C H A P T E R 14
Multiple Disk VM Provisioning

This chapter contains the following sections:

• About Multiple Disk VM Provisioning, on page 293
• Overview of the Procedure for Multiple Disk VM Provisioning, on page 293
• About Templates with Multiple Disks, on page 294
• Assigning Disk Categories, on page 294
• Defining Storage Policies, on page 294
• Creating a Catalog, on page 300
• Creating a VM Disk, on page 307

About Multiple Disk VM Provisioning
Cisco UCS Director supports virtual machine (VM) provisioning of multiple disks from a template. You can
configure VM disk provisioning on a preferred single datastore or on multiple datastores. You can also
configure individual disk policies for each additional disk in a template.

Cisco UCS Director classifies the disks into the following categories:

• System

• Data

• Database

• Swap

• Log

The disk categories that are defined by Cisco UCS Director are for disk labeling only.Note

Overview of the Procedure for Multiple Disk VM Provisioning

Step 1 Check for the availability of a template with multiple disks.
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Step 2 Assign disk categories.
Step 3 Define the storage policy.
Step 4 Create the template catalog.

About Templates with Multiple Disks
To provision a multiple disk virtual machine (VM), a template (image) with multiple disks, must be available.
Before using a template with multiple disks for VM provisioning, you must assign the disk categories for
individual disks.

Assigning Disk Categories

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click Images.
Step 4 Click the row with a template with multiple disks and click View Details.
Step 5 Click Disks.
Step 6 Choose a disk.
Step 7 Click the row with the disk for which you want to assign a disk type and click Assign Disk Type.
Step 8 On the Assign Disk Type screen, choose the disk type from the drop-down list.

It can be one of the following:

• System

• Data

• Database

• Swap

• Log

Step 9 Click Submit.

Defining Storage Policies
A storage policy defines resources such as datastore scope, type of storage to use, minimum conditions for
capacity, and latency. This policy also provides an option to configure additional disk policies for multiple
disks, and an option to provide datastore choices for end users during a service request creation.

Cisco UCS Director supports VM provisioning with multiple disks on multiple datastores. There are five
types of disks: System, Data, Database, Swap, and Log. The System disk policy is configured first, and the
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other disks are configured later depending on the requirements. You can configure the disk policy individually
for each disk type, or choose the default system disk policy.

When using additional disk policies, be sure to uncheck the Provision all disks in a single datastore option
during catalog creation for the multiple disk template. For more information about catalog creation, see Adding
a Catalog, on page 300.

In addition, Cisco UCS Director supports datastore selection during the creation of a service request for VM
provisioning. It gives you an option to enable or disable datastore selection for the end user. When a VDC is
specified at creation of a service request, the scope conditions defined in its storage policy determine which
datastores appear for selection here.

VMware VM provisioning fails when the datastore capacity specified in a storage policy uses the equals
condition for decimal values with two values after the decimal (hundreths place). If specifying a capacity that
includes decimal values, round the value up to one value after the decimal (tenths place).

See the Cisco UCS Director Troubleshooting Guide.

Note

Creating a Storage Policy

Step 1 Choose Policies > Virtual/Hypervisor Policies > Storage.
Step 2 On the Storage page, click VMware Storage Policy.
Step 3 Click Add.
Step 4 On the Add Storage Resource Allocation Policy- System Disk Policy screen, complete the following fields

DescriptionName

Choose the cloud in which resource allocation occurs.Policy Name field

The description of the policy.

If you want to narrow the scope of deployment, choose
whether to use all, include selected data stores, or exclude
selected data stores.

Policy Description field

Choose the cloud account for this resource allocation.

If you choose an SRM account, the Enable Protection
check box is displayed. For more information about how
to enable protection groups for Site Recovery Manager,
see the Cisco UCSDirector VMwareManagement Guide.

Cloud Name drop-down list

System Disk Scope

If you want to use a linked clone, click the check box.

If you do not click this check box, the configuration uses
a full clone.

Use Linked Clone check box

Choose a storage profile if you want to provision one or
more VMs with the associated storage profile.

Storage Profile drop-down list

Cisco UCS Director Administration Guide, Release 6.6
295

Multiple Disk VM Provisioning
Creating a Storage Policy

https://www.cisco.com/c/en/us/support/servers-unified-computing/ucs-director/products-troubleshooting-guides-list.html
http://www.cisco.com/c/en/us/support/servers-unified-computing/ucs-director/products-installation-and-configuration-guides-list.html


DescriptionName

To define the scope of deployment, choose one of the
following options:

• All

• Include Selected Datastores

• Exclude Selected Datastores

• Include Selected Datastore Clusters

• Exclude Selected Datastore Clusters

Depending uponwhich option you choose, additional fields
may display.

The option that you choose determines which
datastores or datastore clusters are available
when you create a VM disk.

Note

Data Stores/Data Store Clusters Scope drop-down list

If you chose Include Selected Datastores or Exclude
SelectedDatastores, click Select to choose the appropriate
datastores.

Selected Data Stores field

Click the check box to use shared datastores only.

This option is only available if you chose to include or
exclude selected datastores.

Use Shared Data Store Only check box

If you chose Include Selected Datastore Clusters or
Exclude Selected Datastore Clusters, click Select to
choose the appropriate datastore clusters.

Selected Datastore Clusters field

If you chose to include or exclude selected datastore
clusters, choose one of the following SDRS rule types:

• Keep VMDKs Together—You need to select an
existing rule on the filtered clusters. The newly
provisioned VM is added to the VM anti-affinity rule.

• Separate VMDKs—If the newly provisioned VM
contains more than one disk, a new VM affinity rule
is created on the datastore cluster.

Select SDRS Rule Type drop-down list

If you chose Keep VMDKs Together, you must choose
the VMs that you want to apply the rule to.

Select SDRS Rule field

Storage Options

By default, the field is checked. Uncheck the check box if
you do not want to use local storage.

Use Local Storage check box

By default, the field is checked. Uncheck the check box if
you do not want to use NFS storage.

Use NFS check box
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DescriptionName

By default, the field is checked. Uncheck the check box if
you do not want to use VMFS storage.

Use VMFS check box

By default, the field is checked. Uncheck the check box if
you do not want to use SAN storage.

Use SAN check box

To add one more conditions to filter the datastores, do the
following for each desired condition:

• Click the appropriate check box.

• Choose the desired option from the drop-down list.

• Enter the criteria by which you want to filter the
datastores.

Any datastores that do not meet these criteria are excluded
from consideration. If more than one condition is chosen,
all conditions must match.

VMware VM provisioning fails when the
datastore capacity specified in a storage policy
uses the equals condition for decimal values
with two values after the decimal (hundreths
place). If specifying a capacity that includes
decimal values, round the value up to one value
after the decimal (tenths place).

For example if the value is 10.25 GB, it displays
as 10.3 GB in the datastore report. For all
options, you must specify any value less than
10.3 but rounded to one value after the decimal,
such as 10.2 GB, 10.1 GB, or 10 GB.

Note

Filter Conditions check boxes

Check the check box to override the template properties.
You are provided with options to enter custom settings,
such as using thin provisioning or setting a custom disk
size.

Override Template check box

Check the check box to use thin provisioning during VM
storage provisioning.

Thin provisioning enables dynamic allocation of physical
storage capacity to increase VM storage utilization.

This option is only available if you choose Override
Template.

Use Thin Provisioning check box

A custom disk size that overrides the disk size of the
template used for VM provisioning.

This option is only available if you choose Override
Template.

Manual Disk Size
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DescriptionName

Resizing Options for VM Lifecycle

Check the check box to provide the end user with an option
to choose the VM disk size before provisioning.

Allow Resizing of Disk check box

Specify the disk size values that can be chosen while
provisioning a VM. You can specify these values in one
of the following formats:

• Range such as 10-1000

• Comma separated values such as 1, 5, 10, 50, 100,
500, 1024, 5120, 10240.

• Combination of range and comma separated values
such as 1,5,10, 10-1000.

This option is only available if you chooseAllowResizing
of Disk.

Permitted Values for Disk in GB field

Check the check box to provide the end user with an option
to choose the datastore during the service request creation.

Allow user to select datastores from scope check box

Step 5 Click Next.
Step 6 On the Additional Disk Policies screen, do one of the following:

• Choose a disk type to configure if you do not want to use the same disk policy for that disk type as you configured
in the System Disk Policy.

• Click Next if you want to use the System Disk Policy options for all disk types.

By default, the disk policy for the disk is the same as in the System Disk Policy that you configured on the
Add Storage Resource Allocation Policy screen.

Note

Step 7 If you chose to configure a custom system disk policy for a specific disk type, do the following:
a) Click the row with the policy you want to edit, and click Edit to edit the disk type.
b) On the Edit Policies Entry screen, uncheck Same as System Disk Policy.
c) On the Edit Entry screen, complete the fields.

All the fields displayed here are the same as the fields displayed in the Add Storage Resource Allocation Policy
screen.

This configuration determines which datastores are available for the disk type when you create a VM
disk.

Note

d) Click Submit.
e) Repeat these steps to configure the other disk types, if desired.

To use the storage policy created with additional disk policies, you must associate the policy with the VDC
that is used for the VM provisioning

Note

Step 8 Click Next.
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Step 9 On the Hard Disk Policy screen, you can specify the number of physical disks that you want to create during VM
provisioning.
a) Click Add to add a disk and complete the following fields:

DescriptionField

A descriptive label for the disk you are adding.Disk Label field

The size of the disk.Disk Size (GB) field

Choose the disk type.

The options that you see in this drop-down list depends
on whether you selected the Same as System Policy
check box earlier in this procedure.

Disk Type drop-down list

Controller Options

Choose a controller type from the drop-down list.

Based on the availability of ports, a controller is mapped
to the VM disks.

Controller Type drop-down list

Check this check box to create a new controller.

The type of controller that is created is based on the
selection you made in the Controller Type drop-down
list.

Create Disk on new Controller check box

Disk Provisioning Options

Check the radio button of the type of provisioning you
want to specify. You can specify one of the following:

• Thin Provision

• Thick Provision lazy zeroed

• Thick Provision eager zeroed

Disk Provisioning Options radio buttons

Resizing Options for VM Life cycle

Check the check box to enable editing of the VM disk
size before provisioning.

Allow Resizing of Disk check box
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DescriptionField

This option appears if Allow Resizing of Disk is
checked.

Specify the custom range of disk size values that are
chosen while provisioning a VM.

You can specify these values in one of the following
formats:

• Range such as 10-1000

• Comma separated values such as 1, 5, 10, 50, 100,
500, 1024, 5120, 10240.

• Combination of range and comma separated values
such as 1,5,10, 10-1000.

Permitted Values for Disk in GB field

Check the check box to provide the user with an option
to choose the datastore during the service request
creation.

Allow user to select datastore from scope check box

Step 10 Click Submit.

To use the storage policy created with additional disk policies, you need to associate the policy with the VDC
that is used for the VM provisioning.

When using the Additional disks policies configured in a policy, make sure to uncheck Provision all disks
in a single database during catalog creation for the multiple disk template. For more information about
catalog creation, see Managing Catalogs, on page 257.

Note

Creating a Catalog

Adding a Catalog

Step 1 Choose Policies > Catalogs.
Step 2 On the Catalogs page, click Add.
Step 3 On the Add Catalog screen, choose the Catalog Type that you want to add.

It can be one of the following:

• Standard—Used to create catalogs for VM provisioning, using images from a list of clouds.

• Advanced—Used to publish orchestration workflows, such as catalog items.

• Service Container—Used to publish application containers as catalog items.

• Bare Metal—Used to create catalogs for bare metal server provisioning.
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For information on how to create a bare metal catalog, see Creating a Bare Metal Server Catalog, on page 266.

Step 4 Click Submit.
Step 5 On the Add Catalog: Basic Information screen, complete the required fields, including the following:

DescriptionName

Enter a name for the catalog.

After created, a catalog name cannot be
modified.

Note

Catalog Name field

Enter a description of the catalog.Catalog Description field

Displays the type of catalog you previously chose. To
change the catalog type, you need to cancel and restart this
procedure.

Catalog Type drop-down list

Choose from a list of icons to associate this catalog with
an image. This icon is seen when you are creating a service
request using this catalog.

Catalog Icon drop-down list

Check the box to enable all groups to use this catalog.
Leave it unchecked to deny its use to other groups.

Applied to all groups check box

Enter the email address of the support contact who is
notified when a service request is created using this catalog
item.

Support Contact Email Address field

Click Select to the check the checkboxes of specific user
groups. The checked groups use this catalog to provision
new VMs. After checking the checkboxes of user groups,
click Select to return to the Add Catalog screen.

Selected Groups list

By default, this box is checked. Uncheck this box if you
do not want this catalog to be visible to users. If you do
not uncheck this box, then this catalog is visible to the
users of the system.

Publish to end users check box

Choose the cloud with the image for VM provisioning.Cloud Name drop-down list

Check this box to clone a new VM from a selected image.
If you do not check this check box, a blank VM is created.

Provision new VM for ISO mounting check box
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DescriptionName

Click Select to the check the checkboxes of the type of
image (any existing templates such as Windows, Linux,
and other files that make up the image) to use when VMs
are provisioned using this catalog. After checking the
checkboxes of the required images, click Select to return
to the Add Catalog screen.

If you are a group administrator, or a user in a group with
permissions to create catalogs, this field displays images
that are assigned to the group to which you belong.

If you are an MSP administrator, then this field displays
images that are assigned to your MSP organization, and
to the groups within the MSP organization.

Image list

Check this box to ensure that the new VM is provisioned
using the Content Library VM Template.

If you choose this option, the Image list is hidden.

Provision new VM using Content Library VM
Template check box

Choose the content library VM template.Content Library VM Template list

Enter the Windows License.

This field appears only when aWindows image
is chosen. This option is not supported in the
RHEV KVM Connector.

Note

Windows License Pool field

Check the box to ensure that VMs are deployed using
ReadyClones.

When this box is checked, the Use Linked Clone and
Provision all disks in single datastore check boxes are
not available for editing.

This checkbox is not visible if:

1. The selected image is not on the HX
datastore.

2. The VM has multiple disks.

Note

Use ReadyClone check box

Check the box if you want to use a linked clone.

Linked Clone or Full Clone depends on the Linked Clone
selection in the Storage Policy.

This field appears only when a Snapshot image
is chosen.

Note

Use Linked Clone check box
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DescriptionName

Check the box to provision all disks in a single datastore.
You can also choose to use the datastores configured for
each disk in the storage policy.

This field appears only if the chosen template
has multiple disks. This option is not supported
in the RHEV KVM Connector.

Note

Provision all disks in single datastore check box

Choose the template from the list.

This field appears only when the chosen Catalog
Type is Service Container.

Note

Service Container Template Name drop-down list

Choose the folder within which this catalog must be
created.

The drop-down list includes names of folders
that are available by default. You can either
choose a folder that is available, or clickCreate
New Folder.

On theAddNew Folder screen, enter a Folder
Name, choose a Folder Icon, and click Add.

Note

Select Folder drop-down list

This field appears only when the chosen Catalog
Type is Bare Metal.

NoteBare Metal Server Provisioning Policy drop-down list

Check this box to enable the user to set the support email
for sending service request status.

Configure Service Request Support Email check box

Step 6 Click Next.
Step 7 On the Add Catalog: Application Details screen, complete the required fields, including the following:

DescriptionName

Expand the list to choose a VDC category and click Select.Category list

Check the box to enable the user to override the selected
category while provisioning a VM using a service request.

Override check box

Enter the email address of the contact who is notified when
a service request is created using this catalog item.

Support Contact Email Address field

Choose the type of OS installed on the VM when it is
provisioned.

This option is not supported in the RHEVKVM
Connector.

Note

Specify OS drop-down list
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DescriptionName

Enter an OS that is not available in the Specify OS
drop-down list.

This option is not supported in the RHEVKVM
Connector.

Note

Specify Other OS field

Check the appropriate boxes to specify applications that
are installed on the VM during provisioning.

This option is not supported in the RHEVKVM
Connector.

Note

Specify Applications check boxes

Enter other applications that are not available from the
Specify Applications check boxes.

This option is not supported in the RHEVKVM
Connector.

Note

Specify Other Applications field

Enter an application code that is used in the VM name.

The application code can be between 1 to 4 characters (for
example: W2K3, DB, WS). The application code can be
used in a system policy for the VM name by using the
variable ${APPCODE}.

For example, if the VM Name Template is
vm-${GROUP_NAME}-${APPCODE}, the VM
provisioned with the system policy has the name
vm-groupname-W2K3.

This option is not supported in the RHEVKVM
Connector.

Note

Application Code field

Step 8 Click Next.
Step 9 On the Add Catalog: User credentials screen, complete the required fields, including the following:

These options are not supported in the RHEV KVM Connector.Note

DescriptionName

Choose to allow or disallow users to retrieve VM access
credentials (shared). The following options are available:

• Do not share

• Share after password reset

• Share template credentials

The Do not share option is chosen if the administrator
wants to send the credentials privately to another user
outside Cisco UCS Director.

Credential Options drop-down list
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DescriptionName

Enter the user ID.

This field is available only if a choice is made
to share under Credential Options.

Note

User ID field

Enter the password.

This field is available only if a choice is made
to share under Credential Options.

Note

Password field

Step 10 Click Next.
Step 11 On the Add Catalog: Customization screen, complete the required fields, including the following:

DescriptionName

Check the box to enable automatic guest customization.

If you do not check this check box, then Cisco UCS
Director does not configure the DNS, Network, and Guest
OS properties.

Automatic Guest Customization Enable check box

Check the Enable check box to enable execution of an
orchestration workflow before VM provisioning.

Pre Provisioning Custom Actions Enable

Click Select to check the compound workflow that should
be used in the orchestration workflow before VM
provisioning.

Check the check boxes of the required workflows, and
click Select to return to the Add Catalog screen.

This field appears when Pre Provisioning
Custom Actions Enable is checked.

Note

Workflow field

Check the box to enable execution of an orchestration
workflow after VM provisioning.

Post Provisioning Custom Actions Enable check box

Click Select to check the check boxes of the workflows
that need to be used in the orchestration workflow after
VM provisioning.

Check the check boxes of the required workflows, and
click Select to return to the Add Catalog screen.

This field appears when Post Provisioning
Custom Actions Enable is checked.

Note

Workflow drop-down list

Check the box to choose storage entries from the Virtual
Storage catalog.

Virtual Storage Catalog Enable check box
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DescriptionName

Chose a storage entry from the catalog.

This field appears when Virtual Storage
Catalog Enable is checked.

Note

Virtual Storage Catalog drop-down list

Cost Computation

Choose Hourly orMonthly.Charge Duration drop-down list

Enter the cost for the application that is included in the
template.

This option is not supported in the RHEVKVM
Connector.

Note

Active VM Application Cost USD field

Enter the cost to this catalog of a VM in inactive state, per
hour or month.

This option is not supported in the RHEVKVM
Connector.

Note

Inactive VM Application Cost USD field

VM Life Cycle Configuration

Check the box to define a lease time (in days and hours).Lease Time check box

Enter the number of days.

This field appears whenLease Time is checked.Note

Days field

Enter the number of hours.

This field appears whenLease Time is checked.Note

Hours field

Check the box to prevent service users from configuring
a lease time for VMs.

Hide end user lease configuration check box

Check the box to prevent service users from provisioning
VMs at a later time.

Hide end user VM provision later check box

Step 12 Click Next.
Step 13 On the Add Catalog: VM Access screen, complete the required fields, including the following:

DescriptionName

Check the box to enable web access to the VM. By default,
this check box is unchecked which means that web access
to the VM is disabled.

Web Access Configuration Enable check box

Enter the URL of the VM.

This field appears whenWeb Access
Configuration Enable is checked.

Note

URL field
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DescriptionName

Enter the label that is defined for this URL.

This field appears whenWeb Access
Configuration Enable is checked.

Note

Label field

Check the box to enable remote desktop access to the VM.
By default, this check box is unchecked, which means that
remote desktop access to the VM is disabled.

Remote Desktop Access Configuration Enable check
box

Enter the IP address of the server for remote access.

This field appears when Remote Desktop
Access Configuration Enable is checked.

Note

Server field

Enter the port number on the server for remote access.

This field appears when Remote Desktop
Access Configuration Enable is checked.

Note

Port field

Enter the label that is defined for this remote access.

This field appears when Remote Desktop
Access Configuration Enable is checked.

Note

Label field

Check the box to enable VMRC console access to the VM.
By default, this check box is unchecked, which means that
the VMRC console access to the VM is disabled.

VMRC Console Configuration Enable check box

Step 14 Click Next.
Step 15 Review the catalog information on the Add Catalog: Summary screen.
Step 16 Click Submit.

Creating a VM Disk
You can add an additional disk with a custom size to provisioned or discovered VMs using the Create VM
disk option.

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click VMs.
Step 4 Click the row with the VM for which you want to create a VM disk.
Step 5 From theMore Actions drop-down list, choose Create VM Disk.
Step 6 On the Create VM Disk screen, complete the following fields:
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DescriptionName

The name of the VM.

Once entered, the VM name cannot be edited.

VM Name field

The disk size for the VM, in GB. Enter an integer in this
field. This integer should be within the range or among the
comma separated values specified in the storage policy
associated with this VM.

New Disk Size (GB) field

Choose the disk type. It can be one of the following:

• System

• Swap

• Data

• Database

• Log

Select Disk Type drop-down list

Specify if the VM disk should be created from a datastore
or a datastore cluster.

Select Datastore/Datastore Cluster drop-down list

Click Select and choose which datastore you want to use
to create the VM disk.

The available datastores depend upon the storage
policy associated with the VDC. Only datastores
that meet the criteria specified in the storage
policy are available for the VM disk.

Note

This field is only available if you specify that the VM disk
should be created from a datastore.

Select Datastore field

Click Select and choose which datastore cluster you want
to use to create the VM disk.

The available datastore clusters depend upon the
storage policy associated with the VDC. Only
datastore clusters that meet the criteria specified
in the storage policy are available for the VM
disk.

Note

This field is only available if you specify that the VM disk
should be created from a datastore cluster.

Select Datastore Cluster field

Check the check box to add a thin provisioned disk to the
VM.

Thin provisioning enables dynamic allocation of
physical storage capacity to increase VM storage
utilization.

Note

Thin Provision check box
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DescriptionName

This option calculates the cost of the new disk based on the
input you specified, and displays it in the dialog box.

Compute New Disk Cost option

Step 7 Click Create.
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C H A P T E R 15
Using the Chargeback Module

This chapter contains the following sections:

• About Chargeback Features, on page 311
• Budget Policies, on page 312
• Cost Models, on page 313
• Modifying a VDC to Include a Cost Model, on page 317
• Package-Based Cost Models, on page 320
• Storage Tier Cost Models, on page 322
• About Assigning a Datastore to Tiers, on page 322
• Chargeback Reports, on page 323
• About Change Records, on page 327
• Chargeback Calculations, on page 327

About Chargeback Features
The chargeback module in Cisco UCS Director offers in-depth visibility into the costs of the virtual
infrastructure. It allows the definition of cost models and their assignment to policies within departments and
organizations. Virtual machine (VM) metering data is collected at frequent intervals to ensure accurate
calculation of resource costs.

The chargeback module is supported only for physical servers that are within an application container.Attention

Following are the features of the chargeback module:

• Flexibility—Provides fixed costs, one-time costs, allocation costs, usage costs, and a combination of
these costs, based on the organizational requirements.

• Reusable Cost Models—Assigns cost models to VMs using standardized cost models or templates. These
templates apply cost models to new environments quickly.

• Reporting—Generates various summary and comparison reports of costs and resource usage for the
virtual infrastructure. These reports are exported to PDF, CSV, and XLS formats and allow you to view
them with a web browser.

• Top Five Reports—Monitors the top five reports for organizations or groups with the highest VM cost,
CPU, memory, storage, and network costs.
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• Dashboard—Monitors and analyzes VM metering information and chargeback in real time with the
built-in dashboard and an extensive set of graphical widgets.

Budget Policies
Overall resources are accounted for by the chargeback module. In addition to chargeback, individual groups
or organizations must be associated with a budget policy where you can enable or disable the budget watch
and over budget.

Configuring a Budget Policy

Step 1 Choose Administration > Users and Groups.
Step 2 On the Users and Groups page, click User Groups.
Step 3 Choose a group and click Budget Policy.
Step 4 In the Budget Policy screen, complete the required fields, including the following:

DescriptionName

If checked, the group’s budget usage is monitored. If
unchecked, all budget entries for this group are ignored.

Enable Budget Watch check box

If checked, the group members are allowed to go over the
provisioned budget. If unchecked, once the budget is
exhausted, all requests are rejected until a new budget is
added.

Allow Over Budget check box

Step 5 Click Save.

Creating a Tag-Based Cost Model
The tag-based cost model capability is supported on all VMs that have been provisioned through a container.

Step 1 Choose Policies > Virtual/Hypervisor Policies > Service Delivery.
Step 2 On the Service Delivery page, click Tag Based Cost Model.
Step 3 Click Add to create a new cost model.
Step 4 In the Add Tag Based Cost Model screen, complete the required fields, including the following:

DescriptionField

The name of the cost model.Cost Model Name field

The description of the cost model.Cost Model Description
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DescriptionField

Select a VM tag from the drop-down list.

The tag costs that you specify are restricted to the VM tag
that you select in this drop-down list. The tag-based cost
model is restricted to the VM tag that you selected.

Tag Name drop-down list

Step 5 Click + sign to add tag costs to the cost model.
Step 6 In the Add Entry to Tag Costs screen, complete the required fields, including the following:

DescriptionField

Choose a tag value from the drop-down list.

This drop-down list displays the possible values for the tag
name that you selected.

VM Tag drop-down list

The per-hour fixed cost for the tag.Fixed Cost field

The fixed one-time cost for the tag.One Time Cost field

Check the check box to include the tag-based cost model
along with the regular cost model for the VM.

Include VM in Regular Chargeback check box

Step 7 Click Submit.
Step 8 In the Add Tag Based Cost Model screen, click Submit.
Step 9 Click OK.

Cost Models
A cost model is used to define the unit-level costs of virtual resources, and physical resources. These costs
are used for chargeback calculations of VMs within the virtual infrastructure as well as physical resources.
Cost models offer a definition of costs in a linear model.

The cost of a particular resource is calculated on how many units are assigned to that resource in the VM or
physical resource. For example, the cost of 1 GB of RAM is defined within the cost model. This unit cost is
used to determine the cost of RAM for a particular VM.

You can define one-time provisioning costs, active or inactive VM costs, and provisioned, reserved, or used
costs for resources, such as CPU, and memory. These values are used to calculate VM costs based on usage.

In addition, you can also create a cost model for bare metal servers within the physical infrastructure.
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You can map a cost model to a VDC or to an application container. For more information on mapping a cost
model to an application container, see the Cisco UCS Director Application Container Guide available at the
following link:

http://www.cisco.com/c/en/us/support/servers-unified-computing/ucs-director/
products-installation-and-configuration-guides-list.html

Note

Creating a Cost Model

Step 1 Choose Policies > Virtual/Hypervisor Policies > Service Delivery.
Step 2 On the Service Delivery page, click Cost Model.
Step 3 Click Add.
Step 4 In the Add Cost Model screen, complete the required fields, including the following:

DescriptionName

The name of the cost model.Cost Model Name field

The description of the cost model.Cost Model Description field

Choose the type of cost model.

Standard indicates a linear cost model.Advanced indicates
a package or script-based cost model. See the
Package-Based Cost Models for the Advanced cost model
description and usage. You can also choose HyperV, if
appropriate.

Cost Model Type drop-down list

Choose the interval at which costs for the VM's resources
are defined. It can be one of the following options:

• Hourly—If you want to quantify the costs of resources
on an hourly basis.

• Daily—If you want to quantify the costs of resources
on a daily basis.

•Weekly—If youwant to quantify the costs of resources
on a weekly basis.

• Monthly—If you want to quantify the costs of
resources on a monthly basis.

• Yearly—If you want to quantify the costs of resources
on a yearly basis.

Charge Duration drop-down list

Virtual Machine Cost Parameters

Fixed Costs (Currency: USD)
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DescriptionName

The fixed one-time cost for provisioning the VM.One Time Cost field

VM Costs (Currency: USD)

The per-hour cost of a VM in the active state.Active VM Cost field

The per-hour cost of a VM in the inactive state.Inactive VM Cost field

Choose the charge unit for CPU: GHz or cores.CPU Charge Unit drop-down list

The provisioned CPU cost per CPU charge unit per-hour.
The system calculates the percentage of CPU that was
provisioned for the VM.

The cost of the CPU charge unit is GHz.

If you enter a value for theUsedCPUCost field,
you must leave this field blank.

Note

Provisioned CPU Cost field

The reserved CPU cost per GHz per hour.

The amount of CPU that has been actually reserved to the
VM is taken into consideration, including the provisioned
CPU cost calculation. Any extra cost for the reserved CPU
(apart from the provisioning cost) is entered here. For
example, if the provisioning cost is $1 and the reserved cost
is $1.4, the extra amount to reserve must be mentioned. In
this example, it is $1.4 – $1 = $0.4.

The cost if the CPU charge unit is GHz.

If you enter a value for theUsedCPUCost field,
you must leave this field blank.

Note

Reserved CPU Cost field

The used CPU cost per GHz per hour. The cost is based on
the actual CPU usage.

This cost does not take into consideration the provisioned
and reserved costs. If you enter a value for the Used CPU
Cost field, the provisioned cost and reserved cost fields
must be left blank.

The cost if the CPU charge unit is GHz.Note

Used CPU Cost field

The provisioned memory cost per GB per hour.Provisioned Memory Cost field

The reserved memory cost per GB per hour.Reserved Memory Cost field

The used memory cost per GB per hour.Used Memory Cost field

The received data cost per GB per hour.Received Network Data Cost field

The transmitted data cost per GB per hour.Transmitted Network Data Cost field
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DescriptionName

The committed storage cost per GB per hour.Committed Storage Cost field

The uncommitted storage cost per GB per hour. The unused
but provisioned storage is defined as uncommitted storage.

Uncommitted Storage Cost field

Select a tag-based cost model.

This list displays all the tag-based cost models that you have
created.

Tag Based Cost Model drop-down list

Physical Server Cost Parameters

Fixed Costs (Currency: USD)

The fixed one-time cost for provisioning the server.One Time Cost field

Choose the charge unit for CPU: GHz or cores.CPU Charge Unit drop-down list

The provisioned CPU cost per CPU charge unit per hour.
The CPU percentage that was provisioned to the server is
taken into consideration.

The cost if the CPU charge unit is GHz.

If you enter a value for theUsedCPUCost field,
you must leave this field blank.

Note

Provisioned CPU Cost field

The provisioned memory cost per GB, per-hour.Provisioned Memory Cost field

The used memory cost per GB, per-hour.Used Memory Cost field

The committed storage cost per GB, per-hour.Committed Storage Cost field

The cost of full-length blade servers, per-hour.

This field does not appear when HyperV is
selected as the cost model type.

Note

Full Length Blade Cost field

The cost of half-length blade servers, per-hour.

This field does not appear when HyperV is
selected as the cost model type.

Note

Half Length Blade Cost field

Step 5 Click Add.

Creating a Bare Metal Cost Model

Step 1 Choose Policies > Physical Infrastructure Policies > Bare Metal Servers.
Step 2 On the Bare Metal Servers page, click Bare Metal Cost Model.
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Step 3 Click Add.
Step 4 In the Add Bare Metal Cost Model screen, complete the required fields, including the following:

DescriptionName

The name of the cost model.Cost Model Name field

The description of the cost model.Cost Model Description field

Choose the charge duration from the drop-down list. It can
be Hourly, Daily, Weekly, Monthly, and Yearly.

Charge Duration drop-down list

The fixed one-time cost for provisioning a bare metal server.One Time Cost field

Choose the charge unit for the CPU. It can be GHz or Cores.CPU Charge Unit drop-down list

The CPU cost per CPU charge unit per hour.CPU Cost field

The memory cost per GB per hour.Memory Cost field

The used memory cost per GB per hour.Used Memory Cost field

The storage cost per GB per hour.Storage Cost field

The cost of the full width blade servers per hour.Full Width Blade Cost field

The cost of the half width blade servers per hour.Half Width Blade Cost field

Step 5 Click Submit.

What to do next

You can choose this cost model when you create a Bare Metal Server provisioning policy.

Modifying a VDC to Include a Cost Model
You can add or edit an existing VDC to assign a newly created cost model. You can edit an existing VDC,
or create a new VDC and assign a cost model to it.

After the cost model is assigned to a VDC, all VMs within the VDC are charged based on the advanced cost
model. Any VMs within VDCs that have the standard type of cost model are still charged according to the
standard cost model.

Adding a Cost Model to a VDC

Step 1 Choose Policies > Virtual/Hypervisor Policies > Virtual Data Centers.
Step 2 On the Virtual Data Centers page, click vDC.
Step 3 Choose the VDC to which you want to add the cost model.
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Step 4 Click Add.
Step 5 In the Add vDC screen, select the account type, and click Submit.
Step 6 In the Add VDC screen, complete the required fields, including the following:

DescriptionName

The name of the VDC.VDC Name field

By default, this check box is not checked, whichmeans that
the VDC is available for further deployments.

Check the check box to deny the use of the VDC for any
further deployments. Actions on existing VMs, within this
VDC, are disabled. Uncheck the check box to allow the use
of the VDC for further deployments.

VDC Locked check box

The VDC-specific description.VDC Description field

Choose the group for which the VDC is being set up.Group drop-down list

Choose the cloud on which the VDC is being set up.Cloud Name drop-down list

Check the check box to enable SRM.Enable Protection check box

Approvers and Contacts

The users who must approve the service request at the
first-level.

Expand the list to check the check boxes of the users. You
can select multiple users.

First Level Approvers list

The users who must approve the service request at the
second-level.

Expand the list to check the check boxes of the users. You
can select multiple users.

Second Level Approvers list

Check this check box to indicate that approval is required
from all users who have been selected as first-level and
second-level approvers.

Approval Required from all users check box

The number of times the reminder email to approve the
service request is sent to the approvers.

By default, the system sends a reminder email once every
24 hours until the service request is approved or rejected.

Number of Approval Requests Reminders field

The time interval between the reminder emails that are sent
to the approvers.

By default, the system sends a reminder email every 24
hours.

Reminder Interval (Hours) field

The contact or user’s email address. The person who is
notified about VM provisioning using this VDC.

Provider Support Email Address field
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DescriptionName

The second contact’s email for receiving copies of
notifications about this VDC.

Copy Notifications to Email Address field

Policies

Choose the system policy applicable to the VDC.System Policy drop-down list

Choose the computing policy applicable to the VDC.Computing Policy drop-down list

Choose the network policy applicable to the VDC.Network Policy drop-down list

Choose the storage policy applicable to the VDC.Storage Policy drop-down list

Choose the cost model applicable to the VDC.Cost Model drop-down list

Check the check box to disable displaying cost in the SR
summary and email page for this VDC.

Disable displaying cost in the SR summary and email
page check box

Choose the policy that is used for execution of orchestration
workflows after provisioning of the VMs. The chosen
workflow appears as an action button for VMs within the
VDC.

User Action Policy drop-down list

End User Self-Service Policies

Check the box to enable all VM power management actions
for VMs that belong to this VDC.

VM Power Management check box

End user self-service policies also include VM Resizing, VM Snapshot Mangement, VM deletion, VM Disk
Management, and VM Network Management. For more information, see Adding a Virtual Data Center, on
page 207.

Note

Step 7 Click Add.

Editing a VDC to Include a Cost Model

Step 1 Choose Policies > Virtual/Hypervisor Policies > Virtual Data Centers.
Step 2 On the Virtual Data Centers page, click vDC.
Step 3 Choose the VDC to add to the cost model.
Step 4 ClickManage Categories.
Step 5 Choose the category to edit.
Step 6 Click Edit.
Step 7 In the Edit App Category screen, in the drop-down list, choose a Cost Model and a Deploy Policy.
Step 8 Click Save.
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Package-Based Cost Models
A package-based cost model enables you to define the costs for the system resources as packages instead of
as individual definitions. There are different packages to choose from based on your requirements. This type
of cost model is suitable for nonlinear models.

Cisco UCS Director supports definitions of CPU memory (server) packages.Note

In this type of cost model, the definition is based on the available resource packages. The model is in the
following format:

C – M:X.

C is the number of CPU cores.

M is the memory in GB.

X is the combined monthly cost of C and M.

For example, a package with an entry of 2-4:200 implies CPU cores = 2, memory = 4 GB, and the cost of this
package is $200 per month.

You can define multiple packages using the following format: C1-M1:X1,C2-M2:X2,......,CN-MN:XN.

For example, 1-1:50,1-2:70,1-4:90,2-4:150,2-6:170,2-8:190,4-8:350,4-12:380,4-16:400. The first entry 1-1:50
is a package of 1 core CPU and 1 GB memory that costs $50 per month.

These entries can be edited at any time to suit the cost package requirements.Note

Creating a Package-Based Cost Model

Step 1 Choose Policies > Virtual/Hypervisor Policies > Service Delivery.
Step 2 On the Service Delivery page, click Cost Model.
Step 3 Click Add.
Step 4 In the Add Cost Model screen, enter a cost model name and description.
Step 5 For the Cost Model Type field, choose Advanced.
Step 6 Paste the script provided in the Advanced Cost Model field.

/********************************/

var CPU_MEMORY_COST =

"1-2:81,1-4:95,1-8:109,2-4:162,2-6:176,2-8:189,2-16:378,4-12:352,4-16:378";

var oneTimeCost = 150;

/********************************/

/* define cost packages as shown above.
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The cost packages can be defined in the following format:

C-M:X.

C is the number of CPU cores.

M is the memory in GB.

X is the combined monthly cost of C and M.

For example, 2-4:162 means CPU cores = 2, memory = 4 GB and the cost of this package is $162 per month. */

/* When defining multiple packages, define it in the following format: C1-M1:X1,C2-M2:X2, ...........,CN-MN:XN

The standard packages are defined at the top of the script using the variable CPU_MEMORY_COST.

This variable can be edited to suit the cost package requirement. */

/* For reference, the storage cost to use is based on the storage tier cost model definition. */

/* do not edit any script below */
computeChargeback(data);
function computeChargeback(data)
{
var map = chargeBackAPI.getCPUMemCostModelMap(CPU_MEMORY_COST);
var cpuCores = data.getVmMeter().getCpuCores();
var memory = data.getVmMeter().getAllocMemGB();
var serverCost = chargeBackAPI.getCostForItem(map,cpuCores, memory);
serverCost = serverCost / (24 * 30);
var storageTierCost = chargeBackAPI.getStorageCostForItem(data.getVmMeter().getVmId());
var storageGB = (data.getVmMeter().getCommittedDiskGB()) +
(data.getVmMeter().getUncommittedDiskGB());
var committedDiskGBCost = (data.getVmMeter().getCommittedDiskGB()) * storageTierCost;
var unCommittedDiskGBCost = (data.getVmMeter().getUncommittedDiskGB()) * storageTierCost;
var storageCost = (storageGB * storageTierCost) / (24 * 30);
var totalVMCost = serverCost + storageCost;
var cb = data.getCbSummary();
cb.setCpuCores(cpuCores);
cb.setMemory(memory);
cb.setServerCost(serverCost);
cb.setCommittedDiskGB(data.getVmMeter().getCommittedDiskGB());
cb.setCommittedDiskGBCost(committedDiskGBCost);
cb.setUncommittedDiskGB(data.getVmMeter().getUncommittedDiskGB());
cb.setUncommittedDiskGBCost(unCommittedDiskGBCost);
cb.setTotalCost(totalVMCost);
}

/********************************/

Step 7 Click Add.

Once the cost model has been defined, assign it to a VDC in order to start the chargeback of VMs based on this
cost model.

Note
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Storage Tier Cost Models
You can use a storage tier cost model to define multiple costs for storage using the tier format. Current storage
types include but not limited to local storage, NFS, SAN, and NAS. Each storage cost could vary. You can
incorporate this variation while calculating costs for storage usage.

You can use this model to define different costs for different tiers and then assign existing datastores to these
tiers. You can group similar datastore types by cost wise using the tier cost model.

Each tier must be assigned a cost, at a per-GB, per-month value. For example, when assigning $0.50 to a tier,
all datastores within this tier are charged at $0.50 per GB per month. By default, four tiers are already created,
so you must assign the costs to them.

Assigning a Cost to a Tier

Step 1 Choose Policies > Virtual/Hypervisor Policies > Service Delivery.
Step 2 On the Service Delivery page, click Storage Tier Cost Model.
Step 3 Choose the tier to edit.
Step 4 Click Edit.
Step 5 Edit the Disk Cost (GB)/Month field.
Step 6 Click Submit.

About Assigning a Datastore to Tiers
You can assign a datastore to a tier so that the cost defined in the tier is used to calculate the cost of storage
within that particular datastore.

When calculating the chargeback for VMs within a datastore, the cost is determined by which tier the datastore
was assigned to. If no tier is assigned to a datastore, the storage cost for that datastore is not considered when
using the advanced (script-based) cost model.

With a regular cost model, you define resource costs in a form. Storage tier costs are taken into consideration
if tier costs are assigned and datastores are assigned to those tiers. However, if no tier is assigned to a datastore,
the storage cost for VMs under that datastore is removed from the storage cost entry of the cost model form.

Assigning a datastore to a tier applies only to the regular cost model.Note

Assigning a Datastore to a Tier

Step 1 Choose Virtual > Storage.
Step 2 On the Storage page, choose the cloud.
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Step 3 On the Storage page, click Datastore Capacity Report.
Step 4 Choose the datastore to assign to a tier.
Step 5 Click Assign Tier and the Storage Tier screen appears.

Currently, the tier-based cost is supported only on VMware cloud accounts.

Step 6 From the drop-down list, choose a tier.
Step 7 Click Submit.

Chargeback Reports
Chargeback provides information about how much your organization may be paying for resources, even
unused resources. This feature allows you to optimize resource consumption and costs. System resources
accounting can be based on monthly usage. Resources, such as CPU and memory usage, are monitored and
measured.

Chargeback reports are based on the cost model type. Chargeback is calculated and shown in the user interface
in the form of tabular reports, summaries, graphical reports, and widgets.

Chargeback summary data is stored only at a daily and monthly interval. So, you cannot generate daily and
hourly trend cost reports using theChargebackmenu option. You can generate trend reports only for weekly
and monthly duration. You can generate these trend reports, in addition to several other trend reports, using
the Report Builder menu available under CloudSense. For more information on using the Report Builder
option, see Report Builder for Custom Report Templates, on page 368.

While generating trend reports for a month, the data is caculated from the first day of the month till the current
date. For example, if you are generating a trend report on 5th March, this report includes data from March
1st, to March 5th.

Important

For VMs that are provisioned through a container, you can associate a tag-based cost model and include those
costs in the regular chargeback calculations and subsequent reports.

Note

Following are the report types that are available:

• Viewing

• Current month summary—The current month summary cost report (VM, CPU, storage costs, and
so on).

• Previous month summary—The previous month summary cost report (VM, CPU, storage costs,
and so on).

• Monthly resource accounting details—The resource accounting details (CPU and memory usage
statistics) on a monthly basis.

• VM level resource accounting details—The resource accounting details at the VM level.
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• VM level chargeback details—The charges that are applicable for VM usage calculated with the
chargeback feature.

• Export

• Export monthly resource accounting details—These reports can be exported as tables.

• Export VM level resource Accounting details—These reports can be exported as tables.

• Export VM level chargeback details—Chargeback reports can be exported as tables.

You can generate these reports for a group, or for a specific virtual data center (VDC). These reports include
information on virtual resources as well as on physical servers.

Important

Viewing the Current Month Summary
Using the Current Month Summary tab, you can view the month’s chargeback details for all VMs and
physical servers that belong to the group.

Step 1 Choose Organizations > Chargeback.
Step 2 On the Chargeback page, choose the user group.
Step 3 On the Chargeback page, click Current Month Summary.

Viewing the Previous Month’s Summary
Using the PreviousMonth Summary tab, you can view the previous month’s chargeback details for all VMs
and physical servers that belong to the group.

Step 1 Choose Organizations > Chargeback.
Step 2 On the Chargeback page, choose the user group.
Step 3 On the Chargeback page, click Previous Month Summary.

Viewing Monthly Resource Accounting Information

Step 1 Choose Organizations > Chargeback.
Step 2 Choose a group or a virtual data center (VDC).
Step 3 On the Chargeback page, click Resource Accounting.
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Viewing the VM Level Resource Accounting Details
Using the Resource Accounting Details tab, you can view the individual VM's resource usage details.

Step 1 Choose Organizations > Chargeback.
Step 2 Choose a group or a virtual data center (VDC).
Step 3 On the Chargeback page, click Resource Accounting Details.

Viewing the VM Level Chargeback Details
Using the Chargeback tab, you can view the chargeback report for the selected group or VDC.

If you indicated that the tag-based cost model must be included in the regular VM chargeback calculations,
then you will see the Fixed Costs column in the report. This column retrieves the cost that you indicated in
the tag-based cost model.

Step 1 Choose Organizations > Chargeback.
Step 2 Choose a group or a virtual data center (VDC).
Step 3 On the Chargeback page, click Chargeback.

Exporting the Monthly Resource Accounting Details

Step 1 Choose Organizations > Chargeback.
Step 2 On the Chargeback page, click Resource Accounting.
Step 3 Click the Export Report icon.
Step 4 In the Export Report screen, choose a format.

It can be one of the following options:

• PDF

• CSV

• XLS

Step 5 Click Generate Report.

After the report is generated, the Download option appears.

Step 6 Click Download to open the report in another browser.

After the report opens in another browser, you can save it on your system.
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Exporting VM Level Resource Accounting Details

Step 1 Choose Organizations > Chargeback.
Step 2 On the Chargeback page, click Resource Accounting Details.
Step 3 Click the Export Report icon.
Step 4 In the Export Report screen, choose a format.

It can be one of the following options:

• PDF

• CSV

• XLS

Step 5 Click Generate Report.

After the report is generated, the Download option appears.

Step 6 Click Download to open the report in another browser.

After the report opens in another browser, you can save it on your system.

Exporting VM Level Chargeback Details

Step 1 Choose Organizations > Chargeback.
Step 2 On the Chargeback page, click Chargeback.
Step 3 On the right side of the toolbar, click the Export Report icon.
Step 4 In the Export Report screen, choose a format.

It can be one of the following options:

• PDF

• CSV

• XLS

Step 5 Click Generate Report.

After the report is generated, the Download option appears.

Step 6 Click Download to open the report in another browser.

After the report opens in another browser, you can save it on your system.
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About Change Records
You can use change records within the Change Management Database (CMDB) to track and manage changes
in the system. These records typically display ADD, DELETE, andMODIFY types of events on any resource,
such as a VM, service request, or group.

Change records display information about the resource type (VM), including the resource name, change type,
change time, and description. When a VM is resized, the change records display information on the resources
that were resized. This includes information on the original resource size and the resized values. You can
view this information from the Change Records tab.

Accessing Change Records

Step 1 Choose Administration > Integration.
Step 2 On the Integration page, click Change Records.

Chargeback Calculations
The total cost calculated for a VM includes the following:

Total cost = active VM cost or inactive VM cost + one-time cost + CPU cost + memory cost + disk cost +
CPU reserved cost + memory reserved cost + CPU used cost + CPU core cost + memory used cost + network
received used cost + network transmitted used cost + application cost.

If a VM is associated with a tag, and has a cost model and a tag-based cost model associated with the vDCs,
then the chargeback calculation is derived as follows:

• When the Include VM in Regular Chargeback check box is not checked, only the tag-based cost is
calculated.

Total Cost - Fixed Cost + One-Time Cost

• When the IncludeVM inRegularChargeback check box is checked, the total cost is calculated including
the tag-based cost and the regular chargeback computation.

Total Cost = active VM cost or inactive VM cost + one-time cost + CPU cost + memory cost + disk cost
+ CPU reserved cost + memory reserved cost + CPU used cost + CPU core cost + memory used cost +
network received used cost + network transmitted used cost + application cost + Fixed Cost

The one-time cost for the VM is determined from the cost specified in the tag-based cost model. If you have
not specified a one time cost in the tag-based cost model, then this cost is derived from the regular cost model.

Note

The total cost calculated for a physical server includes the following:

Total cost = one time cost + CPU cost + memory cost + memory used cost + committed disk cost + CPU core
cost + full blade cost + half blade cost.
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The VM cost calculation is done only on an hourly basis. There is no other option available to calculate the
VM cost. The cost for each resource is calculated based on the values that are defined in the cost model. The
cost calculations are based as follows:

Cost DescriptionCost

The value defined in the cost model for the active VM
cost.

Active VM Cost

The value defined in the cost model for the inactive
VM cost.

Inactive VM Cost

The value defined in the cost model for the one-time
cost.

One Time Cost

CPU usage (provisioned) × cost that is defined in the
cost model for the provisioned CPU cost. The CPU
charge unit is GHz.

CPU Cost

Memory usage (provisioned) × cost that is defined in
the cost model for the provisioned memory cost. The
memory charge unit is GB.

Memory Cost

The committed storage × committed storage cost that
is defined in the cost model + uncommitted storage
× uncommitted storage cost that is defined in the cost
model. The storage charge unit is GB.

Disk Cost

The reserved CPU × cost that is defined in the cost
model for the reserved CPU cost.1.

CPU Reserved Cost

The reserved memory × cost that is defined in the cost
model for the reserved memory cost.2.

Memory Reserved Cost

The used CPU × cost that is defined in the cost model
for the used CPU cost.1.

CPU Used Cost

The used CPU core × cost that is defined in the cost
model for the CPU core cost. The CPU charge unit is
per core.

CPU Core Cost

The used memory × cost that is defined in the cost
model for the used memory cost.2.

Memory Used Cost

The network received usage in KB / (1024.0 × 1024.0)
× cost that is defined in the cost model for the received
network data cost. The network charge unit is GB.

Network Received Used Cost

The network transmitted usage in KB / (1024.0 ×
1024.0) × cost that is defined in the cost model for
the transmitted network data cost.5.

Network Transferred Used Cost
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Cost DescriptionCost

The active VM hours × cost that is defined in a catalog
for active VM application cost + inactive VM hours
× cost that is defined in a catalog for the inactive VM
application cost.

Application Cost

The cost of full-length blade servers per-hour. This
cost is applicable only for physical servers.

This is applicable only for physical servers that are
part of an application container.

Full-length Blade Cost

The cost of half-length blade servers per-hour. This
cost is applicable only for physical servers.

This is applicable only for physical servers that are
part of an application container.

Half-Length Blade Cost

The fixed cost, per-hour, determined for the VM.

This is applicable only if you have indicated that the
tag-based cost model should be included with the
regular cost model for the VM.

Fixed Cost USD
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C H A P T E R 16
System Monitoring and Reporting

This chapter contains the following sections:

• Dashboard, on page 331
• Summary, on page 333
• Inventory Management, on page 333
• Resource Pools, on page 334
• Clusters, on page 334
• Images, on page 335
• Host Nodes, on page 336
• Virtual Machines (VMs), on page 336
• Topology, on page 337
• Assessment, on page 337
• Reports, on page 338

Dashboard
In Cisco UCSDirector, you can enable theDashboard option in the user interface. On theDashboard screen,
you can add important, or frequently accessed report widgets. If you have enabled the Dashboard option,
then this is the first window that you see when you log in to the user interface. After enabling theDashboard,
you can create additional dashboards, and delete them when you no longer need them. For more information,
see Creating Additional Dashboards, on page 332 and Deleting a Dashboard, on page 332.

Enabling the Dashboard

Step 1 On the header, click the user icon, and choose Edit My Profile.
Step 2 On the Edit My Profile screen, scroll down to the Dashboard section.
Step 3 Check Enable Dashboard.
Step 4 Click Save.

When you log out and log in, the first screen that you see is the Dashboard.

Step 5 Click Close to view the Dashboard immediately.
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What to do next

If there are no widgets on the Dashboard, you can access any summary report in the user interface, and select
Add to Dashboard.

Creating Additional Dashboards

Before you begin

You should have enabled the Dashboard in the user interface.

Step 1 Log into Cisco UCS Director user interface.

The default Dashboard screen is displayed.

Step 2 Click the down arrow displayed next to the default dashboard name and choose Create Dashboard.
Step 3 Enter the name of the dashboard.
Step 4 Click Submit.

Deleting a Dashboard
You cannot delete the default dashboard.

Step 1 Log into Cisco UCS Director user interface.

The default Dashboard screen is displayed.

Step 2 Click the drop-down list to view the list of dashboards that you have created.
Step 3 Click the X mark displayed next to the dashboard name.
Step 4 Confirm that you want to delete the dashboard.

Adding Report Widgets

Before you begin

You must be logged in to the appliance to complete this task.

Step 1 Choose the desired option and navigate to the summary report you want to add to your dashboard.

For example, if you want to add a VM-related summary report, choose Virtual > Compute and then click Summary.

Step 2 On the Summary screen, scroll down to the report that you want to add to your dashboard.
Step 3 In the upper right corner of the report, click Settings and then choose Add to Dashboard.
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Refreshing Widget Data
After enabling the Dashboard option, you can set a refresh interval to the widgets on this page. Automatic
refresh can occur at intervals from a minimum of 5 minutes to a maximum of 60 minutes.

The Automatic Refresh button on the dashboard should be set to ON to configure the interval.

Summary
The Summary screen allows you to manage system inventory. It gives you access to a wide array of tabular,
graphical, and map reports, and also helps in managing inventory lifecycle actions.

Each report is displayed as a widget. Reports can be hidden through customization.

Viewing Virtual Machine, Cloud, and System Summary Information

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, click Summary.

All information is displayed in the form of tables, graphs, and charts.

Customizing Summary Report Widgets

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, click Summary.
Step 3 Click the reports drop-down icon to display the available reports.
Step 4 Click and drag a widget onto the Dashboard.
Step 5 From the Show more reports drop-down list, check the name of the report that you want to add.

Inventory Management
You can monitor the system inventory using theDashboard. TheDashboard displays the entire system level
infrastructure information for administrative management.

Accessing System Inventory Details

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.

Cisco UCS Director Administration Guide, Release 6.6
333

System Monitoring and Reporting
Refreshing Widget Data



Step 3 Choose any of the options to view detailed information.

Following is a list of some of the report options visible for each cloud:

• Summary

• Polling

• VDCs

• Clusters

• Host Nodes

• Resource Pools

• VMs

• VM Action Requests

• Events

• Assessment

• Application Categories

• Data Centers

• SRM Sites

Resource Pools
The Resource Pools screen shows resource details at the host node level. These details include the CPU
configured reservation, CPU limit, CPU used, and memory used.

Accessing Resource Details

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click Resource Pools.

All the resource pools for the selected cloud are displayed. You can select a resource pool and click View
Details to view detailed information of each resource pool.

Clusters
If a pod includes clusters, then the Clusters screen displays all the cluster-related information.
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Accessing Clusters

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click Clusters.

All clusters available in the selected cloud accounts are displayed. You can select a specific cluster, and click
View Details.

Images
The Images screen displays all available image IDs and their details. These images include guest OS, CPU,
memory, and storage provisioned. You can use these image IDs to provision new virtual machines (VMs). If
you are a group administrator, or an MSP administrator, then the Images screen displays images that have
been assigned to your group.

If you select a specific VMware cloud account, and click Images, you can assign images to groups or to
individual users. Images assigned to a particular group or user are displayed when administrators of the relevant
group log in to the system.

Accessing Images

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click Images.

A list of images associated with the selected clouds is displayed. You can select a specific image and click
View Details.

Assigning VM Images to Users or Groups
As an administrator, you can assign specific VM images to users or groups. The assignments filter the images
that are displayed when you perform VM provisioning tasks, such as creating catalogs.

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click Images.
Step 4 Click the row with the image that you want to assign to a group.
Step 5 Click Assign Image to Group.
Step 6 On the Assign Image to Group screen, expand the Group ID field, and check the names of the groups to which you

want to assign the image.
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Step 7 To assign an image to individual users, complete the following fields:

DescriptionName

Check to assign the image to specific users.Assign to Users check box

Expand this field to check the names of users to whom you
want to assign the image.

User field

Step 8 Click Submit.

Host Nodes
The Host Nodes screen displays all physical host nodes that are available in the infrastructure. The screen
lists details such as the ESX/ESXi version installed, active VMs, and power status.

Accessing Host Nodes

Before you begin

You must be logged in to the appliance to complete this task.

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, click Host Nodes.
Step 3 Click the row with the host node that you want view, and click View Details.

Virtual Machines (VMs)
The VMs screen displays all the VMs and VM-specific details for the chosen cloud.

Accessing VMs

Step 1 On the menu bar, choose Virtual > Compute.
Step 2 On the Compute page, click VMs.

All virtual machines for all cloud accounts are displayed. You can perform additional tasks on these VMs
such as launching VM client or powering off VMs. For more information, see Managing VM Actions, on
page 343.
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Accessing Group Level VMs

Step 1 Choose Organizations > Virtual Resources.
Step 2 On the Virtual Resources page, choose the user group.
Step 3 On the Virtual Resources page, click VMs.

All virtual machines for the selected group are displayed. You can perform additional tasks on these VMs
such as launching VM client or powering off VMs. For more information, see Managing VM Actions, on
page 343.

Topology
The Topology screen displays VMware cloud topology. There are four view mode types: Hierarchical,
Concentric, Circular, and Force Directed. Depending on the mode, you can adjust the item spacing, distance,
radius, rigidity, and force distance.

Accessing Topology Types

Before you begin

You must be logged in to the appliance to complete this task.

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click Topology.
Step 4 Choose Hostnode-Datastore Topology or Hostnode-VM Topology.
Step 5 Click View Connectivity.

The topology appears in a new window.

Not all of the topology types are displayed.Note

Assessment
The Assessment screen displays assessment reports such as cloud readiness, and virtualization best practices
for a cloud account.
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Accessing Assessments

Before you begin

You must be logged in to the appliance to complete this task.

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click Assessment.
Step 4 From the drop-down list, choose a report type to filter the report.

Reports
Cisco UCS Director can help you monitor virtual infrastructure and system resources. It displays a wide
variety of reports that provide insight into how the system is performing

Following are the types of reports:

• Tabular reports for system information, including overview, host nodes, new VMs, and deleted VMs.

• Bar and pie graph comparisons, including VMs active versus inactive, and CPU provisioned versus
capacity.

• Trend graphs about system resources, including CPU trends, memory trends, and VM additions and
deletions.

• Other reports include Top 5 reports at the group, VDC, host node, and VM levels. The Top 5 reports
focus on groups with the highest number of VMs, groups with the greatest CPU usage, VDCs with the
highest number of VMs, and host nodes with the greatest CPU usage.

• Map reports, displaying the system resource information in the form of heat maps or color-coded maps.

Additional trend reports are available for certain accounts (for example: KVM accounts). Trend reports display
data over a selected time frame.

Accessing Reports

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 Click the name of the report that you want to view (Map, Top 5, orMore Reports).
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C H A P T E R 17
Managing Lifecycles

This chapter contains the following sections:

• Managing VM Power Settings, on page 339
• Managing VM Snapshots, on page 340
• Configuring the Lease Time for a Virtual Machine, on page 342
• Managing VM Actions, on page 343
• Applying a Tag to a VM, on page 362
• Mounting an ISO Image as a CD/DVD Drive, on page 363
• Unmounting an ISO Image as a CD/DVD Drive, on page 364

Managing VM Power Settings
Before you begin

You must be logged in to the appliance to complete this task.

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click VMs.
Step 4 Click the row with the VM on which you want to perform an action.
Step 5 Choose an action and the VM Task screen appears.

DescriptionName

The name of the VM that is the subject of the action.VM Name display-only field

The task to power off the VM.Power Off display-only field

The task to power on the VM.Power On display-only field

The task to put the VM in a suspended state.Suspend display-only field

The task to shut down the guest OS on the VM.Shutdown Guest display-only field
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DescriptionName

The task to move the VM into a standby state.

Not supported in the RHEV KVM Connector.Note

Standby display-only field

The task to perform a hard reset of the VM.

Not supported in the RHEV KVM Connector.Note

Reset display-only field

The task to perform a soft reboot of the VM.

Not supported in the RHEV KVM Connector.Note

Reboot display-only field

Enter any comments that help identify the VM.Comments field

The task to power on a VM now or later at a specific date
and time.

Schedule Action radio button

Step 6 Click Proceed.

Managing VM Snapshots
This process includes the following tasks:

• Create Snapshot—You can create a snapshot of all the VM’s resources in their current state.

• Revert Snapshot—If the VM crashes or malfunctions (For example, if the OS becomes corrupt), you can
revert to the most recent snapshot of the VM. Where there are multiple snapshots for a VM, you can
revert to a specific snapshot.

• Mark Golden Snapshot—You can mark a specific snapshot for a VM as a Golden Snapshot. This feature
protects the snapshot from accidental deletion.

• Delete a Snapshot—You can delete a snapshot, if necessary. A Golden Snapshot must be first unmarked
before it can be deleted.

• Delete All Snapshots—You can delete all snapshots for a VM. However, you cannot delete all snapshots
if they include Golden Snapshots. You must first unmark any Golden Snapshot and then delete all
snapshots.

Creating VM Snapshots

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click VMs.
Step 4 Click the row with the VM for which you want to create a snapshot.
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Step 5 From theMore Actions drop-down list, choose Create Snapshot.
Step 6 On the Create Virtual Machine Snapshot screen, complete the following fields:

DescriptionName

The snapshot name.Snapshot Name field

The snapshot description.Snapshot Description field

Check the check box to include the VM memory in the
snapshot.

Snapshot Memory check box

Check the check box to take the snapshot in quiesce mode.

Quiescing a file system brings the on-disk data
of a physical or virtual computer into a state that
is suitable for backups. This process might
include operations such as flushing buffers from
the operating systems in-memory cache to disk,
or other higher-level application-specific tasks.
To use this option, VMware Tools must be
installed on the VM.

Note

Quiesce Guest File System check box

Step 7 Click Proceed.

Reverting to a Snapshot

Before you begin

You must be logged in to the appliance to complete this task.

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click VMs.
Step 4 Click the row with the VM that you want to revert to a snapshot.
Step 5 From theMore Actions drop-down list, choose Revert Snapshot.
Step 6 On the Revert Snapshot Task screen, check the name of the desired snapshot.
Step 7 Click Proceed.

Marking a Golden Snapshot

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
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Step 3 On the Compute page, click VMs.
Step 4 Click the row with the VM for which you want to mark a snapshot as golden.
Step 5 From theMore Actions drop-down list, chooseMark Golden Snapshot.
Step 6 On theMark Golden Snapshot Task screen, check the name of the desired snapshot.
Step 7 CheckMark as Golden Snapshot.
Step 8 Click Proceed.

Deleting a Snapshot

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click VMs.
Step 4 Click the row with the VM for which you want to delete a snapshot.
Step 5 From theMore Actions drop-down list, choose Delete Snapshot.
Step 6 On the Delete Snapshot Task screen, check the name of the desired snapshot.
Step 7 Check Delete Children to delete child snapshots of the selected snapshot.
Step 8 Click Proceed.

Deleting All Snapshots

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click VMs.
Step 4 Click the row with the VM for which you want to delete all snapshots.
Step 5 From theMore Actions drop-down list, choose Delete All Snapshots.
Step 6 On the VM Snapshot Task screen, enter an optional comment.
Step 7 Click Proceed.

Configuring the Lease Time for a Virtual Machine
A user can configure a lease expiration time for a selected virtual machine (VM). Once the lease time expires,
the VM is powered down. The lease time end is a calendar selection.

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
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Step 3 On the Compute page, click VMs.
Step 4 Click the row with the VM for which you want to configure the lease time.
Step 5 From theMore Actions drop-down list, choose Configure Lease Time.
Step 6 On the Configure Lease Time screen, check Set Lease Time. Complete the following fields:

DescriptionName

The name specified while creating the VM.

Once entered, you cannot edit the name of the VM.

VM Name field

The lease date and time for the VM. There are calendars
for the Date, drop-down lists for the Time (hour and
minute), and radio buttons for AM or PM.

Lease Date/Time calendar, drop-down lists, radio buttons

Step 7 Click Submit.

Managing VM Actions
After creating a VM, you can perform additional tasks on it, by using menus available in the user interface.
You can access these menus in one of the following ways:

• Right clicking on a VM to view a list of limited options,

• Choosing a VM and clicking the down arrow option on the toolbar for a complete list of options.

Following are the other VM actions:

• View VM Details—You can access individual VMs to view details, such as summary reports, vNICs,
disks, and snapshots.

• Stack View—You can view stacks of information about a particular VM including, OS, hypervisor, and
infrastructure information.

• Delete a VM—You can delete a VM from the list. Only a powered-off VM can be deleted.

• Create a VM Disk—You can add an additional disk with a custom size to a VM.

• Delete a VM Disk—You can delete a disk.

• Add vNICs—You can add multiple vNICs to a VM. You also have the option to add or replace a vNIC
in a VM. The options for vNICs depend on the network policy mapped to the VDC associated with the
VM.

• Launch VM Client—You can set up and access either web access, remote desktop, or VMRC Console
access for a VM.

• Launch VNC Console—You can set up and access the VM console using the VNC client.

• VMRC Console (HTML5)—You can launch a VMRC HTML5 console that is web browser and plug-in
independent.
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• Assign VM—You can assign a VM to a group or VDC and modify the category of the VM. You can set
the provisioning time, termination time, and label for a VM.

• Access VM Credentials—You can access a VM’s login credentials when it is set up for web or remote
desktop access, but only if the administrator provides the privileges in the catalog from which the VM
is provisioned.

• Inventory Collection Request for VM—You can choose aVMand request on-demand inventory collection.

• Test VNC—You can test VNC connectivity, for troubleshooting purposes.

• Clone—You can clone or make a copy of an existing VM to make a new VM with the same or similar
qualities.

• Move a VM to VDC—You can move a VM to a VDC so that the rules of the VDC system policy are
followed in the VM.

• VM Resync—You can choose to set the number of minutes to have a VM resynchronize its time
periodically with Cisco UCS Director.

• Mount ISO Image as CD/DVD Drive—You can mount ISO images on the VM without using a physical
drive. Once mounted in your virtual machine, you can open, extract, and use the files from a virtual
CD/DVD drive without a physical disk.

• Unmount ISO Image as CD/DVDDrive—You can unmount an ISO image already attached to CD/DVD
drive on the virtual machine.

Viewing VM Details

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click VMs.
Step 4 Click the row with the VM for which you want to view the details.
Step 5 Click View Details.

Resizing VMs

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click VMs.
Step 4 Click the row with the VM that you want to resize.
Step 5 From theMore Actions drop-down list, choose Resize VM.
Step 6 On the Resize VM screen, complete the following fields:
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DescriptionName

The name of the selected VM.VM Name field

The number of allocated CPUs being used by the VM.Current Allocated CPU field

The amount of memory allocated to the VM.Current Allocated Memory (GB)
field

Choose the CPU required.New CPU Count drop-down list

Choose the cores per socket.New Cores Per Socket drop-down
list

Choose the amount of memory.New Memory drop-down list

Displays the current CPU cost per-hour.

This value is calculated based on the currently allocated CPU for the VM.

Current CPU Cost (Currency:
USD) field

Displays the current memory cost per-hour.

This value is calculated based on the currently allocated memory for the VM.

Current Memory Cost (Currency:
USD) field

Displays the CPU cost per-hour based on the CPU count specified for the VM.New CPU Cost (Currency: USD)
field

Displays the memory cost per-hour based on the memory specified for the VM.New Memory Cost (Currency:
USD)

If you checked the Disable displaying cost details check box while adding or modifying the VDC, then
information on the current and new CPU cost and memory cost is not displayed.

Important

Step 7 Click Resize.

Using the Stack View Option

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click VMs.
Step 4 Click the row with the VM for which you want to view the stack view.
Step 5 Click Stack View.

The Stack View screen displays information on the selected VM.
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• If there are multiple components in the report, such as hard drives or network adapters, you can click the
arrow displayed on each component and select a different component.

• You can view additional information on each component by clicking the eye icon.

Note

Creating a VM Disk
You can create a VM disk only if you checked Allow Resizing of Disk while configuring the storage policy
that is mapped to the vDC.

Before you begin

The VM should be in the powered off state.

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click VMs.
Step 4 Click the row with the VM on which you want to create a VM disk.
Step 5 From theMore Actions drop-down list, choose Create VM Disk.
Step 6 On the Create VM Disk screen, complete the following fields:

DescriptionName

The name of the VM.

Once entered, the VM name cannot be edited.

VM Name field

The disk size for the VM, in GB.

You must enter an integer in this field, and this integer
should be within the range specified in the storage policy
associated with this VM.

New Disk Size (GB) field

Choose the disk type. It can be one of the following:

• System

• Swap

• Data

• Database

• Log

Select Disk Type drop-down list

Specify if the VM disk should be created from a datastore
or a datastore cluster.

Select Datastore/Datastore Cluster drop-down list

Cisco UCS Director Administration Guide, Release 6.6
346

Managing Lifecycles
Creating a VM Disk



DescriptionName

Click Select and choose which datastore you want to use
to create the VM disk.

The available datastores depend upon the storage
policy associated with the VDC. Only datastores
that meet the criteria specified in the storage
policy are available for the VM disk.

Note

This field is only available if you specify that the VM disk
should be created from a datastore.

Select Datastore field

Click Select and choose which datastore cluster you want
to use to create the VM disk.

The available datastore clusters depend upon the
storage policy associated with the VDC. Only
datastore clusters that meet the criteria specified
in the storage policy are available for the VM
disk.

Note

This field is only available if you specify that the VM disk
should be created from a datastore cluster.

Select Datastore Cluster field

Check the check box to add a thin provisioned disk to the
VM.

Thin provisioning enables dynamic allocation of
the physical storage capacity to increase VM
storage utilization.

Note

Thin Provision check box

This option calculates and displays the disk cost, per hour,
based on the new disk size and the datastore you have
specified for the VM disk.

If you checked the Disable displaying cost
details check box while adding or modifying the
VDC, then the Compute New Disk Cost field
is not displayed.

Important

Compute New Disk Cost field

Step 7 Click Create.

Resizing a VM Disk

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click VMs.
Step 4 Click the row with the VM for which you want to resize the VM disk.
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Step 5 From theMore Actions drop-down list, choose Resize VM Disk.
Step 6 On the Resize VM Disk screen, complete the following fields:

DescriptionName

The name of the VM.

This name cannot be edited.

VM Name field

Select the VM disk from the drop-down list.Select Disk drop-down list

Displays the total provisioned space on the VM.Total Provisioned (GB) field

The new size for the VM.

Enter an integer in this field. This integer should be within
the range or among the comma separated values specified
in the storage policy associated with this VM and should
be greater than the total provisioned size.

New Size (GB) field

Displays the current disk cost per hour.Current Disk Cost (Currency: USD) field

This option calculates the disk cost, per hour, based on the
new disk size you specified.

Compute New Disk Cost field

Displays the disk cost per hour for the new disk size
specified for the VM.

New Disk Cost (Currency: USD) field

If you checked the Disable displaying cost details check box while adding or modifying the VDC, then
information on the current and new disk cost is not displayed.

Important

Step 7 Click Resize.

Locking VMs in Cisco UCS Director
As an administrator in Cisco UCS Director, you can create a list of VMs that you would like locked. Locking
VMs implies preventing actions from running on the specified VMs. These actions could be shutting down,
resetting, or powering off VMs.

Step 1 Create an XML file titled VMControls.xml which is similar to the following:
<VMControlList>
--<VMControl>

<ControlType>lock</ControlType>
<MatchType>VM-IPAddress</MatchType>
<MatchValue>19.19.19.19</MatchValue>
<IsRegex>false</IsRegex>
<ContactEmail>admin@admin.com</ContactEmail>
--<Label>

Do not shutdown or delete my machine.
--</Label>

--</VMControl>
--<VMControl>
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<ControlType>lock</ControlType>
<MatchType>VM-IPAddress</MatchType>
<MatchValue>19.29.29.29*</MatchValue>
<IsRegex>true</IsRegex>
<ContactEmail>admin@admin.com</ContactEmail>
--<Label>

Do not shutdown or delete this machine.
--</Label>

--</VMControl>
</VMControlList>

Step 2 Host this file on a server that is accessible from the system that is running Cisco UCS Director.
Step 3 Choose Administration > System.
Step 4 On the System page, click System Parameters.
Step 5 In the Download VM Locking Controls From URL field, enter the URL of the XML file.

The URL will look similar to this: <ip_address>:8000/VMControls.xml.

Step 6 Click Save.
Step 7 On the System page, click System Tasks.
Step 8 Search for and select the VM Control List Poller Task.
Step 9 Click Run Now.

This system task downloads the VMControls.xml file and saves it in the inventory database. After this system task
is run, actions such as powering off, or shutting down are prevented from running on VMs that match the IP addresses
specified in the XML file.

Adding vNICs

When you add a vNIC VM, the values of the Port Group Name andAdapter Type parameters are modified.
The IP address of the VM is changed only if DHCP is enabled on the selected port group. However, the IP
address is not modified if it is sourced from a static pool policy.

Note

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click VMs.
Step 4 Click the rwo with the VM to which you want to add a vNIC.
Step 5 From theMore Actions drop-down list, choose Add vNICs.
Step 6 On the Add VM vNICs screen, choose Add from the Operation drop-down list.

This addition is not allowed if the vNIC limit configured in the network policy will be exceeded.

Step 7 Expand the VM NETWORKS list.
Step 8 Click Add (+).
Step 9 On the Add Entry to VM Networks screen, complete the following fields:
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DescriptionName

Choose a NIC alias from the list.NIC Alias drop-down list

Choose a port group from the list.Port Group Type display-only drop-down list

Choose a port group name from the list.Port Group Name drop-down list

Choose the adapter type.

The choice is available only if the NIC alias does not have
Copy Adapter Type from Template chosen in the
network policy.

Adapter Type display-only drop-down list

If this field is checked, then the IP is assigned using DHCP.DHCP check box

The static IP address pool.Static IP Pool field

The network mask.Network Mask field

The gateway IP address.Gateway IP Address field

The NIC Alias, Port Group Name, Adapter Type, DHCP, and Static IP Pool choices depend on the
settings in the network policies associated with the VM (VM’s VDC). For more information about multiple
NIC network policies, see Managing Policies, on page 169.

The VM is powered down to perform this action. The VM will power up once the action is completed.

Note

Step 10 Click Submit.

Replacing a vNIC

When you replace a vNIC VM, the values for the Port Group Name and Adapter Type parameters are
modified. The IP address of the VM is changed only if DHCP is enabled on the selected port group. However,
the IP address is not modified if it is sourced from a static pool policy.

Note

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click VMs.
Step 4 Click the row with the VM for which you want to replace a vNIC.
Step 5 From theMore Actions drop-down list, choose Add vNICs.
Step 6 On the Add VM vNICs screen, choose Replace from the Operation drop-down list.

This replacement is not allowed if the additional vNIC limit configured in the network policy will be exceeded.

Step 7 Choose a vNIC.
Step 8 On the Add vNIC screen, complete the following fields:
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DescriptionName

Choose a NIC alias.

Only the vNICs configured in the network policy are visible
here.

NIC Alias drop-down list

Choose a port group name from the list.Port Group Name drop-down list

Choose the adapter type.

The choice is available only if the choice of the NIC alias
does not haveCopy Adapter Type fromTemplate chosen
in the network policy.

Adapter Type display-only drop-down list

Check the check box if you want the IP assigned using
DHCP.

DHCP check box

The static IP address pool.Static IP Pool field

The network mask.Network Mask field

The gateway IP address.Gateway IP Address field

Step 9 Click Submit.

The VM is powered down to perform this action. The VM is powered up once the action is completed. The
Replace task removes all existing vNICs from the VM and replaces them with the vNICs that were added.

TheNIC Alias, Port Group Name,Adapter Type,DHCP, and Static IP Pool choices depend on the settings
in the network policy associated with the VM (VM’s VDC). For more information about multiple NIC network
policies, see Managing Policies, on page 169.

Note

Launching the VM Client

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click VMs.
Step 4 Click the row with the VM for which you want to launch the VM client.
Step 5 Click Launch VM Client.
Step 6 On the Launch Client screen choose an access scheme for the VM Client.

If a VM is provisioned through Cisco UCS Director, the access schemes displayed in this dialog box are defined by the
options enabled in the catalog used to provision the VM.

For a VM that is discovered, the options, Remote Desktop,Web Access, VMRC Console (Browser Plug-in), and
VMRC Console (Standalone Plug-in) are displayed.
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Step 7 Click Proceed.

Enabling the VNC Console on a VM

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click VMs.
Step 4 Click the row with the VM for which you want to configure VNC.
Step 5 From theMore Actions drop-down list, choose Configure VNC.
Step 6 On the Configure VNC screen, choose a keyboard mapping language from the drop-down list.

• French (Switzerland)

• Japanese

• US English

• Italian

• Icelandic

• UK English

• French (Belgium)

• German (Switzerland)

• German

• Spanish

• Norwegian

• Finnish

• Polish

Step 7 Click Submit.
Step 8 Click OK.

The system automatically configures VNC console access to a VM when a request is submitted.

Automatically Unconfiguring the VNC Console on a VM
You can enable the VMware Monitor VNC Port Task to enable automatic unconfiguration of VNC consoles.
This task runs every 30 minutes and unconfigures VNC ports that are open for more than a default of 60
minutes. VNC is unconfigured on the ports, and the ports are released for future allocation.
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You can modify the frequency in which the task is run by clickingManage System Task and selecting the
duration from the drop-down list.

You can modify the port wait time by editing the unConfigureVNCPortWaitTime parameter in the
/opt/infra/inframgr/vmware.properties file.

Step 1 Choose Administration > System.
Step 2 On the System page, click System Tasks.
Step 3 Click the VMware Standard Tasks arrow to expand its tasks.
Step 4 Click the row with the VMware Monitor VNC Port Task system task.
Step 5 ClickManage Task.
Step 6 From the Task Execution drop-down list, choose Enable.
Step 7 Click Submit.

Accessing VM Console Using VNC Client
The VNC client is an Ajax-based application that provides access to a VM console. The console window can
be launched by using any standalone web browser. It does not require a dedicated browser plug-in and it
provides full VM control capabilities. However, you must disable popup blockers in the browser for the VNC
console to launch.

Before you begin

• You must configure ESX/ESXi server for VNC access to VM console. For more information, see
Configuring ESX/ESXi Server for VNC Access to VM Console, on page 354.

• Cisco UCS Director provides automatic configuration of the VM console access using VNC client. To
configure, you must open ports 5901-5964 in the ESX/ESXi server to the Cisco UCS Director appliance.

• Import a self-signed certificate or a CA certificate using Cisco UCS Director admin shell. Importing a
certificate enables secured access to the VM console using the VNC client. For more information on
importing certificates, see the Cisco UCS Director Shell Guide

• Disable popup blockers in your browser.

VMware with ESX 4.x, ESXi 5.x, and ESXi 6.0 versions is supported for configuring VM console access
using the VNC client.

Note

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click VMs.
Step 4 Click the row with the VM for which you want to launch the VNC console.
Step 5 Click Launch VNC Console.
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Step 6 On the Launch VNC Console screen, choose the keyboard mapping layout, and click Submit.

If the screen is blank, click in the black area and press Enter.Tip

Configuring ESX/ESXi Server for VNC Access to VM Console
VMware with ESX 4.x and ESXi 5.x versions is supported to configure VNC access to the VM console.

Step 1 Log in to ESXi5.x host.
Step 2 Using the shell, disable the firewall configuration.
Step 3 Copy and paste the following XML configuration to the vnc.xml file.

# cat /etc/vmware/firewall/vnc.xml
<!-- Firewall configuration information for VNC -->
<ConfigRoot>
<service>
<id>VNC</id>
<rule id='0000'>
<direction>inbound</direction>
<protocol>tcp</protocol>
<porttype>dst</porttype>
<port>
<begin>5901</begin>
<end>5964</end>
</port>
</rule>
<rule id='0001'>
<direction>outbound</direction>
<protocol>tcp</protocol>
<porttype>dst</porttype>
<port>
<begin>0</begin>
<end>65535</end>
</port>
</rule>
<enabled>true</enabled>
<required>false</required>

</service>
</ConfigRoot>

This vnc.xml file is available when VNC is enabled for the host. If this file is not available, then create a
vnc.xml file, add the configuration lines mentioned in this procedure, and save the file.

Note

Step 4 Refresh the firewall rules and verify that the new configuration is accurately loaded.
~ # esxcli network firewall refresh
~ # esxcli network firewall ruleset list | grep VNC
VNC true #****************************************

Step 5 Repeat these steps on all ESXi hosts in an ESXi cluster.
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Assigning a VM
You can assign a resource or a VM to a user group. If the resource or VM is in a VMWare cloud, then you
can also assign it to a specific end user in Cisco UCS Director.

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click VMs.
Step 4 Click on the row with the VM that you want to assign.
Step 5 From theMore Actions drop-down list, choose Assign VM.
Step 6 On the Assign VM screen, complete the following fields:

DescriptionName

The name of the VM.VM Name field

VM Ownership Section

Select this radio button to assign the VM to a specific group.Customer Organizations radio button

Click Select to choose the specific user group to which you
want to assign the VM.

This field is visible only when you select the Customer
Organizations radio button.

Only groups that have valid vDCs are displayed.Note

Cutomer Organizations field

Select this radio button to assign the VM to a specific user.User radio button

Click Select to choose the user to whom you want to assign
the VM. This list is populated with users from groups that
allow resource assignment to users.

User field

VM Access Sharing Section

Click Select to choose users who can only access VM
information.

The selected users can only access the VM. They cannot
perform any administrative actions

This option is only available if the User radio button is
selected and you have selected a specific user for this VM.

Users with Access Privilege field

Click Select to choose users who can only manage the VM.

The selected users can perform administrative tasks on the
VM.

This option is only available if the User radio button is
selected and you have selected a specific user for this VM.

Users with Manage Privilege field

General Assignment Information Section
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DescriptionName

Choose the VDC.VDC drop-down list

Choose the category for the VM.Category drop-down list

The VM label if required.VM User Label field

Check the check box to set a specific provisioning time for
the VM.

Set Provision Time check box

The VM’s provisioning date and time. There are calendars
for the Date, drop-down lists for the Time (hour and
minute), and radio buttons for AM or PM.

This option appears when Set Provision Time is checked.

Provision Date/Time calendar, drop-down lists, radio
buttons

Add any comments about the task, if necessary.Comments field

Step 7 Click Assign.

VM Credentials
The web or remote access login credentials for a VM can only be viewed if the administrator provides the
necessary privileges in the Catalog from which the VM is provisioned.

Viewing VM Credentials

Before you begin

You must be logged in to the appliance to complete this task.

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click VMs.
Step 4 Click the row with the VM for which you want to view the credentials.
Step 5 From theMore Actions drop-down list, choose Access VM Credentials.

Initiating Inventory Collection for a VM

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click VMs.
Step 4 Click the row with the VM for which you want to request an inventory collection.

Cisco UCS Director Administration Guide, Release 6.6
356

Managing Lifecycles
VM Credentials



Step 5 From theMore Actions drop-down list, choose Inventory Collection Request for VM.
Step 6 Click Submit.

Testing VNC Connectivity
Testing VNC connectivity is used for troubleshooting purposes. A successful test for VNC connectivity
displays the host node IP address and VNC port number. For example: VNC connectivity intact
at 172.16.0.1:5921.

However if connectivity fails, a failure message displays. For example: VM is not configured for
VNC yet.

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click VMs.
Step 4 Click the row with the VM on which you want to test VNC connectivity.
Step 5 From theMore Actions drop-down list, choose Test VNC.
Step 6 On the Test VNC Connectivity screen, click Submit.
Step 7 Use the result to troubleshoot VNC connectivity.

If connectivity fails, then there is no VNC port assigned to the VM IP address. For more information, see
Enabling the VNC Console on a VM, on page 352.

Note

Cloning a VM
Cloning a VM allows you to create a new VM in the system by using some of the parameters defined in an
existing VM. The cloning option helps you create a VM faster, especially if you want to modify only a few
parameters of an existing VM. The name that you specify for the cloned VM is defined by the system policy.

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click VMs.
Step 4 Click the row with the VM that you want to clone.
Step 5 From theMore Actions drop-down list, choose Clone.
Step 6 On the Clone VM: Select Group screen, complete the following fields:

DescriptionName

Expand the list to choose a predefined group to clone and
click Select. The Default Group is chosen by default.

Select Group list
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DescriptionName

Check the box to assign the VM to a specific user.

This option is visible only if resource assignment to users
is enabled for the group share policy that is applied to the
selected user group. For more information on creating a
group share policy, see Creating a Group Share Policy, on
page 179.

Assign To User check box

Choose the user to whom this VM is assigned.

Currently, only VMs that are in a VMware
cloud can be assigned to a specific user.

Note

User drop-down list

Check the box to clone a VM from a linked clone.

A linked clone is a copy of a virtual machine
that shares virtual disks with the parent VM. A
linked clone is made from a snapshot of the
parent VM. A linked clone must have access to
the parent VM. Without access to the parent
VM, a linked clone is disabled.

Note

Linked Clone or Full Clone depends on the Linked Clone
selection in the Storage Policy.

Use Linked Clone check box

Choose the type of snapshot that is associated with the
linked clone.

You can choose one of the following:

• Existing Snapshot

• New Snapshot

Select Snapshot Type drop-down list

Expand the list to choose an existing snapshot and click
Select.

This field appears only when you select
Existing Snapshot.

Note

Select Existing Snapshot list

Enter a name for the new snapshot.

This field appears only when you select New
Snapshot.

Note

Snapshot Name field

Check the box to ensure that VMs are deployed using
ReadyClones.

When this box is checked, the Use Linked Clone check
box is hidden.

Use ReadyClone check box

Step 7 Click Next.
Step 8 On the Clone VM: Customization Options screen, complete the following fields:
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DescriptionName

Expand the list to choose the required VM category and
click Select.

Category list

Choose to allow or disallow users to retrieve VM access
credentials (shared). The following options are available:

• Do not share

• Share after password reset

• Share template credentials

The Do not share option is chosen if the administrator
wants to send the credentials privately to another user
outside Cisco UCS Director.

Credential Options drop-down list

Enter the user ID.

This field is available only if a choice is made to share
under Credential Options.

User ID field

Enter the user password.

This field is available only if a choice is made to share
under Credential Options.

Password field

Check the box to provision all VM disks in the previously
configured single datastore.

Provision all disks in a single datastore check box

Check the box to assess the budget allocation, resource
limits, and resource availability prior to cloning a VM.
After you check this box, the summary of the assessment
is displayed on the Deployment Assessment screen.

This option is visible only for VMware clouds.Note

Perform deployment assessment check box

This box is checked.Automatic Guest Customization Enable check box

Check the box to enable execution of an orchestration
workflow after VM provisioning.

The chosen workflow initiates when provisioning starts.

Post Provisioning Custom Actions Enable check box

Choose a defined workflow for provisioning.

This field appears when Post Provisioning
Custom Actions Enable is checked.

Note

Any workflow input values are entered on theClone VM:
Custom Workflow screen.

Workflow drop-down list

Choose Hourly orMonthly.VM App Charge Frequency drop-down list

Enter the cost for the application that is included in the
template.

Active VM Application Cost field
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DescriptionName

Enter the cost to this catalog of a VM in inactive state, per
hour or month.

Inactive VM Application Cost field

Step 9 Click Next.
Step 10 On the Clone VM: Deployment Configuration screen, complete the following fields:

DescriptionName

Choose a VDC containing the policies you want for the
VM.

Select VDC drop-down list

Optionally, enter a description of the VDC.Comment field

Choose Now to provision the VDC now or choose Later
to provision the VDC later.

If you choose Later, then fields to specify the date and
time appear.

Provision drop-down list

Check the box to configure a lease expiration time.Lease Time check box

Enter the number of days for the lease time.

This field appears only when Lease Time is
checked.

Note

Days field

Enter the number of hours for the lease time.

This field appears only when Lease Time is
checked.

Note

Hours field

Step 11 Click Next.
Step 12 On the Clone VM: Custom Specification screen, complete the following fields:

DescriptionName

Choose the CPU cores for the VM being provisioned.CPU Cores drop-down list

Choose the cores per socket for the VM being provisioned.
The number of cores per socket available is specified in
the VM computing policy.

Cores Per Socket drop-down list

Choose the amount of memory for the VM being
provisioned.

Memory drop-down list

Step 13 Click Next.
Step 14 On the Clone VM: Custom Workflow screen, enter any workflow input values, if applicable.
Step 15 Click Next.
Step 16 On the Clone VM: Select Datastores screen, expand VM Disks to assign any applicable datastores to the applicable

disk.
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Step 17 Click the row of the disk to which you want to assign a datastore.
Step 18 Click Edit selected entry in the table below.
Step 19 On the Edit VM Disks Entry screen, complete the following fields:

DescriptionName

The name of the VM disk to which datastores are assigned.Disk Name

Choose the VM disk type. For example, System.Disk Type

Choose the datastores that you want for this VM disk. The
available datastore choices are from the data storage policy
associated with the VDC.

Selected Datastores

Check this box if you do not want the disks resized before
cloning the VM.

If you check this box, then the Size drop-down list is
hidden.

Do not resize check box

Choose the new size of the disk while cloning the VM.

You can edit the size of the disk only if you
enabled Allow Resizing of Disk in the storage
policy.

Note

Size drop-down list

Step 20 Click Submit.
Step 21 Click Next.
Step 22 On the Clone VM: Select VM Networks screen, click the VM Networks pencil icon to edit a VM network.

The Clone VM: Select VM Networks screen is empty unless Allow end user to select optional NICs is
chosen in the network policy.

Note

Step 23 On the Select screen, choose the clouds that you want associated with the VM.
Step 24 Click Submit.
Step 25 Click Next.
Step 26 Required: If you checked Perform deployment assessment on the Clone VM: Customization Options screen, then

review the report of the assessment displayed on the Deployment Assessment screen.

If this assessment report identifies errors, return to the previous screens and rectify the errors before submitting the
request. If the assessment report shows no errors, then you can continue.

Step 27 Click Next.
Step 28 Review the cloned VM information on the Clone VM: Summary screen.
Step 29 Click Submit.

The cloned VM gets its new name from the VDC policy.
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Moving a VM to VDC
A VM is moved to a VDC so that the rules of the VDC system policy are followed in the VM. The existing
VM is replaced by the one that is moved to the VDC.

The old VM is deleted. The new VM name is given according to the system policy.Note

Before you begin

You must be logged in to the appliance to complete this task.

Step 1 On the menu bar, choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click VMs.
Step 4 Click the row with the VM that you want to move to a VDC.
Step 5 From theMore Actions drop-down list, chooseMove VM to VDC.
Step 6 On theMove VM to VDC screen, you can make modifications to the VM that you are moving in the same way you did

when cloning a VDC.
See Cloning a VM, on page 357.

Resynchronizing a VM

Before you begin

You must be logged in to the appliance to complete this task.

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, click Clouds.
Step 3 On the Compute page, click VMs.
Step 4 Click the row with the VM that you want to resynchronize.
Step 5 From theMore Actions drop-down list, choose Resync VM.
Step 6 On the Resync VM screen, choose the number of minutes from 0 to 30 from theMax Wait Time drop-down list.
Step 7 Click Submit.

Applying a Tag to a VM
With the introduction of tagging support for a VM, you can manage tags in Cisco UCS Director to categorize
and identify specific VMs as firewall VMs or as load balancer VMs.
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Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, choose the cloud.
Step 3 On the Compute page, click VMs.
Step 4 Click the row with the VM to which you want to add tags.
Step 5 From theMore Actions drop-down list, choose Add Tags.
Step 6 On the Add Tags screen, complete the following fields:

DescriptionField

Choose the tag that you want to apply to the VM.

This drop-down list displays all the tags that you have
previously created. You can choose a tag from this list, or
create a new tag. For information on creating a tag, see
Creating a Tag, on page 133.

Tag Name drop-down list

Choose a value for the tag.Tag Value drop-down list

Step 7 Click Submit.

What to do next

You can create a tag-based cost model for the VMs. For more information, see Creating a Tag-Based Cost
Model, on page 312.

Mounting an ISO Image as a CD/DVD Drive
An ISO is a disk image. You can mount ISO images on the VMwithout using a physical drive. Once mounted
in your virtual machine, you can open, extract, and use the files from a virtual CD/DVD drive without a
physical disk.

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, click VMs.
Step 3 Click the row with the VM on which you want to mount an ISO image.
Step 4 From theMore Actions drop-down list, chooseMount ISO Image As CD/DVD Drive.
Step 5 On the CD/DVD Drive Mount ISO screen, choose the ISO image from the list of available images.
Step 6 Choose one of the following options:

• Create New CD/DVD Drive and check Power OFF VM.
• Use Existing CD/DVD Drive and choose the drive from the Select DVD/DVD Drive drop-down list.

Step 7 Click Submit.
The new or existing CD/DVD drive is mapped to your VM. You can log into the VM to view the mapped drive.

Cisco UCS Director Administration Guide, Release 6.6
363

Managing Lifecycles
Mounting an ISO Image as a CD/DVD Drive



Unmounting an ISO Image as a CD/DVD Drive
You can unmount an ISO image already attached to CD/DVD drive on the virtual machine.

Step 1 Choose Virtual > Compute.
Step 2 On the Compute page, click VMs.
Step 3 Click the row with the VM on which you want to unmount an ISO image.
Step 4 From theMore Actions drop-down list, choose UnMount ISO Image As CD/DVD Drive.
Step 5 On the CD/DVD Drive UnMount ISO screen, choose the CD/DVD drive to unmount from the Select CD/DVD Drive

drop-down list.
Step 6 Click Submit.

Cisco UCS Director Administration Guide, Release 6.6
364

Managing Lifecycles
Unmounting an ISO Image as a CD/DVD Drive



C H A P T E R 18
Managing CloudSense Analytics

This chapter contains the following sections:

• CloudSense Analytics, on page 365
• Generating a Report, on page 366
• Generating an Assessment, on page 367
• Report Builder for Custom Report Templates, on page 368
• Creating a Report Builder Template, on page 368
• Generating a Report from a Template, on page 370
• Viewing Reports Generated From a Template, on page 371
• Emailing Reports Generated From a Template, on page 371

CloudSense Analytics
CloudSense Analytics in Cisco UCS Director provide visibility into the infrastructure resources utilization,
critical performance metrics across the IT infrastructure stack, and capacity in real time. CloudSense
significantly improves capacity trending, forecasting, reporting, and planning of virtual and cloud infrastructures.

You can generate the following reports with CloudSense:

• Billing Report for a Customer

• EMC Storage Inventory Report

• NetApp Storage Inventory Report

• NetApp Storage Savings Per Group

• NetApp Storage Savings Report

• Network Impact Assessment Report

• Organizational Usage of Virtual Computing Infrastructure

• PNSC Account Summary Report

• Physical Infrastructure Inventory Report for a Group

• Storage Dedupe Status Report

• Storage Inventory Report For A Group
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• Thin Provisioned Space Report

• UCS Data Center Inventory Report

• VM Activity Report by Group

• VMware Host Performance Summary

• Virtual Infrastructure and Assets Report

This is a complete list of reports available in the system. However, the number of reports available in the
system for a user depends on the user role. By default, the CloudSense option is not visible to MSP
administrators. The system administrator needs to enable this option for MSP administrators. Once this is
done, then when an MSP administrator logs in, only reports relevant to customer organizations are displayed.

Note

Generating a Report
Before you begin

You must be signed into the appliance before completing this task.

Step 1 Choose CloudSense > Reports.
Step 2 Click a tab based on the type of report you want to generate. It can be one of the following:

• Application Container Report

• Billing Report for a Customer

• Cisco C880M4 Inventory Report

• EMC Storage Inventory Report

• Group Infrastructure Inventory Report

• Hyper V Cloud Utilization Summary Report

• IBM Storwize Inventory Report

• NetApp Storage Inventory Report

• NetApp Storage Savings Per Group Report

• NetApp Storage Savings Report

• Network Impact Assessment Report

• Organizational Usage of Virtual Computing Infrastructure Report

• PNSC Account Summary Report

• Physical Infrastructure Inventory Report for a Group

• Service Request Statistics
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• Service Request Statistics Per Group

• Storage Dedupe Status Report

• Storage Inventory Report for a Group

• Thin Provisioned Space Report

• UCS Data Center Inventory Report

• VM Activity Report By Group

• VM Performance Summary Report

• VMware Cloud Utilization Summary Report

• VMware Host Performance Summary Report

• Virtual Infrastructure and Assets Report

Step 3 Click Generate Report.
Step 4 In the Generate Report screen, complete the required fields, including the following:

DescriptionName

Select the group that you want to generate the report for.

If you are an administrator, then this drop-down
list displays all the groups for which you have
administrative privileges. For example, if you
are an MSP administrator, then this drop-down
list displays all the customer groups that you
manage. This list does not display any other
groups.

Note

Context drop-down list

You can provide a label for the report to distinguish it from
the other reports that you generate.

Report Label field

Step 5 Click Submit.

The report is generated in the system. This generated report is accessible only to you and to users in the groups that you
manage. For example, if you are anMSP administrator, then this generated report is not visible to otherMSP administrators
or groups.

Generating an Assessment

Step 1 Choose CloudSense > Assessments.
Step 2 Click Generate Report.
Step 3 In the Generate Report screen, complete the required fields, including the following:
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DescriptionName

Select the group that you want to generate the report for.

If you are an administrator, then this drop-down
list displays all the groups for which you have
administrative privileges. For example, if you
are an MSP administrator, then this drop-down
list displays all the customer groups that you
manage. This list does not display any other
groups.

Note

Context drop-down list

You can provide a label for the report to distinguish it from
the other reports that you generate.

Report Label field

Step 4 Click Submit.

Report Builder for Custom Report Templates
Using theReport Builder option in Cisco UCSDirector, you can create custom report templates to run reports
on specific parameters. You can specify the context, the type of report to run, and the duration of the data
samples for the report. You can also create multiple templates.

After you have created a report template, you can use it to generate a report in either PDF or HTML formats.
You can view custom reports in Cisco UCS Director or you can email reports, either to yourself and to other
users in your organization. You can review and archive these reports outside Cisco UCS Director.

In addition to creating a template, you can edit, clone, and delete custom report templates.

You cannot generate daily and hourly trend cost reports using the report builder. You can generate trend
reports only for weekly and monthly duration.While generating trend reports for a month, the data is caculated
from the first day of the month till the current date. For example, if you are generating a trend report on 5th
March, this report includes data from March 1st, to March 5th.

Note

Creating a Report Builder Template

Step 1 Choose CloudSense > Report Builder.
Step 2 Click Add Template.
Step 3 In the Add Template screen, complete the required fields, including the following:

DescriptionName

The name of the report template.Name field
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DescriptionName

A description of the template.Description field

Click + to add entries to the reports.Reports field

Step 4 In the Add Entry to Reports screen, complete the required fields, including the following:

DescriptionName

Choose one of the following options:

• VDC

• Cloud

• Physical Account

• Multi Domain Manager

• Global

• Global Admin

Report Context drop-down list

Choose a VDC.

This field is displayed only when the report context is set
to VDC.

VDC drop-down list

Choose a cloud from the drop-down list. This list displays
all the clouds that have been previously configured in the
system.

This field is displayed only when the report context is set
to Cloud.

Clouds drop-down list

Choose a physical account from the drop-down list. This
list displays all the accounts that have been previously
configured in the system.

This field is displayed only when the report context is set
to Physical Accounts.

Physical Accounts drop-down list

Choose a multi-domain manager from the drop-down list.
This list displays all the accounts that have been previously
configured in the system.

This field is displayed only when the report context is set
toMulti Domain Manager.

Multi Domain Manager

Click Select to choose the reports that you want included
in the template.

This list is filtered depending on the report context that you
have selected.

Reports drop-down list
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DescriptionName

If you specified VDC as the report context, then choose
one of the following durations for the template:

• Hourly

• Daily

•Weekly

• Monthly

If you specified Cloud as the report context, then choose
one of the following durations for the template:

• Daily

•Weekly

• Monthly

Duration for Trend Reports drop-down list

Step 5 Click Submit.
Step 6 In the Add Template screen, click Submit.

What to do next

After you have created a template, you can generate a report based on the template. For more information,
see Generating a Report from a Template, on page 370.

Generating a Report from a Template
Before you begin

You should have created a report template in the system. For information, see Creating a Report Builder
Template, on page 368.

Step 1 Choose CloudSense > Report Builder.
Step 2 Select a template from the table.
Step 3 From theMore Actions drop-down menu, choose Generate Report.
Step 4 In the Confirm Report Generation screen, complete the required fields, including the following:

DescriptionName

A title for the report.Report Title field

A description of the report.Description field

Step 5 Click Generate.
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The report is generated and saved in the system.

What to do next

You can view the report that has been generated, and if necessary, email the report.

Viewing Reports Generated From a Template
Before you begin

You should have created a template, and generated a report using the template.

Step 1 Choose CloudSense > Report Builder.
Step 2 Select a template from the table.
Step 3 From theMore Actions drop-down menu, choose View Reports.

The Custom Reports screen displays the reports that have been generated using the template.

Step 4 Select a report from the table.
Step 5 Click View Report.
Step 6 In the View Report screen, choose the format in which you would like to view the report.

You can choose either HTML or PDF.

Step 7 Click Submit.

The report opens in a new browser tab.

What to do next

You can email the reports to other users in the organization.

Emailing Reports Generated From a Template
You can email a report that is generated from a template to yourself or to other users within the organization.

Before you begin

• You should have created a template, and generated a report using the template.

• You should have configured your email address during the initial system set-up. Your name and email
address identifies you as the sender with the report.

Step 1 Choose CloudSense > Report Builder.
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Step 2 Select a template from the table.
Step 3 Click View Reports.

The Custom Reports screen displays the reports that have been generated using the template.

Step 4 Select a report from the table.
Step 5 Click Email Report.
Step 6 In the Email Report screen, complete the required fields, including the following:

DescriptionName

The email address of the recipient.

You can enter multiple email addresses separated by
commas.

To field

The subject of the email message.Subject field

Choose the format of the report that will be attached to the
email message. You can choose one of the following:

• HTML

• PDF

Format drop-down list

Step 7 Click Submit.

What to do next

If you no longer need the report, you can select it, and click Delete to erase the report from the system.
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